Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

EXEL - formuła liczenia proszę o pomoc

rbt.RBT 24 Lut 2016 17:01 474 6
  • #1 24 Lut 2016 17:01
    rbt.RBT
    Poziom 3  

    Witam. Mam Exel 2007 i 2010.
    W komórce a1 wstawiam jakieś liczby; b1 jest stawka 100, w c1 jest funkcja =suma(a1*b1);
    W komórce A2 jest funkcja =a1;b2 jest stawka 200, w c2 jest funkcja =suma(a2*b2);
    Problem mam w komórce a3; b2 jest stawka 171,25, w c3 jest funkcja =suma(a3*b3);
    Jaki mam problem.W komórce A3 jest odejmowanie od komórki A1. Warość odjęta nie może być mniejsza niż "0"(zero), oraz wartość wyższa nie może być większa niż 27. Przykład jak w komórce a1 jest 4 to w A3 jest 1 (to nie jest problem), ale jeśli w komórce A1 jest 2, to w komórce A3 musi być wartość zero. Jesli w komórce A1 jest 40 to w komórce A3 musi być 27. Problem jak mam napisać taką funkcje.

    Inny problem. Jak w komórce a5 mam 10, w B5 jest 179 to w c5 funkcja =suma(a5*b5). to wiem jak zrobić. Mam problem taki jak napisać funkcje dla takich założeń 1.00-25,00-100%(wartośc z B5) od 25,01 do 50,00-50%(wartości z b5) , jeżeli 50,01 do 75,00- 25%(wartości z B5), jeżeli powyzej 75.01-0% z komorki B5.
    Czyli jak wpisze w komórke A5 liczbe 80, to wynik ma być 7911,25.

    Ktoś pomoże? jak mają wygladać takie fukcje? Ślicznie dziekuje za pomoc:)

    Dodano po 1 [minuty]:

    W komórce A3 odejmujemy od komórki a1 liczbe 3 i wartość ma się zgadzać ale wynik nie mniejszy niż 0 i nie wiekszy niż 27 i odejmuje zawsze liczbę 3

    Dodano po 22 [minuty]:

    Przyklad dla komorki a3. Jeśli w a1jest 4 to w a3 wuynik 1; jeśli a1 jest 2 to w a3 jest zero

    0 6
  • Pomocny post
    #2 24 Lut 2016 17:27
    JRV
    Specjalista - VBA, Excel

    w A3 =JEŻELI(A1<3;0;JEŻELI(A1>30;27;A1-3))

    Dodano po 2 [minuty]:

    rbt.RBT napisał:
    jest funkcja =suma(a3*b3);

    dosyć =a3*b3

    0
  • #3 24 Lut 2016 18:42
    rbt.RBT
    Poziom 3  

    Slicznie dziekuje, a jest jakaś funkcja dla drugiego przypadku? czy musiałbym rozbiać na przedziały? jesli tak to jak by mialo to wygladać?

    0
  • #4 24 Lut 2016 18:58
    JRV
    Specjalista - VBA, Excel

    rbt.RBT napisał:
    dla takich założeń 1.00-25,00-100%(wartośc z B5) od 25,01 do 50,00-50%(wartości z b5) , jeżeli 50,01 do 75,00- 25%(wartości z B5), jeżeli powyzej 75.01-0% z komorki B5.
    Czyli jak wpisze w komórke A5 liczbe 80, to wynik ma być 7911,25.

    Lepiej raz zobaczyć niż usłyszeć 10 razy. Zalacz arkusz z komentarzem

    0
  • #5 25 Lut 2016 08:18
    rbt.RBT
    Poziom 3  

    Wpisując w dane w komórce a8, np 80 to efekt chciałbym uzyskac w c8, jak rozpisałem w przedziale komórek a10:c15. jest taka mozliwość?

    0
  • Pomocny post
    #6 25 Lut 2016 22:38
    adamas_nt
    Moderator Programowanie

    Czyli maksymalna, "efektywna" liczba, to 75? Spróbuj

    Kod: text
    Zaloguj się, aby zobaczyć kod

    0
  • #7 26 Lut 2016 07:35
    rbt.RBT
    Poziom 3  

    Wszystko działa jak powinno. Jak dla mnie temat zamkniety. Ślicznie dziękuje wszystkim za pomoc.

    0