Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

AMILO PRO V3505 - Gasnące i powracające podświetlenie po wymianie matrycy

power_pc 20 Mar 2016 21:03 861 9
  • #1
    power_pc
    Level 11  
    Witam,
    Mam problem ze zdiagnozowaniem usterki w laptopie Fujitsu Siemens Amilo Pro V3505.
    Została w nim wymieniona matryca z innego modelu (PI2540) - generalnie wszystko pasowało i działa - przez parę godzin.
    Pierwszy problem pojawił się gdy po pewnym czasie ekran nie wchodził w swoją rozdzielczość, tylko cały czas wyświetlał 1024x768 (powinno być 1280x800).
    Wtedy poprawiłem raz jeszcze taśmę z tyłu ekranu, przy okazji odpiąłem do tej operacji inwerter.
    Teraz rozdzielczość jest już prawidłowa - ale pojawił się inny problem - ekran gaśnie zwykle po kilkunastu sekundach, czasem po kilku minutach.

    Pomiary napięcia na wejściu inwertera dają poprawne wartości:
    1) Masa
    2) Masa
    3) 3.2 V
    4) 0.5 V
    5) 20 V
    6) 20 V

    I tu ciekawostka, gdy ekran zgaśnie i dokonuję pomiaru na linii nr 4 (sterowanie), to samo dotknięcie styku miernikiem powoduje, że podświetlenie wraca, oczywiście po chwili znów gaśnie.



    Co więcej, nie mogę regulować intensywności podświetlenia z klawiatury.
    Jakieś pomysły, co może być zwalone? Może ta matryca jednak nie do końca jest kompatybilna? Tylko czemu przez parę godzin pracowała poprawnie?

    EDIT:
    Te pomiary były robione na podłączonym inwerterze.
    Na samej kostce sytuacja jest nieco inna:

    1) GND
    2) GND
    3) 3.2 V
    4) 0.0 V
    5) 11.5 V
    6) 11.5 V

    Czy to oznacza, że kabelek ma przerwę? Może coś urwałem wyciągając wtyczkę?
  • #2
    DG06
    Level 18  
    power_pc wrote:
    Czy to oznacza, że kabelek ma przerwę? Może coś urwałem wyciągając wtyczkę?

    Może sprawdź...
  • #3
    power_pc
    Level 11  
    A co właśnie robię? Sprawdzam ...
    Nawet dotknięcie kostki na wejściu inwertera palcem powoduje że podświetlenie mryga, zapala się lub gaśnie. Delikatne szarpanie kabelkiem nie powoduje takich zmian.
  • #4
    power_pc
    Level 11  
    Taśma przemierzona, jest sprawna.
    Dziwne, bo dziś jak mierzyłem to napięcie sterujące się pojawiło i zmienia się przy regulacji jasności z klawiatury, jednak matryca świeci cały czas tak samo. Obstawiam, że padł inwerter - zamówiony, po wymianie dam znać.

    A jeszcze jedno dziwne zachowanie, jak gaśnie podświetlenie, to gaśnie płynnie, tak jakby się stopniowo ściemniało.
  • #5
    power_pc
    Level 11  
    Po zmianie inwertera podświetlenie już nie gaśnie, więc jeden problem rozwiązany.
    Pozostał jednak problem braku regulacji jasności.
  • #7
    power_pc
    Level 11  
    Dzięki lisek, przemierzyłem konektor na płycie i jednak brak jest napięcia odpowiadającego za jasność matrycy.

    Zastanawiam się tylko jak mogłem to uszkodzić, gdyż przed zmianą matrycy wszystko działało jak należy.
  • #8
    lisek
    Service technician RTV
    W tym KBC kb3910 pin.33 > BRIGHTNESS_PWM
    *lub pin.99 - jeśli reg.Jasnośći analogowa.
    Prześledz drogę od KBC do złacza lvds.


    Baterię wyjąleś na czas zabawy z matrycami.?
  • #9
    power_pc
    Level 11  
    Bateria i kabel były odłączone. Była to równoległa przekładka, z tego v3505 zabrałem sprawną matrycę i wsadziłem do v3545 - i w nim wszystko działa jak należy.
    v3505 został bez matrycy, ale miałem matrycę od pi2540, niby taka sam, niby pasowała, a jednak są problemy.

    Grzebanie na płycie chyba sobie odpuszczę, gdyż sprzęt nie warty jest zachodu.

    Zastanawia mnie jeszcze jedna rzecz odnośnie tych inwerterów
    1) inwerter od v3505 - matryca świeci bardzo jasno, ale po chwili gaśnie
    2) inwerter od v3515 niby pasuje - matryca świeci ale dosyć ciemno, nie gaśnie
    3) mam jeszcze inwerter od pi2540 który oryginalnie był z tą matrycą, ale niestety ma inne złącze, więc go nie mogę przetestować w tym zestawie.
  • #10
    power_pc
    Level 11  
    Ostatecznie rozwiązałem problem mostkując na inwerterze styki 3 i 4, podświetlenie teraz świeci z maksymalną jasnością tylko regulacji brak.

    Ciekawostką pozostaje jednak sprawa inwertera, gdyż oba które mam okazały się sprawne, jednak każdy z nich zachowywał się inaczej.