Elektroda.pl
Elektroda.pl
X
Elektroda.pl
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

LENOVO B590 czujnik zamknięcia klapy

21 Mar 2016 21:06 2571 8
  • Poziom 9  
    Mam Laptop B590. Problem polega na tym, że co jakiś czas, w różnych momentach, niezależnie czy cos na nim piszę czy ruszam myszką itp., uruchamia się w nim funkcja przypisana w opcjach zasilania dla zamknięcia pokrywy. Obecnie ustawiłem na "Nic nie rób" czyli po prostu efektem jest wyłączanie ekranu. wyłączanie to jest na pewno skutkiem wykonania zamknięcia klapy a nie na przykład skutkiem wciśnięcia przycisku zasilania lub upłynięcia jakiegoś czasu bezczynności - testowałem to stosując różne ustawienia w opcjach zasilania właśnie dla zamknięcia klapy i gdy zmienię te ustawienie na na przykład uśpienie to laptop w tych dowolnych momentach wchodzi w uśpienie. Na razie, zeby zmniejszyć uciążliwość ustawiłem tę opcję na "Nic nie rób". Ekran wyłącza się na sekundę po czym włącza znowu. Jakby klapa została przymknięta i natychmiast otwarta, czyli jakby czujnik zamknięcia klapy został na moment tylko wzbudzony. Wokół laptopa nie mam żadnych silnych źródeł pola magnetycznego itp., klapa jest cały czas otwarta. Wyłączanie ekranu (czyli wykonanie działania przypisanego dla "nic nie rób") ma miejsce czasem co kilkanaście/kilkadziesiąt sekund przez pół godziny, po czym jest wszystko OK na przykład przez 10 dni a potem znowu jest problem z wyłączaniem przez pół dnia i potem znowu spokój przez tydzień i tak w kółko.

    Zgłosiłem to jako reklamację do komputronik z tytułu niezgodności z umową, ale odpisali mi, że to wina mojego systemu operacyjnego i oprogramowania. Odpisali, ze oni testowali na innym systemie u siebie i u nich jest OK. Tymczasem ja mam identyczny system i oprogramowanie na drugim identycznym laptopie B590 (identyczne oprogramowanie, gdyż jest na obu laptopach ten sam obraz (ghost) na dyskach), więc nie może tu być winy softu, gdyż drugi laptop mimo, że kupiony tego samego dnia działa do tej pory prawidłowo. Oczywiście testowałem tez wgrywanie zupełnie świeżego systemu itd i nadal jest to samo. Odpisałem im póki co, że się nie zgadzam z takim rozwiązaniem sprawy i szczegółowiej opisałem co i jak i czekam na odpowiedź.

    W każdym razie czy ma ktoś pomysł jak spowodować by laptop przestał reagować na zamykanie klapy? Najlepiej software'owo. Ewentualnie mechanicznie jak to wyłączyć w tym modelu. Wiem, gdzie ten czujnik jest bo sprawdzałem magnesem - jest po lewej u góry nad matrycą. Tylko samo odcięcie czujnika pewnie nic nie da, jeśli problemem jest chwilowe zwieranie się ścieżek (lub przerywanie?) na płycie głównej. Tak przy okazji pytanie: czy ten czujnik działa na zasadzie, że po zbliżeniu magnesu (zamknięciu klapy) powoduje zwarcie i przesyła sygnał czy też przerywa obwód i sygnału nie ma?
  • Pomocny post
    Poziom 27  
    Zostaw włączony w biosie, jak dalej będzie migać, to masz dowód, że to nie wina systemu.
    Jak gwarancja pozwala na rozkręcanie to odepnij czujnik.
  • Pomocny post

    Spec od komputerów
    Jeśli masz gwarancję i rozbierzesz - tracisz gwarancję. To tak dla formalności...
    Czujnik oparty jest na halotronie i zazwyczaj wlutowany w płytę - więc go nie odepniesz tak po prostu.
  • Poziom 9  
    Z tym zostawianiem w BIOSie to owszem juz próbowałem na chwilę, ale ciężko jest patrzeć kilka godzinw w ekran biosu, aby trafic w końcu na to losowe wyłączenie, więc sobie odpuściłem.

    To rozwiazanie z odpięciem czujnika to ostateczność jak już nic się nie uda załatwić gwarancyjnie, więc się jeszcze wstrzymam.

    Z tego co kojarzę sygnął czujnika idzie chyba razem z kablami wifi (bo chyba na tej samej płytce co antena wifi jest. Rozwiążę to może tak, że zaślepię po prostu wtyki odpowiadajace za czujnik we wtyczce anteny, którą wtyka się w płyte główną. Ewentualnie zewrę te styki czujnika na stałe (bo na razie nie wiem czy zamykając klapę zwiera się styki czy tez przerywa się obwód, bede musial przetestować). Wtedy wykluczę możliwość robienia problemów przez czujnik, płytkę wifi i kable.

    Dobrze kombinuję?

  • Spec od komputerów
    Źle kombinujesz.
    Jeśli magnes masz w ramce matrycy (99% współczesnych konstrukcji) - to czujnik jest wlutowany w płytę.
  • Pomocny post
    Poziom 27  
    sk1977 napisał:
    Jeśli magnes masz w ramce matrycy (99% współczesnych konstrukcji) - to czujnik jest wlutowany w płytę.

    Albo na którejś z bocznych płytek na tasiemkach. W tym modelu na 99% czujnik jest na płytce razem z kontrolkami obok prawego zawiasu.
    wilkuu napisał:
    (bo na razie nie wiem czy zamykając klapę zwiera się styki czy tez przerywa się obwód, bede musial przetestować

    Czujnik zwiera sygnał do masy po zamknięciu klapy.
  • Pomocny post

    Spec od komputerów
    Dawno nie miałem tego modelu to nie będę się spierał - ale zakładając że jest na płytce - to i tak nie jest samodzielnym elementem który można wypiąć nie tracąc funkcjonalności.

    Ale coś mi świta, że w którymś modelu (być może tym) był na płytce kamerki i połączony tasiemką LVDS.

    Może autor podzieli się wiedzą gdzie siedzi magnes :)
  • Poziom 9  
    sk1977 napisał:
    Źle kombinujesz.
    Jeśli magnes masz w ramce matrycy (99% współczesnych konstrukcji) - to czujnik jest wlutowany w płytę.

    sk1977 napisał:

    Może autor podzieli się wiedzą gdzie siedzi magnes :)


    Napisałem, że:
    wilkuu napisał:
    Wiem, gdzie ten czujnik jest bo sprawdzałem magnesem - jest po lewej u góry nad matrycą.


    Dokładnie to w klapie matrycy, w pionie na wysokości kamerki a w poziomie jakieś 6 cm. od lewej krawędzi. Czyli tam gdzie według instrukcji dochodzi antena od wifi i tam jest pewnie właśnie jakaś płytka z tym czujnikiem.

    nanab napisał:

    Czujnik zwiera sygnał do masy po zamknięciu klapy.


    Czyli wystarczy, że z wtyczki wchodzącej w płyt główną odłacze żyły odpowiedzialne za czujnik i nie będę nic zwierał i lap będzie widział cały czas otwarte klapę. Teoretycznie - chyba, że jeszcze płyta główna będzie mieć jakies zwarcia. Jak juz będe miał to rozkręcone to się przyjrzę płycie też, ale nie bardzo mam pomysł jak tą płyte sprawdzić.
  • Pomocny post

    Spec od komputerów
    W B490 idzie tą samą tasiemką co sygnały do matrycy. Na płycie sygnał LID_CLOSE# jest podwieszony do 3,3V.
    Nie mam schematu do B590, ale może być podobnie.