Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

[Flyback] - Uruchomienie zasilacza impulsowego UC3845

25 Mar 2016 14:58 3999 8
  • Poziom 13  
    Witam.
    Po wcześniej wykonanej przetwornicy flyback postanowiłem zbudować zasilacz o mocy 50W, niestety mam z nim problemy.
    [Flyback] - Uruchomienie zasilacza impulsowego UC3845
    Na razie nie zamontowałem gasika C14, R4
    Parametry transformatora:

    E30, AL całego rdzenia około 170
    Pierwotne 91 zwoi
    Bias 11 zwoi
    Wtórne 8 zwoi

    Pierwszy test przy 230V zaczął się od spalenia tranzystora i rezystora z bramki, ponieważ zapomniałem włożyć kontroler. Później po wymianie było już lepiej. Przetwornica pracowała paczkami z częstotliwością około, 17Hz co było słyszalne – takie stykanie. Tak jakby nie potrafiła zastartować z uzwojenia pomocniczego. Napięcie na zasilaniu układu było niskie – około 7,5V.

    Zrobiłem test polegający na podłączeniu z zasilacza 12V na elektrolit wejściowy – przetwornica jest martwa. Zrobiłem zwarcie rezystora startowego i wtedy przetwornica ruszyła. Częstotliwość 100kHz (nie wiem, dlaczego, bo to kontroler UC3845) wypełnienie około 50% stale. Przebieg prądu i napięcia na uzwojeniach – prostokątny bez narostów, są trochę oscylacji. Na wyjściu napięcie 0,4V na biasie jeszcze mniej (ale transformator jest projektowany tak, że ścina z 320V). Na pętli sprzężenia zwrotnego (noga 1) 6V i o dziwo na Vref jest tylko około 3-2,7V a nie 5V. Zasilanie układu 12V.
    Co dziwniejsze, co jakiś czas sama się wyłączy i po odcięciu zasilania i odczekaniu chwili i ponownym uruchomieniu znowu pracuje jakiś czas. Patrząc na oscyloskop zmniejsza się częstotliwość aż zacznie się „trząść” przebieg i wtedy ona umiera. Kontroler, tranzystor, transil gorący, po pewnym czasie transformator lekko ciepły.

    Nie mam już pojęcia, co jest zgrane, macie jakieś pomysły?
  • Poziom 29  
    Zasil sam kontroler z 12V i zobacz co się dzieje na OUT.

    Kontroler w podstawce to proszenie się o problemy. Chociażby ze stykiem na nóżkach.

    1) Czy jesteś pewien ze uzwojenia mają dobrze podłączone początki i końce?
    2) Czemu tak dużo pojemności na zasilaniu kontrolera (C9, C11)
    3) Po co R13? Czemu obciążasz uzwojenie pomocnicze?
  • Poziom 13  
    CosteC Właśnie to, co opisywałem to efekt po podaniu 12V na zasilanie układu, po padaniu na sam kondensator główny brak reakcji. Na wyjściu jest około 50% wypełnienia, czasem to gaśnie, ale raczej pracuje w miarę stabilnie.
    Rezystor obciążający uzwojenie pomocnicze dodałem, bo tak było w dokumentacji kontrolera, wyrzuciłem go i nie było zmiany.
    Na uzwojeniu pierwotnym jest prostokąt ±1V po podaniu 12V na zasilanie.

    Uzwojenia raczej są połączone dobrze, pilnowałem tego, a później nawet dałem wykonać transformator firmie i brak efektu. Kondensatory są niskoimpedacyjne, a 100n pomocniczo, żeby usunąć wyższe częstotliwości.

    Nie rozumiem dlaczego pracuje przy 100kHz skoro generator RC jest ustawiony na 50kHz a jest to układ 3845.
  • Poziom 28  
    R2 i R3 mają po 100Ω? Nie powinno być ~100x mniej?
  • Poziom 29  
    Którego klona 3845 używasz?
    Czy mógłbyś sprawdzić częstotliwość na OUT i częstotliwość na RT/CT?

    Może układ jest uszkodzony albo to niestandardowy klon.
  • Poziom 11  
    Tak z ciekawości....
    Udało się rozwiązać problem, jaka była przyczyna ?
  • Poziom 12  
    Przepraszam, iż piszę w archiwalnym wątku, ale przypomniałem sobie moje pierwsze kroki z przetwornicami i widzę wiele błędów więc dla potomnych mogę dodać:
    1) Nie ma rezystora GS przy tranzystorze mocy, mosfety powinny mieć "zblokowaną bazę"
    2) Nie ma rezystora bramkowego dla tranzystorze mocy, ja daję równolegle połączony z diodą.
    3) Nie ma indukcyjności dla połączenia uzwojenie - dren tranzystora.
    4) Nie ma zabezpieczenia (może być dioda zenera) dla złącza GS tranzystora mocy.
    5) Brak rezystora rozładowującego pojemność układu pośredniczącego.
    6) Brak termistora dla obwodu ładowania kondensatora głównego.
    Ps. Układy UC3844/45 działają na max 50% wypełnienia więc częstotliwość masz x2.
    Układy UC3842/43 działają do 100% wypełnienia.

    Pozdrawiam
  • Poziom 29  
    Co masz na myśli w punkcie 3? Jeśli dobrze rozumiem zwiększyło by to indukcyjność rozproszenia transformatora.