Elektroda.pl
Elektroda.pl
X
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Wykrywanie błędnej ilości pamięci RAM w starym PC

Nowaczke 30 Mar 2016 20:09 1521 28
  • #1
    Nowaczke
    Level 8  
    Witam Wszystkich serdecznie. :)
    Mam problem ze starym komputerem, znalezionym w piwnicy. Chciałbym przywrócić go do życia, lecz mam problem z pamięcią RAM.
    Komputer:
    Płyta główna: Abit NF7-S
    Pamięć: 2 x 512 MB DDR
    Załączam zdjęcie z widocznym problemem.
    Wykrywanie błędnej ilości pamięci RAM w starym PC20160330_1..725.jpg Download (1.68 MB)
    Po uruchomieniu komputera, wskazuje on, że posiada dziwną ilość pamięci RAM, a mianowicie 262144K. Raz na sto razy uda się go uruchomić z całą ilością pamięci (1024 MB). Mam dwie kości po 512 MB. Testowałem różne konfiguracje, ale nie znalazłem metody na wyeliminowanie problemu. Sprawdziłem również 512 MB kość z innego komputera i efekt ten sam.
    Bardzo chętnie udzielę dodatkowych informacji, jeśli są potrzebne.
    Z góry wielkie dzięki za wszelką pomoc.
    Pozdrawiam i życzę miłego dnia. :)
  • #2
    kokapetyl
    Level 43  
    Nowaczke wrote:
    Bardzo chętnie udzielę dodatkowych informacji

    Nie napisałeś co się dzieje ze sprzętem, oprócz tego komunikatu.
    Jak widać, bios się włącza i co dalej się dzieje ?
  • #4
    Nandish
    Level 18  
    Co wyświetla, jak dasz tylko jeden moduł (raz jeden, raz drugi)?
  • #5
    Nowaczke
    Level 8  
    Dokładnie to samo. Próbowałem pojedynczych kości w różnych slotach i wciąż ten sam problem. Wybrałem w BIOS ustawienia testowe, system przechodzi test pamięci na starcie bez żadnego problemu.
  • #6
    Nandish
    Level 18  
    Masz możliwość podmiany (nawet pożyczonego) zasilacza? Może w nim jest problem? Zobacz też kondensatory na płycie głównej (i w zasilaczu), czy nie są wybrzuszone/wylane. Jak napięcia zasilacza?
  • #7
    Nowaczke
    Level 8  
    Kiedyś, gdy był to mój główny komputer, w tym PC był zasilacz NeoTEC X3800, ale później były problemy z jego odpaleniem. Należało poczekać 10 min. od włączenia do prądu, żeby móc uruchomić komputer. Aktualnie zasilacz ten jest chyba już kompletnie niesprawny.
    Wykrywanie błędnej ilości pamięci RAM w starym PCdasdas.jpg Download (347.47 kB)
    Znajomy wygrzebał z piwnicy zasilacz HEDY-400. Otworzyłem go, pobieżnie oczyściłem z kurzu i podłączyłem. Komputer działał. :) Jednak są problemy z pamięcią. Zauważyłem w BIOS, że dla -5V pomiar wynosi -60V, więc postanowiłem wymienić zasilacz.
    Wykrywanie błędnej ilości pamięci RAM w starym PCdsadas..jpg Download (415.7 kB)
    Zakupiłem najtańszy zasilacz na Allegro, Akyga 400W, który jest aktualnie podłączony do starego PC. Myślałem, że to wyeliminuje problem, ale jednak nie. Pomiary napięcia w BIOS wcale nie są lepsze. Zdjęcie z BIOS przy podłączonym zasilaczu Akyga.
    Wykrywanie błędnej ilości pamięci RAM w starym PCdsadasd...jpg Download (369.44 kB)Wykrywanie błędnej ilości pamięci RAM w starym PCsdadas..jpg Download (417.81 kB)
    Mam w domu, w moim aktualnym komputerze, zasilacz Fortron FSP460.
    Wykrywanie błędnej ilości pamięci RAM w starym PCdsadsa.jpg Download (381.85 kB)
    Elektronikiem nie jestem, ale przy wyjęciu płyty i wymianie pasty na procesorze, nie zauważyłem żadnych niepokojących oznak na płycie głównej.
    Tak, wiem, w razie uaktualniania czarnej listy zasilaczy, chętnie udostępnię posiadane egzemplarze. ;)
  • #8
    Hackmsr
    Level 23  
    Niech kolega wsadzi tam coś innego, niż te wyroby zasilaczopodobne. Akyga już figuruje, tylko nie wiem na jakiej liście. Wykonaj bootowalny MemTest. Z tym -60V to mogły już coś uwalić. Jest kolega pewny, że płyta głowna jest sprawna?
  • #9
    RADU23
    Moderator of Computers service
    Nowaczke wrote:
    Pomiary napięcia w BIOS wcale nie są lepsze.

    Pomiarów dokonuje się miernikiem a nie sugeruje odczytami programowymi.
    https://www.elektroda.pl/rtvforum/topic1199202.html
    Hackmsr wrote:
    Akyga już figuruje, tylko nie wiem na jakiej liście.

    Na czarnej. To jeden z najgorszych zasilaczy jeśli chodzi o jakość.
    Nowaczke wrote:
    Mam w domu, w moim aktualnym komputerze, zasilacz Fortron FSP460.

    To jest dobry, markowy zasilacz.
  • #10
    gosztekseba
    Level 31  
    Hackmsr wrote:
    Z tym -60V to mogły już coś uwalić. Jest kolega pewny, że płyta głowna jest sprawna?


    Gdyby tam w rzeczywistości pojawiło się takie napięcie to raczej już nie byłoby tego tematu... Bez pomiaru miernikiem można sobie darować.
  • #11
    Hackmsr
    Level 23  
    To był żart. By mu poleciał cały komputer. Wymianie pasty, ale czy kolega przeczyścił socket i styki procesora?
  • #12
    Nowaczke
    Level 8  
    Po podłączeniu Fortrona, wykryte zostało 1024 MB, jednak radość nie trwała zbyt długo, ponieważ po jego ponownym uruchomieniu znów było tylko 256 MB. W BIOS, dla - 5V, odczytywane wartości są wciąż kosmiczne.
  • #13
    junior84
    Level 22  
    A gdzie śmigło od wentylatora chipsetu ? Czy kondensatory na płycie wyglądają dobrze - czy nie są napuchnięte ?
  • #15
    junior84
    Level 22  
    DriverMSG wrote:
    junior84 wrote:
    A gdzie śmigło od wentylatora chipsetu ?
    Gdzie tam widzisz wentylator bez śmigła?


    Mój błąd - został tylko radiator bez śmigła Wykrywanie błędnej ilości pamięci RAM w starym PC
  • #16
    DriverMSG
    Admin of Computers group
    junior84 wrote:
    Mój błąd - został tylko radiator bez śmigła
    Prostując - został radiator bez wentylatora, co nie ma raczej wpływu na wykrywanie (lub nie) pamięci RAM.
    Obawiam się, że płyta gł. leżąc w piwnicy zaśniedziała, kondensatory powysychały i jej los jest przesądzony.
  • #18
    kokapetyl
    Level 43  
    Nandish wrote:
    Zobacz też kondensatory na płycie głównej

    Zrób może jeszcze raz zdjęcie płyty, ale tak aby było widać wyraźnie wszystko, ocenimy jak te kondensatory wyglądają.
  • #20
    Nowaczke
    Level 8  
    Jeden z przewodów wentylatora chłodzącego chipset złamał się, więc zdemontowałem ten wentylator. Czy z tego powodu płyta może przechodzić w jakiś tryb awaryjny? Wentylator ten był podpinany wtyczką 2-pin.
    W najbliższym czasie postaram się załatwić jakiś aparat aby zrobić zdjęcie w jak najlepszej jakości.
  • #21
    kokapetyl
    Level 43  
    Nowaczke wrote:
    najbliższym czasie postaram się załatwić jakiś aparat aby zrobić zdjęcie w jak najlepszej jakości.

    No to poczekamy.
    Ze zdjęcia jakie zamieściłeś, nie widać dokładnie, ale mam wątpliwości co do stanów tych kondensatorów.
    Jak do tej pory nikt nie wspomniał o resecie biosu, wykonaj go .
  • #22
    Nowaczke
    Level 8  
    Zdjęcia płyty głównej: www.imgur.com/a/U2iH8
    Jeśli mam zrobić zdjęcie jakiejś poszczególnej części płyty głównej, to proszę dać znać.
    Wiele razy wykonywałem powrót do ustawień fabrycznych jak i do ustawień testowych z poziomu BIOS. Przy pomocy zworki również resetowałem ustawienia.
    Pewnie powinienem wcześniej o tym wspomnieć, ale w płycie nie działają złącza SATA. Musiałem kupić dysk na ATA, aby komputer go wykrył.

    EDIT:
    Nie chciałem obciążać serwera 20 MB zdjęć. ;)
    Wykrywanie błędnej ilości pamięci RAM w starym PC Wykrywanie błędnej ilości pamięci RAM w starym PC Wykrywanie błędnej ilości pamięci RAM w starym PC Wykrywanie błędnej ilości pamięci RAM w starym PC Wykrywanie błędnej ilości pamięci RAM w starym PC
  • #24
    kokapetyl
    Level 43  
    Nowaczke wrote:
    problem ze starym komputerem, znalezionym w piwnicy

    Jeśli to są zdjęcia tej płyty z piwnicy, to jest w dobrym stanie.

    Nowaczke wrote:
    ale w płycie nie działają złącza SATA.

    Jakie dyski podpinałeś SATA III ?
    Jeśli tak, to płyta może mieć problem z odczytem, w dysku trzeba ograniczyć transfer. Można to zrobić za pomocą zworek na dysku, lub programowo (zależy od typu dysku)
    I jeszcze jedno na temat wykrywania dysku SATA, jeśli to jest XP to trzeba zintegrować sterowniki SATA, ten system ich nie posiada.
  • #26
    Nowaczke
    Level 8  
    kokapetyl wrote:
    Jeśli to są zdjęcia tej płyty z piwnicy, to jest w dobrym stanie.
    W razie czego to ta płyta nie leżała gdzieś na wierzchu w piwnicy, przy oknie, czy jakimś innym wilgotnym miejscu. :) Jak kupiłem nowy komputer, to wyjąłem go, a stary PC powędrował do kartonu po nimi i tak przeleżał sporo czasu w piwnicy.
    kokapetyl wrote:
    Jakie dyski podpinałeś SATA III ?
    Jeśli tak, to płyta może mieć problem z odczytem, w dysku trzeba ograniczyć transfer. Można to zrobić za pomocą zworek na dysku, lub programowo (zależy od typu dysku)
    I jeszcze jedno na temat wykrywania dysku SATA, jeśli to jest XP to trzeba zintegrować sterowniki SATA, ten system ich nie posiada.
    Kupiłem jakiś stary 80 GB dysk Seagate na SATA. Zworką ograniczyłem go, aby pracował jedynie w trybie 1.5 GB/s. Komputer zawieszał się na ekranie kontrolera SATA, zaraz po ekranie początkowym. Raz na sto razy komputer wykrywał dysk i przechodził dalej.
    Hackmsr wrote:
    Niech kolega sprawdzi inne podzespoły na tej płycie głównej.
    Jakie dokładnie podzespoły masz na myśli? Wydaje mi się, że mam na stanie do podmiany wszystko, poza procesorem. Chyba nie znajdę w domu aktualnie nic na tę podstawkę.
  • #27
    DriverMSG
    Admin of Computers group
    Zacznij od podstaw diagnostyki:
    - Sprawdź gniazdo i piny procesora - oczyść, przedmuchaj.
    - Sprawdź napięcie baterii bios - wymień, jeśli ma mniej jak 3V.
    - Podłącz sprawny zasilacz i jeden moduł RAM.
    - Podłącz procesor i głośniczek systemowy (buzzer).
    - Zresetuj ustawienia bios, testuj.
    - Ponów testy sprawdzając RAM w każdym ze slotów.

    Jeśli w każdym z przypadków płyta zgłasza jedynie brak karty graficznej, można przystąpić do jej podłączenia i ponowić testy.
    Kolejnym krokiem są testy samej pamięci w programie MemTest, uruchamianym z nośnika bootującego.

    Jeśli testy wypadną pozytywnie, można sprawdzić stabilność systemu z jakiegoś Linuxa LiveCD.


    Nowaczke wrote:
    Kupiłem jakiś stary 80 GB dysk Seagate na SATA
    Dysk należy sprawdzić przed zamontowaniem - minimum SMART dysku.
  • #29
    Nowaczke
    Level 8  
    Poddałem się. :(
    Miałem pod ręką jeszcze inny komputer i to jego udało mi się przywrócić do życia. Jako że używa on pamięci DDR, dorzuciłem do niego problematyczne pamięci z poprzedniego PC i oczywiście działają bez problemu. Na początku włączyłem MemTest i nie wykrył on niczego niepokojącego.
    Specyfikacja:
    - Płyta główna: Asus A8N-E Rev 2,
    - Procesor: AMD Athlon 64 3200+ (2000 MHz),
    - Zasilacz: Tracer 4Life/400HellFire (tak, wiem, ale przez ostatnie 10 lat ten komputer działał z tym zasilaczem i na razie wciąż będzie z nim pracował),
    - Pamięć: 4 x 512 MB DDR @ 400 MHz,
    - Karta graficzna: Leadtek WinFast PX6600 (nVidia GeForce 6600) PCIe 128 MB DDR 128-bit,
    - Dysk twardy: WD800BB-00JHA0 (80 GB) ATA,
    - Monitor: Philips 150B5 (VGA),
    - System: Windows XP SP3.
    Wykrywanie błędnej ilości pamięci RAM w starym PC

    Wielkie dzięki Wszystkim za pomoc. :)