Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

RPi3 max pobór na 1A i nie chce więcej

12 Kwi 2016 22:16 1941 6
  • Poziom 9  
    Cześć, mam problem ze swoim raspberrypi 3

    Ostatnimi czasy coraz częściej pokazuje mi się kwadrat w rogu informujący o słabym zasilaniu. Nie wierzyłem w swoją ładowarkę więc zakupiłem miernik V/A podpinany do USB i widzę, że moje Rpi3 nie chce przez micro usb pobierać więcej niż 1A.
    Kiedy dobija do tego 1A wyświetla się w rogu tęczowy kwadrat informujący właśnie o tym słabym zasilaniu.

    Tym samym miernikiem i ładowarką testowałem swój telefon i power bank aby zobaczyć ile potrafi dać prądu.
    Podczas ładowania 2 urządzeń (telefon pobiera 1,5A, powerbank w porywach do 2A) pokazywało coś około 2,8A i ładowarka USB dosyć mocno się grzała - potrafi oddać 3A wg specyfikacji.
    Następnie testowałem Rpi3 na tych samych kablach gdzie bez problemu power bank ciągnął około 2A.
    Mam więc wykluczone: ładowarka, kable, miernik, wszystko działa ok.

    Natomiast na Rpi3 nigdy nie skacze powyżej 1A nawet jak odpalę stress, podepnę mechaniczny dysk do USB i zacznę go męczyć bonnie++, zacznę coś przerzucać po wifi, i puszczę jakiś obraz na hdmi.
    Wszystko działa, nie zawiesza się, ale w rogu mam ten upierdliwy kwadrat (na każdej dystrybucji) i ładowarka nie rozgrzewa się tak szybko jak przy mega teście telefonu i powerbanku.

    Przy wpiętym dysku na usb i stress na cpu mam równe 0.9A i napięcie 5.05V więc jest bardzo dobrze i zero alertów.
    Odpalam dodatkowo bonnie++ aby dysk trochę więcej prądu chciał i wybija się na 0.96A przy 5.04V, od razu pojawia się kwadrat w malinie, i natychmiast spada na mierniku natężenie na 0.67A podnosząc napięcie na 5.06V.

    Może miernik jest zbyt wolny aby to wyłapał spadek w stosunku do maliny.
    Przy 1.9A (Rpi3 plus ładowanie telefonu) mam 4.99V skaczące na 5.00V więc spokojnie mieści się w normie +-0.15.

    Testowałem na osmc, raspbian, openelec więc nie jest to wina konkretnej dystrybucji, ani ustawień (domyślne obrazy).
    Ma ktoś jakiś pomysł co to może być i jak podać mojej malinie więcej prądu - może przez GPIO??
    Albo czy ma ktoś jakaś malinę3 i dysponuje miernikiem aby sprawdzić ile w stressach pokazuje Amperów - może te szpilki przy poborze są tak szybkie że miernik nie zdąży odczytać wartości.

    Ma ktoś jakieś pomysły? Micro usb więcej nie daje i muszę zasilać go przez gpio?
  • Specjalista - Mikrokontrolery
    Pod spodem masz takie coś jak bezpiecznik polimerowy oznaczony jako F1, przy microUSB. Zewrzyj go do testów i zobacz co będzie się działo.
  • Poziom 9  
    Zwarłem, nic to nie daje na mierniku nie widać aby przeskoczyło 1A i takie same objawy pod stressem.
    Może ta moja ładowarka jest coś nie teges...
    Pod ładowarką telefoniczną LG 1.8A mam cały czas alert o słabym zasilaniu.
    Chyba się szarpnę i kupię oryginalną pod rpi3 2,5A 5.1V bo może te od telefonów/tabletów rzeczywiście są jakieś trefne.


    PS. Podpiąłem sobie pico USB (do teestów nie używałem aby ładowanie baterii nie fałszowało pomiaru). Potrafi ono czytać status napięcia wejściowego jakie dociera do RPi3

    zasilane po kablu:
    ***********************************
    Powering Mode: RPi
    BAT Volatge: 4.21 V
    RPi Voltage: 4.76 V
    SOT23 Temperature: 28 C
    ***********************************

    A na liczniku w zasilaczu 5.03V.
    Skąd takie rozbieżności - aż tyle tracę na kablu który testowałem i który spokojnie dawał 2A do powerbanka przy 5V?
    Odpinam zasilanie aby szło z ogniwa LIPO via ups i jest elegancko:

    Na LiPo z ups (zasila przez GPIO)
    ***********************************
    Powering Mode: BAT
    BAT Volatge: 4.13 V
    RPi Voltage: 5.13 V
    SOT23 Temperature: 30 C
    ***********************************

    Teraz qrcze pytanie, czy to gniazdo micoro usb jakieś lewe, albo coś w samym RPi3.
  • Poziom 21  
    Produkowane teraz kable są naprawdę miernej jakości. Ale z podstaw elektrotechniki wiemy, że prąd w obwodzie jest ten sam niezależnie gdzie wpinasz miernik, ale już napięcie ma wartość 5 V tylko zaraz za ładowarką. Uwzględniając rezystancję przewodu do płytki może docierać sporo mniej. Przy pomocy zwykłego miernika sprawdź napięcie na gnieździe zasilającym malinę. Użyj markowego, krótkiego kabla...
  • Poziom 9  
    Markowe kable są, wykazał to test na innych odbiornikach. Mam kilka chińskich dziadostw i tam rzeczywiście opór jest duży i max prąd do źródła to nawet poniżej 1A.
    Patrząc na schemat maliny wystarczy że zmierzę napięcie pomiędzy metalową obudowa micro usb, a F1. Znajdę tylko miernik i podzielę się wynikami, może szybciej przyjdzie mi dedykowany zasilacz dla RPi3 2.5A z logiem maliny i problem magiczne się rozwiąże.

    Ps. Zauważyłem że miernik usb już trochę został zmęczony, trzeba go mocno odginać aby dociskał teraz styków i pokazał 2A podczas ładowania powerbanku.
  • Poziom 9  
    Dedykowany zasilacz rozwiązał wszystkie problemy. Na oko średnica 2 przewodów które z niego wychodzą jest większa niż całość na kablu usb (a tam są 4 żyły, plus jeszcze czasem ekran na obudowę).