Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Lenovo IdeaPad Flex 10 - Płyta po innym serwisie, martwa, brak 3 i 5V

17 Kwi 2016 15:45 4839 22
  • Poziom 16  
    Bardzo proszę o pomoc bo utknąłem. Cały dzień zajęły mi poszukiwania schematu czy boardview i analiza płyty głównej z rozszyfrowywaniem skróconych oznaczeń układów. Schematu nie ma, ale co nieco ustaliłem.

    Lenovo IdeaPad Flex 10
    płyta: BM5338 rev 1.6 (platforma bitland)
    hybryda procesor+pch: sr1w2 (intel mobile pentium N3530)
    zasilanie: 3 pin, 20V 2.25A


    Płyta po innym serwisie. To był pierwszy serwis tego laptopa. Mieli tylko wymienić gniazdo zasilania. Fajnie to wygląda :) (proszę zobaczyć zdjęcia) Pewnie użyli stare, żeby testować płytę, a ta nie wstaje. Brak śladów na nogach biosów, KBC i przetwornic, ale w pierwszej kolejności postanowili grzać hybrydę (cpu+pch) bo sticker przypalony i topnik pod układem :)


    problem? - brak napięć 3/5V, ale vin/b+ jest.

    ZDJĘCIA:
    Lenovo IdeaPad Flex 10 - Płyta po innym serwisie, martwa, brak 3 i 5V Lenovo IdeaPad Flex 10 - Płyta po innym serwisie, martwa, brak 3 i 5V Lenovo IdeaPad Flex 10 - Płyta po innym serwisie, martwa, brak 3 i 5V
    Lenovo IdeaPad Flex 10 - Płyta po innym serwisie, martwa, brak 3 i 5V Lenovo IdeaPad Flex 10 - Płyta po innym serwisie, martwa, brak 3 i 5V Lenovo IdeaPad Flex 10 - Płyta po innym serwisie, martwa, brak 3 i 5V
    PU6: przetwornica 3/5V z oznaczeniami EN=1D. Będzie to richtek RT8205MZQW. Przełączanie na tranzystorach B20 NO3.
    PU2: przetwornica 5V? z oznaczeniami AEAE 87, co wskazuje na MPS NB671GQ-Z
    KBC: IT8528E 1417 EXA
    BIOS: EC (64KByte/512KBit) + MAIN (8MByte/64MBit)
    linki do datasheet-ów:
    RT8205MZQW http://www.richtek.com/assets/product_file/RT8205L=RT8205M/DS8205LM-05.pdf
    NB671GQ-Z http://www.s-manuals.com/pdf/datasheet/n/b/nb671_r1.02_mps.pdf
    IT8528E 1417 EXA tylko taki pinout http://www.datasheet-pdf.info/attach/1/2191298859.gif

    Gniazdo sprawdziłem pod kątem zwarć i poprawności wlutu i jest ok, więc chwilowo zostawiam sprzątanie po nich na później.

    Rezystancja do masy po odłączeniu wszystkiego i napięcia po podłączeniu zasilacza serwisowego.
    gniazdo zasilania: 22kOhm
    Cewki:
    PL8(3V): 0V, 7k Ohm
    PL9(5V): 0V, 19k Ohm
    PL10(bateria): 2.96V, nieskończoność
    PL5(ram): 177k Ohm
    PL6(cpu/pch): 8.2 Ohm
    PL7(cpu/pch): 8.3 Ohm
    L12(?): 114k Ohm

    pobór płyty 0.00A[/b] aż do 20V
    brak sygnalizacji ładowania baterii, bateria padnięta zupełnie (nietypowa, nie mam na podmiankę)
    brak reakcji na włącznik (ciągłość do KBC sprawdzona)

    przetwornica 3/5V, układ PU6, RT8205MZQW:
    test diody na zwarcie do masy: masa tylko na pinach masowych.
    Piny:
    1 entrip1=0V 166k Ohm
    2 fb1=0V 166k Ohm
    3 rev=2V
    4 tonsel=5V
    5 fb2=0V 7k Ohm
    6 entrip2=0V 166k Ohm

    7 vout2=0V
    8 vreg3=3V
    9 boot2=4.56V
    10 ugate2=0V
    11 phase2=0V
    12 lgate2=0V

    13 EN=2.74V
    14 skipsel=2V
    15 GND=masa
    16 Vin=20V
    17 Vreg5=5V
    18 secfb=0.39V

    19 lgate1=0V
    20 phase1=0V
    21 ugate1=0V
    22 boot1=4.56V
    23 pgood=0V
    24 vout1=0V

    4 tranzystory przełączające na liniach 3 i 5 oraz kondensatory w drobnicy dookoła brak zwarć.

    Skoro mamy takie warunki jak: 1.vin, 2.EN stan wysoki, 3.vreg3 i vreg5 obecne, 4 boot1-2= 5V, 5 rev=2V, 6 rezystancja na lini 3 i 5V powyżej 100 Ohm
    to dlaczego ta przetwornica nie startuje?

    KBC to ITE IT8528E 1417 EXA.
    masa tylko na pinach masy ORAZ na pinie 128! jest to CK32K/GPJ6 (FLASH_DESCRIPTOR?)
    piny:
    3 VBAT=3.35V (oraz połączone piny VSTBY1-6+PLL)
    74 +3VACC=3.35V
    11 VCC=0V (próbowałem wyśledzić drogę i są 2-3, jedna prowadzi z cewki PL8 5V. Czy kbc dostaje napięcie tylko z tej cewki? czy to tylko wsparcie?)

    BIOS:
    po zdjęciu kości EC (64KByte/512KBit) i wsadzeniu w programator niespodzianka - tylko 3 linijki zapisane a reszta była ff! Coś zamazało cały wsad. Wgrałem prawidłowy ale od wersji 1.4, bo tylko taką znalazłem. Zrobiłem to samo z kością biosu MAIN (8MByte/64MBit). Ta nie miała braków. Sytuacja bez zmian. Po podaniu napięcia na płytę, ponownie wylutowałem bios EC aby sprawdzić czy KBC nie zamazuje wsadu, ale jest cały.

    Bateria RTC ma 3V. Odlutowałem i odczekałem (aby zrestartować zegar) i wlutowałem - brak zmian.

    Zdjąłem cewkę PL9 (5V) i przyłożyłem zasilacz serwisowy na pad po stronie kondensatorów filtrujących. Stopniowo podnosiłem napięcie aż do 5V. Pobór wynosi 0.02A. To samo zrobiłem z PL8 (3V). Przy 3V pobór wynosi 0.06A.

    Nie mam przy sobie ani takiego KBC ani takiej przetwornicy, więc szykują się zakupy. Osycloskop jest dalej w dziale "marzy mi się".

    Proszę pomóc mi, przywrócić tą płytę do życia.
  • Pomocny post
    Spec od monitorów
    (':!:') Kol. popraw
    - napisałeś (płyta: BM5538 rev 1.6 (platforma bitland) )

    Zaś na foto.(dół-lewa_strona) jest BM5338 rev.1.6
    * standartowo pod SR1W4 (Celeron N2830)
    ___________________________
    RT8205M(L) Link sterowany jest
    - syg, na EN - tylko dla uruchomienia Vreg 3,3V i 5V oraz V REF.
    - natomiast napięcia właściwe pojawią się gdy na ENTRIP1 oraz ENTRIP2 masz odpowiedni poziom napięcia

    Poczytaj zasada działania tego IC
    Jeśli na pin.VREG5 masz własciwe napięcie to dzięki elementom _oporniki przy pin."ch Entrip klucze na polowych tranzystorach (do masy) sa wysterowywane. * prąd z wewn.zródeł ref. wymusza odpowiedni poziom napięcia i IC się uruchamia
    Cytat:
    If the VREG5 voltage is, resistors ENTRIP s must appear the levels of internal current sources (10 µA), which are powered from VREG5. If a level becomes more than the threshold (in the range 0.5 V - 2V to RT8205A), resp. the output of the PWM voltage will appear (i.e. it will turn on).


    Jeli zaś masz na Entrip na nich "zero V" w przypadku obecności VREG5 - znaczy, sterujące polowe klucze "sadzą" ENTRIP-y do masy.
    Trzeba szukać problemu nie w IC, a w tym czemu nie otwierają się te klucze (sterowanie)

    Ważne:
    "3.3V and 5V LDO Output : 70mA" (RT8205A)
    * "3.3V and 5V LDO Output : 100mA" (RT8205L)
    czasem te nadmiarowe 30mA jest tym "jezyczkiem uwagi" przy niedziałaniu.
    patrz np. SM pod LA-8712P Rev1.0

    W zał. Bios"y
  • Poziom 16  
    lisek napisał:
    (':!:') Kol. popraw
    - napisałeś (płyta: BM5538 rev 1.6 (platforma bitland) )
    Zaś na foto.(dół-lewa_strona) jest BM5338 rev.1.6
    tak, moja nieuwaga. poprawiłem.
    Cytat:

    RT8205M(L):
    - syg, na EN - tylko dla uruchomienia Vreg 3,3V i 5V oraz V REF.
    dzięki, bo myślałem, że wszystko załącza.

    Cytat:

    - natomiast napięcia właściwe pojawią się gdy na ENTRIP1 oraz ENTRIP2 masz odpowiedni poziom napięcia...
    ...dzięki elementom _oporniki przy pinach Entrip klucze na polowych tranzystorach (do masy) sa wysterowywane. * prąd z wewn.zródeł ref. wymusza odpowiedni poziom napięcia i IC się uruchamia...
    Jeli zaś masz na Entrip na nich "zero V" w przypadku obecności VREG5 - znaczy, sterujące polowe klucze "sadzą" ENTRIP-y do masy.
    Trzeba szukać problemu nie w IC, a w tym czemu nie otwierają się te klucze (sterowanie)

    ok, czyli jeśli będę miał 0V na obu pinach entrip to przetwornica nie będzie generować pulsów sterujących tranzystory od linii 3 i 5 V? Bo tak jak napisałem na początku, mam tam 0V.
    Spójrz poniżej na schemat umowny z noty katalogowej RT8205M. Tam jest pokazane, że entrip-y powinny być wyprowadzone do masy poprzez rezystory 155K Ohm. U mnie na płycie są takie rezystory tyle że mają 166k i 167k Ohm i jest 0V.
    Lenovo IdeaPad Flex 10 - Płyta po innym serwisie, martwa, brak 3 i 5V

    ALE
    poniżej jest schemat z płyty samsunga z platformy LA-8868P. Tam jest co prawda RT8205L ale różnica pomiędzy wersją z końcówką M to tylko pin 18 czyli secfb.
    Lenovo IdeaPad Flex 10 - Płyta po innym serwisie, martwa, brak 3 i 5V
    OK zobacz, że oba entrip-y oprócz do rezystorów, prowadzą też do wspomnianych przez Ciebie tranzystorów polowych (na schemacie PQ333A i 333B) i ja go (bo u mnie to jeden podwójny tranzystor) odnalazłem miernikiem metodą testu diody na swojej płycie, oraz znalazłem tranzystor poniżej (PQ334)co steruje tymi dwoma. Na tym PQ334 mam na pinie3 masę, a na pinie 1 dojście do bramek tych dwóch PQ333, więc wszystko się zgadza. PQ334 na pinie 2 ma 3,34V, a na bramkach tych PQ333 jest 3,32V. Czy to oznacza, że jeśli na bramach mamy tu 3V to te tranzystory będą (jak to nazwałeś) "sadzić" entrip-y do masy i dlatego przetwornica do końca nie wstaje? Nic tu nie ma zwarć.
  • Pomocny post
    Spec od monitorów
    Popatrz np. w schemat od Link_ LA-8714p_HP , gdzie jest RT8205LZ
    *pin.18 secfb nie wykorzystany
    * jeśli ten pin.18 jest w "powietrzu" można zastosować oprócz orginału , każdy z 8205,lub nawet TPS51125 (ma 100mA LDO)
    podobnie w LA-8712P Rev1.0
    Poniżej masz fragment z LA-8714p
    Lenovo IdeaPad Flex 10 - Płyta po innym serwisie, martwa, brak 3 i 5V

    Nastąpiła mała pomyłka w opisie
    (':idea:') - to sygnały na Entrip1/Entrip2 są "sciągane do masy" przez polowe (nie jak pisałem )
    (':idea:')

    Czyli jeśli masz VREG5 (a masz ) zaś na Entrip1/2 "0V" to szukaj uszkodzenia w otoczeniu tych polowych lub ich sterowaniu

    Reszta ok. czyli
    Cytat:
    If the VREG5 voltage is, resistors ENTRIP s must appear the levels of internal current sources (10 µA), which are powered from VREG5. If a level becomes more than the threshold (in the range 0.5 V - 2V to RT8205A), resp. the output of the PWM voltage will appear (i.e. it will turn on).

    Pokrywa to się z opisem kol.
    Cytat:
    schemat z płyty samsunga z platformy LA-8868P


    ______________
    Układy RT8205x są b. wrażliwe i często się uszkadzają.
  • Poziom 16  
    lisek napisał:
    jeśli masz VREG5 (a masz ) zaś na Entrip1/2 "0V" to szukaj uszkodzenia w otoczeniu tych polowych lub ich sterowaniu
    Bardzo dobry trop. Podobnie kolega z innego forum radził aby od razu zdjąć z płyty ten podwójny tranzystor polowy najbliższy entrip-om, oraz ten który steruje tym podwójnym i zobaczyć co się stanie.

    Zdjąłem i przetwornica wystartowała. Mam już 3.32V i 5.02V na cewkach :D Czyli mieliście rację.
    ALE! płyta nie wstaje
    -wylutowane tranzystory są sprawne
    -na pinach entrip pojawiło się 1.68V, a na padach bramek zdjętego podwójnego tranzystora od entrip-ów mam dalej 3,24V, więc tu trzeba to zbadać.
    -na włączniku power mam 3.32V a po wciśnięciu spada do 0 i brak reakcji (jak mówiłem wcześniej ciągłość tej linii do KBC sprawdzona)
    -po podłączeniu baterii nie ma sygnalizacji ładowania a napięcie na cewce od baterii spada z 2,98 na 1,03V (może wina zasilacza serwisowego - oryginalny zasilacz ma 3 piny)
    -KBC: dwie niedobre sprawy - pin 11-VCC: dalej 0.02V, oraz pin 19-SUSON: 0.65V
    -napięcie na kostce biosu EC jest 3.29V (było takie wcześniej), ale pojawiło się w końcu napięcie na kostce MAIN. Było ledwo ponad 0 a teraz jest 1.81V.
    Te napięcia się zgadzają bo kość EC to Winbond 25X05CL (64KByte/512KBit, litera L napięcie 2.3-3.6V), oraz MAIN: Winbond 25Q64DW (8MByte/64MBit, litera W=1.7-1.95V)

    Słuchaj a KBC? Nie jest jakiś taki podejrzany? Zbiorę fakty:
    -przetwornica 3/5V w 100% sprawna bo działa prawidłowo,
    -co wystawia sygnał do kierowania tranzystorami polowymi, które ciągnęły entrip-y przetwornicy do 0V? może właśnie KBC? i on ją blokował?
    -KBC ma masę na pinie 128 a nie jest to masa według datasheet-u
    -KBC na pinie 19 suson ma jakąś szopkę. (raz włącze zasilacz to jest 0.4V, raz 1,44V, a teraz 0,6V)
    -pin11 Vcc KBC ma dalej 0V, może KBC go ciągnie w dół? i gdybym zdjął KBC to wróciłoby tu napięcie?
    -jak pisałem wcześniej bios EC od KBC został kompletnie zamazany (trzy linijki kodu, reszta FF) Może KBC go zamazał bo ma bałagan pod sufitem
    -brak reakcji na power
    -brak ładowania baterii (jeśli KBC w ogóle cokolwiek rozkazuje chargerowi)

    Czy to wszystko nie zaczyna przemawiać za uwalonym KBC?

    Moderowany przez RADU23:

    Proszę nie używać pogrubionej czcionki bez potrzeby. By zadać pytanie, nie trzeba go wyróżniać.

  • Pomocny post
    Spec od komputerów
    psycode napisał:

    Czy to wszystko nie zaczyna przemawiać za uwalonym KBC?

    Podstaw układ to chwila roboty a z analizy opisu jest bardzo podejżany.
  • Poziom 29  
    Doklładnie jest tak jak kol boro1234567 pisze, poza tym ja bym tak nie wieszał psów na poprzednim serwisie bo nie wiadomo jak to było - środkowy pin z gniazda zasilania to id zasilacza idący bezpośrednio na przetwornik ac w kbc a praktycznie o grubość cienkiej plastikowej ścianki gniazda od niego są piny plusowe, wystarczy że użytkownik próbuje pracować z połamanym gniazdem i jeden pin zetknie się z drugim - trafiają póżniej takie lenovo do serwisu z opisem "uszkodzone gniazdo ale pracował mimo to , obecnie już się nie uruchamia", w domyśle nadzieja że naprawa to będzie koszt gniazda plus drobne na piwo dla serwisanta :).
  • Spec od monitorów
    Masz uszkodzony KBC , popatrz np.w platformę Quanta U92 (schemat dostępny) jest ten sam KBC ITE IT8528E

    Ponadto masz wej.3-pin. czyli sygnał z "igły" na bank idzie na KBC (AD_TYPE , chyba na pin.71 KBC)

    __________
    Masz rozwiązanie z Quanta U92 poniżej gdzie owe sygnały z gniazda 3-pin. idą na KBC (str.27)

    Lenovo IdeaPad Flex 10 - Płyta po innym serwisie, martwa, brak 3 i 5V

    W zał. schemat IT8528E
  • Poziom 16  
    boro1234567 napisał:
    Podstaw układ to chwila roboty a z analizy opisu jest bardzo podejżany.
    Roboty chwila ale trzeba ten układ jeszcze mieć :) zamówiłem dopiero.
    strucel napisał:
    ja bym tak nie wieszał psów na poprzednim serwisie bo nie wiadomo jak to było
    zakładam taka możliwość, że to mogło być stare gniazdo, które miało popękane piny i je sobie przylutowali tylko tymczasowo aby badać dalej płytę, ale litości - jak Ci brakuje 3/5V to grzejesz PCH+CPU? Nogi biosu były nietknięte, więc nie programowali, nogi KBC ani piny przetwornicy - też nie, więc nigdzie nie było śladów ingerencji - tylko gniazdo, więc postanowili grzać pch+cpu? Czy to jest normalne? Mało tego wmawiali, że klientka nie dała zasilacza - a dała. Może go uwalili i musieli jakoś bronić się przed kosztami. Skasowali za naprawę 150zł i oddali laptopa w częściach bo nie dało się złożyć obudowy przez niewycentrowane gniazdo zasilania. Studentka się kłóciła o swoje ale nic to nie dało. a przecież koszt gniazda to 8zł. Dlaczego nie wlutowali nowego i tak nie oddali w całości jak należy? Można skasować za nieudaną naprawę jeśli poświęciło się dużo czasu, ale 150zł? Nie mam taryfy ulgowej dla takich ludzi. Jakby można było mieć tutaj psy, to bym na nich je publicznie powiesił. :)

    lisek napisał:
    Ponadto masz wej.3-pin. czyli sygnał z "igły" na bank idzie na KBC (AD_TYPE , chyba na pin.71 KBC)
    dziękuję za namiary na schematy. Z tą igłą i wklejonym kawałkiem schematu, to chodziło Ci o potwierdzenie, że 3ci pin gniazda zasilania DC JACK idzie prosto do KBC jako 6ty pin AD_ID na schemacie?
    Zamówiłem oryginalny zasilacz, bo ten co miałem był pożyczony i muszę oddać. Narazie mam więc tylko serwisowy. Tak czy inaczej - jeśli gniazdo było luźne, nie stykało, a klientka im ruszała i dociskała to połamane piny mogły zrobić zwarcie i np 20V poleciało na KBC i go uwaliło, poprzez ten pin AC_ID, tak?

    Zdjąłem KBC i pad 19=0V, pad 128=masa. Tu trochę się rozjaśniło bo patrzyłem już na inny schemat z platformy quanta u92 i tam jest ten sam KBC i tam 128 jest podpięte też do masy, więc zależy od platformy, więc ten trop zostawiam.
    a na bramkach zdjętego podwójnego tranzystora jest dalej 3,24V. Po wlutowaniu go z powrotem (i tego drugiego też) - znowu entrip-y mają 0 i brak 3 i 5V.
    Skoro na drenach tego podwójnego są entrip-y a na źródłach masa - to dopóki na bramkę idzie 3,24V to tranzystor będzie nieco przepuszczał i będę tracił napięcie na entrip-ach i tym samym przetwornica nie włączy 3V i 5V. Nie wiem po co jest tam ten tranzystor... może to badanie płynącego prądu - tzw current sense.
    Ok czekam na KBC
  • Poziom 31  
    Po prostu partacze i zdzieracze bez jakiejkolwiek większej wiedzy i umiejętności cóż więcej pisać, pewnie klientka zrobi im odpowiednią reklamę
  • Poziom 16  
    slawmix1234 napisał:
    Po prostu partacze i zdzieracze bez jakiejkolwiek większej wiedzy i umiejętności cóż więcej pisać, pewnie klientka zrobi im odpowiednią reklamę
    Najlepsze jest to, że to był jej pierwszy serwis i laptop na którego długo zbierała. Jak brałem tą płytę to się normalnie bała, że znowu będą wydadki a nic z tego nie będzie. Takich klientów mi szkoda. Facet pójdzie, zrobi aferę i odzyska co jego - czujemy się pewniej w elektronice, a kobieta co zdziała? Owiną ją wokół palca i oskubią.
  • Spec od monitorów
    Skoro zdjąłeś ten podwójny polowy .. SSM6N7002FU po "entripach" i
    Cytat:
    Mam już 3.32V i 5.02V na cewkach

    czyli masz +3VALWP oraz +5VALWP

    Zmierz oporności w tych liniach.
    ma być więcej jak 1k_Ohm w obu liniach.

    ???
    Jak masz mało w jednej np. +5VALWP , zastosuj metodę zwarciową (zasilacz z reg.pradu) i znajdz winnego
    - może w zasilaniu USB, może w której z DC-DC np. +1,1VALW
  • Poziom 16  
    lisek napisał:
    Skoro zdjąłeś ten podwójny polowy .. SSM6N7002FU po "entripach"...
    W końcu ogarnąłem start przetwornicy. Jest trochę inaczej niż na schematach z tą przetwornicą rt8205l/m.
    Entripy są podpięte pod rezystory i tu się zgadza ALE są także tranzystory. Jeśli drugi nie dostanie nic od KBC na bramkę to nie zabierze napięcia 3.24V docierającego na bramkę pierwszego, a skoro idzie tam napięcie to ten tranzystor otwiera masę na entripy z rezystorami podpiętymi do masy, dlatego przetwornica nie startuje z 3/5V.

    Narysowałem na szybko (więc nieprofesjonalnie) jak to wygląda (przyda się komuś kto trafi na ten temat z tym samym problemem):
    Lenovo IdeaPad Flex 10 - Płyta po innym serwisie, martwa, brak 3 i 5V

    Czyli o starcie 3/5V decyduje KBC. Jeśli nie wystawi stanu wysokiego na 84 to nie będzie 3/5V na płycie. Czy to rozwiązanie służy to oszczędzania baterii? W sensie - gdy KBC wykryje zasilacz to włącza 3/5V na płycie, a kiedy nie wykryje to nie włącza 3/5V (a on sam i jego bios EC jak sprawdziłem jest zasilany prosto z vreg3).

    Przyszedł już nowy KBC i zasilacz 3 pin. Wlutuję i dam znać.

    EDIT
    Po wlutowaniu KBC i podłączeniu zasilacza 3 pin w końcu mam 3/5V na cewkach bez kombinowania. Czyli ten etap jest ogarnięty.
    (bo teraz KBC wystawia stan wysoki na pin 84, przez co znika 3.24V z bamki podwójnego tranzystora, a to zabiera masę z entripów, więc zostają im same rezystory dlatego ostatecznie przetwornica wstaje całkowicie i jest 3/5)

    Przy pierwszym podłączeniu płyta przeszła w stan S0 bo zaświeciły się diody od power i nagrzewał się procesor/pch.
    Wyłączyłem ją i podłączyłem tasiemkę z matrycą. Brak reakcji na power, więc sprawdziłem gniazdo i tasiemkę pod kątem zwarć. Czysto.
    Po odłączeniu tasiemki, płyta znowu przeszła w stan S0. Wyłączyłem i tym razem podpiąłem HDMI i zewnętrzny monitor. Znowu brak reakcji na power.
    Po odłączeniu Hdmi, znów brak reakcji na power. Pin 125 KBC ma 3,32V a po wciśnięciu power jest 0V więc tu jest ok.
    Po długim odczekaniu i podłączeniu płyta znów jakby wstaje bo świeci się power ale nie grzeje się cpu/pch
    W takim stanie mierze napięcia na cewkach: PL8:3V, PL9:5V, PL10(bat): 3V (a z baterią 1V) (bateria ma nadruk 11,1V, a jej napięcie to 1.01V może spadła zbyt nisko),
    oraz nowość cewka L12: 1,08V. Reszta cewek 0V.
    Po którymś razie udaje się włączyć płytę z HDMI - brak obrazu.
    wylutowywuję biosy. EC w porządku. Main kompletnie pusty! (a nie był). Wgrałem wsady z powrotem. Weryfikowałem 2 razy. Po wlucie brak zmian. Napięcie na kości MAIN w porządku.

    pomiary z KBC:
    pin14: 3.32V
    pin19: 2.54V
    pin120: 3.30V

    pomiary z gniazda baterii z podpiętą baterią:
    1: 1.03V
    2: 1.03V
    3: 3.33V (biały)
    4: 3.33V (zółty)
    5: 0.10V (zielony)
    6: masa
    7: masa
    (bateria ma nadruk 11,1V. może spadła zbyt nisko i dlatego charger jej nie ładuje?),

    Pomiary z charger-a BQ24735 (różnice z baterią w nawiasach)
    1 acn: 20.3V
    2 acp: 20.3V
    3 cmsrc: 20.3V
    4 acdrv: 26.1V
    5 acok: 3,32V (z baterią: 3.34V)

    6 acdet: 2.88V
    7 iout: 0V
    8 sda: 3.34V (z baterią: 3.33V)
    9 scl: 3.34V (z baterią: 3.33V)
    10 ilim: 0V (z baterią: 0.64V)

    11 batdrv: 2.99V (z baterią: 1.05V)
    12 srn: 2.98V (z baterią: 1.03V)
    13 srp: 0V (z baterią: 1.03V)
    14 gnd: masa
    15 lodrv: 0V

    16 regn: 5.95V
    17 btst: 5.59V (z baterią: 5.56V)
    18 hidrv: 2.98V (z baterią: 1.03V)
    19 phase: 2.98V (z baterią: 1.03V)
    20 vcc: 20.1V

    bardzo proszę o dalsze wskazówki

    Posty scaliłem
    RADU23
  • Spec od monitorów
    Na jakim układzie masz zrobiony charger (BQ or ISL, ) na tej MB Pegatron BM5338 Rev. ?
  • Pomocny post
    Spec od monitorów
    BM5338 rev 1.6 (platforma Bitland), płyta od Pegatron

    CMSRC(3) -18,8V * ACN=ACP=CMSRC
    ACDRV(4)- 24V
    ACOK(5) - >2,5V (3.3)
    ACDET(6) -2,8V
    ILIM (10)

    Patrz w SM od Scala3-14, SCALA3-15/17CRV, LA-8712P,LA-8061 ... tam masz ten BQ735
    Popatrzza danymi o nim na forum, opcja Szukaj.

    Cytat:
    Adapter Over Voltage (ACOVP)
    When the ACDET pin voltage is higher than 3.15V, it is considered as adapter over voltage. ACOK will be pulled low, and charge will be disabled. ACFET will be turned off to disconnect the high voltage adapter to system during ACOVP.
    BATFET will be turned on if turns on conditions are valid.
    See the System Power Selection section for details.


    Lenovo IdeaPad Flex 10 - Płyta po innym serwisie, martwa, brak 3 i 5V
  • Poziom 16  
    dzięki Lisek.

    Siedziałem nad tym ponad 2godziny. Odszyfrowałem trochę elementów zgodnie z podobnym schematem co mi dałeś... ale nic złego nie znalazłem. Podciągnąłem nawet baterię do 11V - myślałem, że jak ma 1V to nie będzie ładowana. Nic to nie zmieniło.
    Ja nie wiem jak Wy sobie dajecie rade z płytami bez schematów czy boardview. Rozumiem - sa podobieństwa na innych platformach, ale wystarczy jedna-dwie różnice i już tego nie odnajdziesz. A tu i przetwornica 3/5 i wyprowadzenia KBC i charger mają dużo róźnic. Nawet jak zdnajduję trop to tranzystory sprawdzę, zwarcie na kondensatorach też - ale jak ustalić bez schematu prawidłową wartość kondesatora czy rezystora? To się troche mija z celem.
  • Spec od monitorów
    Lenovo IdeaPad Flex 10 - Płyta po innym serwisie, martwa, brak 3 i 5V

    Cytat:
    "Enable current" and "Disable current" means wrt ILIM setting?
    Will the charging be enabled/Disabled if ILIM pin is between 75mV and 105mV?-
    - Use 0.105V to get enable current. Use 0.075V to get disable current.

    If ILIM pin is between 75mV and 105mV, converter may be off or may be on that depends on the part variation.
    Are you going to set ILIM pin between 75mV and 105mV?
    If yes, please adjust sense resister value to avoid that range.
    * setting ILIM to 250mV to set maximum charging current to 1.25A


    Str.22 zał.

    Masz jakieś impulsy na SCL i SDA bq735? czy tylko statyczny level ?
    Gdy brak zajrzyj do SM np. LA-8061P ... lub w te podane wcześniej
    idą na Aku ...
    Tam czasem te piny przy Aku są dołączone do masy poprzez układ np. SOT-636 code 7D A (MUN5214DW1) lub diody
    Można je wylutować (jak mas diody / lub ten MUN : dwa tranzystory w obudowie> C_E: 3-4/1-6) patrz datasheet) i zobaczyć efekt.
  • Poziom 16  
    lisek napisał:
    Masz jakieś impulsy na SCL i SDA bq735? czy tylko statyczny level ?
    Brak oscyloskopu. Multimetr nie buja napięciem więc niby statyczny, ale wiem, że impulsów tak nie wyłapię.
    Cytat:
    Tam czasem te piny przy Aku są dołączone do masy poprzez układ np. MUN5214DW1) lub diody.Można je wylutować i zobaczyć efekt.
    Sprawdziłem - tutaj takiego nie ma.


    Siedziałem trochę nad tym, ale nawet na dwóch schematach (pegatron va70hw, oraz quanta u92) mających ten sam KBC są różnice w wyprowadzeniach stanów S5-S0.
    Nie ma więc pewności czy to co mierze jest tym czym ma być.
    124=s5on=0.14V
    19=suson=2.69V
    95=mainon=3.34V
    84=vron=3.34v
    88=hwpg=3.32V
    Po wciśnięciu power (125 spada do 0V) a pozostałe nogi się nie zmieniają. Wychodzi z tego bałagan, więc pewnie tutaj wyprowadzenia od stanów są na innych nogach niż w podanych schematach.

    Dodatkowo skoro po wymianie KBC płyta zareagowała na power 2-3 razy i grzał się wtedy cpu/pch, a teraz tego nie robi, to być może coś znowu ubiło KBC i jest ryzyko, że będzie ubiało każde następne. Gniazdo zasilania było wyłamane, klientka przez długi czas je dociskała by laptop działał, to mogło powodować naprężenia płyty a to mogło spowodować ostatecznie pęknięcie jakiejś ścieżki w laminacie lub oderwanie się kulek pod cpu/pch.

    Konsultowałem się więc w sprawie zakupu sprawnej używanej płyty, która jest dostępna w cenie 290zł. Okazało się, że decyzja się zmieniła - mam porzucić naprawę i sprzedać laptopa na części bo klientka upatrzyła sobie lepszego na raty.

    Stwierdzam zatem zgon pacjenta :) Dalsze inwestycje w naprawę organów przy obawie, że być może nastąpił zgon "mózgu" (cpu/pch) nie są już dla mnie opłacalne.
    Muszę nauczyć się, po prostu odpuszczać, szczególnie wtedy kiedy nie ma schematu czy boardview.

    Dziękuję bardzo wam za poświęcony czas i sugestie.
  • Spec od monitorów
    IT8528E-EXA ...skoro masz zasilacz 3-pin. i sygnał ze "szpilki" wtyku zasilania ( ad_id) idzie dalej na pin.71 KBC IT8528E-EXA (ad_type)
    To rozwiązanie z Quanta R75/R76
    Lenovo IdeaPad Flex 10 - Płyta po innym serwisie, martwa, brak 3 i 5V

    Tam jeśli nie startował czasem problem był w R460+ nowy wsad Bios+ KBC

    KBC org. ( IT8528E-EXA) zamieniałeś na ten sam czy na układ z inną rev. np, IT8528E- FXA czy z końc. -AXS/-CXS ?
  • Poziom 16  
    lisek napisał:
    IT8528E-EXA ...skoro masz zasilacz 3-pin. i sygnał ze "szpilki" wtyku zasilania ( ad_id) idzie dalej na pin.71 KBC IT8528E-EXA (ad_type)
    Tam jeśli nie startował czasem problem był w R460+ nowy wsad Bios+ KBC
    szpilka z wtyczki zasilacza to prawdopodobnie tylko rezystor 175K do masy. A na szpilce po stronie płyty jest napięcie po dzielniku rezystorów, które bierze sie z +3VPCU, więc niby podobnie ALE jest jednak inaczej - odnalazłem te dwa rezystory, bliższy szpilki ma 750K, a dalszy 466K.Po między nimi jest linia +3VPCU. Nie ma diody, ale za tym 466K jest jakiś układ w obudowie sot23 o oznaczeniu K03hB. Nic z tych rzeczy nie łaczy się bezpośrednio z KBC. A na nodze 71 mam 3.14V. Skoro kilka rzeczy jest tutaj inaczej rozwiązanych niż na podobnych schematach to znaczy dla mnie, że bez schematu sobie nie poradzę.

    Cytat:
    KBC org. [u]( IT8528E-EXA) zamieniałeś na ten sam czy na układ z inną rev.
    oczywiście wstawiłem nowy ten sam EXA.

    Dzięki Lisek za pomoc. Ty pewnie byś tą płytę ogarnął na ślepo - ja bez schematu mam jej już dosyć ;)
  • Spec od monitorów
    Cytat:
    Ty pewnie byś tą płytę ogarnął na ślepo - ja bez schematu mam jej już dosyć


    Niestety bez SM to zabawa na dłuższy okres, też czasem siedzę "długimi godzinami"
    - np.w Twim przypadku owe rozwiązania z KBC

    Ale głowa do góry, bazując na swoim doświadczeniu i SM innych producentów szybko sie podciągniesz i wkrótce nie będzie problemu + pomoc tego forum (innych podobnych)

    Lenovo IdeaPad Flex 10 - Płyta po innym serwisie, martwa, brak 3 i 5V
  • Poziom 16  
    Oby tylko nie przegoniła mnie miniaturyzacja. Bo już teraz przy niektórych płytach przydałby się mikroskop. A za parę lat pewnie naprawy albo nie będą już możliwe albo już nie będą opłacalne.
    Kiedyś kondensatory można było z płyt palcami ściągać :)
    Lenovo IdeaPad Flex 10 - Płyta po innym serwisie, martwa, brak 3 i 5V