Elektroda.pl
Elektroda.pl
X
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Vectra C 1.8 - Brak komunikacji CAN z ABS/TC, speed sensor mulfunction

Pascalt 21 May 2016 21:28 5676 7
  • #1
    Pascalt
    Level 22  
    OBJAWY:
    Licznik przebiegu i prędkościomierz nie działają, w polu informacyjnym świeci się klucz, świecą się kontrolki ABS i TC - ABC i kontrola trakcji oczywiście nie działają, poza tym wskazania temperatury chłodziwa, wskaźnik poziomu paliwa i obrotomierz działają bez zarzutu, inne objawy nie występują.

    ODCZYTANE BŁĘDY:
    - Brak komunikacji CAN z ABS/TC
    - Nieprawidłowy sygnał z czujnika prędkości (który zapewne jest konsekwencją błędu pierwszego

    CO SPRAWDZIŁEM:
    - przedzwoniłem przewody komunikacji CAN: ABS[1,2] - ECU[6,38] - OK
    - czujnik prawego koła - usunięte niepewne połączenie w okolicach złączki przy piaście
    - wszystkie bezpieczniki w skrzynce bezpiecznikowej komory silnika oraz przy drzwiach kierowcy - OK

    Czujnika lewego koła nie sprawdzałem, bo pomimo tego, że to z niego sygnał przekazywany jest na zegary, jak się domyślam, na pewno nie odpowiada on za komunikację CAN. Bynajmniej jego oporność widziana z gniazda przy module ABS/TC jest podobna do 3 pozostałych czujników - ok 5,1MOhm.
    Z powodu trudnego dostępu nie przedzwaniałem też przewodów CAN pomiędzy sterownikiem kolumny kierownicy, a modułem ABS, ale moduł ABS jest wpięty szeregowo pomiędzy ECU, a CIM, więc zakładam że ciągłość jest zachowana, gdyż z ECU komunikuję się przez gniazdo diagnostyczne, a ono jest wpięte bezpośrednio do CIM.

    Czy pomoże ktoś?? Będę bardzo wdzięczny. Każda sensowna wskazówka na wagę złota...

    Dodano po 5 [godziny] 5 [minuty]:

    Wiem, że temat nie jest prosty, ale czyżby przerósł doświadczonych Forumowiczów? :(((
    Jedyne, co przychodzi mi na myśl, to podjechać do kogoś, kto ma na sprzedaż sterownik ABC/TC, na miejscu podpiąć tylko wtyczkę elektryczną i sprawdzić, czy z tym sterownikiem będzie mógł się skomunikować po CAN...
  • Helpful post
    #2
    piotrekwoj1
    Level 40  
    Pascalt wrote:
    ale moduł ABS jest wpięty szeregowo pomiędzy ECU, a CIM, więc zakładam że ciągłość jest zachowana, gdyż z ECU komunikuję się przez gniazdo diagnostyczne, a ono jest wpięte bezpośrednio do CIM.


    Hej no nie wydaje mi się ale też mogę się mylić. Czym diagnozujesz auto? Jakie jest nap w sieci CAN ? Nie łączysz się tylko z ABS?
    Czujniki ABS sprawdzaj oscyloskopem a nie omomierzem.
  • Helpful post
    #3
    grala1
    VAG group specialist
    Masz komunikację z ABS?
    W innych sterownikach też są błędy komunikacji z CAN?
    Jeżeli na pierwsze pytanie odpowiedź brzmi nie a na drugie tak to sprawdź zasilanie na ABSie.
  • #4
    Pascalt
    Level 22  
    piotrekwoj1 wrote:
    Pascalt wrote:
    ale moduł ABS jest wpięty szeregowo pomiędzy ECU, a CIM, więc zakładam że ciągłość jest zachowana, gdyż z ECU komunikuję się przez gniazdo diagnostyczne, a ono jest wpięte bezpośrednio do CIM.


    Hej no nie wydaje mi się ale też mogę się mylić. Czym diagnozujesz auto? Jakie jest nap w sieci CAN ? Nie łączysz się tylko z ABS?
    Czujniki ABS sprawdzaj oscyloskopem a nie omomierzem.


    Diagnozuję auto Op-com'em - jak do tej pory nie zawiodłem się na nim jeszcze. Przyznam, że napięcia w sieci CAN nie sprawdzałem, bo jest to protokół oparty na sygnale różnicowym. Sugerujesz, żeby zmierzyć napięcie stałe pomiędzy linią high, a linią low? Tak, jedynie z modułem ABS/TC nie mam komunikacji, co również zarejestrowane jest w m.in w CIMie.
    Jasne - tutaj mam pełną świadomość, że miarodajny pomiar jakości sygnału z czujnika można uzyskać jedynie od koła w ruchu, badając oscyloskopem. Przez pomiar rezystancji ograniczyłem się jedynie do sprawdzenia okablowania - wykluczyłem zwarcie/rozwarcie. Wykluczyłem zatem uszkodzenie, które mogłoby oddziaływać w jakiś sposób na sterownik ABS/TC przy nieruchomym pojeździe.

    Dodano po 30 [minuty]:

    grala1 wrote:
    Masz komunikację z ABS?
    W innych sterownikach też są błędy komunikacji z CAN?
    Jeżeli na pierwsze pytanie odpowiedź brzmi nie a na drugie tak to sprawdź zasilanie na ABSie.


    Tak, pojawia się w innych sterownikach błąd mówiący o braku komunikacji ze sterownikiem ABS/TC (i tylko z nim). Wszystkie pozostałe sterowniki są widoczne. Któryś z modułów (bodajże UAC) zarejestrował błąd o nieprawidłowych danych z modułu CIM, ale podejrzewam, że jest to związane z brakiem sygnału odnośnie prędkości. Błędy cały czas te same, powtarzające się, nie pozwalające się wykasować - występują ciągle.
    Zasilanie na ABS/TC - prawidłowe na wszystkich, stosownych pinach - tak zasilanie, jak i GND.
  • Helpful post
    #5
    sk700
    Level 31  
    Pascalt wrote:
    zmierzyć napięcie stałe pomiędzy linią high, a linią low?

    Najlepiej pomiędzy jedną i drugą a masą. Jeśli tutaj napięcia będą prawidłowe, tak samo jak zasilanie to martwa pompa absu. Mam nadzieję, że zasilania sprawdzałeś żarówką?
  • #6
    Pascalt
    Level 22  
    sk700 wrote:
    Pascalt wrote:
    zmierzyć napięcie stałe pomiędzy linią high, a linią low?

    Najlepiej pomiędzy jedną i drugą a masą. Jeśli tutaj napięcia będą prawidłowe, tak samo jak zasilanie to martwa pompa absu. Mam nadzieję, że zasilania sprawdzałeś żarówką?


    Mnie również aktualnie wszystko wskazuje na uszkodzony sterownik ABS/TC. Prawdopodobnie jutro podjadę do człowieka, który ma na sprzedaż wymontowaną pompę ze sterownikiem, wepnę samą wtyczuchę i zobaczę, czy będzie komunikacja. Dam znać.
    W przypadku uszkodzonego sterownika, trochę zabawy będzie z jego wymianą z tego co widzę. Dostęp do niego w Vectrze C nie jest najlepszy. Może ktoś wymontowywał? Myślę o wykręceniu torxów mocujących pompę do kielicha i odchyleniu pompy ze sterownikiem, aby mieć dostęp do śrub mocujących sterownik do pompy. Tylko czy nie połamię przewodów hydraulicznych...:/ Wolałbym uniknąć wymontowania całej pompy i babrania z płynem... A może tego nie uniknę??
  • #7
    Pascalt
    Level 22  
    Niestety w moich okolicach nie znalazłem pompy o dokładnie tych samych nr katalogowych, podpinałem 2 pompy od Vectry C o innych numerach. Jedna wcale nie była widziana na linii CAN przez inne moduły, natomiast druga co prawda komunikowała się, ale rejestrowała błędy o niesprawnych czujnikach prędkości dwóch kół.
    Więc problem prawdopodobnie się rozwiązał. Muszę znaleźć pompę o odpowiednich numerach i wszystko powinno hulać. Prawdopodobnie sterownik mojej starej pompy zwyczajnie zmarł...
  • #8
    Pascalt
    Level 22  
    Problem rozwiązany. Brak styków na wtyczce pompy ABS/ESP ;) Pompa sprawna.
    Pozdrawiam i dziękuję wszystkim próbującym pomóc:)