Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Sprawdzanie Atmegi

30 Cze 2005 22:28 1106 12
  • Poziom 11  
    Witam,
    Zaczynam bawic sie uC i wpadlem na stronke http://www.patron.net.pl/AVRintropl.htm . Zbudowalem programator i uklad z LED-em. Niestety nie dziala. Układ jest dobry - zadnych zimnych lutów itd.(sprawdzone przez "prawdziwego" elektronika). I teraz moje pytanie:
    Czy jest możliwosc sprawdzenia Atmegi8 czy jest dobry(obawiam sie ze nie)?
  • Poziom 28  
    A kompilator przypadkiem nie wyrzuca bledow ?? Adres tej strony przewija sie co chwila tu na forum z informacja ze przyklady z tej strony powoduja ze kompilator wyrzuca bledy.
    Pozdro
    Dexter
  • Poziom 11  
    Kompiluje sie ladnie
    A blad jest :D
    > "C:\AVR_projekty\LED\zaprogramuj.bat"

    C:\AVR_projekty\LED>REM Plik procedury programowania ATMega8

    C:\AVR_projekty\LED>avrdude -p m8 -c bsd -e -U flash:w:led.hex

    avrdude: AVR device not responding

    avrdude: initialization failed, rc=-1

    Double check connections and try again, or use -F to override

    this check.

    avrdude done. Thank you.

    Ø Process Exit Code: 1
    Z opisu wynika ze albo programator, bateria (nowa) albo atmega nie dziala
  • Poziom 28  
    Albo masz podlaczenia nie takie jak potrzeba. Czy wykonales zalecenia odnosnie drajwera LPT ?? Jesli oczywiscie masz XP lub 2000.
    Pozdro
    Dexter
  • Poziom 11  
    Mam XP.Czy chodzi o "rem Umożliwienie dostępu do portu LPT dla win 2000 i XP". Robilem wszystko co dotyczy XP. Aha i nie mialem drukarki LPT na tym systemie. Jak na moje szczescie to bedzie uC.
    Pozdro
  • Poziom 28  
    Chodzilo mi o to:
    "W systemach operacyjnych , na bazie NT4 ( Win 2000,XP) dostęp do portu drukarki jest blokowany przez system. Aby umożliwić prawidłowe funkcjonowanie programatora, należy wcześniej uruchomić odpowiedni drajwer. Znajduje się on w pliku C:\WinAvr\Bin\ instal_giveio.bat

    Po uruchomieniu drajwera, można sprawdzić czy pracuje on prawidłowo wydając z konsoli komendę:

    C:\WinAvr\Bin\ status_giveio.bat
    "
    Pozdro
    Dexter
  • Poziom 11  
    po wpisaniu C:\WinAvr\Bin\ status_giveio.bat wyswietla mi:
    status of giveio:
    Type: [0x01] Kernel driver
    Start type: [0x02] Automatic
    Error Control [0x01] NORMAL: Display a message box.
    Binary path: \??\C:\WINDOWS\giveio.sys
    Load order grp:
    Dependencies:
    Start Name:
    ok.

    Cos takiego.
  • Poziom 28  
    No to pozostaje Ci "Double check connections and try again" Jesli nie podlaczysz odwrotnie zasilania to dosc ciezko jest zepsuc procesor. Najlepiej sie przespij i jutro rano ze swiezym umyslem sprawdz te polaczenia.
    Pozdro
    Dexter
  • Poziom 11  
    a jesli podlacze odwrotnie to spale tak?
    no to nie musze sprawdzac bo na 99,999% raz podlaczylem odwrotnie. Caly dzien podlaczanie i sprawdzanie to troche bylo tego :)
    A tak zeby ustalic Vcc to + a GND to - tak??
  • Pomocny post
    Poziom 28  
    Tak Vcc to PLUS, a GND to MINUS. Jesli jestes pewien ze podlaczyles przez chwile odwrotnie to faktycznie mozesz biec do sklepu po nowy procesor.
    Pozdro
    Dexter
  • Poziom 11  
    biec do sklepu 25 kilosow? ehhh
    moja glupota nie ma granic....
    Dzieki za uswiadomienie mi mojej niewiedzy
    Pozdrawiam
  • VIP Zasłużony dla elektroda
    Oczywiście jeżeli tylko odwrócisz układ w podstawce, to nie będzie problemu, odwrócony układ ma identyczną konfigurację zasilania.
  • Poziom 18  
    Witam. Chyba przypne sie do tego tematu. Mam ATMEGE8 i od dwoch dni probuje ja zaprogramowac zrobilem sobie programator wg instrukcji z nalezionej w internecie. Pozniej podlaczylem ja bezposrednio pod LPT i bez skutku chyba nie ma zadnej komunikacji:( uzywalem bascoma ISP programmera i nic sie nie dzieje:( zero pozytywnych skutkow mojej dzialalnosci:/ system na kompie to WinMe. Czy wie ktos co moze byc grane?