Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Mercerdes D2B Bose - Star Diagnostic nie widzi nic z systemu audio

PanFranek 24 Jun 2016 11:05 1830 1
  • #1
    PanFranek
    Level 7  
    Witam

    Mam w Mercedesie ML W163 system audio BOSE na pętli D2B (Audio 30 APS, zmieniarka, telefon)

    Wszystko działa sprawnie, ale chciałem zmienić jedno ustawienie (dostosowywanie głośności do prędkości) i podłączyć inne radio (Audio 10 CD)



    Znalazłem opisy jak to zrobić w Star Diagnosis (Correct vehicle model -> "Control units"-> "Information and Communication" -> "D2B – COMAND" or "Audio")
    Po podłączeniu dochodzę do listy modułów gdzie mam wszystkie elementy audio (comand, zmieniarka, telefon itd) oraz Parktronik, ale nie mogę się połączyć z żadnym elementem systemu audio - brak komunikacji, przy czy Parktronik łączy się normalnie.
    Ta sytuacja dotyczy starego radia jak i nowego

    Dodatkowo sprawdziłem samochód skanerem ODB2, na starym radiu pokazuje brak błędów i wyświetla DIAGNOSE na radiu, na nowym pokazuje błąd komunikacji ale to jak rozumiem wynika z nie zaprogramowania nowej jednoski

    Przeszukałem całe forum, google, i fora zagraniczne. Jedyne na co się natknąłem to że W163 nie doprowadza CAN do radia, a radio powinno mieć wyprowadzone dodatkowe połączenie do ODB2 w celu zakodowania, ale to dotyczy modeli z przed 2002

    "To install the diagnostic connection (so that the COMAND can be coded using Star Diagnosis by the dealer) – you need to run a cable from pin 2 of the A connector to pin 12 of the diagnostic (OBDII) connector. "


    I teraz nie wiem, czy brak połączenia z wszystkimi elementami audio to jakaś awaria czy właśnie brak połączenia dodatkowym kablem do radia?
  • #2
    PanFranek
    Level 7  
    Udało mi się w końcu zaprogramować radio MF2910 do całego pierścienia D2B, ale mam kolejny problem - radio i cd gra bardzo cicho, słychać coś dopiero na końcu skali, jednocześnie zmieniara gra z normalnym poziomem. Nie mam za bardzo pomysłu co dalej, połączenie jest cyfrowe, tylko gdzieś w którymś momencie elementy się nie dogadały co do poziomu dźwięku.

    Udało mi się nawet wyszukać jak się wchodzi w menu serwisowe tego radia (Wciskamy tony+PTY, a po chwili szybko RDS), ale mam tam tylko test D2B (ok) oraz zmienianie fal radia.

    Jakieś pomysły?