Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Philips 42PFL3007H/12 - nie uruchamiał się do końca... a teraz w ogóle.

26 Cze 2016 20:53 3327 3
  • Poziom 21  
    Witam. Mam tv jak w temacie który po 10 sek. od załączenia zawieszał się. Gdzieś coś przez moment można było przełaczyć ale pustka na ekranie (brak treści prócz OSD) czy przez HDMI czy z tunera. Próbowałem na początek poczytałem na forum o takich przypadkach, potem klawiszologia kodów z pilota. Bezskutecznie na żadne nie było reakcji. Po wgraniu softu ze strony Philipsa niestety TV tylko reaguje na pilota mrugając a tak brak jest jakichkolwiek odznak życia. Brak podświetlenia, cisza w głośnikach. Czytając na forum post https://www.elektroda.pl/rtvforum/topic1984642.html postanowiłem tak samo podłączyć hiper terminal z xp. Udało się. Pokombinowałem trochę i mam odczyt. Z analizy treści wydruku z włożonym nośnikiem USB wywnioskowałem że szukany plik przez tv powinien nazywać się upgrade_loader.pkg a nie autorun.upg czy upgrade.pkg. Zmieniłem nazwę na nośniku zadowolony że może teraz się uda? Owszem coś tam czyta ale czy zapisuje? A już tym bardziej nie widzę by była jakaś reakcja na pilota zapisana w logach czy w trakcie uruchamiania cisnę domek czy ok lub klawisz w dół?
    Wkleję tu wydruk terminala może ktoś światły mi coś podpowie? Czy tak jest dobrze czy są błędy?

    Code:
    đBoot-
    
    DRAM Channel A Calibration.
    Byte 0 : DQS(0 ~ 27), Size 28, Set 11.
    Byte 1 : DQS(0 ~ 28), Size 29, Set 12.
    Byte 2 : DQS(7 ~ 30), Size 24, Set 16.
    Byte 3 : DQS(0 ~ 30), Size 31, Set 13.
    DRAM A Size = 256 Mbytes.
    Boot
    Start Pmain
    0x00004000
    NID=0x9510daad
    LZHS addr:0x00100040
    LZHS size:0x000a7968
    LZHS checksum:0x00000077
    Boot
    Start Lmain

    MT5365 Boot Loader v0.9
    [PCMCIA]Set PCMCIA Access IF : SPI
    SPIHW_Init ----- Set SPI PinMux
    SPI dummy delay:0x10
    External CI Version : MT5135
    Output clock from main chip.
    PCMCIA Reset Demod GPIO=35, 0->1
    SPI_SetPll(), spi clock: 27 Mhz
    External IC Initilization done
    MUSB none SoftReset 0x29424 = 0x01030000.
    MUSB pBase = 0xF0029000 init ok.
    MUSB none SoftReset 0x29424 = 0x01030000.
    MUSB pBase = 0xF002E000 init ok.
    Boot reason: A/C power on!!-------------use external edid, disable internal edid
    ------------------
    SIF_Master0: new design
    SIF_Master1: old design
    Boot reason: A/C power on!!T8032 init A/C on case loader stage...
    Load T8032 FW (addr: 0x  d3f710, size: 24576)success!!
    T8032 FW version: 5
    T8032 change to loader stage...
    LDR_FlashCopy 0xf010 0x3d300 0x80
    Switch NAND pinmux
    Detect NAND flash ID: 0x9510DAAD
    Detect HY27UF082G2B NAND flash(SLC): 256MB
    NAND_BDM_Mount: Partid=0, offset=0x0, size=0x200000
    [BDM] Partition: 0, Bad Block Count: 0

    Do USB upgrade
    Wait USB medium to be mounted...
    USB Medium on Device, Time = 1574 ms.
    USB block size = 512 bytes.
    Read Dir Entries: 0
    File Name:
            upgrade_loader.pkg
             file_name = upgrade_loader.pkg - prefix = upgrade_loader - check prefix
     = PS_2K12_3K_DL
    Match file name not found, use the default one: upgrade_loader.pkg
    Upgrade File Name: upgrade_loader.pkg
    Upgrade File Size: 63425290 Bytes
    Display 0x00db0720 Idx:1 BG:0x00eeeeee
    2 bytes panel index is : 152 (0x  98)
    Find panel index 152 from EEPROM
    [LVDS] DVOPLL init control word only
    [LVDS] VOPLL Initialize successful !
    LODFP.
    Boot reason: A/C power on!!---------- Panel[152] PANEL_CAS_LC420WUE_SCA1_V10 192
    0x1080 ----------
    PixelClk[Max=175000000, 60Hz=143472527, 50Hz=146988800, Min=120000000]
    HTotal[Max=2239, 60Hz=2175, 50Hz=2175, Min=1999] HSyncLen[60Hz=255, 50Hz=255]
    VTotal[Max=1380, 60Hz=1099, 50Hz=1350, Min=1091] VClk[Max=75, Min=50]
    HSyncWidth=16, VSyncWidth=6, HPosition60Hz=0x800, HPosition50Hz=0x800, VPosition
    =1016
    LVDS_NS, LVDS_ODD_SW_ON, DUAL_PORT, DISP_30BIT, WFB_PANEL_RESET_OFF, PWM_LOW_PAN
    EL_BRIGHT
    3D_POLARIZED
     Backlight[High=0x0, Middle=0x0, Low=0x0]
    DimFreq60Hz=120, DimFreq50Hz=100
    Delay[LvdsOn=60, BacklightOn=600, BacklightOff=300, LvdsOff=100]
    MaxOverscan=50

    Current panel setting is PANEL_CAS_LC420WUE_SCA1_V10
    Backlight gpio=25, turn on value=0, LVDS gpio=16, turn on value=1
    Pixel Shift=0 (1920 x 1080)
    Color:13 BmpAddr:0x00d645c0 Width:448 Height:60
    OSD_SetTVEOut: 1
    Panel 1920 x 1080
    LDR_OsdDisplay(13, 0x00d645c0, 448, 60) return 0
    u4NANDFlashBlockSize:20000
    Use internal integrity check API
    open File = /mnt/usb_0/upgrade_loader.pkg
    open File = /mnt/usb_0/upgrade_loader.pkg
    Locate codefile header failed - /mnt/usb_0/upgrade_loader.pkg
    No proper firmware exist, Display 0x00db0720 Idx:3 BG:0x00eeeeee
    Color:13 BmpAddr:0x00d7e9c0 Width:448 Height:60
    Panel 1920 x 1080
    LDR_OsdDisplay(13, 0x00d7e9c0, 448, 60) return 0
    USB upgrade stop
    Boot reason: A/C power on!!Boot reason: A/C power on!![PDWNC]PDWNC_TPV_Determine
    NextState : u4Event = 0x6
    PDWNC_TPV_DetermineNextState : u4Current = 1
    PDWNC_TPV_DetermineNextState : system booting
    [PDWNC] Virgin Mode Status : 0x0, Offset :0x38
    PDWNC_TPV_DetermineNextState : event = PDWNC_POWER_DOWN_AC_POWER
    Current = 0x1, Event = 0x6, Next = 0x1
    Wakeup keypad array rCmd.u1SubCmd 31
    Wakeup keypad array = 1
    Boot reason: A/C power on!![PDWNC]PDWNC_ReadWakeupReason = 0x6
    [PDWNC]PDWNC_WAKE_UP_REASON_AC_POWER, enter semi standby mode, LED changes to st
    andby
    PDWNC_TPV_EnterNextState : u4Next = 0x1
    Boot reason: A/C power on!!
    A_Mute GPIO=11 release
    AMP mute GPIO=cb release
    Reset Demod GPIO=23, 0->1
    Display 0x00db0720 background:0x00000000
    LDR_OsdDisplay(13, 0x00d50d40, 400, 100)
    Color:13 BmpAddr:0x00d50d40 Width:400 Height:100
    Panel 1920 x 1080

    NAND load lzhs header from 0x80000 to dram(0x1025670), size=2048
    Decompression uboot to 0x00f00000...

    NAND load image from 0x80000 to dram(0x1025670), size=0x3fce1
    secure boot ok
    LZHS hardware decode start
    LZHS hardware decode done
    Starting image...



    U-Boot starts...

    NAND Flash:  Detect NAND flash ID: 0x9510DAAD
    Detect HY27UF082G2B NAND flash: 256MB
    256 MiB
    Booting sequence is from NAND Flash
    In:    serial
    Out:   serial
    Err:   serial
    SIF_Master0: new design
    SIF_Master1: old design
    eeprom para:4c0(6ffc90) u4MemLen:0x00000009
    eeprom para:4c9(6ffc84) u4MemLen:0x00000009
    eeprom para:4d2(6ffc78) u4MemLen:0x00000009
    eeprom para:4c0(6ffc4c) u4MemLen:0x00000009
    eeprom para:4c9(6ffc4c) u4MemLen:0x00000009
    eeprom para:4d2(6ffc4c) u4MemLen:0x00000009
    eeprom para:4c0(6ffec0) u4MemLen:0x00000009
    Boot from kernelA and rootfs at partition 6
    Hit any key to stop autoboot:  0
    Partition rootfsA defined at mtdparts:
    ID:6, Offset:0x00c00000, Size:0x00a00000

    Loading from nand0, offset 0x800000
    Automatic boot of image at addr 0x00008000 ...
    eeprom para:4c0(6fe4d8) u4MemLen:0x00000009
    Check signature from sigA
    Partition sigA defined at mtdparts:
    ID:2, Offset:0x00400000, Size:0x00200000
    Loader succeeded in signature verification
    ## Booting kernel from Legacy Image at 00008000 ...
       XIP Kernel Image ... OK
    OK

    Starting kernel ...

    Uncompressing Linux.............................................................
    ............................... done, booting the kernel.
    INIT: version 2.86 booting
    Mounting local filesystems: mount mount: according to /proc/mounts, /dev/root is
     already mounted on /
    Running rc.local...
    net.ipv4.tcp_window_scaling = 6
    # mount basic
    UBI device number 0, total 672 LEBs (85327872 bytes, 81.4 MiB), available 0 LEBs
     (0 bytes), LEB size 126976 bytes (124.0 KiB)
    real    0m 0.21s
    user    0m 0.00s
    sys     0m 0.09s
    real    0m 0.05s
    user    0m 0.00s
    sys     0m 0.02s
    [AppManager]init
    [AppManager]init dfb start
    [AppManager]init dfb
    input thread's parent pid is 350 tid is 350
    [DirectFB]: Wait to Init IR...!
    [AM] findProcessNameByPid = app_man
    [ProcessManager] startDefaultProcess
    [ProcessManager]init
    [AM] init succeed
    [AM] default process state '4' 'dtv_app_mtk'
    input thread pid is 350 tid is 354
    original scheduler policy 0
    scheduler nice -10
    original child scheduler policy 0 prio 0
    new child scheduler policy 2 prio 99
    Start to wait IR event...
    [dtv_app_mtk]>[FM-Linux]Mount /dev/mtd8 to /basic successfully.
    [FM](/dev/mtd8) is mounted to (/basic) successfully(0)
    {CI_glue}:ci_eng_init
    {CI}CI_RegInterrupt_nfy
    {CI_glue}- expect PROD key
    {CI_glue}- c[1]
    EEPROM size is 0x70.
    {DT} Real Time Clock is available on this system.
    [dtv_app_mtk]>
    {SECM_DBG_INFO}fail to set request,PID 20,SRC(h_open_src<67218>,type<18,1>,flag<
    0x1>,connection<0>),SEC(flags<0xc0a>)
    <AM> wakeup reason = 6
    EEPROM size is 0x38d0.
    EEPROM size is 0x4000.
    [ACFG_CUSTOM] acfg_custom_get_svl_tsl_dual_bank ui1_g_svl_tsl_dual_bank == DUAL_
    BANK_SVL_TSL_INVALID and get form plf is 1
    [ACFG_CUSTOM] acfg_custom_get_svl_tsl_dual_bank: MAIN
    {CDB} Loading metadata (version 7)
    {CDB} Loading metadata (version 7)
    {CDB} Loading metadata (version 7)
    {CDB} Loading metadata (version 7)
    [ACFG_CUSTOM] acfg_custom_get_svl_tsl_dual_bank: MAIN
    <PLF_OPT> Align option codes (OPC_USED[NVM] - OPC1  OPC2  OPC3)
     12 _app -   0     0     0
      7 _app -   0     0     0
    208 _app -   0     0     0
      2 _app -   0     0     0
     56 _app -   0     0     0
     32 _app -   0     0     0
      7 _app -   0     0     0
     30 _app -   0     0     0
     56 _app -  56    56    56
     23 _app -   0     0     0
      0 _app -   0     0     0
    106 _app -   0     0     0
     64 _app -   0     0     0
      0 _app -   2     2     2
      0 _app - 152   152   152
    122 _app -   0     0     0
    [ACFG_CUSTOM] acfg_custom_get_svl_tsl_dual_bank: MAIN
    [dtv_app_mtk]>
    {SECM_DBG_INFO}fail to set request,PID 17,SRC(h_open_src<67218>,type<18,1>,flag<
    0x1>,connection<0>),SEC(flags<0x40a>)
    [dtv_app_mtk]>
    {SECM_DBG_INFO}fail to set request,PID 16,SRC(h_open_src<67218>,type<18,1>,flag<
    0x1>,connection<0>),SEC(flags<0x40a>)
    [ACFG_CUSTOM] acfg_custom_get_svl_tsl_dual_bank: MAIN
    [a_cfg_custom_bds_update_mutirc_state] state = 0
    [ACFG_CUSTOM] acfg_custom_get_svl_tsl_dual_bank: MAIN
    [ACFG_CUSTOM] acfg_custom_get_svl_tsl_dual_bank: MAIN
    [dtv_app_mtk]>
    {SECM_DBG_INFO}fail to set request,PID 20,SRC(h_open_src<67218>,type<18,1>,flag<
    0x1>,connection<0>),SEC(flags<0xc0a>)
    [dtv_app_mtk]>
    {SECM_DBG_INFO}fail to set request,PID 20,SRC(h_open_src<67218>,type<18,1>,flag<
    0x1>,connection<0>),SEC(flags<0xc0a>)
    _stvapi_app_init_fct
    [dtv_app_mtk]>
     Call function : a_msg_convert_register.
    [dtv_app_mtk]>
     Call function _mc_app_init_fct.
    <msgconvert> language is pol
    country is POL
    [ACFG_CUSTOM] acf[CLI]SCE 1
    *wFS = 0
    *wFS = 4004500
    g_custom_get_svl_tsl_dual_bank: MAIN
    [CLI]SCE 1
    *wFS = 0
    *wFS = 4004500
    [ACFG_CUSTOM] acfg_custom_get_svl_tsl_dual_bank: MAIN
    [ACFG_CUSTOM] acfg_custom_get_svl_tsl_dual_bank: MAIN
    [ACFG_CUSTOM] acfg_custom_get_svl_tsl_dual_bank: MAIN
    Zero TDC memory address
    Zero TDC memory address
    [ACFG_CUSTOM] acfg_custom_get_svl_tsl_dual_bank: MAIN
    [ACFG_CUSTOM] acfg_custom_get_svl_tsl_dual_bank: MAIN
    ****FIX ME****, acfg_custom_post_init:6330
    [dtv_app_mtk[CLI]SCE 1
    *wFS = 0
    *wFS = 4004500
    ****FIX ME****, acfg_custom_post_init:6330
    ****FIX ME****, acfg_custom_post_init:6330
    /release/auto/p4/w/20130103_093001/TPV_linux_REL_TPV_P1.75/vm_linux/dtv_linux/dt
    v_driver_adpt/mt5365/adaption/adpt_res_mngr/rm_dev.c 2807:RM SET COMP DEV ERR:e_
    set_type 0, e_drv_type 500, ret:-16
    [DRV_INTERFACE] Set Operation Error. (-16)
    [CLI]SCE 1
    *wFS = 0
    *wFS = 4004500
    TunerNimTest(TunerId=1) ok(return=0)
    [LINUX_FAKE_API] sys_overscan_mode_sync
    [ACFG_CUSTOM] acfg_custom_get_svl_tsl_dual_bank: MAIN
    {CDB} Loading metadata (version 7)
    {CDB} Loading metadata (version 7)
    {CDB} Loading metadata (version 7)
    {CDB} Loading metadata (version 7)
    # mount clip]>
    [dtv_app_mtk]>UBI device number 3, total 64 LEBs (8126464 bytes, 7.8 MiB), avail
    able 0 LEBs (0 bytes), LEB size 126976 bytes (124.0 KiB)
    [dtv_app_mtk]>real      0m 0.08s
    [dtv_app_mtk]>user      0m 0.00s
    [dtv_app_mtk]>sys       0m 0.02s
    UBIFS: recovery needed
    UBIFS: recovery completed
    [dtv_app_mtk]># mount usb
    [dtv_app_mtk]>real      0m 0.07s
    [dtv_app_mtk]>user      0m 0.00s
    [dtv_app_mtk]>sys       0m 0.02s
    [dtv_app_mtk]>[FM-Linux]Mount /dev/mtdb to /mnt/aud successfully.
    [FM](/dev/mtdb) is mounted to (/mnt/aud) successfully(0)
    # mount edfu]>
    [dtv_app_mtk]>UBI device number 4, total 80 LEBs (10158080 bytes, 9.7 MiB), avai
    lable 0 LEBs (0 bytes), LEB size 126976 bytes (124.0 KiB)
    [dtv_app_mtk]>real      0m 0.07s
    [dtv_app_mtk]>user      0m 0.00s
    [dtv_app_mtk]>sys       0m 0.02s


    I czy tu się ma tak kończyć ? Bo tak się zatrzymuje za każdym razem.
    Pozdrawiam Piko.
  • Pomocny post
    Spec od monitorów
    To chassis TPM9.1E LA
    Poczytaj i zastosuj _ upgrade loader czyli coś z biuletynu SCC9345 dla tego chassis od Ph
    *
    Cytat:
    SCC_93457 бюлютень испрвления прошивки v2.08.rar
    * v2.09 (PS_2K12_3K_DL.pkg)

    spod adresu Link

    Cytat:
    unpacked the firmware to file recorded in the root directory 4 Gb stick (FAT32 formatted)
    - when the TV is turned off (from the socket) and inserted the flash drive and turned on the TV
    - the screen immediately displays the message "software upgrade in progress...."
    - a couple of minutes the television turned on (works)
    - .... turned off the TV - included
    next reset to factory settings

    wsad dla 24C128 EEPROM ,co prawda dla 42PFL3007H/12 TPM9.1E LA
    -main 715G5155_M01_002_005K
  • Poziom 21  
    Witam.
    Wielkie dzięki Lisek.
    Telewizor działa. Sobotę i niedzielę spędziłem na szukaniu tego pliku. Właśnie w logach był on tez widoczny że TV się pytał o takowy (PS_2K12_3K_DL.PKG). Wgranie tego ożywiło TV. Powrót do ustawień fabrycznych i jak na razie Telewizor gra nadal. :)
    Jeszcze raz Wielkie Dzięki za pomoc. Bo jutro chciałem wyjechać na kilka dni w Polskę.. i wygląda na to że mogę spać spokojnie.
    Pozdrawiam Piko.
  • Poziom 1  
    Hello,

    This file fixed the TV!! Thanks allot!!!

    Greetings from Holland