Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

S7-315 - Problem z komunikacją z enkoderem po profibus

rmatusik 28 Jun 2016 21:05 948 4
SterControl
  • #1
    rmatusik
    Level 10  
    Witam,
    po raz pierwszy wykorzystuje do pomiaru kąta obrotu enkoder absolutny firmy kubler 8.5888 który wpięty jest po sieci Profibus dp do sterownika S7-315. Całość realizowana jest w środowisku TIA portal v13. Zainstalowane ma GSD, zaterminowany jest enkoder(znajduje się na końcu magistrali), adres sieciowy ustawiony zgodnie z dtr-ka 63. Jednakże nie potrafię się z nim połączyć. Nie widzę go w TIA ani nie świeci się na nim kontrolka BUS. Czy ma ktoś z was jakiś pomysł jak zaradzić temu problemowi?
  • SterControl
  • #2
    Rafik4
    Level 30  
    Sprawdź czy dobrze ustawiłeś adres w enkoderze, trzeba przeliczyć na hex. Zobacz też czy masz dobry plik gsd, do silngleturn jest inny niż do multiturn.
  • SterControl
  • #3
    rmatusik
    Level 10  
    Sęk w tym, że żeby być pewnym adresu nastawiłem go tak jak wskazuje DTR-ka na adres 63 (dec) 3f (hex). I jest on na pewno dobry. GSD mam do multiturn.
    Masakra jakaś.
    S7-315 - Problem z komunikacją z enkoderem po profibus
  • #4
    cyp3k
    Level 13  
    Zapnij się do niego bezpośrednio, ew. sprawdź w accesible nodes czy go widzisz. Ustaw jakiś prosty adres bo możliwe że się gryzie z czymś.
    Dysponujesz profitrace'em ?
  • #5
    rmatusik
    Level 10  
    Problem rozwiązany. Dość niedorzeczne bo okazało się ze problem był w wtyczce przy cpu. Co ciekawe następnym elementem był falownik z którym była komunikacja a następnie enkoder w którym nie działała komunikacja. Zakładałem ze jak widzę falownik to ten odcinek jest oki, a jednak nie do końca tak jest :)