Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

PIC16LF627A zaprogramowany przez TL866a nie działa

techrys 08 Lip 2016 17:30 2895 5
  • #1 08 Lip 2016 17:30
    techrys
    Poziom 28  

    Witam,
    Procesor PIC16LF627A zaprogramowany w urządzeniu przez ISP przez programator TL866a nie działa. Program jest zapisywany w procesorze, procesor jest sprawny.
    Wiem, że orginalnie jest programowany za pomocą ICD3, i ważne jest aby wybrać import zamiast open, plik jest hex.

    Ktoś wie jaka jest różnica pomiędzy tymi dwoma funkcjami?

    0 5
  • #2 09 Lip 2016 09:41
    Zielonka
    Poziom 20  

    Witam
    A kolega sprawdził ustawienia rejestru konfiguracyjnego. Odpowiednik dla fusebit avr-a.
    Pozdrawiam
    W.B.

    0
  • #3 09 Lip 2016 09:53
    p.kaczmarek2
    Poziom 23  

    A skąd wiesz, że nie działa przez programator?
    Może wgrywasz zły hex? Sprawdzałeś, czy wgrany innym programatorem działa?
    Ten PIC jest z zewnętrznym rezonatorem? Może tej konfiguracji nie programujesz i w bitach jest ustawienie zewnętrznego, a on go nie ma, przez co nie startuje?

    0
  • #4 09 Lip 2016 14:53
    techrys
    Poziom 28  

    Skąd wiem, że nie działa przez programator - układ przestał działać po testowym wykasowaniu procka.
    Obecnie nie mam innego programatora.
    Hex jest prawidłowy, fabryczny. PIC chodzi na wewnętrznym rezonatorze.
    Może być coś z ustawieniami, tylko prawdę mówiąc nie mam pojęcia co.

    0
  • #5 09 Lip 2016 18:09
    Zielonka
    Poziom 20  

    Witam
    Wrzuć skany z ustawień rejestru konfiguracyjnego i schemat układu w jakim pracuje procek. Bez tego nikt Ci nie pomoże.
    Pozdrawiam
    W.B.

    0
  • #6 11 Lip 2016 11:00
    techrys
    Poziom 28  

    Problem rozwiązany - procesor był programowany, ale bez bitów konfiguracyjnych, pomimo że bity były ładowane a w procesie programowania oprogramowanie pokazywało, że weryfikacja jest poprawna.

    0