Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

VBA - macierz danych godzinowych, a funkcja countif > 1h

m4xon 19 Lip 2016 13:28 1569 4
  • #1 19 Lip 2016 13:28
    m4xon
    Poziom 15  

    Czołem koledzy,

    Mam do Was takie pytanko, mianowicie mam macierz czasów (załącznik) i potrzebuję stworzyć makierko, które w wierszach po ostatniej kolumnie wrzuci liczbę dni, w których czas został przekroczony o 1h w stosunku do limitu (B2).

    Kombinowałem, żeby najpier odjąć jedną wartośc od drugiej w każdej komórce, a następnie zliczać używając zwykłego countif ale myślę, że dałoby się to obejść łatwiejszą drogą, stąd prośba do Was o pomoc.

    Dzięki z góry!

    0 4
  • Pomocny post
    #2 19 Lip 2016 14:10
    JRV
    Specjalista - VBA, Excel

    X2 =LICZ.JEŻELI(C2:W2;">" &(B2+1/24))

    0
  • #3 05 Sie 2016 12:36
    m4xon
    Poziom 15  

    Dzięki JRV, do tego momentu używałem kodu:

    Kod: vbscript
    Zaloguj się, aby zobaczyć kod


    Code:
    =COUNTIF(RC[-24]:RC[-5],"">""&RC[-25])
    tą część muszę za każdym razem modyfikować odpowiednio do liczby kolumn, a chciałbym to zastąpić na bardziej dynamiczne i elastyczne rozwiązanie z zastosowaniem w kolejnej po ostatniej kolumnie
    Kod: vbscript
    Zaloguj się, aby zobaczyć kod

    ale nie za bardzo mogę ogarnać jak wprowadzić range stosujac CountIF.

    Z góry dziękuje za pomoc

    0
  • Pomocny post
    #4 05 Sie 2016 13:18
    JRV
    Specjalista - VBA, Excel

    w kolejnej po ostatniej kolumnie ma to byc formula lub wartosc?
    Sprobuj

    Kod: vb
    Zaloguj się, aby zobaczyć kod

    tylko bedzie przesuniecie zakresu
    lub
    CountIf(range(Cells(k, 3), Cells(k, ColumnEndDes)), ">" & Cells(k, 2)
    kriteria to kolumna 2, zakres od kol. 3 do ColumnEndDe

    Dodano po 8 [minuty]:

    to bylo dla wartosci
    dla Formuly w komorce potrafisz sam

    0
  • #5 08 Sie 2016 12:32
    m4xon
    Poziom 15  

    niesamowite, widzę gdzie robiłem błąd - dziękuję!

    0