Elektroda.pl
Elektroda.pl
X
Computer ControlsComputer Controls
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

MC34063 step-up 100-350V - za małe napięcie, sprawdzenie schematu, porady

20 Lip 2016 15:13 4404 16
  • Poziom 20  
    Witam.

    Mam problem z uruchomieniem zasilaczy na MC34063.
    Muszę uzyskać następujące napięcia:
    100V (60mA)
    225V (60mA)
    350V (60mA)
    -150V (35mA)

    Wykonałem zasilacz jak na schemacie:
    MC34063 step-up 100-350V - za małe napięcie, sprawdzenie schematu, porady

    Obliczone wartości poszczególnych elementów nie zdały egzaminu, więc na drodze prób i błędów uruchomiłem układ Step-up dla napięcia wyjściowego 100V z następującymi parametrami:
    Vin=38V
    Ct=10nF
    L=1mH
    RSC=0,833om (1+10+10 równolegle)
    C0=440uF
    zastosowałem tranzystor IGBT.
    Wiem, że zgodnie ze schematami w PDFie powinien być NPN, ale próby uruchomienia układu z MJE13007 dawaly dziwne efekty i dopiero na IGBT zaczęło to jakoś działać

    Poniżej to co mi wyszło na oscyloskopie:
    MC34063 step-up 100-350V - za małe napięcie, sprawdzenie schematu, porady MC34063 step-up 100-350V - za małe napięcie, sprawdzenie schematu, porady

    Kanały:
    1 - sygnał sterujący z MC34063
    2 - sygnał na bramce tranzystora kluczującego
    3 - tętnienie napięcia wyjściowego 100V (tu uwaga - tak wygląda za filtrem 68uH i 220uF)
    4 - prąd cewki

    I teraz seria pytań:

    Czy prąd cewki zawsze będzie schodził do zera? Zwiększając lub zmniejszając Ct napięcie wyjściowe spada (logicznym jest dla mnie, że po zwiększeniu częstotliwości powinno być lepiej, a nie gorzej)
    Zabawy z Rsc także nie przyniosły efektu, cewka którą miałem nasyca się przy prądzie ok 1A, więc do takich wartości dobierałem Rsc. Kiedy pozwalałem płynąć większym prądom to przetwornica przerywała pracę co jakiś czas zamiast skrócić czas Toff. Podobnie przy zmianie obciążenia. Zupełnie mnie to wybijało z tropu.
    Proszę w takim razie o jakieś porady odnośnie tej konfiguracji, ponieważ co prawda napięcie 100V uzyskałem nawet z satysfakcjonującymi tętnieniami, ale przy zdjęciu obciążenia (ok 20mA) pojawia się coś takiego:
    MC34063 step-up 100-350V - za małe napięcie, sprawdzenie schematu, porady

    Jak widać przetwornica przerywa cyklicznie pracę i na wyjściu pojawiają się niezłe tętnienia (tu także oscylogram za filtrem).
    Jest jakiś sposób, aby działało to lepiej?

    Druga sprawa to kwestia pozostałych napięć.
    Przy próbie 225V poddałem się, ponieważ też musiałem wymieniać elementy na czuja (te obliczone jakoś nie dawały rady) i max napięcie jakie uzyskałem to 210V przy obciążeniu rezystorami ok. 3,5k W końcu spaliła się dioda BY299 i dałem sobie spokój na razie.
    Próbę wykonywałem z:
    L=1mH (taka sama)
    Ct=2,2 4,7, 10nF
    C0=440uF
    Rsc=0,25 (ale rdzeń cewki już chyba zaczynał się nasycać przy tym prądzie - jednak minimalnie mniejszy byłby do zaakceptowania wg mnie).

    Na koniec może zdjęcie samego układu i symulacja zastosowanymi wartościami elementów:
    MC34063 step-up 100-350V - za małe napięcie, sprawdzenie schematu, porady MC34063 step-up 100-350V - za małe napięcie, sprawdzenie schematu, porady MC34063 step-up 100-350V - za małe napięcie, sprawdzenie schematu, porady MC34063 step-up 100-350V - za małe napięcie, sprawdzenie schematu, porady MC34063 step-up 100-350V - za małe napięcie, sprawdzenie schematu, porady MC34063 step-up 100-350V - za małe napięcie, sprawdzenie schematu, porady MC34063 step-up 100-350V - za małe napięcie, sprawdzenie schematu, porady MC34063 step-up 100-350V - za małe napięcie, sprawdzenie schematu, porady MC34063 step-up 100-350V - za małe napięcie, sprawdzenie schematu, porady

    I PCB:
    MC34063 step-up 100-350V - za małe napięcie, sprawdzenie schematu, porady
  • Computer ControlsComputer Controls
  • Poziom 43  
    Całość problemów wynika prawdopodobnie z fatalnego projektu PCB.
    Ale poza tym sterowanie i tak będzie dość trudne na MC34063. To w ogóle nie jej najgorszy sterownik, ale akurat w tym układzie pokaże swoje wady. Np. ciężko nim będzie wysterować tranzystor MOSFET czy IGBT.
    Prościej by to było zrobić na UC3843, choć wtedy pomiar prądu miał być na źródle tranzystora a nie na szynie dodatniej (nie wiem czy to dla Ciebie problem).

    Cytat:
    Czy prąd cewki zawsze będzie schodził do zera?

    Zależy od obciążenia. Od pewnego obciążenia przestanie schodzić do zera.
  • Poziom 20  
    atom1477 napisał:
    Całość problemów wynika prawdopodobnie z fatalnego projektu PCB.


    Co powinienem poprawić?
    Zwracałem uwagę na to, aby dioda, klucz i cewka były jak najciaśniej połączone.
    Masa pewnie mogłaby być lepiej, ale nie mam doświadczenia i nie wiem co na co wpływa w przypadku takiego projektu.

    atom1477 napisał:
    Np. ciężko nim będzie wysterować tranzystor MOSFET czy IGBT.
    Prościej by to było zrobić na UC3843, choć wtedy pomiar prądu miał być na źródle tranzystora a nie na szynie dodatniej (nie wiem czy to dla Ciebie problem).


    Też tak myślałem, może być z NPNem - mi to bez różnicy, byle działało.
    Ale tak jak pisałem wcześniej, z MJE13007 (prąd bramki ograniczony przez 500om) niby działało dobrze, ale przetwornica dziwnie się zachowywała - przy ustalonym stanie pracy na oscyloskopie pojawiały się różnej wysokości przebiegi prądów na cewce, jakby sterownik nie potrafił sobie z tym poradzić (może NPN za długo się wyłączał czy coś).

    Jeśli chodzi o pomiar prądu to jest mi zupełnie obojętny gdzie, mi zależy na sztywnym napięciu przy prądach o nieznacznym rozrzucie. (ok. 50-70mA, 30-30mA)

    atom1477 napisał:
    Zależy od obciążenia. Od pewnego obciążenia przestanie schodzić do zera.


    No właśnie tak powinno być w teorii, ale wydaje mi się, że gdy obciążałem bardziej przetwornicę to siadało napięcie. Zmniejszanie Rsc (nawet minimalne) powodowało tylko tyle, że przetwornica robiła większe przerwy między cyklami ładowania i rozładowania cewki.
  • Pomocny post
    Poziom 43  
    as88 napisał:
    Co powinienem poprawić?
    Zwracałem uwagę na to, aby dioda, klucz i cewka były jak najciaśniej połączone.
    Masa pewnie mogłaby być lepiej, ale nie mam doświadczenia i nie wiem co na co wpływa w przypadku takiego projektu.

    Poza tymi elementami ważne są też kondensatory wejściowy i wyjściowy. te 5 elementów powinno być ciasno połączone (nie tylko dioda, klucz i cewka).
    W przypadku obecności rezystora pomiaru prądu jeszcze ten element docodzi od ciasnego umieszczenia.
    U Ciebie nawet elementy które wymieniłeś nie są ciasno.
    Nie jest też zachowana kolejność podłączania. Np. kondensator wejściowy. Do niego powinno przychodzić zasilanie. I z niego dalej iść do cewki. A u Ciebie zasilanie przychodzi do kondensatora i tyle. Do cewki idzie nie z kondensatora tylko ze złącza zasilania.
    Dodatkowo pomiar prądu w R3 idzie długą ścieżką pod cewką. To ogromy błąd (puszczanie sprzężenia zwrotnego pod cewkami w ogóle).

    as88 napisał:
    No właśnie tak powinno być w teorii, ale wydaje mi się, że gdy obciążałem bardziej przetwornicę to siadało napięcie. Zmniejszanie Rsc (nawet minimalne) powodowało tylko tyle, że przetwornica robiła większe przerwy między cyklami ładowania i rozładowania cewki.

    Może rezystor R3 nie jest bezindukcyjny?
  • Poziom 38  
    MC34063 ma stały wspólczynnik Ton do Toff dlatego jak Kolega wyżej napisał to kiepski pomysł by go zastosować w tym układzie. Jak już chcesz mieć wyższe napięcie to musisz zdecydowanie wyłączać tranzystor, również polecam MOSFET-a. Szybkość wyłączania tranzystora ma kluczowe znaczenie dla generowania wartości napięcia wyjściowego. Tutaj trzeba by było dodać driver na dwóch koplementarnych tranzystorach np. 2N2222A+2N2709A albo lepiej zastosować już polecany UC3843, który ma już wbudowany driver do sterowania bramką MOSFET/IGBT.
  • Pomocny post
    Poziom 43  
    Cytat:
    Zabawy z Rsc także nie przyniosły efektu, cewka którą miałem nasyca się przy prądzie ok 1A, więc do takich wartości dobierałem Rsc. Kiedy pozwalałem płynąć większym prądom to przetwornica przerywała pracę co jakiś czas zamiast skrócić czas Toff. Podobnie przy zmianie obciążenia. Zupełnie mnie to wybijało z tropu.
    MC34063 tak właśnie działa, nie reguluje wypełnienia, tylko przerywa pracę po osiągnięciu nominalnego napiecia, dlatego doświadczeni konstruktorzy unikają tego badziewia.

    Cytat:
    Druga sprawa to kwestia pozostałych napięć.
    Przy próbie 225V poddałem się, ponieważ też musiałem wymieniać elementy na czuja (te obliczone jakoś nie dawały rady) i max napięcie jakie uzyskałem to 210V przy obciążeniu rezystorami ok. 3,5k W końcu spaliła się dioda BY299 i dałem sobie spokój na razie.


    Oprócz za małej szybkości wyłączania tranzystora, wzrost napięcia wyjściowego może zostać ograniczony przez pojemności pasożytnicze klucza i diody, pojemności te ograniczają szybkość narastania napięcia, oraz wartość szczytową, dlatego nie warto stosować elementów z dużym zapasem prądu maksymalnego.
    W skrajnym przypadku cała energia cewki nie wystarczy do naładowania pojemności pasożytniczych i zamiast prostokątnego impulsu na kolektorze, mamy połówkę sinusoidy, prąd cewki zmienia kierunek i wraca do zasilania.

    Dioda mogła sie spalić z powodu zbyt długiego czasu wyłączania, bo prądu ani napięcia maksymalnego raczej nie przekroczyłeś.
  • Computer ControlsComputer Controls
  • Poziom 20  
    Witam ponownie.

    Idąc za waszymi radami postanowiłem zamienić MC34063 na UC3842.
    Skoro PCB i tak źle zaprojektowałem i muszę zrobić to raz jeszcze to myślę, że warto zrobić też dodatkowy krok i użyć nowszej kostki.

    Na razie zatrzymałem się na etapie takim:

    MC34063 step-up 100-350V - za małe napięcie, sprawdzenie schematu, porady

    i okazuje się, że nie mogę zrobić symulacji, gdyż mam wersję demo spice'a, która ma ograniczenia co do ilości tranzystorów.
    Poproszę kolegów o rzucenie okiem na schemat, może coś rażącego rzuci się w oczy. Ewentualnie jeśli ktoś ma możliwość to proszę o wykonanie symulacji (plik w załączniku). Jutro chciałbym wykonać płytkę i we wtorek uruchomić ten układ.
    Ten konkretny schemat dotyczy:
    Uwe=38V
    Uwy=350V
    Iwy=35mA (30 do 40mA)
    element kluczujący to IRF840 lub jakiś IGBT - takie mam.

    Obliczając elementy bazowałem na:
    http://schmidt-walter-schaltnetzteile.de/smps_e/aww_smps_e.html
    pdfie uc3842 oraz przykładowym projekcje z UC3842 w bibliotece spice'a

    w załączniku dodaję plik do spice'a:
    uc3842.zip Download (56.82 kB)

    Pozdrawiam
  • Poziom 43  
    Przecież tam jest tylko jeden tranzystor. Więc coś innego tutaj ogranicza.
    Użyć może LTSpice.
    Chcesz wykonać nową płytkę ale nie zamierzasz nas spytać o zdanie w sprawie projektu?
    To się potem nie zdziw że znowu będziemy wytykali rażące błędy :D
  • Computer ControlsComputer Controls
  • Poziom 20  
    No nie wiem czy jeden... w strukturze UC3842 na pewno jest ich znacznie więcej.
    Spróbuję poszukać w sieci innego programu i jakoś wykonać symulację.
    Chcę wykonać nową płytkę po konsultacji na tym forum - wydaje mi się, że dokładnie o to prosiłem w poprzednim poście :) jeśli nie jest to jasne to proszę jeszcze raz.
    Mam wątpliwości co do zasilania przez diodę zenera - czy to wypali? Zasilanie ok 38-40V, a w datasheecie UC3842 znalazłem info, że powinno być 30V (chyba max), stąd pomysł z diodą.
  • Poziom 28  
    Jeśli napięcie zasilające (wspomniane 38-40V) jest w miarę stabilne i brak jest tętnień, to taki sposób zasilania przez diodę Zenera jest jak najbardziej poprawny.
    Napięcie zasilające układ sterujący należy tak dobrać, aby nie przekroczyć dopuszczalnego napięcia na bramce tranzystora wykonawczego. Optymalna wartość napięcia zasilającego układ UC3842 będzie więc dość wąska: 17-20V.
  • Poziom 20  
    atom1477 napisał:
    Użyć może LTSpice.


    LT spice wyrzuca mi błąd:
    "undefined subcircuit: ()"

    A w logu:

    "Questionable use of curly braces in "xlatch 8 2 22 18 6 7 fflop {}"
    Error: no expression present in: "[]"
    Fatal Error: Undefined subcircuit: ()"

    Nie bardzo wiem, jak naprawić ten problem.
    Plik utworzyłem w programie ICAP windows (demo ze strony intusoft), a otwarty w LTspice MAC OS X.
    W spoilerze załączam "tekst pliku", będę wprowadzał jeszcze zmiany do schematu (np. zasilanie UC3842 z LM317), ale na początku chciałbym w ogóle uruchomić symulację :) Także proszę o sprawdzenie czego ewentualnie brakuje bo nie mam pomysłów...

    Spoiler:

    Cytat:

    C:\Users\Emilka\Desktop\350v(uc3842).cir/Config 1/Setup1
    *#save @Rload[i] @Rload[p] @C2[i] @Vline[i] @Vline[p] @Rsense[i] @Rsense[p] @Rgate[i]
    *#save @Rgate[p] V(2) @CVcc[i] V(13) @C7[i] V(11) V(12) V(6)
    *#save @R12[i] @R12[p] @C9[i] @R13[i] @R13[p] V(14) V(4) V(8)
    *#save @L2[i] @L2[p] @D1[id] @D1[p] @R3[i] @R3[p] @R4[i] @R4[p]
    *#save V(1) @D2[id] @D2[p] V(7) V(3) @R1[i] @R1[p] V(10)
    *#alias vds v(10)
    *#view tran vds
    *#alias vout v(14)
    *#view tran vout
    *#view tran il
    *#alias il @l2[i]
    .TRAN 1u 3m 0 100n UIC
    .OPTIONS abstol=1u itl1=1k itl4=100 method=GEAR
    .OPTIONS gmin=10n reltol=0.01 vntol=1m
    .PRINT TRAN Vds
    .PRINT TRAN Vout
    .PRINT TRAN Il
    R1 8 1 100k
    CVcc 13 0 22uF IC=19
    D2 13 4 ZN4742
    .MODEL ZN4742 D
    X1 10 3 7 IRF840
    .SUBCKT IRF840 10 20 40
    * TERMINALS: D G S
    * Harris 500 Volt 8 Amp .8 ohm N-Channel Power MOSFET 02-08-1993
    M1 1 2 3 3 DMOS L=1U W=1U
    RD 10 1 .679
    RS 30 3 21M
    RG 20 2 4.7
    CGS 2 3 1.74N
    EGD 12 0 2 1 1
    VFB 14 0 0
    FFB 2 1 VFB 1
    CGD 13 14 1.69N
    R1 13 0 1
    D1 12 13 DLIM
    DDG 15 14 DCGD
    R2 12 15 1
    D2 15 0 DLIM
    DSD 3 10 DSUB
    LS 30 40 7.5N
    .MODEL DMOS NMOS (LEVEL=3 THETA=31.2M VMAX=1.04MEG VTO=3.3 KP=5.13)
    .MODEL DCGD D (CJO=850P VJ=.6 M=.68)
    .MODEL DSUB D (IS=33.2N N=1.5 RS=93.7M BV=500 CJO=494P VJ=.8 M=.42 TT=1.1U)
    .MODEL DLIM D (IS=100U)
    .ENDS
    C7 11 0 2.2n
    X3 8 1 12 11 0 2 13 6 UC3842B
    .SUBCKT UC3842B 3 14 15 1 18 4 20 2
    * E/A FDBK IS RT/CT GND OUT VC VREF
    *
    .SUBCKT 1845AMP 4 1 9 20
    * VREF INV OUT V-
    .MODEL QPMOD PNP
    .MODEL DCLAMP D (RS=10 BV=5 IBV=.01)
    .MODEL DMOD D
    R1 10 4 100K
    R2 10 20 100K
    R3 6 20 316MEG
    C1 6 20 15.9P
    E1 5 20 6 20 1
    R4 1 20 8MEG
    I2 4 9 .8M
    D12 9 4 DMOD
    R6 20 3 300
    D11 9 12 DMOD
    Q1 20 13 12 QPMOD
    I3 13 20 68U
    D14 3 13 DMOD
    D15 20 6 DCLAMP
    L1 2 3 10U
    C2 3 20 200P
    R9 5 2 5
    C5 2 20 .02U
    G1 20 6 10 1 100U
    .ENDS
    *
    .SUBCKT 1845OUT 4 7 3 12
    * +V -V IN OUT
    .MODEL QMOD NPN RC=1.5 RE=.5 RB=100 IKF=0.5 CJC=0.4P
    .MODEL QMOD2 NPN TF=400P TR=400P
    .MODEL QIN NPN BF=100 BR=2 IS=1E-16 VAF=50
    + CJE=1.5P CJC=.15P TR=1N TF=4N
    .MODEL DMOD D RS=1 IS=0.4U
    I3 4 8 100U
    D3 8 4 DMOD
    D4 12 8 DMOD
    Q3 8 1 9 QIN
    Q4 12 9 7 QMOD
    Q5 4 8 6 QMOD
    I4 7 1 .9M
    R1 3 2 10K
    Q8 1 2 7 QIN
    Q2 4 6 12 QMOD2
    .ENDS
    *
    .SUBCKT FFLOP 1 2 11 12 5 6
    * CLK D R S QBAR Q
    X1 7 4 2 8 NAND3 {IC=0}
    X2 8 3 10 9 NAND3 {IC=0}
    X3 1 8 10 7 NAND3 {IC=3.5}
    X4 4 9 1 10 NAND3 {IC=0}
    X5 4 7 6 5 NAND3 {IC=3.5}
    X6 5 10 3 6 NAND3 {IC=0}
    X7 11 4 INV {IC=3.5}
    X8 12 3 INV {IC=3.5}
    .ENDS
    .SUBCKT NAND3 1 2 3 4 {IC=0}
    B1 5 0 V=~(V(1)&V(2)&V(3))
    R1 5 4 400
    C1 4 0 20P IC={IC}
    .ENDS
    .SUBCKT INV 1 2
    B1 3 0 V=~(V(1))
    R1 3 2 100
    C1 2 0 10P IC={IC}
    .ENDS
    *
    ****OSCILLATOR*****
    S1 8 18 1 18 SOSC
    .MODEL SOSC SW(RON=.01 ROFF=1MEG VT=2.05 VH=.8)
    BDISCH 1 18 I=V(8,18) < 2.5 ? V(13,18) > 2.5 ? 8.3M : 0
    RPULL 8 2 100K
    ****UVLO***********
    S4 20 19 20 18 SUVLO
    .MODEL SUVLO SW(RON=.01 ROFF=1MEG VT=13 VH=3)
    RUVLO 19 18 1MEG
    RSTDBY 20 18 32K
    ROP 10 18 500
    ****REFERENCE*******
    BREF 13 18 V=V(19,18) > 6 ? 5 : 0
    RREG 10 2 .33
    CREF 2 18 1n
    V3 13 10
    B6 19 18 I=I(V3)
    ****CURRENT COMPARATOR*******
    B3 21 18 V=V(15,18) > V(16,18) ? 5 : 0
    R7 15 18 1MEG
    RDELAY 21 22 1K
    CDELAY 22 18 150P
    ****ERROR AMPLIFIER**********
    XAMP 2 14 3 18 1845AMP
    ****OFFSET LIMITER***********
    R4 12 11 2MEG
    R6 11 18 1MEG
    B2 16 18 V=V(11,18) > 1 ? 1 : V(11,18)
    V4 3 9 1
    D1 9 12 D2
    .MODEL D2 D
    ****OUTPUT DRIVER************
    XDRIVE 19 18 5 4 1845OUT
    ****S-R LATCH****************
    XLATCH 8 2 22 18 6 7 FFLOP { }
    ****OUTPUT AND GATE**********
    B8 5 18 V=V(2,18) > 2.5 ? V(7,18) > 2.5 ? V(8,18) > 2.5 ? 10 : 0
    .ENDS
    R12 6 11 8.2k
    C9 12 0 470p
    R13 12 7 1k
    Rload 14 0 10k
    C2 14 0 220uF IC=350
    Vline 4 0 DC=38
    L2 10 4 4.5m
    D1 10 14 DN4006RL
    .MODEL DN4006RL D
    R3 14 1 139k
    R4 1 0 1k
    Rsense 7 0 2.2
    Rgate 2 3 10
    .END

  • Poziom 43  
    Chodziło mi o narysowanie tego od nowa w LTSpice.
  • Poziom 20  
    Z tego co widzę (a szukałem długo), nie ma modelu UC3842 do LTSpice'a.
    Ściągam kolejny program do symulacji...

    Zaczynam myśleć, że to jakiś spisek.
  • Poziom 43  
    Tu nie trzeba UC3842. Wystarczy dać źródło napięcia prostokątnego (symbol "voltage").
    Tylko wtedy trzeba ręcznie ustawiać wypełnienie.
    Albo jak się chce żeby to działało samo to jakiś układ np. na komparatorach zrobić.
    W załączniku masz mój układ innej przetwornicy zrobiony właśnie w taki sposób (do przeróbki żeby uzyskać 30V, na razie jest a 24V).

    PS. A tak w ogóle to w LTSPice jest odpowiednik układu UC3842. Nazywa się LT1242.
  • Poziom 20  
    atom1477 napisał:
    Tu nie trzeba UC3842. Wystarczy dać źródło napięcia prostokątnego (symbol "voltage").
    Tylko wtedy trzeba ręcznie ustawiać wypełnienie.



    No tak, ale wtedy symulacja będzie tyczyła się tylko pozostałych elementów.
    A mi chodzi o przewidzenie problemów z samym układem i ewentualnie rozwiązanie ich zanim zacznę wytrawiać. Pewnie później też będzie coś do poprawienia, ale to inna sprawa.

    Faktycznie jest taki układ jak napisałeś, wykonałem z nim symulację i nie działa...
    Patrzę na schemat od 3 godzin, czytam pdfa i nic mi nie przychodzi do głowy.
    W załączniku moje wypociny...
    Model klucza chyba nie ma nic do rzeczy.
    Eksperymentowałem z innymi napięciami Vcc i tez klapa. Nie wiem co blokuje ten układ.

    Wiem jak to wygląda (takie tandetne pytania i problemy), ale nie mam siły na to dłużej patrzeć.
  • Poziom 43  
    as88 napisał:
    No tak, ale wtedy symulacja będzie tyczyła się tylko pozostałych elementów.

    Ale tylko symulacja tych elementów ma sens. Widać prądy. Czy cewka pracuje z prądem ciągłym czy opadającym do zera, itp.
    as88 napisał:
    A mi chodzi o przewidzenie problemów z samym układem i ewentualnie rozwiązanie ich zanim zacznę wytrawiać. Pewnie później też będzie coś do poprawienia, ale to inna sprawa.

    No właśnie tego nie przesymulujesz bo to zbyt skomplikowany układ.
    Generalnie takie układy scalone są w symulacji tylko po to żeby za ich pomocą można było przesymulować pozostałą część układu.

    A Twój układ nie działa, bo kondensator C3 nie jest połączony z pinem Rt/Ct (przyjrzyj się w powiększeniu). Z tego powodu oscylator w LT3842 nie rusza.
    Oraz tranzystor dałeś typu PMOS. Z tego powodu na pinie ISense ciągle jest 7V i układ LT3842 ciągle utrzymuje wyjście w stanie wyłączenia.
    A model klucza ma znaczenie. Domyślny gdy wstawisz NMOS i nie przypiszesz mu konkretnego typu ma napięcie przebicia UDS jakieś 40V a więc do tego napięcia będą zwierane impulsy z cewki.
    Więc wstaw np. STP8NM60.
    Po poprawieniu tych 3 rzeczy przetwornica u mnie ruszyła i dobija do 350V w ciągu na oko jakichś 900 ms.
  • Poziom 20  
    Okej.
    Ostatnim postem nie popisałem się, trochę zmęczony byłem.

    Wszystko niby działa, ale mam pewne wątpliwości co do działania tego układu.

    Otóż po wykonaniu kilku symulacji doszedłem do czegoś co mnie dość mocno zmartwiło. Widzę podobne problemy jak w oryginalnej aplikacji, którą robiłem z MC34063.
    Mianowicie:
    Spodziewałem się (nawet z symulacji) równego przebiegu przy ustalonym napięciu. Równego tzn ładnie piłokształtnego o równych ząbkach, a tymczasem mam wrażenie, że poza napięciem wyjściowym coś jeszcze decyduje o sygnale na bramce klucza. Tak jakby znowu przetwornica po prostu podnosiła napięcie, a po osiągnięciu zadanej wartości przerywała pracę (na krótką chwilę) co widać na przebiegach jako impuls z mniejszym wypełnieniem. I tak cyklicznie. Czy te układy po prostu tak działają i ja spodziewam się cudów, czy coś jest nie tak?
    W MC34063 można było tylko manipulować częstotliwością w niewielkim zakresie (a raczej czasem Ton lub Toff - nie pamiętam którym, ale miało to generalnie wpływ na częstotliwość).
    Tu jest nieco lepiej bo poza częstotliwością można też ustalić max wypełnienie, co uczyniłem i nieco pomaga. Wiem, że ograniczając max wypełnienie wydłużam czas ustalenia się napięcia wyjściowego i pewnie także odpowiedź na ewentualne skoki obciążenia, ale wtedy wydaje mi się, że mamy mniejsze tętnienia napięcia wyjściowego przy stałym obciążeniu (skoki tylko o te małe trójkąty, a nie o ich grupy).
    No i teraz nie wiem czy taka natura tych regulatorów, czy może jakiegoś parametru nie dobrałem prawidłowo.
    Nad MC34063 spędziłem sporo czasu niwelując ten efekt (skutecznie), a tu widzę że znowu jest podobnie...
    Może przy budowie powinienem dać elementy nastawne (Ct i Rt, żeby móc doregulować max wypełnienie na pracującym układzie przy obciążeniu?
    Powinienem się tym martwić i coś jeszcze poprawiać czy przystąpić do projektowania PCB?

    W załączniku pliki z wykresami:
    ster - sygnał wychodzący z na element kluczujący
    Vout - napięcie wyjściowe (350V)
    IL - prąd cewki
    literami CRT oznaczyłem przebiegi z nieco ograniczonym maksymalnym wypełnieniem (iloczyn C*R=const, ale R zmniejszone a C odpowiednio zwiększone)