Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Komparator napięcia, dioda awarii w układzie

strfind 21 Jul 2016 19:33 3231 53
Testo
  • #1
    strfind
    Level 16  
    Witajcie. Mam regulator napięcia stabilizowany który służy do zasilania wentylatora 12-8.5V.

    Po jakimś czasie zaczęła się świecić dioda awarii a napięcia na wyjściach układów były w okolicach 4V (min. 8.5V, maks. 12V).


    Po rozebraniu wymieniłem 2 kondensatory które były wystrzelone.
    Teraz napięcie na wyjściach wynosi 11.5V ale dioda awarii dalej świeci.
    Ustaliłem, że komparator LM393P załącza diodę awarii ponieważ Wyjście B- wynosi 11.5V a wyjście B+ tylko 2.5V co załącza diodę.
    Próbuję ustalić skąd się to 2.5V bierze, co za element uległ uszkodzeniu. Niestety nie mam wprawy w takich rzeczach dlatego zrobiłem kilka zdjęć i liczę na waszą pomoc.


    Komparator napięcia, dioda awarii w układzie
    Komparator napięcia, dioda awarii w układzie
    Komparator napięcia, dioda awarii w układzie
    Komparator napięcia, dioda awarii w układzie
    Komparator napięcia, dioda awarii w układzie
    Komparator napięcia, dioda awarii w układzie
    Komparator napięcia, dioda awarii w układzie
    Komparator napięcia, dioda awarii w układzie


    Proszę o radę co powinienem sprawdzić.
  • Testo
  • #2
    mariuszw19640717
    Level 35  
    strfind wrote:

    Po rozebraniu wymieniłem 2 kondensatory które były wystrzelone.

    Jak te dwa na zasilaniu, układ mógł się uszkodzić.
    Przed wymianą układu sprawdź te małe tranzystory i szklaną diodę przy układzie.
  • #3
    strfind
    Level 16  
    Tak te 2. Ale one są już za transformatorem, na 35V.
    O które tranzystory i diody chodzi ? (możesz zaznaczyć?)
  • Testo
  • #4
    mariuszw19640717
    Level 35  
    strfind wrote:
    Tak te 2. Ale one są już za transformatorem, na 35V.

    Tak na zasilaniu układu.
    strfind wrote:
    O które tranzystory i diody chodzi ? (możesz zaznaczyć?)

    Załącznik.
  • #5
    strfind
    Level 16  
    Dioda w kierunku przewodzenia ma: 676Ω, w zaporowym nie przewodzi.

    Tranzystor BC327 (PNP) (mój miernik ma jedynie pomiar diod i tym sprawdziłem przejścia na tym tranzystorze):

    B -> C : brak przejścia
    B -> E : brak przejścia
    C -> B : 784
    E -> B: 784


    Ten drugi to jest TL431A.
    A -> K : 713
    K -> A : zaporowy
  • #6
    _jta_
    Electronics specialist
    TL431 to jest dość dokładny stabilizator napięcia 2.5V połączony ze wzmacniaczem tak, by można było podłączyć dzielnik i uzyskać wyższe napięcie, może to napięcie 2.5V jest z niego, może zrobiła się przerwa w dzielniku i dlatego daje tylko 2.5V, a nie to wyższe, które miało być?

    Może odrysuj schemat według tego, co jest na płytce - ze zdjęć to niewykonalne, bo wiele oznaczeń jest nieczytelnych, łatwo mylnie zidentyfikować jakiś element, i nie ma jak na zdjęciu sprawdzać, gdzie jest połączenie - ścieżki jakoś widać, ale z cewkami transformatora gorzej.
  • #7
    strfind
    Level 16  
    Co to jest za element zaznaczony? Komparator napięcia, dioda awarii w układzie
    Za co on odpowiada i jaką powinien mieć rezystancję?



    Schematu nie potrafię narysować :(

    Lepsze zdjęcia

    Komparator napięcia, dioda awarii w układzie
  • #8
    mariuszw19640717
    Level 35  
    strfind wrote:
    Co to jest za element zaznaczony?
    strfind wrote:
    Za co on odpowiada i jaką powinien mieć rezystancję?

    Dławik, opór to, ułamki Ω.
    strfind wrote:
    Schematu nie potrafię narysować

    Pomierz chociaż opory w ramce.
  • #9
    Aress124
    Level 23  
    Nie znam się dokładnie na elektronice, ale moją szczególną uwagę przykuł jeden element, który jest chyba rezystorem i wygląda jak by był przypalony.
    Może on zmieniać parametry układu? Czy jednak on wygląda normalnie?
    I tak poza tym to kondensator na wyjściu jest lekko napuchnięty czy tak na zdjęciu wyszło?

    Komparator napięcia, dioda awarii w układzie
    Pozdrawiam.
  • #10
    strfind
    Level 16  
    Dziękuję za odpowiedzi. Zamieszczam pomiary z ramki:

    Komparator napięcia, dioda awarii w układzie


    EDIT:

    Aress124 wrote:
    Nie znam się dokładnie na elektronice, ale moją szczególną uwagę przykuł jeden element, który jest chyba rezystorem i wygląda jak by był przypalony.
    Może on zmieniać parametry układu? Czy jednak on wygląda normalnie?
    I tak poza tym to kondensator na wyjściu jest lekko napuchnięty czy tak na zdjęciu wyszło?

    Komparator napięcia, dioda awarii w układzie
    Pozdrawiam.

    Ten rezystor ma taki kolor :D Jego rezystancja to 68 Ω.
    Wszystkie kondensatory na wyjściu wymieniłem na nowe.
  • #12
    strfind
    Level 16  
    Tak to jest TL431A a BC327 jest na prawo od dławika.
    Jak rozległy ma być ten opis? Całą stronę za transformatorem? Czy wystarczy od tej diody awarii ?
  • #14
    strfind
    Level 16  
    dioda LED awarii jest jedną nóżką z wyjściem +12V a drugą:

    1. dioda LED > rezystor 988 > Output B w LM393P.

    2. Input B- w LM393P > rezystor 504 > wyjście "P" (to wyjście jest połączone na wyjściu z "+" przez rezystor 5670 Om.

    3. Input B+ w LM393P odchodzi w dwa miejsca:
    a. Input B+ > Input A-
    b. Input B+ > rezystor 149600 Om > "REFERENCE" LM431
  • #15
    _jta_
    Electronics specialist
    Do REF LM431 oprócz opornika 150k są podłączone oporniki 12k (nie jestem pewien - trzeci pasek jet pomarańczowy?) i 5k6, wszystkie są 5%. Pytanie, czy któreś z tych połączeń nie ma przerwy. Opornik 5k6 (prostopadły do wielu oporników w okolicy, paski zielony-niebieski-czerwony-złoty) jest między REF, a masą (pin 4 LM393). Podejrzewam, że to on ma przerwę.
  • #16
    strfind
    Level 16  
    _jta_ wrote:
    5k6 (prostopadły do wielu oporników w okolicy, paski zielony-niebieski-czerwony-złoty) jest między REF, a masą (pin 4 LM393).

    Miernik twierdzi, że ma on 4300 Om

    Jeśli chodzi o oporniki to każdy ma jakąś rezystancję, nie ma przerwy na żadnym (na całej płytce sprawdzałem).
  • #17
    _jta_
    Electronics specialist
    Miernik twierdzi, że ma on 4300 Om
    Pewnie nie tyle opornik, co cały układ oporności, jakie są w układzie.

    Może zrób pomiar napięć, ze sprawdzaniem osobno na każdej końcówce, która powinna być połączona? Jeśli jest przerwa, to taki pomiar pokaże np. brak napięcia na którymś oporniku, choć końcówki innych elementów, które powinny być z nim połączone, mają napięcie względem tego opornika - i już będzie wiadomo.

    Podam, która końcówka jest która, żeby przy analizowaniu nie trzeba było zaglądać do not katalogowych: LM393 (patrząc od góry numeracja w lewo od oznaczenia) 1=OUT_A 2=IN_A-, 3=IN_A+ 4=GND 5=IN_B+ 6=IN_B- 7=OUT_B 8=VCC; TL431 (patrząc od nóżek, płaskim do góry, 1 z lewej) 1=REF 2=Anoda 3=Katoda (anoda działa jak emiter, katoda jak kolektor).
  • #18
    strfind
    Level 16  
    _jta_ wrote:
    Pewnie nie tyle opornik, co cały układ oporności, jakie są w układzie.

    No faktycznie masz rację!

    Nie bardzo rozumiem co chcesz bym pomierzył.
    Mam przyłożyć sondę do jednej nóżki opornika a drugą do drugiej nóżki czy do następnego elementu połączonego z tym opornikiem?

    Dodano po 39 [minuty]:

    Dodałem sobie pracy i wylutowałem każdy rezystor i zmierzyłem, oto rezultaty:

    Komparator napięcia, dioda awarii w układzie
  • #19
    mariuszw19640717
    Level 35  
    Wszystkie opory sprawne to, może po zmianie kondensatorów zmieniło się napięcie i układ wymaga regulacji, tym niebieskim RN-em, sprawdź.
  • #20
    strfind
    Level 16  
    Mówisz o tym potencjometrze? On ma regulować w zakresie 8.5V - 12V, szybkość wentylatora. Poza tym oczywiście próbowałem i jego kręcenie zmienia napięcie na wyjściu ale nie wpływa na świecenie diody awarii (ta środkowa).
  • #21
    mariuszw19640717
    Level 35  
    lWylutuj LM393 i go sprawdź w prostej aplikacji, lub podstaw nowy.
    Pod pin 6 jest wentylator podpięty?
  • #22
    strfind
    Level 16  
    Jutro kupię LM393 w sklepie i zamienię.


    Pod Pin 6 w LM393? Z tego pinu wychodzi przez rezystor na wyjście oznaczone "P" do którego jest podłączony przewód od wentylatora ale nie wiem do czego służy. Powiem, że na tym "P" jest takie samo napięcie jak na "+" względem "-".

    Jest to właściwie urządzenie: HX VBP.


    Quote:
    Cechy· ochrona nasady poprzez detekcję stanów przeciążeniowych · układ miękkiego rozruchu · sygnalizacja optyczna stanu napięcia wyjściowego - zielona dioda LED · sygnalizację stanów awaryjnych - czerwona dioda LED · zabezpieczenie termiczne, obniża parametry pracy jeżeli temperatura wewnątrz rozdzielnicy przekroczy 60°C (wyświetla powiadomienie - dioda żółta) · płynna regulacja wydajności przy pomocy potencjometru ·

    Może to właściwie pomoże w ustaleniu usterki.
  • #23
    _jta_
    Electronics specialist
    Najczęstszym uszkodzeniem jest brak połączenia tam, gdzie ono powinno być (bo coś się urwało, skorodowało... często tak, że nie widać). Mierzyć trzeba tak, by takie uszkodzenia wykryć, gdziekolwiek są. Oporniki raczej rzadko zmieniają swój opór - i zwykle po takim potraktowaniu, którego i inne elementy nie wytrzymują, albo po którym mają przypalony lakier. Ale może skorodować cyna, którą opornik jest przylutowany, i wtedy pogarsza się, albo znika połączenie między końcówką opornika, a ścieżką na płytce (często przygrzanie lutownicą, a tym bardziej wylutowanie opornika i wlutowanie go z powrotem usuwa takie uszkodzenie). Często zdarza się też, że suwak potencjometru (rzadziej koniec) traci kontakt. Zazwyczaj przez oporniki płynie jakiś prąd - jeśli przerwało się połączenie opornika ze ścieżką, to pomiar napięć pokazuje brak napięcia na oporniku, a obecność napięcia między końcówką opornika, a ścieżką, do której jest przylutowany. Tylko jest to trochę żmudne - w takim układzie dziesiątki, albo nawet setki pomiarów, bo mierzyć trzeba wszędzie. I początkujący więcej mają chęci do tego, by wymienić połowę elementów, niż żeby sprawdzać napięcia i pomyśleć - a wymiana elementów nie pomoże, jeśli pękła ścieżka, i niby jest, a połączenia nie ma.
  • #24
    strfind
    Level 16  
    Wymieniłem LM393P oraz BC327, TL431 nie mieli. Nie pomogło.


    Zgodnie z twoimi wytycznymi @_jta_ zrobiłem pomiar rezystancji scieżki pomiędzy elementami aby sprawdzić czy ścieżka nie ma przerwy. Ustawiłem na 200Ω z piszczkiem i raczej nie szło przez cały obwód bo 0Ω pokazuje na ścieżkach pomiędzy elementami. Teoretycznie jeśli metodologia jest prawidłowa to ścieżki są ok.

    Jestem w stanie zmierzyć omomierzem czy kondensator ceramiczny 222 3kV jest sprawny? Bo miernik ustawiony na 20MΩ pokazuje nieskończoność natomiast jak przykładam do takiego kondensatora tylko 472 3kV pokazuje 1.2MΩ (oczywiście oba wylutowane).
  • #25
    mariuszw19640717
    Level 35  
    strfind wrote:
    miernik ustawiony na 20MΩ pokazuje nieskończoność

    Sprawny.
    strfind wrote:
    natomiast jak przykładam do takiego kondensatora tylko 472 3kV pokazuje 1.2MΩ

    Uszkodzony.
  • #26
    strfind
    Level 16  
    Jednak to mój błąd pomiarowy. (mierzyłem przez palec przypadkiem) Oba mają nieskończoność.

    Dioda zapala się przez podanie masy przez LM393, B- z LM393 jest połączone z "+" przez rezystor (obecnie ma napięcie ok. 9.5V), a B+ z LM393 jest połączone z katodą TL431. Nie wiem co teraz zrobić :(

    Dodano po 23 [minuty]:

    Wylutowałem TL431. Miernik na tester diod.
    Po przyłożeniu czerwonej sondy do Reference a czarnej do Katody wskazuje 970Ω.
    Po przyłożeniu czerwonej sondy do Anody a czarnej do Katody wskazuje 705Ω.
    Po przyłożeniu czerwonej sondy do Katody nie przewodzi do żadnej innej nóżki.

    Da się to jakoś zinterpretować ?

    Dodano po 15 [minuty]:

    Po uruchomieniu układu bez TL431 dioda zasilania oraz awarii wciąż świeci tylko, że pulsują z częstotliwością ok. 1Hz
  • #27
    _jta_
    Electronics specialist
    Może najpierw sprawdzaj, zanim wymienisz? Wymieniając na ślepo małe masz szanse, żeby trafić, a TL431 najprościej sprawdzać w układzie poprzez pomiar napięć, na przykład mierząc napięcia REF i katody względem anody, oraz napięcia na opornikach (między końcówkami każdego z nich) połączonych z REF.
  • #28
    strfind
    Level 16  
    Trzeba było od razu mówić jak mierzyć :)

    Pomiędzy referencją a anodą jest 7.6V
    Pomiędzy katodą a anodą jest 6.9V


    Bezpośrednio do REF jest połączony tylko potencjometr.

    Dodano po 28 [minuty]:

    Napięcie pomiędzy REF a Katodą TL431 wynosi 0.7V, nie powinno być 2.5V?
  • #29
    _jta_
    Electronics specialist
    W normalnych warunkach pracy między REF (pin 1 - tu jest dobrze pokazane, która nóżka jest która), a anodą (pin 2) powinno być 2.5V; napięcie katody zależy od oporników w układzie. Wygląda na to, że TL431 jest uszkodzony. Ale wypadałoby to sprawdzić. A może po wylutowaniu wlutowałeś nie w tę stronę? Koniecznie sprawdź, masz zdjęcia. Jeśli był w odwrotną stronę, to sprawdź, czy działa, zanim go wlutujesz.

    Bezpośrednio do REF jest połączony tylko potencjometr.
    Ja widzę, że ścieżka, do której jest podłączony REF, ma 5 lutowań - REF, kondensator (szeregowo z opornikiem 3.25k do katody), i 3 oporniki. Natomiast nie widzę, by bezpośrednio był podłączony potencjometr. Katoda, o dziwo, jest (oprócz opornika 3.25k) połączona tylko z opornikiem 1k (chyba, że ja czegoś nie widzę), który idzie do 4-pinowego układu (transoptor?).

    Wygląda na to, że te 2.5V, które masz na nóżce IN_B+ (5) LM393, przychodzi z REF poprzez opornik 150k - więc zapewne tam miało być 2.5V; pytanie, jak miało być coś zbliżonego do 2.5V na IN_B- (6 - ta nóżka jest połączona z czymś przez opornik 510 om, ale nie widzę, z czym)?
  • #30
    strfind
    Level 16  
    _jta_ wrote:
    A może po wylutowaniu wlutowałeś nie w tę stronę? Koniecznie sprawdź, masz zdjęcia. Jeśli był w odwrotną stronę, to sprawdź, czy działa, zanim go wlutujesz.

    Wlutowałem dobrze bo nóżki są oryginalnie wygięte i pamiętałem, że płaski do wnętrza układu.

    _jta_ wrote:
    Natomiast nie widzę, by bezpośrednio był podłączony potencjometr.

    Fakt, potencjometr jest podłączony przez rezystor 11.83k.

    _jta_ wrote:
    Katoda, o dziwo, jest (oprócz opornika 3.25k) połączona tylko z opornikiem 1k (chyba, że ja czegoś nie widzę), który idzie do 4-pinowego układu (transoptor?).

    Dokładnie tak jest.

    _jta_ wrote:
    6 - ta nóżka jest połączona z czymś przez opornik 510 om, ale nie widzę, z czym)?


    Z tego opornika 500 Om idzie na wyjście oznaczone literą "P" na obudowie urządzenia. Nie mam pojęcia po co się podłącza do wentylatora.

    W każdym bądź razie na tym "P" panuje takie samo napięcie jak na "+" względem "-".
    Samo "P" jest połączone przez rezystor 5k z "+".