Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

FUJITSU SIEMENS D2750-A2 - Wymiana procesora na Q9650

tinware 21 Lip 2016 20:29 1020 7
  • #1 21 Lip 2016 20:29
    tinware
    Poziom 9  

    Witam,

    Posiadam płytę FUJITSU SIEMENS D2750-A2, w internecie znalazłem dokumentację (do modelu D2750-A, ale to chyba o to samo chodzi):
    Link

    W płycie zainstalowany jest procesor Intel Core 2 Duo E4600. Wzorując się na dokumentacji postanowiłem zakupić procesor Q9650.

    Po dzisiejszym pierwszym zainstalowaniu nowego procesora w gnieździe pojawia się monit podczas włączania:

    Cytat:
    (...)
    No Microcode Update Loaded for Booting Processor
    Press <F1> to resume

    Mam do wyboru F2 (konfiguracja biosu) oraz F1 - po wciśnięciu system się włącza, dalsza praca na komputerze przebiega bez problemu.

    1.
    Po wymianie procesora wentylator na radiatorze od procesora chodzi w sposób ciągły na maksymalnych obrotach przez cały czas pracy komputera, nie zależnie czy obciążam go, czy pracuje bez obciążenia (pulpit), czy jestem w konfiguracji biosa.

    2.
    To mój pierwszy kontakt z czymś, co ma więcej niż 2 rdzenie taktowane 2GHz, ale wydaję mi się, że mój nowy procesor nie wykorzystuje wszystkich zasobów swojej mocy.

    3. Próbowałem aktualizować bios, lecz moja obecna wersja to 6.00 R1.04.2750.A2. Postanowiłem znaleźć nowszą wersję na oficjalnej stronie, lecz jej nie widzę:
    Link

    Jeden z tematów na tym forum nawiązuje do aktualizacji biosa:
    Link

    4.
    Dziwne jest to, że mimo dokumentacji i doboru nowego zakupu wedle jej pojawia się jakiś problem. Czy muszę liczyć się z wymianą płyty głównej czy da się z tym coś zrobić?

    5.
    Proszę o wyprowadzenie mnie z błędu jeśli się mylę: Q9650 jest procesorem 32-bitowym i nie muszę dokonywać instalacji systemu 64-bitowego, ponieważ obecnie mam 32-bit.


    Jeśli to w ogóle istotne, to powierzchownie:
    ram: 2x 2gb ddr2
    grafika: nVidia 256MB
    system: Windows 7 Ultimate
    Dysk: 80GB
    Zasilacz: 280W


    To chyba wszystkie informację jakie mogłem udzielić. Liczę na Waszą pomoc.

    0 7
  • Pomocny post
    #2 21 Lip 2016 21:34
    Stando01
    Poziom 18  

    Moim zdaniem większość problemów powinna rozwiązać aktualizacja BIOS. Tylko takiej nie widzę.

    Ad 4. Z nową płytą może być problem, bo to nie ma wielu płyt w formacie µBTX.

    Ad 5. Intel Core 2 Duo E4600 jest 64 bitowy podobnie jak Q9650. Nie musisz instalować systemu 64 bitowego.

    Można spróbować zresetować CMOS.

    Przy okazji rozważyłbym wymianę zasilacza. 280W może nie wytrzymać za długo dodatkowego obciążenia.

    0
  • Pomocny post
    #3 21 Lip 2016 21:42
    310artur
    Poziom 43  

    Trzeba by updetować cpu patch w twoim BIOS czyli w najnowszym jaki jest na stronie którą podałeś. Jednak konstrukcja tego BIOSu jest co najmniej dziwna. Nie jestem specjalistą. Data CPU patcha dla procesorów o CPUID 01067Ah (czyli też twojego) jest 9.4.2008 a sam procesor wedle informacji intela ma premierę 3.2008 czyli miesiąc wcześniej. Możliwe że brakuje w CPUpatchu informacji o tym procesorze.
    Ja nie potrafię tego uaktualnić. Widać że microcody są w osobnym pliku o nazwie P6_INTEL.ALL ale nie wiem jaki format ma ten plik i jak go edytować. Same CPU pache mogę podesłać do te akurat mam datowane na 2010 rok. Mogę też wyłuskać całą tablice P6 ze swojego BIOSu tylko nie wiem jak ją podstawić.

    0
  • #4 21 Lip 2016 21:53
    tinware
    Poziom 9  

    Cześć! Dzięki za odpowiedź.

    Stando01 napisał:
    Moim zdaniem większość problemów powinna rozwiązać aktualizacja BIOS. Tylko takiej nie widzę.

    Właśnie... Nie jestem znawcą tych tematów, ale skoro producent podaje w specyfikacji, że "pójdzie" to powinien dać pod to odpowiednie oprogramowanie.

    Stando01 napisał:
    Ad 4. Z nową płytą może być problem, bo to nie ma wielu płyt w formacie µBTX.

    Format płyty może być prawie dowolny, najważniejsze jest dla mnie, aby ze strony krótszej była jak najkrótsza. Chyba microATX byłoby dla mnie najlepszym rozwiązaniem: niecałe 200mm głębokości komputera. To dość nietypowa obudowa (jeszcze nie powstała), ale nie to jest tematem tego tematu ;)

    Stando01 napisał:
    Ad 5. Intel Core 2 Duo E4600 jest 64 bitowy podobnie jak Q9650. Nie musisz instalować systemu 64 bitowego.

    Chyba będę musiał poszerzyć swoją wiedze w tym zakresie, bo wydawało mi się, 32-bitowy procesor = 32 bitowy system, 64bit CPU = 64bit system.

    Stando01 napisał:
    Można spróbować zresetować CMOS.

    Wyciąganie baterii od układu na którym jest BIOSu, zwarcie 2 lub 3 pinów na czas jednej minuty oraz powrót do stanu pierwotnego?

    Stando01 napisał:
    Przy okazji rozważyłbym wymianę zasilacza. 280W może nie wytrzymać za długo dodatkowego obciążenia.

    Tak, myślałem o tym, ale jak na razie podczas użytkowania E4600 nie było problemów, a Q9650 w tym wypadku chodzi trochę lepiej od tego E4600 - to zapewne wina tego błędu BIOSa. Chciałbym, aby wszystko działało, następnie obciążyć procesor w 100% i wtedy wydać werdykt, czy wymienić zasilacz czy nie wymieniać. Komputer jest budżetowy, używany rzadko, więc też nie chce "pakować" w niego pokaźnych kwot, zwłaszcza, że w tym roku używam go drugi raz.

    0
  • Pomocny post
    #5 21 Lip 2016 22:21
    Stando01
    Poziom 18  

    tinware napisał:

    Wyciąganie baterii od układu na którym jest BIOSu, zwarcie 2 lub 3 pinów na czas jednej minuty oraz powrót do stanu pierwotnego?

    Można spróbować. Choć bez aktualizacji mikrokodów niewiele może to pomóc.

    0
  • #6 21 Lip 2016 22:25
    tinware
    Poziom 9  

    310artur napisał:
    Trzeba by updetować cpu patch w twoim BIOS czyli w najnowszym jaki jest na stronie którą podałeś. Jednak konstrukcja tego BIOSu jest co najmniej dziwna. Nie jestem specjalistą. Data CPU patcha dla procesorów o CPUID 01067Ah (czyli też twojego) jest 9.4.2008 a sam procesor wedle informacji intela ma premierę 3.2008 czyli miesiąc wcześniej. Możliwe że brakuje w CPUpatchu informacji o tym procesorze.
    Ja nie potrafię tego uaktualnić. Widać że microcody są w osobnym pliku o nazwie P6_INTEL.ALL ale nie wiem jaki format ma ten plik i jak go edytować. Same CPU pache mogę podesłać do te akurat mam datowane na 2010 rok. Mogę też wyłuskać całą tablice P6 ze swojego BIOSu tylko nie wiem jak ją podstawić.


    Artur, OK.

    Doszedłem do podobnych wniosków, że coś jest nie tak.

    Czy zalinkujesz mi jakąś instrukcję jak to zrobić? Na co dzień poruszam się w shellu, więc nie powinienem mieć problemów. Niestety, takich rzeczy nigdy w życiu nie robiłem i nie jestem specem od "Hardwaru".

    Czy w wyniku tych operacji mogę jakoś nieodwracalnie "ubić" moją płytę, coś innego lub uszkodzić, gdzie naprawa była by trudna/kosztowna/czasochłonna?


    Stando01 napisał:
    Można spróbować. Choć bez aktualizacji mikrokodów niewiele może to pomóc.

    To zdjęcie tej płyty (lub bardzo podobnej wyciągnięte z internetu). Nad baterią znajduje się gniazdo z 4 gold pinami. Czy to te należy wszystkie razem ze sobą zewrzeć po wyjęciu baterii?

    0
  • Pomocny post
    #7 21 Lip 2016 23:12
    310artur
    Poziom 43  

    W wyniku takie manewru możesz po prostu uwalić BIOS. Recovery po takim updacie zadziała albo i nie. Jeśli nie pozostanie ci programator albo kości lutowanie jeśli jest na stałe a interface nie dali na płycie.

    Instrukcje do BIOSu który dostarczony jest w kawałkach? Wątpię że takowa istnieje.
    Próbowałem wstawić te tabele za pomocą narzędzia do edycji BIOSu AMI MMTOOL da się ale jest z jakimś błędem (kawałek tabeli widać) więc tak się nie uda.
    Ja zrobiłbym tak - tylko strona fuhitsu mnie odstrasza. Poszukaj tam płyty z soketem LGA775 najlepiej na chipsecie P45 czy Q45 lub nowszym bo tu powinny być najnowsze cpu pache. Każdy BIOS tam ogólnie ma taką samą strukturę. W każdym masz plik P6_INTEL.ALL i ten plik cie interesuje. Pod nim masz plik tekstowy a tam wypisane jakie są CPUpatche. Musisz znaleźć taki który ma pach dla CPUID 067A nowszy niż jest w twoim biosie (daty też są). Wtedy podmieniasz tylko ten plik P6_INTEL.ALL na nowszy w swoim BIOSie. Taka modyfikacja uda się na 99%. I rozwiąże problem. Oczywiście Update BIOS robisz później zgodnie z instrukcją całym tym swoim BIOSem z podmienioną tabelą P6. Tego jestem pewien co pisze bo mam Xeonmod zrobiony na swojej płycie i trochę czytałem o tych tabelach P6 i cpupachach. W BIOSach AMI podmienia się często całą tabele P6 na taką z wyższego modelu płyty i to działa (jeśli tylko chipset obsługuje dany procesor to po podmianie płyta najczęściej też)

    I jedna jeszcze uwaga - na stronie Fujitsu jest tak płyta D2750-A2 jak płyta D2750-A1 więc musisz wiedzieć dokładnie jaką masz.


    Nad baterią to widzę piny FUN2 czyli gniazdo wentylatora. Jak nie masz zworki CMOS to wyjmujesz baterie na odpiętym zasilaczu oczywiście z gniazdka (bez napięcia 5VSB musi to być) i wciskasz power kilka razy na obudowie jakbyś PC włączyć chciał. To rozładuje kondensatory na płycie i w zasilaczu co powinno skutecznie zresetować BIOS. Efekt poznasz jak godziny zapomni.

    0
  • #8 23 Lip 2016 20:16
    tinware
    Poziom 9  

    Cześć,

    Udało się. Dziękuję Wam za pomoc i trafne znalezienie przyczyny mojego problemu. Chciałem zostawić jakiś ślad dla "potomnych", więc postaram się przybliżyć co zrobiłem.

    Resetowanie ustawień BIOS poprzez wyjęcie baterii zasilającej CMOS uznałem tak jak i Wy za mało prawdopodobne lekarstwo na zaistniały problem, więc postanowiłem wykonać to na samym końcu, jeśli dotychczasowe próby usunięcia problemu nie przyniosłyby żadnych efektów. Jedyne co zrobiłem to przywróciłem BIOS do ustawień fabrycznych wybierając jedną z opcji już w samym Phoenix.

    Instalację BIOSu postanowiłem wykonać następująco: zainstalować oryginalny, ponieważ płyta powinna obsłużyć mój nowy procesor, a jeśli nie dałoby to efektów spróbować Waszej propozycji z podmianą pliku "P6" - bałem się, że moja ingerencja w pliki oprogramowania spowoduję błąd podczas instalacji i BIOS się nie zainstaluje, co zmusiłoby mnie do jego wylutowania z płyty głównej i programowania na programatorze.

    Pobrałem więc ze strony producenta "Flash BIOS Update - Compressed Flash Files" dla mojej płyty FUJITSU SIEMENS D2750-A2, wypakowałem i przerzuciłem zawartość na pen drive. Podczas rozruchu wcisnąłem F12 i wybrałem pamięć USB - komputer pominął go i zaczął bootować się system z dysku twardego.

    Postanowiłem wypalić te dane na pen drive za pomocą programu Ultra ISO i tym razem powodzenie - komputer podczas rozruchu wykrył i prawidłowo wczytał jego zawartość. Poinformował mnie, że wersja którą próbuję zainstalować jest identyczna z tą, którą aktualnie posiadam. Zaakceptowałem jej wykonanie. Cała instalacja BIOSu trwała około 15 sekund. Po ponownym uruchomieniu komputera uruchomił się on bez dwukrotnego dźwięku i nie wyświetlił błedu:

    Cytat:
    (...)
    No Microcode Update Loaded for Booting Processor
    Press <F1> to resume


    Wydaje mi się, że sam system jak i całość używanego przeze mnie oprogramowania chodzi dużo szybciej i użycie procesora nie przekracza 60%, gdzie przy tym samym zestawie oprogramowania przy użyciu starego procesora E4600 procesor był w 100% użyciu.

    Za Waszą pomoc podarowałem Wam punkty. Jeszcze raz dziękuję i temat uważam za zamknięty, rozwiązany.

    0