Elektroda.pl
Elektroda.pl
X
Arrow Multisolution Day
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Transoptor i stan niestabilny przekaźnika

matej1410 02 Sie 2016 14:11 588 11
  • #1 02 Sie 2016 14:11
    matej1410
    Poziom 21  

    Witam.

    Transoptor i stan niestabilny przekaźnika

    W schemacie jak na rysunku po podaniu stanu wysokiego z mikrokontrolera Atmega przekaźnik zaczyna wariować tzn. załącza się i wyłącza z bardzo dużą częstotliwością.
    Wartości:
    R2 680 Ohmów
    OK2 PC817
    R3,R4 1k
    Tranzystor BC817

    Wydaje mi się, że tranzystor jest poprawnie wysterowany. Proszę o radę.

    0 11
  • Arrow Multisolution Day
  • #2 02 Sie 2016 14:30
    trymer01
    Moderator Projektowanie

    Vdd= ?
    Przekaźnik na jakie napięcie?, jaki ma pobór prądu?
    Napięcie zasilania Vdd to zasilacz/bateria...? Jaka wydajność prądowa?
    Prawdopodobnie zasilacz ma zbyt małą wydajność prądową, po włączeniu przekaźnika pobór prądu powoduje obniżenie napięcia Vdd, wyłączenie przekaźnika itd.
    Pomierzyć/obejrzeć na oscyloskopie Vdd.

    0
  • Arrow Multisolution Day
  • #3 02 Sie 2016 16:44
    matej1410
    Poziom 21  

    Vdd 5V
    Przekaźnik AZ6991-1C-5DE
    Stabilizator LM1117 5V

    Nie doprecyzowałem bardzo istotnej rzeczy.
    Dla pojedynczego obwodu tak jak na obrazku nie ma problemu ale dla dwóch i trzech dzieje się właśnie tak jak napisałem.

    Dodano po 1 [godziny] 51 [minuty]:

    Problem rozwiązany. Zbyt mała wydajność prądowa trafa.

    0
  • #4 03 Sie 2016 08:49
    matej1410
    Poziom 21  

    To jednak nie trafo. Prąd jednej cewki przekaźnika to 35mA. Gdy aktywuje dwa przekaźniki prą około 70mA i wszystko ok. Po załączeniu 3 przekaźników zaczyna się problem i styki przekaźników słyszalnie drgają. W momencie gdy podam 5V z zasilacza laboratoryjnego na wyjście układu stabilizującego wszystko działa jak należy i trzy przekaźniki działają poprawnie. Prąd tego transformatora na uzwojeniu wtórnym zgodnie z notą producenta to max 160mA.

    0
  • #5 03 Sie 2016 09:32
    trymer01
    Moderator Projektowanie

    matej1410 napisał:
    gdy podam 5V z zasilacza laboratoryjnego na wyjście układu stabilizującego wszystko działa jak należy i trzy przekaźniki działają poprawnie.

    To dowód na to, iż problem leży w zasilaczu - jak pisałem wyżej - w jego niewystarczającej wydajności prądowej.
    Transformator 160mA nadaje się do zasilacza 100mADC.
    Proszę zmierzyć:
    - napięcie zmienne na transformatorze w momencie gdy zasilacz jest obciążony układem z trzema włączonymi przekaźnikami (zmienne, na transformatorze),
    - napięcie stałe 5V.
    Proszę zamieścić schemat zasilacza.

    0
  • #6 03 Sie 2016 10:42
    jdubowski
    Specjalista - urządzenia lampowe

    matej1410 napisał:
    Po załączeniu 3 przekaźników zaczyna się problem


    Co pokazuje woltomierz na wyjściu zasilacza w takim stanie?

    matej1410 napisał:
    styki przekaźników słyszalnie drgają.


    Słaba filtracja zasilania?

    0
  • #7 03 Sie 2016 11:04
    matej1410
    Poziom 21  

    Trymer01 mam 10,9V na wtórnym przy obciążeniu trzema przekaźnikami.

    schemat:
    Kondensatory C3 oraz C4 10uF i C8 i C6 100nF.
    Transoptor i stan niestabilny przekaźnika

    Bez obciążenia przekaźnikami na wyjściu stabilizatora 5V. Po włączeniu pierwszego przekaźnika spada o 0,6V do 4,4V, gdy dwa przekaźniki działają to robi się 4V, gdy 3 przekaźniki działają również 4V.

    Dodano po 6 [minuty]:

    Jak zasiliłem z zasilacza laboratoryjnego to przy trzech przekaźnikach prąd wyniósł 110mA, ale przecież wydajność prądowa transformatora wynosi max 167mA.

    Przylutowałem nowy stabilizator oraz trafo ale nadal tak samo.

    0
  • #8 03 Sie 2016 11:22
    trymer01
    Moderator Projektowanie

    Przy tej pojemności C3=10mikroF tętnienia są ogromne, i to nie jest zasilacz ale generator 100Hz. Czyli zasilasz przekaźniki napięciem zmiennym, stad "brzęczenie".
    Zwiększ C3 min. 20 razy, najlepiej do 470 mikroF/25V. Pozostałe pojemności są OK.

    matej1410 napisał:
    przecież wydajność prądowa transformatora wynosi max 167mA.

    Dla obciążenia ciągłego transformator w tym układzie powinien mieć wydajność 1,6 razy większą od poboru prądu DC - czyli tutaj max. obciążenie DC to 100mA.
    Jeśli przekaźniki nie są włączane na dłuższy czas (powiedzmy 0,5 godz.) to można transformator przeciążyć, 110mA to nieznaczne przeciążenie.

    LM1117 w jakiej obudowie? - czy ma radiator? - bo wydziela się na nim ponad 1W.

    0
  • #11 03 Sie 2016 11:43
    trymer01
    Moderator Projektowanie

    matej1410 napisał:
    Obudowa SOT

    Powinna być przylutowana do sporego pada miedzi na PCB, albo inna obudowa+radiator.

    Jeszcze n/t kondensatorów; - http://www.ti.com/lit/ds/symlink/lm1117.pdf str. 16 - Figure 16.
    Ten stabilizator wymaga takich pojemności gdy jest oddalony od prostownika z kondensatorem (470 mikroF). Jeśli jest przy kondensatorze 470 mikroF - ten 10mikroF/tantal na wejściu jest niekonieczny, ale na wyjściu - tak.
    Zamiast 10mikroF/tanatal można dać 10mikroF+0,1mikroF (jak u Ciebie).
    W przeciwnym razie stabilizator może się wzbudzać (generować drgania=napięcie zmienne na wyjściu)

    0
  • #12 03 Sie 2016 11:51
    matej1410
    Poziom 21  

    Pomogło zwiększenie pojemności. Wygląda, że jest ok. Dzięki za pomoc.

    0