Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Windows 10 build 14393 - storahci 129, dysk się zawiesza

lelekx 07 Sie 2016 18:42 3894 6
  • #1 07 Sie 2016 18:42
    lelekx
    Poziom 29  

    Wczoraj zrobiłem aktualizację Windows 10 do wersji 14393 (Anniversary Update). Od tego czasu nieregularnie, średnio co 30 minut, komputer przestaje reagować, zapala się dioda dysku i po ok. 5-15s wszystko wraca do normy.
    W logach pojawiają się 2 wpisy:
    - storahci 129: Wydano polecenie resetowania urządzenia \Device\RaidPort0.
    - disk 153: Operacja we/wy została ponowiona dla adresu bloku logicznego 0x******** dysku 0 (nazwa PDO: \Device\00000030).

    System: Windows 10 Home build 14393
    Komputer: Dell Latitude E5510: i3 370, 6GB DDR3, HM55
    Firmware: BIOS (nie włączałem rozruchu przez UEFI)
    SSD: GoodRAM C40 120GB, firmware S9FM02.3; 1 partycja systemowa MBR + 3 małe zarezerwowane partycje; 20GB wolne na partycji systemowej; przepracowane 2560 godzin, SMART OK.

    Podobny problem miałem wcześniej przy okazji Insider Preview, niestety nie pamiętam który build. Wówczas problem się stopniowo nasilał i musiałem zaorać dysk - nie dało się wrócić do systemu sprzed instalacji Insider Preview.

    Jakieś wskazówki?

    0 6
  • #2 07 Sie 2016 21:55
    Robert B
    Poziom 43  

    Pokaż SMART tym zamiast opowiadać:
    www.hdsentinel.com
    Tylko ten SSD masz?

    0
  • #4 07 Sie 2016 22:20
    lelekx
    Poziom 29  

    Bios A16. Podniosłem firmware SSD do najnowszej wersji 2.08, nie pomogło.
    SMART:
    Windows 10 build 14393 - storahci 129, dysk się zawiesza
    ---
    Update: A16 nie A10, 2.08 nie 2.09

    0
  • #5 07 Sie 2016 22:29
    Robert B
    Poziom 43  

    Jeżeli

    lelekx napisał:
    zapala się dioda dysku i po ok. 5-15s wszystko wraca do normy

    To za długo nawet dla talerzowca a dla SSD zdecydowanie.
    Prosiłem o HD Sentinel, żeby można było sprawdzić czas odczytu komórek.

    0
  • #6 07 Sie 2016 22:46
    lelekx
    Poziom 29  

    Dysk jest fizycznie sprawny. Te same problemy występowały w Windows 10 Insider Preview 14316. Po powrocie do wcześniejszej kompilacji wszystko chodziło dobrze.

    Tymczasowo przestawiłem kontroler dysku w tryb IDE, problem ustąpił. Na razie mnie to zadowala, ale nie w 100%. Wygląda na to, że jest bug w sterowniku AHCI Microsoftu.

    Raport w załączniku, usunąłem informacje niedotyczące dysku.

    Senitel ma mnóstwo opcji dostępnych po zapłaceniu wygórowanej ceny, ściągnąłem HDDScan for Windows:

    Cytat:

    Open Disk
    Test : RD-Read


    Executing
    Block start at 42669056 time 65ms
    Block start at 116129536 time 72ms
    Block start at 160429824 time 69ms
    Block start at 160430080 time 101ms

    Microsoft opublikował KB3083595, objawy się zgadzają. Zaraz przestawię z powrotem kontroler na AHCI i sprawdzę, czy to rozwiązanie działa.
    ----
    Niestety, rozwiązanie z KB3083595 nie pomogło, objawy w trybie AHCI występują nadal. W trybie IDE wszystko działa dobrze.
    Spróbuję jeszcze podmienić sterownik storahci.sys z poprzedniej kompilacji.
    ----
    Sterownik storahci.sys w wersji 10.0.10586 działa poprawnie, nie ma problemów z dyskiem. To rozwiązanie urządza mnie w 95%, 5% to niepewność, kiedy zostanie on podmieniony z powrotem przez aktualizacje.

    Problem uważam za rozwiązany.

    0
  • #7 13 Sie 2016 18:32
    lelekx
    Poziom 29  

    Dla potomnych.

    Jeżeli problem też występuje u Ciebie, możesz spróbować podmienić plik storahci.sys na starszy. Ale na starcie dwie uwagi:
    NIGDY nie instaluj sterowników z nieznanych źródeł; jeżeli podmieniasz pliki systemowe, upewnij się, że nowy plik jest podpisany cyfrowo przez producenta sterownika (tu: Microsoft).
    MOŻESZ USZKODZIĆ SYSTEM jeżeli coś pójdzie nie tak - przeczytaj instrukcję 2x zanim zabierzesz się do modyfikacji plików systemowych.

    Oryginalny plik w wersji 10586 masz na pewno w kopii zapasowej robionej przez aktualizację, ale nie pamiętam w którym folderze (na pewno nie Windows.old).
    W razie potrzeby plik storahci.sys jest w załączniku: storah..zip Download (71.98 kB). Instalacja jest dość kłopotliwa, system może Ci nie pozwolić ot tak go podmienić:
    - otwórz folder c:\windows\system32\drivers, zlokalizuj storahci.sys,
    - zmień uprawnienia do pliku:
    * kliknij PPM na pliku i wybierz Właściwości, na karcie Zabezpieczenia kliknij Zaawansowane,
    * obok Właściciel: TrustedInstaller kliknij Zmień,
    * w oknie "Wybieranie: Użytkownik lub grupa" kliknij Zaawansowane,
    * w kolejnym oknie "Wybieranie: Użytkownik lub grupa" kliknij Znajdź teraz i wskaż nazwę swojego użytkownika, kliknij OK,
    * we wszystkich oknach po kolei kliknij OK,
    * jeszcze raz na storahci.sys kliknij PPM->właściwości, na karcie Zabezpieczenia kliknij Edytuj,
    * w oknie "Uprawnienia dla storahci.sys" kliknij Dodaj,
    * wpisz nazwę swojego użytkownika albo tak jak wcześniej wyszukaj ją; kliknij OK,
    * w oknie "Uprawnienia dla storahci.sys" wybierz swoją nazwę użytkownika i zaznacz "Pełna kontrola"; kliknij OK we wszystkich oknach po kolei.

    - wypakuj załączony plik storahci.sys w łatwo dostępne miejsce,
    - zmień nazwę oryginalnego storahci.sys na storahci.bak i szybko wrzuć do tego folderu wypakowany storahci.sys,
    - sprawdź, czy plik został prawidłowo podmieniony - bez tego komputer może się nie uruchomić!
    - zrestartuj komputer.

    2