Elektroda.pl
Elektroda.pl
X
AM TechnologiesAM Technologies
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Przetwornica 12/220 230 W na sg3524

devolt 16 Kwi 2012 19:16 79280 151
  • #121
    Endriuk944
    Poziom 10  
    Super z tym układem zabezpieczenia będę próbował

    a co do sterowania wentylatorem czytałem że zamiast termistora PTC 10K

    można wstawić LM35 tylko nie mam pojęcia jak

    są trzy nóżki V+ Vout GND

    wiem że któreś trzeba zewrzeć tylko które ?
  • AM TechnologiesAM Technologies
  • #122
    andy127
    Poziom 30  
    Endriuk944 napisał:
    Super z tym układem zabezpieczenia będę próbował
    a co do sterowania wentylatorem czytałem, że zamiast termistora PTC 10K
    można wstawić LM35 tylko nie mam pojęcia jak
    są trzy nóżki V+ Vout GND
    wiem, że któreś trzeba zewrzeć tylko które?

    Ja bym nic nie zwierał.
    LM35 podłączyłbym zamiast R21 i PTC:
    +Vs do plusa,
    Vout do nogi 3 układu US5,
    GND do minusa.
    Dobrać wartości R18 i PR2 dla uzyskania odpowiedniego progu zadziałania (załączenie wentylatora).
    Tak bym próbował gdybym miał LM35 (ale nie mam i nie mogę wypróbować).
    http://pdf1.alldatasheet.com/datasheet-pdf/view/8866/NSC/LM35.html
    Andrzej

    Ja jeszcze w temacie sterowania wentylatorem.
    Zamiast termistora PTC można zastosować NTC.
    Trzeba go wstawić w miejsce rezystora R21, a w miejsce PTC wstawić rezystor.
    Oczywiście trzeba dobrać wartości rezystorów.
    Andrzej
  • #123
    Damianos115
    Poziom 10  
    Witam, temat dośc dawno nie odświeżany, ale gdyby zamiast rezystora RA i RB dać Potencjometry? Wtedy moglibyśmy dostosować napięcią ? Dobrze myślę czy coś mi się pokręciło? Pozdrawiam
  • AM TechnologiesAM Technologies
  • #124
    andy127
    Poziom 30  
    Damianos115 napisał:
    Witam, temat dośc dawno nie odświeżany, ale gdyby zamiast rezystora RA i RB dać Potencjometry? Wtedy moglibyśmy dostosować napięcią ? Dobrze myślę czy coś mi się pokręciło? Pozdrawiam

    Jeśli chodzi Tobie o mój schemat z postu #118 to jak najbardziej wstawienie potencjometrów pozwoli dobrać progi wg indywidualnych upodobań.
    Po dobraniu warto wymienić potencjometry na rezystory (wg dobranej wartości). Zapobiega to zmianie parametrów pod wpływem wstrząsów.
    https://www.elektroda.pl/rtvforum/viewtopic.php?p=10723730#10723730
    Andrzej
  • #125
    Damianos115
    Poziom 10  
    Dokładnie o to chodziło, jutro dostanę nowe Trafo do przetwornicy to będę kombinował z wartościami ;) Pozdrawiam
  • #126
    nowakus
    Poziom 19  
    Witam.
    Także buduje tą przetwornicę, ale z wszystkimi poprawkami o jakich była mowa w temacie (termistor NTC, układ rozładowania akumulatora). Tylko w celu sprawdzenia proszę powiedzieć mi czy dobrze narysowałem połączenia płytki z elementami zewnętrznymi (tranzystory, transformator, akumulator).
    Przetwornica 12/220 230 W na sg3524
    Zaprojektowałem jeszcze ładowarkę do akumulatora 60Ah na schemacie rezystor 2,4k chcę zastąpić potencjometrem do regulacji napięcia. Chcę żeby układ pracował jako zasilacz buforowy, i utrzymywał napięcie na akumulatorze, oraz ładował go jak potrzeba. Razem z przetwornicą ma stworzyć coś w rodzaju małego UPSa. Pozdrawiam. Przetwornica 12/220 230 W na sg3524
  • #128
    nowakus
    Poziom 19  
    Ok widziałem tą notę katalogową, ale z tego układu nie wyduszę więcej jak 1,5A, a mam akumulator 60Ah co przy prądzie 10-godzinnym daje 6A. Stąd to pytanie o poprawność mojego schematu. A jeszcze odnośnie przetwornicy czy poprawnie narysowane są połączenia zewnętrzne z płytką?? Najpierw i tak będę uruchamiał przetwornicę i to na razie jest sprawa priorytetowa. Ładowarka buforowa, będzie jako druga. Pozdrawiam.
  • #129
    andy127
    Poziom 30  
    nowakus napisał:
    Ok widziałem tą notę katalogową, ale z tego układu nie wyduszę więcej jak 1,5A, a mam akumulator 60Ah co przy prądzie 10-godzinnym daje 6A. Stąd to pytanie o poprawność mojego schematu. A jeszcze odnośnie przetwornicy czy poprawnie narysowane są połączenia zewnętrzne z płytką?? Najpierw i tak będę uruchamiał przetwornicę i to na razie jest sprawa priorytetowa. Ładowarka buforowa, będzie jako druga. Pozdrawiam.

    Z tym LM317 to nie chodziło mi o prądy tylko o diodę zabezpieczającą (rys. 18).
    A jeśli chodzi o połączenia zewnętrzne przetwornicy to (mimo, że jej nie robiłem) nasunęło mi się, że na Twoim rysunku brak jest podłączenia bezpiecznika, wentylatora i termistora, wyłącznika i ewentualnie LED-ów. Reszta wygląda OK. Nie bardzo rozumiem co ma oznaczać opis TR4 bo transformator ma oznaczenie schematowe TS1, ale do punktu TR4 faktycznie powinien być podłączony środek uzwojenia pierwotnego transformatora.
    Andrzej
  • #130
    nowakus
    Poziom 19  
    Właśnie między innymi z tego powodu chciałem skonsultować poprawność połączeń. Czyli mam tylko dodać diodę w taki sposób jak w nocie katalogowej i będzie dobrze??
    Przetwornica 12/220 230 W na sg3524
    Dziękuję bardzo za sprawdzenie połączeń, oczywiście ze nie ma elementów i połączeń które były bobrze zaznaczone na schemacie. Pozdrawiam :)
  • #131
    andy127
    Poziom 30  
    nowakus napisał:
    Czyli mam tylko dodać diodę w taki sposób jak w nocie katalogowej i będzie dobrze?? Przetwornica 12/220 230 W na sg3524

    Ja jestem jeszcze zwolennikiem dodawania w bazach tranzystorów rezystorów ograniczających prąd tak jak to jest pokazane na rysunku pochodzącym z noty katalogowej (w przykładzie 100Ω).
    Przetwornica 12/220 230 W na sg3524
    Pogarsza on co prawda trochę charakterystykę stabilizacji prądu, ale czyni układ bardziej odpornym na uszkodzenia w przypadku nagłego poboru prądu z ładowarki.
    Gdy robiłem układy z taką konfiguracją sterowania tranzystora w ograniczeniu prądu to bez rezystora w bazie zdarzały się uszkodzenia tranzystora po dołączeniu obciążenia. Po prostu zanim zadziała ograniczenie na złącze baza-emiter jest podane duże napięcie (spadek) z rezystora szeregowego i nie ma co ograniczyć prądu bazy.
    Myślę, że będziesz wiedział o co mi chodzi.
    Andrzej
  • #132
    nowakus
    Poziom 19  
    Wielkie dzięki. W weekend zabieram się za trawienie płytki, oraz jej montaż. Jak skończę to wstawię fotografie. Muszę jeszcze nawinąć transformatory. Jeden do przetwornicy a drugi do ładowarki. Pozdrawiam.
  • #133
    nowakus
    Poziom 19  
    Witam.
    Dzisiaj zacząłem budowę przetwornicy. Nawinąłem transformator, zmontowałem płytkę i mam dwa problemy. Jeden dotyczy zabezpieczenia temperaturowego, drugi napięciowego. Odnośnie pierwszego. Zastosowałem termistor NTC 10k, zamieniłem nóżki 2 z 3 US5, i pomimo nagrzania termistora i kręceniu potencjometrem wentylator nie załącza się. Zwierałem nawet termistor i nic. Gdzie może być problem? Drugi kłopot to zabezpieczenie przed nadmiernym wyładowaniem akumulatora. Układ poddany wszystkim przeróbką jakie podał kolega Andy. O ile z dolną granicą nie ma problemu, <zamiast rezystorów 430 i 22 omy dałem PRki> to na chny nie mogę zejść z granicą załączania poniżej 13V. Wymiana rezystora histerezy niewiele dała, nawet jak było 130k to załączenie nastąpiło około 13,5V. Co wydaje mi się zdecydowanie za dużo, bo jak chciałem uruchomić przetwornicę na lekko "podjechanym" akumulatorze to nie dało rady. A jeszcze jedno przekaźnik to RELPOL RM83Z (cewka 12V).
    Poza tymi dwiema rzeczami to przetwornica działa prawidłowo.
    Pozdrawiam.
  • #134
    nowakus
    Poziom 19  
    Problem z załączaniem wentylatora rozwiązałem. Okazało się że omyłkowo wlutowałem nieodpowiedni rezystor, oraz OAmp był wadliwy. Ale nadal mam problem z za dużą histerezą zabezpieczenia przeciw wyładowaniu akumulatora. Co mam robić ?? Co wymieniać, zmieniać ??
  • #135
    andy127
    Poziom 30  
    nowakus napisał:
    Zastosowałem termistor NTC 10k, zamieniłem nóżki 2 z 3 US5, i pomimo nagrzania termistora i kręceniu potencjometrem wentylator nie załącza się. Zwierałem nawet termistor i nic. Gdzie może być problem?

    Miałem właśnie pisać, że na "oka" to taki układ powinien działać prawidłowo ale przyszli goście i musiałem odejść od komputera. A teraz widzę, że problem rozwiązany.
    nowakus napisał:
    Drugi kłopot to zabezpieczenie przed nadmiernym wyładowaniem akumulatora. Układ poddany wszystkim przeróbką jakie podał kolega Andy. O ile z dolną granicą nie ma problemu, <zamiast rezystorów 430 i 22 omy dałem PRki> to na chny nie mogę zejść z granicą załączania poniżej 13V. Wymiana rezystora histerezy niewiele dała, nawet jak było 130k to załączenie nastąpiło około 13,5V. Co wydaje mi się zdecydowanie za dużo, bo jak chciałem uruchomić przetwornicę na lekko "podjechanym" akumulatorze to nie dało rady. A jeszcze jedno przekaźnik to RELPOL RM83Z (cewka 12V).

    PR-ki miałeś dać: jeden zamiast rezystorów 430Ω+22Ω czyli RA i drugi zamiast rezystora 3,3kΩ czyli RB. Ale to szczegół.
    Napisz czy Twój układ jest identyczny z tym który opisałem. Wstaw rezystory takie jak na moim rysunku i pomierz napięcia. Mam nadzieję, że będzie można z nich coś wywnioskować. Sprawdź sam przekaźnik: przy jakim napięciu załącza i przy jakim puszcza.
    Tego pięknego układu próbnego (na zdjęciu w poscie #118) jeszcze chyba nie rozlutowałem więc możemy trenawać dalej.
    Andrzej
  • #136
    nowakus
    Poziom 19  
    Znaczy tak. PRki dałem inaczej. Zamiast 430Ω dałem jedną, zamiast 22Ω drugą, tego rezystora od histerezy nie ruszałem został na twardo 3,3k. Stwierdziłem że przydatna będzie tylo regulacja napięcia. Ale jutro pojadę po PRkę i wstawię zamiast 3,3k także. Nie wiem czy to ma coś związanego, bo jak uruchamiałem układ, to pozmieniałem płytkę i ten 3,3k miał być przylutowany od strony ścieżek. I podczas pierwszych kilku uruchomień go nie było. Ale potem jak przeszedłem do regulacji tego zabezpieczenia wykryłem błąd i wlutowałem. Przekaźnik to RELPOL RM83-1021-25-1012 12VDC, załącza przy 5,80V, rozłącza przy 3,80V. Opór cewki 250Ω.
  • #137
    andy127
    Poziom 30  
    nowakus napisał:
    Znaczy tak. PRki dałem inaczej. Zamiast 430Ω dałem jedną, zamiast 22Ω drugą, tego rezystora od histerezy nie ruszałem został na twardo 3,3k. Stwierdziłem że przydatna będzie tylo regulacja napięcia. Ale jutro pojadę po PRkę i wstawię zamiast 3,3k także.

    Przeczytaj uważnie posty #118, #119 i #120.
    Wstawiać 2 PR-ków zamiast RA nie ma potrzeby. Na czas uruchomienia daj jeden jako RA i drugi jako RB. Napięcia działania przekaźnika RM83 są OK.
    Jeśli w trakcie pierwszych prób nie miałeś wlutowanego rezystora RB i regulowałeś PR-kami wlutowanymi jako RA to mogłeś uzyskać zmianę napięcia zadziałania zabezpieczenia, ale bez potrzebnej histerezy. Po zastosowaniu takiego układu miałbyś sytuację, że po rozładowaniu akumulatora do napięcia progu zadziałania przekaźnik by puścił i wtedy bez obciążenia napięcie na akumulatorze by wzrosło i przekaźnik chwyciłby ponownie. Wtedy napięcie znowu by spadło pod wpływem obciążenia i przekaźnik ponownie by wyłączył. I tak w kółko. Zrobiłby się z tego generator.
    Aby temu zapobiec wprowadzona jest histereza. Przekaźnik ma puścić przy np. 10,5V (rozładowany akumulator) a dać się załączyć np. przy 12V.
    Oczywiście progi zadziałania możesz sobie dobrać indywidualnie uwzględniając konieczność właściwego zabezpieczenia akumulatora przed nadmiernym rozładowaniem (aby go nie uszkodzić lub nie zmniejszyć zbytnio jego żywotności) i pewność działania (możliwość załączenia przy częściowo rozładowanym akumulatorze - jeśli jest taka potrzeba).
    Andrzej
  • #138
    nowakus
    Poziom 19  
    My się chyba nie zrozumieliśmy. Czytałem te posty nie jeden raz. Ale chodzi mi o to że pomijając czy są PRki czy rezystory stałe (są wartości podane przez Ciebie) układ rozłącza się na 10,5V, ale załącza przy powyżej 13. Co przy używaniu na lekko wyładowanym akumulatorze dyskwalifikuje układ. przy zmianie wartości rezystora RA (430 +22) następuje zmiana napięcia wyłączenia przetwornicy. Ale przy zmianie wartości rezystora RB (3,3k) prawie nic się nie dzieje, lub jak doszedłem do ponad 130k napięcie załączenia trochę spadło. A chcę żeby, układ rozłączył sie na 10,5 V (i tak jest, tak teraz działa) i chcę żeby załączył przy około 12V co nie działa pomimo zmian wartości opornika 3,3k. ciągle załączenie następuje powyżej 13V (raz uało mi sie zejść do 12,7~12,8V) A 2 PRki zamiast RA dają regulację zgrubną i dokładną. Co uważam za fajne rozwiązanie.
  • #139
    andy127
    Poziom 30  
    OK. Sprawdzę jeszcze raz progi z RA=430+22Ω i RB=3,3kΩ a następnie z RB zmienionym na 130kΩ.
    Andrzej
  • #140
    nowakus
    Poziom 19  
    Wstawiłem PRkę zamiast 3,3kΩ i regulując nią, mogę jedynie podwyższać napięce zasilania. A jakby pokombinować z wymianą T1 bo on jest odpowiedzialny za złączanie przekaźnika?? Bo może jest zły w takim sensie że potrzebuje "dużego" napięcia na bazie żeby zaczął przewodzić?? I wstawić coś o mniejszym progu przewodzenia??
  • #141
    andy127
    Poziom 30  
    andy127 napisał:
    OK. Sprawdzę jeszcze raz progi z RA=430+22Ω i RB=3,3kΩ a następnie z RB zmienionym na 130kΩ.
    Andrzej

    Sprawdziłem.
    Progi wyłącz/załącz:
    dla RB=3,3kΩ 10,51/11,90V
    dla RB=130kΩ 11,23/11,27V
    dla RB=∞ 11,24/11,25V
    W układzie testowym mam:
    D2 C5V1
    US1 LM741CN
    T1 BC313
    TA BCAP77B
    PK1 RM96Z-12-W
    https://obrazki.elektroda.pl/6260925300_1332797938.jpg
    Z pomiarów widać, że dla otwartej pętli sprzężenia zwrotnego (RB=∞ czyli bez rezystora) działa praktycznie w punkcie (niewielkie opóźnienie działania powoduje kondensator C1. Dla RB=130kΩ histereza też praktycznie nie istnieje. Dla RB=3,3kΩ jest bliska założonej.
    Zrób pomiary progów zadziałania (wył./zał.) dla jakiś konkretnych wartości elementów i zobaczymy, czy da się z nich coś wywnioskować.
    Andrzej
  • #142
    nowakus
    Poziom 19  
    Okej przy chwili czasu pomierzyłem wszystko jeszcze raz. Tranzystor T1 mam BC308, ale jutro kupię BC313 i sprzwdzę jeszcze raz. Na chwilę obecną:
    1) RB=∞; RA=(430+22)Ω Progi: 10,80V/10,00V
    2) RB=3,3kΩ; RA=(430+22)Ω Progi 11,40V/10,19V
    3) RB=3,3kΩ; RA=(238+60)Ω Progi 13,7V/10,59V
    Próba nr.3 jest po wyregulowaniu progu wyłączania który mnie satysfakcjonuje. Ale załączanie przy 13,7V jest niedopuszczalne. Mam nadzieję że wymiana T1 coś zmieni bo już powoli mnie to wnerwia. Pozdrawiam.
  • #143
    andy127
    Poziom 30  
    nowakus napisał:
    Okej przy chwili czasu pomierzyłem wszystko jeszcze raz. Tranzystor T1 mam BC308, ale jutro kupię BC313 i sprzwdzę jeszcze raz. Na chwilę obecną:
    1) RB=∞; RA=(430+22)Ω Progi: 10,80V/10,00V
    2) RB=3,3kΩ; RA=(430+22)Ω Progi 11,40V/10,19V
    3) RB=3,3kΩ; RA=(238+60)Ω Progi 13,7V/10,59V
    Próba nr.3 jest po wyregulowaniu progu wyłączania który mnie satysfakcjonuje. Ale załączanie przy 13,7V jest niedopuszczalne. Mam nadzieję że wymiana T1 coś zmieni bo już powoli mnie to wnerwia. Pozdrawiam.

    Nie wydaje mi się aby zamiana tranzystora pomogła. BC313 włożyłem ponieważ taki akurat wpadł mi w rękę. O progach przełączenia decydują głównie napięcie diody zenera i wartości rezystorów R1, Ra i RB (zakładam, że US1, T1 i R3 są sprawne i razem stanowią wystarczające wzmocnienie).
    Wyniki Twoich pomiarów dają nadzieję na wyregulowanie do tego, czego oczekujesz. Wydaje mi się nadal, że jest potrzeba regulacji RA, RB (prawdopodobnie RB nieco więcej niż 3,3kΩ).
    Andrzej
  • #144
    Son Goku
    Poziom 11  
    Witam a czy dało by Rade dołożyć tranzystorów mocy i zwiększyć moc np 4x lub więcej ? (kupiłem kit AVT2463 bo był tani tylko nie daje ładnego sinusa bawiłem sie z tym kitem i ni jak nie zrobię sinusa 50Hz- 60Hz transformator strasznie brzęczy działać działa Tylko mi sie nie podoba praca tej przetwornicy na wyjściu dało by rade jakoś zmienić przeprojektowując te generatory lub zmienić na coś innego by kluczowały te tranzystory jak rzecz żeby nie było prostokąta na wyjściu sami rozumiecie :) Pozdrawiam (a ta by była lepsza ?
  • #145
    andy127
    Poziom 30  
    Tutaj też na ładnego sinusa bym nie liczył.
    Andrzej
  • #146
    Son Goku
    Poziom 11  
    Panie Andrzeju a te generatory są lepsze jak w tym avt? Podłączyłem wzmacniacz do tego AVt kitu i jest do kitu strasznie sieje wiem ze sie da zrobić sinus(ale bedą straty na mocy jak zrobię końcówkę mocy tranzystory będą sie grzały i połowa mocy pójdzie na nie a tego bym wolał uniknąć na procesorze jest mysl,ale w sieci jest dużo harmonicznych ale siec ma zbliżony sinus chciał bym taki osiągnąć możne forumowicze zróbmy to tak zaprojektować wspólnie dobra przetwornice na trafie 15kw bo co to jest 2kw przetwornica sam czajnik uruchomi pozdrawiam oddać moc straty mocy itd sami rozumiecie :)(a zeby nas za bardzo nie zalali całkiem Chińską myślą techniczna :)
  • #147
    andy127
    Poziom 30  
    Son Goku napisał:
    Panie Andrzeju a te generatory są lepsze jak w tym avt? Podłączyłem wzmacniacz do tego AVt kitu i jest do kitu strasznie sieje wiem ze sie da zrobić sinus(ale bedą straty na mocy jak zrobię końcówkę mocy tranzystory będą sie grzały i połowa mocy pójdzie na nie a tego bym wolał uniknąć na procesorze jest mysl,ale w sieci jest dużo harmonicznych ale siec ma zbliżony sinus chciał bym taki osiągnąć możne forumowicze zróbmy to tak zaprojektować wspólnie dobra przetwornice na trafie 15kw bo co to jest 2kw przetwornica sam czajnik uruchomi pozdrawiam oddać moc straty mocy itd sami rozumiecie :)(a zeby nas za bardzo nie zalali całkiem Chińską myślą techniczna :)

    Strasznie długie zdania konstruujesz :D . Nie bardzo wiem o co chodzi z tymi transformatorami 15kw i 2kw.

    A wracając do przetwornicy AVT2463 to na transformator podany jest przebieg prostokątny o wypełnieniu 50/50. W przetwornicy opisanej w tym temacie przebieg jest również prostokątny. Jest tu wprowadzona modulacja szerokości impulsu w celu "stabilizacji" napięcia wyjściowego. Zrobienie przetwornicy dającej na wyjściu przebieg sinusoidalny to jest zupełnie inna bajka.
    Andrzej
  • #148
    Son Goku
    Poziom 11  
    aha to dzięki za odpowiedź pewnie tą złoże pozdrawiam
  • #149
    rami8
    Poziom 20  
    Witam. Widzę że temat chwilę już nie poruszany ale potrzebuję pomocy dlatego piszę.
    Poskładałem przetwornicę z tego schematu znalezionego gdzieś w sieci.


    Przetwornica 12/220 230 W na sg3524 Przetwornica 12/220 230 W na sg3524

    W zasadzie lepiej byłoby kupić gotowca, ale to bardziej z ciekawości poskładałem na tej oto płycie.


    Przetwornica 12/220 230 W na sg3524


    Niestety pojawiły się problemy z uruchomieniem, a konkretnie brak napięcia sieci na wyjściu. Pierwsza część przetwornicy działa prawidłowo. Na wyjściu z trafo po diodach mam 300 V DC. Później niestety już nie mam napięcia na wyjściu po falowniku. Oscyloskop pokazuje jakieś "krzaki" nie wiadomo skąd. Pomiar miernikiem niby pokazuje napięcie około 230V ale na ustawieniu na pomiar prądu stałego.
    Może ja coś przeoczyłem rysując płytkę, a może ktoś z forum wykonywał ten projekt i powie czy to ma prawo jakkolwiek działać. Pozdrawiam.
  • #150
    kypc3
    Poziom 2  
    marcin44430 napisał:
    Zamieszczam wzór płytki gotowy do wydruku.:D




    Hi i would like to ask.. what is the size of pcb in centimeters?

    from: Philippines :D