Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Mikrotik Ubuntu - Przekierowanie portów

30 Sep 2016 15:05 828 7
  • Level 14  
    Chciałbym połączyć się zdalnie z linuxem, ale nie udaje mi się. Co do tej pory zrobiłem.


    W Ubuntu zmieniłem port ssh z 22 na 29

    W Mikrotiku dodałem regułę

    Code:
    /ip firewall nat add action=dst-nat chain=dstnat comment="" disabled=no dst-address=000.0.00.00 dst-port=29 protocol=tcp to-addresses=10.0.5.66 to-ports=19


    Pod windowsem otwieram putty i w hoscie wpisuje
    000.0.00.00 a port daję 29


    i nie działa. Co jest nie tak?
  • Level 43  
    > 000.0.00.00
    co to za adress ip v4 ?
  • Level 14  
    bogiebog wrote:
    > 000.0.00.00
    co to za adress ip v4 ?


    Zamiast tego, idzie numer IP routera.
  • Level 31  
    Spróbuj
    Code:
    /ip firewall nat add chain=dstnat dst-port=29 action=dst-nat protocol=tcp to-address=10.0.5.66 to-port=29 comment="ssh"
  • Level 17  
    Hi,

    Kod od WMichał powinien załatwić sprawę.

    Ale dodam swoje 3gr :)

    Skopiowane z mojego MT, może jeszcze zajść potrzeba dodania zezwolenia dla portu w ip firewall filters (zależy jak masz).
    Code:

    ip firewall nat>
    ;;; DVR API WAN
    chain=dstnat action=dst-nat to-addresses=10.0.5.5 to-ports=63222 protocol=tcp dst-address-type=local dst-port=63222 log=no log-prefix=""

    ;;; DVR API HAIRPIN
    chain=srcnat action=masquerade protocol=tcp src-address=10.0.0.0/16 dst-address=10.0.5.5 out-interface=LAN dst-port=63222 log=no log-prefix=""


    dst-address-type = local pozwala na dostęp do usługi z dowolnego interfejsu WAN (mam 2 łącza) - czyli nie musisz dublować reguły dla każdego WANu


    Jeszcze mi się przypomniało, może port 29 jest blokowany przez twojego ISP? Niby 29 powinien być wolny, ale może ISP blokuje wszystkie niskie porty...

    Ps. w razie pytań: WAN Fail-over mam na skrypcie.
  • Level 14  
    WMichał wrote:
    Spróbuj
    Code:
    /ip firewall nat add chain=dstnat dst-port=29 action=dst-nat protocol=tcp to-address=10.0.5.66 to-port=29 comment="ssh"


    Tak zrobiłem i nie działa.
    w putty przez lokalną sięć wpisuję 10.0.5.66 port 29 i polaczyl
    w putty przez lokalną sięć wpisuję (ip zewnetrzne) port 29 i nie laczy, ale w firewall w polu bytes i packets w/w reguły pojawiło się poruszenie tak jakby reguła widziała próbę połączenia.
  • Level 31  
    Bo to jest przekierowanie z ruchu zewnętrznego na ip i port wewnątrz sieci.
  • Level 14  
    Faktycznie. Z domu działa. Dzięki!