Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Czujka magnetyczna nie działa - jakie mogą być tego przyczyny?

ZaquPL 01 Oct 2016 14:49 1974 10
Optex
  • #1
    ZaquPL
    Level 8  
    Witam,

    Na wstępie zaznaczam, iż jestem amatorem, więc proszę o wyrozumiałość.

    Mam problem z czujką magnetyczną (kontaktronem) Satel B-3A.
    Czujka magnetyczna nie działa - jakie mogą być tego przyczyny?

    Podłączyłem ją do zamka szyfrowego Roger SL2000F według schematu podanego w instrukcji, jednak czujka nie działa tak jak powinna, tzn. nie sygnalizuje otwarcia drzwi po oddaleniu jej od magnesu. Na razie czujkę testuję "na sucho", to znaczy na stole montażowym, gdyż wolę mieć pewność że będzie działać już po zamontowaniu. Niestety, na razie nie działa. Czujka nie posiadała opisanych kabli, więc uznałem, że nie ma znaczenia gdzie podłączę plus, a gdzie minus.

    Poniżej schemat podłączenia:
    Czujka magnetyczna nie działa - jakie mogą być tego przyczyny?

    Alarm nie włącza się po niedomknięciu drzwi, mimo iż czas nastawy na ich zamknięcie jest ustawiony na 8 sekund. Bez względu na to czy magnes jest blisko czy daleko od czujki, nic się nie dzieje. Sygnalizator działa, bo testowałem funkcję dzwonka.

    Czerwonym kolorem oznaczyłem gdzie mierzyłem napięcia miernikiem. Przez czujkę przepływa prąd 5V. Zbliżanie i oddalanie magnesu nic nie zmienia w tych wartościach.

    Uznałem, że może to jakaś wada tej czujki. Posiadałem jeszcze jedną, dlatego postanowiłem (nie wiem czy słusznie, czy to była zwykła głupota...) podłączyć ją szeregowo do akumulatora i sygnalizatora, w następujący sposób:

    Czujka magnetyczna nie działa - jakie mogą być tego przyczyny?

    No i super! Działał... przez chwilę. Później przestał. W takiej konfiguracji połączenia sygnalizator przez chwilę świecił (10 sekund?), a później przestał i już zbliżanie magnesu ani jego oddalanie nic nie dawało.

    Nie mam już pomysłu co robić. Proszę, czy macie jakieś koncepcje na rozwiązanie tego problemu?
  • Optex
  • #2
    User removed account
    User removed account  
  • Optex
  • #3
    kosimierz
    Level 17  
    Według producenta 0,4A.

    Coś mi się wydaje, że kontaktron ma dawać SYGNAŁ rozwarcia i zwarcia (otwarcia i zamknięcia).
    Sprawdz miernikiem na przewodach gdzie masz rozwarcie przy przyłożeniu magnesu do siebie i zwarcie gdy go oddalisz.

    "WejścieIN2: Czujnik Otwarcia. Wejście służy do podłączenia czujnika otwarcia drzwi i jest typu NO Jeśli styk ten jest zwarty zamek interpretuje to że drzwi są otwarte natomiast w odwrotnym przypadku uznaje że drzwi są zamknięte."
  • #4
    User removed account
    User removed account  
  • #5
    Polon_us
    Level 42  
    Moim zdaniem, ta czujka jest nieprawidłowo podłączona.
    Powinna być dołączona do (+) zasilacza.
    Przy obecnym połączeniu wejście układu nie dostaje prawidłowego sygnału wskazującego na otwarcie/zamknięcie drzwiczek.
  • #6
    User removed account
    User removed account  
  • #7
    Zbigniew 400
    Level 38  
    Sprawdż czujkę omomierzem, zbliżając magnes i oddalając. Co pokazuje miernik ?
  • #8
    ZaquPL
    Level 8  
    [quote="R-MIK"]
    ZaquPL wrote:

    Jaki prąd pobiera synalzator, a jaki jest dopuszczalny prąd płynący przez czujkę?


    Z kart katalogowych produktów (nic więcej nie jestem w stanie powiedzieć, bo nie pisze):

    SYGNALIZATOR:
    - Napięcie zasilania 12 V DC ±15%
    - Maksymalny pobór prądu w czasie sygnalizacji akustycznej 250 mA
    - Maksymalny pobór prądu w czasie sygnalizacji optycznej 270 mA
    - Maksymalny pobór prądu w czasie sygnalizacji optycznej i akustycznej 520 mA

    CZUJKA:
    - Maksymalne napięcie przełączalne kontaktronu 100 V
    - Maksymalny prąd przełączalny 0,4 A

    Sprawdziłem obie czujki omomierzem podłączając miernik do obu przewodów wychodzących z kontaktronu. Wyniki:
    - Pierwsza czujka: bez względu na odległość od magnesu, miernik wskazuje wartość poza zakresem.
    - Druga czujka: gdy magnes znajduje się daleko, miernik wskazuje wartość poza zakresem, gdy magnes zbliżam na odległość mniejszą od 4 cm, następuje spadek wartości i dąży ona do ok. 4 omów.
    Wygląda na to, że druga działa, a z pierwszą coś niedobrego się stało.

    // Dodano:

    Podłączyłem drugą czujkę do układu z pierwszego rysunku, ale to również zawiodło. Obwód cały czas jest rozwarty. Natomiast zwarcie styków IN2 i GND powoduje prawidłowe uruchomienie alarmu, czyli to wina czujki. Pomysły?
  • #9
    User removed account
    Level 1  
  • #10
    ZaquPL
    Level 8  
    Próbowałem pierwszą czujkę z każdym magnesem i niestety nie działa.

    Nawet przez myśl mi nie przeszło aby podłączać jednocześnie do sygnalizacji optycznej i akustycznej. Raz, że bym zwariował przy dłuższym przebywaniu w pomieszczeniu ze 120 dB alarmem i świecącymi po oczach diodami, a dwa, że nawet nie chciałoby mi się tego podłączać (wiadomo, dodatkowe kable).

    Teraz znowu spróbowałem z drugą czujką i zadziałało... niesamowite. Nie wiem dlaczego, podłączałem w dokładnie ten sam sposób i za każdym razem sprawdzałem czy przewody są prawidłowo złączone.
  • #11
    ZaquPL
    Level 8  
    Czujka okazała się wadliwa, poszła do reklamacji. Dziękuję za pomoc.