Elektroda.pl
Elektroda.pl
X

Wyszukiwarki naszych partnerów

Wyszukaj w ofercie 200 tys. produktów TME
Europejski lider sprzedaży techniki i elektroniki.
Proszę, dodaj wyjątek elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Pomiar transformatora - szpilki prądowe

_lazor_ 17 Paź 2016 23:10 3453 54
  • #1 17 Paź 2016 23:10
    _lazor_
    Poziom 25  

    Witam,

    Robiłem dziś pomiar uzwojenia pierwotnego na nawiniętym transformatorze i zauważyłem dość spore szpilki prądowe i zaczynam się zastanawiam, co jest przyczyną tyk szpilek.
    Pomiar transformatora - szpilki prądowe Pomiar transformatora - szpilki prądowe

    układ jaki stosuje to falownik półmostkowy na IRS2153 coś w tym stylu:
    Pomiar transformatora - szpilki prądowe

    MOSFET'y jakie stosuje to IRF740, na bramkach mam rezystory 12ohm.

    Co jest dodatkowo zastanawiające, to fakt, że grzeje się tylko górny mosfet, dolny jest chłodny. Czyżby problemy z bootstrapem?

    Może, te szpile to tylko błąd pomiarowy wynikający z faktu użycia przekładnika prądowego nawiniętego na rdzeń ferrytowy SM-100?

    0 29
  • #2 18 Paź 2016 01:20
    cooltygrysek
    Warunkowo odblokowany

    Obciążony stałą wartością prądu za pomocą rezystora czy bez obciążenia ? Jeśli z obciążeniem to wydaje się że problem może leżeć w użytych tranzystorach. Zrób pomiary z obciążeniem i bez obciążenia. Jaka częstotliwość pracy ? Na oscylogramie widać 200khz ? Sam przekładnik przy takiej częstotliwości może się nasycać chociaż wątpię w to.

    0
  • #4 18 Paź 2016 08:12
    _lazor_
    Poziom 25  

    cooltygrysek napisał:
    Obciążony stałą wartością prądu za pomocą rezystora czy bez obciążenia ? Jeśli z obciążeniem to wydaje się że problem może leżeć w użytych tranzystorach. Zrób pomiary z obciążeniem i bez obciążenia. Jaka częstotliwość pracy ? Na oscylogramie widać 200khz ? Sam przekładnik przy takiej częstotliwości może się nasycać chociaż wątpię w to.


    Obciążenie jest indukcyjne (tak jak pisałem w opisie, jedynie pierwotne uzwojenie transformatora). Dodam dość ważną informacje o której zapomniałem, że Vcc wynosi ponad 320V a częstotliwość pracy to około 78kHz.

    gwas27 napisał:
    Szpilki można wyeliminować jak się podłączy kondensator 10nF równolegle do cewki


    Przy 80kHz i napięciu na cewce około 160V 10nF to zdecydowanie za dużo, ale skorzystam z uwagi i dodam mniejszy kondensator foliowy prawdopodobnie w szeregu z rezystorami.

    0
  • #5 18 Paź 2016 08:39
    cooltygrysek
    Warunkowo odblokowany

    Pewnie że można ale nie w tym układzie boostr. Dodając kondensator równolegle, zepsujemy charakterystykę czasową opadania podczas przełączania kluczy. W temacie chodzi koledze o to skąd one się biorą i co jest ich przyczyną a nie jak je wyeliminować.

    0
  • #6 18 Paź 2016 09:17
    _lazor_
    Poziom 25  

    cooltygrysek napisał:
    Pewnie że można ale nie w tym układzie boostr. Dodając kondensator równolegle, zepsujemy charakterystykę czasową opadania podczas przełączania kluczy.


    Trochę nie rozumie co miałeś na myśli. W końcu podczas przełączania jeden z kondensatorów (zamykając się przez diodę od MOSFET) jest równolegle do cewki (względem zacisków Vcc i GND). Możliwe, że dioda z MOSFET jest za wolna?

    370-790 ns - zdecydowanie jest za wolna, trzeba będzie coś wrzucić równolegle jeszcze do tego. Jednak podczas pracy rezonansowej diody z MOSFET nie biorą praktycznie żadnego udziału, ale przy twardym przełączaniu na obciążeniu indukcyjnym jak najbardziej.

    Nadal dla mnie jest zagadką, dlaczego górny MOSFET (sterowany z bootstrap) się mocniej grzeje od dolnego? IRS2153 ma gorsze charakterystyki przełączania dla górnego klucza?

    0
  • #7 18 Paź 2016 09:27
    ak44
    Poziom 18  

    Witam
    To co nazywasz szpilką prądową jest prawdopodobnie oscylacją układu rezonansowego: pojemność pasożytnicza + indukcyjność trafa.

    0
  • #8 18 Paź 2016 10:15
    -XantiO-
    Poziom 17  

    Jaki zastosowałeś kondensator bootstrapu? Dodaj jeszcze diody w obwód bramki tranzystorów w celu ich szybszego rozładowania.

    0
  • #10 18 Paź 2016 11:05
    coolrob
    Poziom 14  

    Czy mógłbyś pokazać przebiegi napięciowe na tranzystorach?

    0
  • #11 18 Paź 2016 11:50
    -XantiO-
    Poziom 17  

    O właśnie. Przebiegi napięciowe G-S i D-S by dużo pomogły.

    0
  • #13 18 Paź 2016 19:15
    cooltygrysek
    Warunkowo odblokowany

    _lazor_ napisał:
    cooltygrysek napisał:
    Pewnie że można ale nie w tym układzie boostr. Dodając kondensator równolegle, zepsujemy charakterystykę czasową opadania podczas przełączania kluczy.



    Trochę nie rozumie co miałeś na myśli.


    Chodziło o czas rozładowania pojemności bramki tranzystora. W jaki sposób sterujesz kluczami ? Z układu bezpośrednio czy inaczej poprzez tranzystory sterujące, lub za pomocą układu sterującego ? Zapodaj schemat obwodu kluczującego ze sterowaniem.

    0
  • #14 18 Paź 2016 22:07
    _lazor_
    Poziom 25  

    Pomiar transformatora - szpilki prądowe Pomiar transformatora - szpilki prądowe Pomiar transformatora - szpilki prądowe

    Powyżej przebieg napięcia na D-S na dolnym mosfecie oraz prądu na obciążeniu. Konfiguracja podłączenia oscyloskopu:
    Pomiar transformatora - szpilki prądowe


    Pomiar transformatora - szpilki prądowe Pomiar transformatora - szpilki prądowe

    Na powyższych pomiar górnego mosfet. Sygnał odwróciłem, z faktu że odnoszę się do "wyższego" potencjału. Konfiguracja podłączenia oscyloskopu:
    Pomiar transformatora - szpilki prądowe

    Napięcie na bramkach jest stosunkowo wysokie bo wlicza się na nie napięcie na kondensatorach oraz napięcie wymuszenia z cewki.
    Najgorsze, że nie widzę dead time na tych oscylogramach, a przecież musi występować, inaczej wszystko by majestatycznie by eksplodowało...

    Jestem ciekawy waszej opinii na ten temat.

    0
  • #15 18 Paź 2016 22:26
    tadeusz12345
    Poziom 16  

    Masę oscyloskopu można również podłączyć do środkowego zacisku półmostka, pod warunkiem, że nie spowodujesz zwarcia, inną sondą!

    Oscylacje jakieś zawsze będą, pytanie czy one szkodzą, i czy są prawidłowo zmierzone.

    Teraz jest parę pytań do Ciebie:
    - czym mierzyłeś prąd?
    - jaka jest odległość kondensatorów od tranzystorów (długość całej pętli)
    - jakie masz rezystory bramkowe i jakie tranzystory ?

    Dead time jest, na oko daję 0,5 µs:

    Pomiar transformatora - szpilki prądowe

    0
  • #16 18 Paź 2016 23:14
    coolrob
    Poziom 14  

    Te szpilki prądu to najprawdopodobniej efekt pojemności pasożytniczych uzwojenia, które jest obciążeniem półmostka. Dużo masz tych zwojów? Ile warstw, jak nawinięte?

    0
  • #17 18 Paź 2016 23:26
    tadeusz12345
    Poziom 16  

    Mi się wydaje jednak że to są szpiki zaindukowane w sondzie prądowej, na skutek sprzężenia magnetycznego/pojemnościowego.

    Zobaczcie że są mierzone mA, więc wystarczy złe podłączenie sondy przy źle zaekranowanym transformatorze i szpiki gotowe.

    0
  • #18 19 Paź 2016 00:04
    _lazor_
    Poziom 25  

    tadeusz12345 napisał:

    Teraz jest parę pytań do Ciebie:
    - czym mierzyłeś prąd?
    - jaka jest odległość kondensatorów od tranzystorów (długość całej pętli)
    - jakie masz rezystory bramkowe i jakie tranzystory ?

    Dead time jest, na oko daję 0,5 µs:

    Pomiar transformatora - szpilki prądowe


    Mierzę prąd poprzez przekładnik prądowy własnej roboty, 50 uzwojeń terminowany 50ohm, wychodzi 1A/1V. Może zniekształcać wykres, ale niestety ta szpila występuje...

    Odległość tranzystorów od kondensatorów to około 5cm.

    Układ jest sterowany IRS21531S, rezystory na bramkach mam dość małe bo 12ohm.

    Co do dead time, tak to jest dead time, ale już dla taktu gdzie wyłącza się górny i załącza się dolny tego dead time nie widzę. Czyżby jednak dioda by się przydała do rozładowania górnego tranzystora?

    Zwojów mam około 60 na rdzeniu ferrytowym w kształcie toroidu. Nie za wiele jest tej pojemności...


    Cóż masy nie mogę podłączyć do środkowego zacisku półmostka, powodem jest transformator separujący, który nie do końca jest przystosowany na takie zabawy (duża pojemność) a oscyloskop ma masę na PE, więc trochę by popłynęło, a jak dużo nie chce testować.

    0
  • #20 19 Paź 2016 11:24
    _lazor_
    Poziom 25  

    coolrob napisał:
    Transformatory nawijane na rdzeniach toroidalnych mają relatywnie dużą pojemność pasożytniczą. Polecam do przeczytania:

    http://coefs.uncc.edu/mnoras/files/2013/03/Tr...r-and-Inductor-Design-Handbook_Chapter_17.pdf

    http://cds.linear.com/docs/en/application-note/an39f.pdf


    Między pierwotnym a wtórnym, a ja nie mam nawiniętego wtórnego... Taki psikus :D. W takim wypadku można mówić tylko o pojemności własnej cewki. Pozwolę sobie przytoczyć tekst znaleziony na:
    http://radioinfo.pl/pracownia-radio/177-cewki-indukcyjne-garsc-teorii

    "Pojemność własna cewki – każda cewka oprócz indukcyjności posiada także własną pojemność. Jej wartość jest wprost proporcjonalna do średnicy uzwojenia oraz odwrotnie proporcjonalna do odległości pomiędzy zwojami. Pojemność zawarta w cewce skutkuje tym, że można ją traktować jako równoległy obwód rezonansowy. Częstotliwość rezonansowa takiego „obwodu” nazywa się rezonansem własnym cewki. Znajomość tej częstotliwości jest ważna, ponieważ wraz ze zbliżaniem się do niej spada skuteczność obwodu. Dlatego też dla skutecznego pomiaru dobroci częstotliwość na której bada się cewkę nie może być wyższa niż 0,1 częstotliwości rezonansu własnego."

    Bym musiał to chyba w GHz sterować by to wpadło w rezonans, a nawet jakby wpadło to, jest to rezonans równoległy po za punktem gdzie mierzę prąd. Przekładnik mam zaraz za wyjściem falownika.

    0
  • #21 19 Paź 2016 11:41
    -XantiO-
    Poziom 17  

    Spróbuj zastosować prosty filtr RC np. 2.2nF i 330Ohm i pomierz wtedy prąd. Oraz nawiń na próbę uzwojenie wtórne np. 10 zwoi i obciąż je tak z 100mA jakimś rezystorem i dokonaj też wtedy pomiaru prądu.

    0
  • #22 19 Paź 2016 12:37
    _lazor_
    Poziom 25  

    Mam tylko stare pomiary na tym rdzeniu gdzie mam nawinięte uzwojenie wtórne obciążane 50W żarówką, ale śmiga to na rezonansie LC, więc nie ma tutaj twardego przełączania.
    Tutaj z obniżonym napięciem i bez sprzężenia zwrotnego:
    Pomiar transformatora - szpilki prądowe

    Tutaj pełne napięcie z podłączonym sprzężeniem zwrotnym:
    Pomiar transformatora - szpilki prądowe

    Będę stosować po kolei rozwiązania układu RC, szybsze diody free wheele oraz diody przyśpieszające rozładowanie bramek, zobaczymy co z tego pomoże.

    0
  • #23 19 Paź 2016 14:55
    -XantiO-
    Poziom 17  

    Z jakiego materiału jest rdzeń? Spróbuj również dać na bootstrap kondensator 1uF nawet jakiś elektrolityczny.

    0
  • #25 20 Paź 2016 22:17
    _lazor_
    Poziom 25  

    Dobra pierwsza próba:

    Cap 3,3nF 1kV i rezystory 2x 1,8k Ohm 1/4W

    rezultat - rezystory spłonęły :D -XantiO- Ty chcesz mi pomóc czy spalić mi pokój? xD

    Druga próba (tym razem obliczenia przed podpinaniem):

    33pF 1kV i rezystory 2x 20k Ohm 1/4W

    I pierwszym i w drugim wypadku układ RC równoległy do cewki (uzwojenia pierwotnego transformatora) nie przyniósł oczekiwanego skutku. Zwiększyła się jedynie długość oscylacji.

    Jednak podpiąłem jeszcze jeden przekładnik prądowy na przygotowaną pętelkę zaraz za źródłem górnego mosfet'a. Niby takie nie pozorne miejsce w układzie a patrzcie co się tam dzieje (żółty oscylogram):

    Pomiar transformatora - szpilki prądowe Pomiar transformatora - szpilki prądowe

    :D ja to mam szczęście, że to nie wybuchło :D Ale widać, że mu się już pięty paliły, dlatego górny mosfet się tak grzeje xD

    Zbadam jutro bez obwodu mocy przebiegi na bramce, zobaczę czy sterownik nie jest uszkodzony.

    0
  • #26 21 Paź 2016 00:21
    _jta_
    Specjalista elektronik

    Dobrze byłoby sprawdzić, czy twój przekładnik prądowy nie generuje tych oscylacji - może daj mu sygnał z prostego generatora prostokąta i zobacz, co z niego wyjdzie.

    0
  • #27 21 Paź 2016 21:19
    _lazor_
    Poziom 25  

    Porobiłem pomiary sygnałów sterujących:

    Pomiar transformatora - szpilki prądowe

    Powyżej sygnały na bramkach wględem GND bez napięcia zasilającego obwodu mocy. (żółty mosfet dolny, niebieski górny). Zasilony został tylko sterownik.

    Pomiar transformatora - szpilki prądowe

    Powyżej przebieg na bramkach, niestety górną bramkę mierzyłem względem GND sondą x100, więc widać tylko delikatne załamanie kiedy się sygnał się wyłącza, ale dead time jest ok.
    Podałem napięcie na mosfety (Vcc), ale bez obciążenia (na wyjściu falownika, nie ma obciążenia).

    Jednak zastanawia mnie to, że pojawia się napięcie na bramce dolnego mosfeta, gdy załącza się górny.


    Pomiar transformatora - szpilki prądowe

    Podłączyłem sondę prądową do źródła górnego mosfet i zmierzyłem sygnał na dolnej bramce względem GND i jest korelacja między szpilką prądową a załączeniem się drugiego mosfet. Nadal układ bez obciążenia.
    Może ktoś wie cóż to za zjawisko może być?


    I tak przy okazji zrobiłem zdjęcie efektu Millera dla dolnego mosfet:

    Pomiar transformatora - szpilki prądowe
    napięcie dren-źródła = 0V
    Pomiar transformatora - szpilki prądowe
    napięcie dren-źródła = około 150V

    0
  • #28 21 Paź 2016 23:13
    _jta_
    Specjalista elektronik

    A jakbyś tak opisał dokładniej, co i w jakich warunkach mierzyłeś...

    0
  • #30 22 Paź 2016 07:56
    coolrob
    Poziom 14  

    To może być również efekt Millera. Napięcie na drenie dolnego tranzystora szybko narasta i przez pojemność załącza bramkę. Czy widać ten efekt na przebiegu napięciowym na drenie dolnego tranzystora?

    0
TME logo Szukaj w ofercie
Zamknij 
Wyszukaj w ofercie 200 tys. produktów TME
TME Logo