Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Excel - operacje na wybranych komórkach

mlewan 09 Lis 2016 22:10 645 2
  • #1 09 Lis 2016 22:10
    mlewan
    Poziom 20  

    Cześć,

    mam szybkie pytanie, jak w kolumnie wyciągnąć kolejne średnie z grup po 12 komórek? Np. =ŚREDNIA(A2:A13); =ŚREDNIA(A14:A25); =ŚREDNIA(A26:A37) i tak dalej? Kolumna ma 5000 wierszy, więc na piechotę nie bardzo :)

    Z góry dziękuję i pozdrawiam :)

    0 2
  • Pomocny post
    #2 10 Lis 2016 04:41
    dt1
    Moderator - Komputery Serwis

    Cześć. Być może da się bardziej elegancko, ale na szybkiego przychodzi mi coś takiego na myśl (załącznik).

    Krótkie wyjaśnienie:
    Kolumna A - liczby, z których wyciągam średnią.

    Metoda pierwsza: w kolumnie pomocniczej (C) mam liczby od 1 do 20, to jest kolejny numer grupy. W D1 mam ilość elementów przypadających na grupę. Wtedy pierwsza komórka (B1) może zawierać formułę:
    =ŚREDNIA(PRZESUNIĘCIE($A$1:$A$100;$D$1*(C1-1);0;$D$1;1))
    Oczywiście odwołanie do $D$1 można zastąpić liczbą 5 (lub w Twoim przypadku 12). Kolumnę pomocniczą da się ukryć. Plus tego rozwiązania - można łatwo nie zmieniając formuły w różnych miejscach w dokumencie wyświetlić wyniki z różnych grup (tzn nie muszą być one koniecznie wszystkie pod sobą). Minus - dodatkowa kolumna.

    Jeśli wszystko mamy być po kolei (lub co najmniej w regularnych odstępach, można łatwo zmodyfikować formułę) to można zastosować drugi wariant, z kolumny G. Tam numer grupy jest pozyskiwany wprost z numeru wiersza. Pierwsza grupa ma numer zero, więc w przypadku kolumny G odejmujemy jedynkę. Jeśli zaczynamy od wiersza drugiego to odejmujemy 2, od piątego odejmujemy 5 (jak w kolumnie J) - zawsze taką samą liczbę w całym ciągu. Można też numer grupy sobie generować z numeru kolumny, jeśli chcemy rozciągać w bok a nie w dół. Przykład w wierszu 32. Tak jak w przypadku wierszy, żeby liczyć od zera trzeba za nr.kolumny odjąć odpowiednią liczbę (aby numerację grup rozpocząć od zera).

    0
  • #3 10 Lis 2016 08:18
    mlewan
    Poziom 20  

    Dziękuję, ja w międzyczasie po prostu zaznaczyłem 11 pustych komórek i dwunastą z formułą i metodą kopiuj wklej przeleciałem całą kolumnę równoległą do tej z wartościami. Też nie elegancko, ale działa :)

    0