Elektroda.pl
Elektroda.pl
X
IGE-XAO
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Toshiba Satellite L670 - Wymiana dysku, brak możliwości instalacji Win10

18 Lis 2016 19:37 1011 4
  • Poziom 8  
    Witajcie !

    Siedze już 3h po pracy (projektuje systemy IT dla produkcji i magazynów) z niesfornym komputerem wujka (moja ambicja na tym cierpi) :D :D :D
    Więc tak:
    Komputer po wymianie dysku na nowy (HDD) przez poprzedni serwis, bo stary, cóż... popsuli... Problem w tym, że rodzinka z zagranicy i miałem im zainstalować ich wersję językową. No to bach:
    1. wyjąłem dysk z laptopa,
    2. wpiąłem do mojej stacjonarki (zależało mi na czystym formacie i instalacji na czystym dysku, nie było żadnych potrzebnych danych na dysku).
    3. Zarządzanie dyskami
    4. Usunąłem wszystkie partycje z dysku, połączyłem je w jedną dużą partycję na tym dysku, sformatowałem i widnieje teraz jako:
    Toshiba Satellite L670 - Wymiana dysku, brak możliwości instalacji Win10

    Podpinam go do laptopa, model jak w temacie - Toshiba Satellite L670.

    Następnie przychodzę to przygotowania pendrive - najpierw standardowo przez Windows 7 USB DVD Download Tool wypalam najnowszy obraz Windows 10 Multiple Editions (64bit) ISO pobrany z MSDNa na pendrive, który wcześniej wykorzystywałem do instalowania (przez takie samo wypalanie) polskiej wersi Windy.

    Wchodzę do boot menu, wybieram pendrive - nie działa.

    Restart > BIOS > Boot priority > USB na pierwsze miejsce. Restart > Nie działa

    Restart > Boot menu > ręcznie wybieram pendrive - nie działa.

    No to google: okazuje się, że trzeba wyłączyć Safe Boota i zmienić Boot Mode na CSM/Legacy. I tu pierwszy problem: BIOS w wersji 2.10 nie ma żadnych wymienionych ustawień/opcji do wyboru/etc. Przejrzałem go, czy nie odblokowuje się gdzieś reszty opcji BIOSa (coś wstylu "Ustawienia dla zaawansowanych użytkowników"_ - brak.

    Aktualizacja z BIOSa - na stronie Toshiby znalazlem informacje o bodajże 6 różnych mozliwościach, wszystkie z poziomiu Windowsa... Gwoli przypomnienia - mam laptopa z czystym dyskiem.

    To kombinujemy z pendrive - znalazłem informacje, że Toshiby podobno obsługują tylko schemat partycjonowania GPT dla UEFI (zatem skoro nie mogę wyłączyć UEFI z biosa, to przerabiam pena pod partycjonowanie, które płyta podobno obsługuje). Odpalam Rufusa, wybieram mój obraz dysku, zmieniam schemat partycjonowania na w/w, system plików na FAT32, bo gdzieś w internecie trafiłem na informacje, że z NTFS bywa różnie), rozmiar jednostki alokacji [Domyślnie], Szybki format, no i wiadomo opcje bootowalnego ISO. Proces przebiega gładko, żadnych błędów program nie zwraca, no to jazda, lecimy dalej!

    Podpinam pendrive, odpalam BIOSa, sprawdzam czy boot priority się nie pozmieniało, wszystko w porządku, ale jako przezorny polaczek po restarcie odpalam boot menu, wybierma usb i... nic, ekran kilka razy mrugnie tak szybko, ze nie da sie przeczytac (wyłapać mi się udało tylko Boot Failed) i system znowu wisi. Nie czyta pendrive. Nie mogę bootowalnym pendrive zainstalować tam systemu (teoretycznie zgodnym z obostrzeniami Toshiby).

    Rozwiązania nad którymi myślałem i podjąłem się próby ich realizacji, ale spełzły na niczym (moze macie co do tego własne propozycje ? ):
    1. Instalacja poprzez dysk wpięty do innego kompa (wiem, naiwne, ale jednak spróbowałem) nie działa.
    2. Wrócenie do struktury partycjonowania MBR dla BIOS lub UEFI - nie działa.
    3. Zrobienie małej partycji na tym dysku (przy wpięciu do innego kompa) i przekopiowanie zawartości obrazu płyty - nie działa.

    NIE TESTOWAŁEM, BO JUŻ MI BRAK NERWÓW (k******** !!! :D :D :D :D ) następujące metody:
    1. Aktualizacjia BIOSa - bo to zawsze ostateczna ostateczność, dwa, że najpredzej zrobie to pendrivem, a te bootowalne nie działają...
    2. Taki miałem pomysł (znalazłem kilka jakichś ogólnych poradników, ale żaden pokrywający się z tym co chcę zrobić): Czy jeśli przez przejściówkę USB podepnę ten dyskz laptopa A do innego laptopa B z Windowsem 10 i z tego laptopa B zrobię kopię odyzskiwania i obraz na dysku z laptopa A, to czy po podpięciu do Toshiby (laptop A) tego dysku będę go mógł naprawić i odzyskać system z obrazu ?

    Wybaczcie, ale 8h w pracy + teraz juz kolejne 3h i próba wielu wariacji doprowadzają mnie... do wariactwa :P

    Będę wdzięczny za jakiekolwiek wsparcie z tym laptopem, może ktoś z Was serwisował Toshiby, zna jakieś knify, wie co i gdzie może wadzić albo po prostu macie propozycje - z góry wielkie podziękowania.

    Pozdrawiam Was,
    Tadek
  • IGE-XAO
  • IGE-XAO
  • Poziom 8  
    Dzieki Panowie, za pol godiziny bd w domu i przechodze do dzialania, mam nadzieje, ze zatrybi!

    Dodano po 2 [godziny] 39 [minuty]:

    DriverMSG napisał:


    DriverMSG, podziękowania poszly na priv, UDAŁO SIĘ :DDDDDD to jest dokładnie ta metoda, choć z drobną modyfikacją (możesz dodać do swojego posta jako podpowiedź "jeśliby nie działało, to spróbujcie też:")

    Zarządzanie dyskami nie pozwalało mi na przełączenie nowej partycji z instalatorem jako aktywnej. Co zrobiłem?
    1. Wiersz poleceń (z uprawnieniami Administratora)
    2. Wpisywałem po kolei komendy:
    2a. diskpart
    2b. list disk
    2c. select disk 2 (w moim przypadku zewnętrzny dysk z laptopa, który miałem podpięty do stacjonarki był dyskiem o id 2)
    2d. list partition
    2e. select partition 1 (j/w, w odniesieniu do partycji, która była partycją przewidzianą na wgranie na nią instalatora)
    2f. active (aktywacja partycji)

    Po tym wszystkim zostawiłem otwarte CMD/Wiersz poleceń, zweryfikowałem w Zarządzaniu dyskami - moja partycja wyświetlana była jako Aktywna.

    PRZED PRZEJŚCIEM DO NASTĘPNEGO KROKU (czyli egzekwowanie komendy z wiersza poleceń/cmd podanej w następnych krokach poradnika, należy wyjść z uruchomionego poprzednio diskparta komendą... bodajże 'Exit' xD w każdym bądź razie, jeśli w linii komend nie wyłączycie diskparta, to następne komendy z tego poradnika nie zadziałają!

    Dodatkowo podpowiem, że (przynajmniej u mnie) pkt 8 wymagał bardzo drobnej modyfikacji:
    Oryginalnie komenda (oczywiście kazdy musi podac litery odpowiednie dla swojej maszyny): M:\boot\bootsect/nt60 O:
    Powinno być: M:\boot\bootsect /nt60 O:

    Brakowało spacji przed /nt60

    Jeszcze raz dziękuję użytkownikom leonov ale w szczególności DriverMSG, który podał jedyną działającą opcję. DZIĘKUJE!

    Pozdrawiam,
    Tadek
  • Admin grupy komputery
    thadeus napisał:
    Brakowało spacji przed /nt60
    Nie wiem jak w twoim systemie, ale u mnie nadal to bez znaczenia - spacja nie gra roli, komenda wykonywana jest jednakowo.

    Toshiba Satellite L670 - Wymiana dysku, brak możliwości instalacji Win10


    Najważniejsze, że działa. :)
    Temat uznaję za wyczerpany - zamykam.