Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Czarny ekran - Czarny ekran po instalacji sterowników karty graficznej Intel

Twistero 26 Lis 2016 02:55 909 7
  • #1 26 Lis 2016 02:55
    Twistero
    Poziom 5  

    Witam serdecznie.

    Mam dość spory problem z moim laptopem Acer E1-571, mianowicie był w nim fabrycznie procesor Intel Core I3 2328m, jako że laptop posiada tylko zintegrowaną kartę graficzną (HD3000) to w celu ulepszenia go kupiłem procesor Intel Core I5 3320m z HD4000, wszystko fajnie procesor śmiga jednak problem pojawia się przy próbie instalacji sterowników do karty graficznej. Jak tylko system załapie, że je instaluje (moment gdy w menadżerze urządzeń zmienia się z "Podstawowa karta graficzna Microsoft" na "Intel HD 4000" laptop się zawiesza i pokazuje jedynie czarny ekran (podświetlony) wtedy jedynie co pozostaje to usunąć sterownik przez tryb awaryjny.
    Próbowałem już:

    *Instalacja różnych sterowników (ze strony producenta) starszych, nowszych
    *Instalacja przez tryb awaryjny
    *Reinstall jak i zmiana Windowsa z 8.1 na 10
    *Aktualizacja Biosu

    Wszystko daje ten sam efekt czyli czarny ekran, automatyczna instalacja przez Windows Update także . Oczywiście przed instalacją sterowników do karty instaluje sterowniki do chipsetu.
    Jest jeszcze jedna rzecz która mnie dziwi ponieważ nie mogę przełączyć biosu w tryb Legacy Mode, żeby np spróbować odpalić jakiś live CD , bo przy próbie zmiany z UEFI na Legacy Mode i zatwierdzeniu laptop się resetuje i nawet nie widać loga Acer a tylko od razu czarny ekran, dodam że na procesorze I3 (oryginalnym) normalnie działa Legacy Mode a na I5 już tylko w UEFI.

    Zastanawia mnie także co to Zespół główny PCI Express i gdzie do tego znaleźć sterownik
    Czarny ekran - Czarny ekran po instalacji sterowników karty graficznej Intel


    Przeglądałem dość sporo tematów z tym problemem na różnych forach i nic nie działa. Bardzo proszę o pomoc bo mi się już skończyły pomysły. Pozdrawiam.

    0 7
  • #2 26 Lis 2016 04:50
    Robert B
    Poziom 43  

    Twistero napisał:
    w celu ulepszenia go kupiłem procesor Intel Core I5 3320m z HD4000

    Zadziała w zależności od modelu:
    https://community.acer.com/t5/Legacy-Laptops-.../Acer-E1-531-2801-CPU-Support-List/m-p/395182

    0
  • #3 26 Lis 2016 12:57
    Twistero
    Poziom 5  

    No właśnie i wszędzie pisze, że bez problemu obsługuje ten procesor. Sam procesor działa, tylko sterowniki do graficznej dają cały czas efekt czarnego ekranu.
    Teraz zauważyłem, że w zdarzeniach urządzenia Intel HD 4000 jest coś napisane o amd64, nie wiem czy tak ma być czy nie więc wstawiam kolejne zdjęcie Czarny ekran - Czarny ekran po instalacji sterowników karty graficznej Intel może tu coś nie tak, ja już przy tym wymiękam.

    0
  • #5 26 Lis 2016 14:28
    Twistero
    Poziom 5  

    No tak racja.
    Ktoś ma jakiś pomysł?
    Teraz mnie tak zastanawia, że skoro procesor nie jest taki jak w oryginalnych E1-571 to może jakieś inne sterowniki trzeba wgrać? Wiem że potrzeba do HD4000 ale może jakieś inne niż że strony Acera? Ma ktoś na to jakiś pomysł skąd jeszcze bym mógł spróbować pobrać sterowniki oprócz strony Acera i Windows Update ?

    0
  • #6 26 Lis 2016 19:40
    310artur
    Poziom 43  

    Na początek sprawdziłbym na live linuksie. Tam spróbować podinstalować sterowniki albo zobaczyć czy w ogóle będzie działać.
    Innych sterowników to bym nie szukał jeśli jakieś to chipset/system różnie pisywane. Zobacz w managerze urządzeń czy wszytko jest OK. Czy gdzieś tam w nazwie czegoś nie wisi nadal stary CPU.

    Możesz zobaczyć co pokaże Intel® Processor Diagnostic Tool
    Może to chyba być też kwestia BIOSu ale tu pewności nie mam.

    0
  • #7 29 Lis 2016 02:57
    Twistero
    Poziom 5  

    Więc tak, menadżer urządzeń nie pokazuje żeby czegoś brakowało, Intel® Processor Diagnostic Tool wszystko ok, ale zaciekawiła mnie taka linijka w dxdiag:

    Current Mode: 1366 x 768 (32 bit) (64Hz)
    Monitor Name: Generic PnP Monitor
    Monitor Model: unknown
    Monitor Id: AUO26EC
    Native Mode: 1366 x 768(p) (60.014Hz)

    Dlaczego monitor pracuje w 64Hz a Native mode jest 60Hz ? Może to jest przyczyną ? Dodam, że we właściwościach nie mam możliwości zmiany częstotliwości odświeżania jest tam tylko 64Hz.

    PS. Z linuxem jak na razie walczę bo gdy jakiegoś odpalam to przy samym bootowaniu (po wyborzy czy chcę go zainstalować czy tylko sprawdzić) ekran się gasi i tyle mimo iż pendrive miga lub na niektórych wersjach na początku wywala artefakty w postaci białych pasków na górze ekranu a sam pendrive już nie miga.

    0
  • #8 29 Lis 2016 18:10
    310artur
    Poziom 43  

    Coś jest nie tak z tym CPU (z grafiką) . IntelHD to powszechny prostu układ. Takich objawów po linuksie spodziewałbym się po nietypowej karcie jakiejś. Możesz pobawić się linuksem antix - w wersji full ma 4 powłoki graficzne do wyboru. Bywa że te najlżejsze powłoki ruszają gdy te ładniejsze wymagające akceleracji nie. Możesz też zobaczyć czy ten który nie działa (bo czarny ekran) ruszy w trybie tekstowym. Z trybu tekstowego możesz spróbować jakiś program odpalić (firefox na przykład). Powiem ci że takie przejścia miałem z linuksami jak miałem kartę amd hd3650 na AGP - nietypowa konstrukcja i jedne linuksy się uruchamiały inne rzucały artefaktami a inne wcale nie ruszały.

    Stąd wydaje mi się że z tą grafiką jest coś nie tak.
    Sam monitor też źle wykrywa. To nawet możliwe że odświeżanie jest problemem. Nie wiem jak działa identyfikacja monitora w laptopie ale to też może być trop - w końcu domyślam się trzeba to było wszystko rozebrać i złożyć.
    A możesz podpiąć drugi monitor? Ma jakiejś wyjście? Może to coś da. Może zewnętrzny wykryje poprawnie.

    0