Elektroda.pl
Elektroda.pl
X

Wyszukiwarki naszych partnerów

Wyszukaj w ofercie 200 tys. produktów TME
Proszę, dodaj wyjątek elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Przetwornica DC/DC 150W - zasilacz buforowy

For323 29 Gru 2016 13:55 1449 26
  • #1 29 Gru 2016 13:55
    For323
    Poziom 9  

    Witam!

    Aktualne pytanie w 8 poście. :D

    Temat przetwornic jest mi kompletnie obcy, tak samo jak temat zasilaczy impulsowych. Dotychczas robiłem tylko zwykłe zasilacze i liniowe stabilizatory.

    Układ jest następujący:
    Przetwornica DC/DC 150W - zasilacz buforowy
    Opis:
    1 - Zasilacz impulsowy 12V 350W (wyjście regulowane - można troszkę zmienić napięcie) - kupiony, działa
    2 - Procesorowa ładowarka akumulatorów żelowych - nie zrobiona, ale nie przewiduje problemów :)
    3 - Akumulator żelowy 12V 40-100Ah - pojemność jak największa, ale z ograniczeniem przez portfel ;)
    4 - Przetwornica DC/DC - i tu jest problem
    5 - Układ przełączający - tu chyba po najprostszej linii oporu czyli przekaźnik i kondensator
    6 - picoPSU-150-XT (czyli 150W zasilacz do komputera tolerujący na wejściu 11,4-12,5V choć to nie potwierdzone tak do końca) - niestety kupiony, działa

    I teraz pytanie:
    Jak zrobić przetwornicę DC/DC (4), która na wejściu ma 12V akumulator żelowy, a na wyjściu stabilne 12V przez jak najdłuższy czas podczas rozładowywania (podczas ładowania akumulator będzie zawsze odłączony przełącznikiem 5). Moc 150W.
    A może lepiej zrobić przetwornice step down 12V 15A i dać dwa akumulatory 12V połączone szeregowo na 24V.
    A może zrobić przetwornice step up 13,8V z akumulatora, podkręcić zasilacz (1) na 13,8 i nadmiar napięcia wytracić np na diodzie mocy za układem przełączającym (5).
    Co jest lepsze, tańsze, z mniejszymi stratami mocy?

    Pozdrawiam

  • Ups
  • #2 30 Gru 2016 01:52
    For323
    Poziom 9  

    Nie wiem dlaczego post został przeniesiony do działu początkujących elektroników. Tu mi chyba nikt nie pomoże.
    Było w dziale zasilaczy, bo wszystkiego co potrzebuję to namiar na schemat przetwornicy pozwalającej z akumulatora żelowego (6, 12 lub 24V) zrobić zasilacz 12V o mocy 150W przy małych stratach.

  • #3 30 Gru 2016 11:18
    _lazor_
    Poziom 24  

    Może dlatego, że pytanie jest tak mdłe, że zakrawa o prośbę zaprojektowania układu. Pewnie dlatego został wrzucony do tego działu.

    Ogólnie jak masz akumulator to po co chcesz coś z tym jeszcze robić? prędzej zrób wyłącznik który spowoduje by odłączyć urządzenie gdy na akumulatorze napięcie spadnie poniżej 11,5V.

  • #4 30 Gru 2016 12:30
    For323
    Poziom 9  

    Może było mdłe :) Dokładnie opisałem co chce zrobić i po co.
    Dlatego w opisie jest, że układ toleruje 11,4-12,5V. Akumulator naładowany w pełni ma ponad 13V (fakt że krótko, ale ma).
    Nigdzie nie ma żadnych namiarów na prostą przetwornicą przerabiającą to co mam Link na to co chcę Link.

    Jak oni to robią?

  • Ups
  • #5 30 Gru 2016 18:06
    jarek_lnx
    Poziom 43  

    Istnieją przetwornice, które mogą obniżać lub podwyższać, np. SEPIC.

  • #7 30 Gru 2016 23:31
    For323
    Poziom 9  

    SEPIC, Ćuk, buck-boost - w końcu jakiś punkt zaczepienia. Biorę się do czytania.
    Ten kalkulator też się przyda. Dzięki.

    Buck-boost - o tym żeby "obrócić" akumulator w ogóle nie pomyślałem...
    Są jakiej gotowe scalaki do sterowania taką przetwornicą? Bo jak rozumiem moc przetwornicy zależeć będzie od mocy diody, tranzystora w kluczu i samej cewki. Scalak sterujący chyba nie ma na to wpływu?

    PS. Te zasilacze, których link dałem nie mają nawet radiatorów. Jak to możliwe?

  • #8 06 Sty 2017 01:31
    For323
    Poziom 9  

    Więc tak:

    Na przetwornicy poległem na całej linii - za dużo niewiadomych...
    Znalazłem AVT2732. I właśnie o to mi chodziło. Poszperałem trochę i wyszło mi, że jeszcze prościej przerobić stary zasilacz ATX na TL494.
    Oba moje stare zasilacze były nie na TL494 tylko na SG6105, ale zasada działania taka sama. Zasilacz Cube 500W - linia 12V ma 12 i 14A.
    Całość od strony pierwotnej wywaliłem, transformatory wywaliłem, klucze na MOSFETach zrobione na IRFZ44N.
    Z transformatora impulsowego odwinąłem uzwojenie pierwotne - było 19 zwojów. Ale to jest chyba połowa uzwojenia. Druga połowa jest pod wtórnym więc niech tam zostanie. To chyba nie będzie przeszkadzać?
    Tym samym drutem (nie wiem jaka to grubość - nie mam suwmiarki) nawinąłem 2x5 zwojów. Złożyłem całość i z zasilacza 10,5 - 13,8V zasiliłem.
    Działa. Startuje dopiero przy 11,7V ale później można zejść z zasilaniem niżej. Pobór prądu przy obciążeniu wentylatorem 12V (tym oryginalnym z zasilacza) i diodą COB 12V 3W - ok. 580mA przy zasilaniu najniższym napięciem.
    Odwinąłem dla testu trochę i w tych samych warunkach:
    2x4 zwoje - start 11,0V - pobór prądu ok. 680mA
    2x3 zwoje - start 10,5V (lub niżej) - pobór prądu ok. 780mA. Po zwiększeniu napięcia wejściowego do 13,8V pobór prądu spadł do 580mA
    (Pomiar prądów może być obarczony bardzo dużym błędem, nie mam amperomierza, więc podłączyłem na wejściu rezystor ok. 0,1om i mierzyłem na nim napięcie)
    Napięcie wyjściowe 12V stabilne (pozostałe napięcia mnie nie interesują, ale też są ok)
    Rdzeń transformatora zimny, klucze zimne.

    I teraz pytanie:
    Zgodnie z założeniami potrzebuję stabilnego zasilacza 12V min. 150W, ale wolałbym więcej, zasilane z akumulatora AGM 12V min. 30Ah (czyli 9,5 - 13,8V w pracy buforowej).
    Jakie dać uzwojenie pierwotne na tym trafo? Zostawić te 2x3 zwoje? Skoro dla 160V było 2x19 zwojów, to powinno być właśnie 2x3 zwoje. Jaki gruby drut? Ile wiązek w zwoju?
    W pdf od SG6105 jest Fosc=70kHz. Jeśli to jest częstotliwość kluczy to max. grubość drutu to 0,5mm - przekrój 0,196mm^2. Przy gęstości 5A/mm^2 i prądzie 12,5A przekrój powinien być 2,5mm^2 czyli 13????? drutów na zwój?
    Przecież na wtórnym (a tam jest ten sam prąd) na pewno jest mniej.

  • #10 10 Sty 2017 13:16
    For323
    Poziom 9  

    Poważnie?
    Nikt nie pomoże?

  • Ups
  • #12 10 Sty 2017 15:38
    For323
    Poziom 9  

    Ważniejsze pytanie to czy 2x3 zwoje?

  • #14 10 Sty 2017 16:20
    For323
    Poziom 9  

    Bardzo dziękuję za pomoc!
    Czyli nawijam 2x3 zwoje licą 2,5mm^2.

  • #15 11 Sty 2017 09:38
    coolrob
    Poziom 14  

    Domyślam się, że ten zasilacz pracuje w topologii półmostka. Jeśli tak, co zatem oznaczają zapisy 2x3zw, 2x4zw itd. w odniesieniu do pierwotnego uzwojenia? W półmostku jest raczej jedno uzwojenie pierwotne. Jeśli tak jest i miało ono 19zw jak napisałeś, to:

    Pierwotnie było (320V / 2) / 19zw -> 8,4[V/zw]. Teraz zasilasz z max 14V, czyli (14V /2) / 8,4[V/zw] = 0,8zw. Możesz zatem nawinąć nawet jeden zwój i powinno być ok. Grubość przewodu oraz ilość żył tak ja napisałeś.

  • #17 11 Sty 2017 11:20
    coolrob
    Poziom 14  

    Jeśli to push-pull, który pierwotnie miał 2 x 19zw, to wyjdzie 14V / 8,4[V/zw] = 1,6zw -> 2 x 2 zwoje minimum powinny być.

  • #19 11 Sty 2017 13:06
    For323
    Poziom 9  

    Było 2x19. Jedno odwinąłem, a drugie jest pod wtórnym to zostawiam. Ale było połączone razem, czyli 38 zwojów w półmostku.
    Teraz będzie push-pull zasilany 10,5 - 13,8V.
    (320V / 2) / 38zw = 4,21[V/zw]
    10,5V / 4,21 = 2,49zw - chyba się liczy dla minimalnego napięcia, ale pewny nie jestem
    13,8V / 4,21 = 3,27zw
    Dlatego przyjąłem wstępnie 2x3 zwoje, co _lazor_ potwierdził.

  • #21 11 Sty 2017 13:31
    For323
    Poziom 9  

    Czyli jednak muszę dać 2x4 zwoje.... Ciekawe czy się zmieści.
    Tylko, że te 38 zwojów pierwotnego było dla całego zasilacza o "mocy 500W". Jak teraz będzie sama linia 12V i moc 150W (w porywach do 180) to te 3 zwoje nie wystarczą?
    Prąd będzie znacznie mniejszy niż w oryginale.

  • #22 11 Sty 2017 13:39
    coolrob
    Poziom 14  

    Ok to teraz jasne. W push-pull mamy 320V / 19zw -> 16,8[V/zw]. Aktualnie masz 14V więc 14V / 16,8[V/zw] = 0,8zw. Wystarczy 2 x 1zwój.

    For323 - obciążenie transformatora nie ma znaczenia dla tych obliczeń, transformator nasyca się prędzej, gdy jest nieobciążony.

  • #23 11 Sty 2017 13:54
    _lazor_
    Poziom 24  

    Z obliczeń wygląda ok, ale z zdrowego rozsądku dałbym przynajmniej te 2x3. 16.8[V/zw] to jest wartość bardzo duża i nie wiem jak duży by był rdzeń lub z czego by mógłby być zrobiony by osiągnąć taką wartość. wartość 4[V/zw] jest już dla mnie bardziej do przyjęcia przy częstotliwości 70kHz.

  • #24 11 Sty 2017 14:03
    For323
    Poziom 9  

    coolrob napisał:
    W push-pull mamy 320V / 19zw -> 16,8

    Nie. W oryginale było 38 zwojów podzielone na 2 części (jedna pod, druga nad wtórnym) i półmostek czyli: 160/38 -> 4,21
    Ogólnie z pdf do SG6105 w oryginale była aplikacja 2 (str 7) przewijam oczywiście trafo T2, a teraz będzie aplikacja 1 (str 6). Wyjścia sterujące trafo to OP1 i OP2.

    _lazor_ napisał:
    ale z zdrowego rozsądku dałbym przynajmniej te 2x3

    To mogę zostać przy 2x3, czy jednak muszę 2x4?

  • #26 11 Sty 2017 14:36
    For323
    Poziom 9  

    Może się trochę grzać, bo to ups :)
    Jak akumulator padnie po godzinie czy dwóch to się wyłączy i wystygnie. A pracować będzie raz na ruski rok.

    Dodano po 17 [minuty]:

    coolrob napisał:
    transformator nasyca się prędzej, gdy jest nieobciążony

    W testowym nawinięciu 2x3 zwoje i bardzo małym obciążeniu (oryginalny wentylator zasilacza i 3W dioda) układ pobierał ok. 580-780mA. Więc chyba się nie nasyca. Tym bardziej, że nie wiem czy nie robię błędu na sterowaniu mosfetami bo użyłem do sterowania mosfeta tranzystora, który obraca sygnał PWM, a w aplikacji 1 SG6105 jest tylko tranzystor kluczujący.
    Całkiem możliwe, że się pozbawiłem tego całego death time:) i mam zwarcie 70 tys razy na sekundę...
    W docelowym układzie chcę dać albo IR4426 albo IR4427.
    Ponieważ nie mam oscyloskopu to muszę to przemyśleć na sucho (chyba, że ktoś pomoże).

  • #27 26 Sty 2017 18:43
    For323
    Poziom 9  

    Dałem odwracający TC4426.
    Przetwornica działa. Narazie sprawdziłem z obciążeniem 70W (2 halogeny). Rdzeń zimny, uzwojenie zimne, klucze dość ciepłe ale jeszcze nie parzą.
    Problem jest tylko z włączeniem. Obciążona diodą 3W startuje zawsze, ale przy halogenach trzeba kilka razy włączyć (PSON) i wyłączyć, żeby wystartowała.
    Podejrzewam, że to może jakiś duży prąd udarowy zimnego halogenu, który przy tych kilku włączeniach się rozgrzewa. Jeśli tak to w docelowym miejscu (naładowany kondensator) nie będzie problemu.

    PS.
    Po sklejeniu rdzenia, po przewinięciu, prąd podskoczył z 780mA do 990mA (przy obciążeniu jak poprzednio dioda + wentylator i przy pomiarze z dużym błędem jak poprzednio - nie chodzi o wartość tylko o jej wzrost). Pewnie za słabo ścisnąłem rdzeń i została jakaś mikroszczelinka. Ale mocniej nie chciałem, bo to delikatne dziadostwo. Połamałem trzy zanim się udało... Po wymianie sterowania kluczy na TC4426 spadł do 750mA.

 Szukaj w ofercie
Zamknij 
Wyszukaj w ofercie 200 tys. produktów TME