Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Nie działa komunikacja raspberry PI3 z modułem HX711 przez I2C

mahonxx 04 Jan 2017 20:35 1455 10
  • #1
    mahonxx
    Level 12  
    Witam,
    mam problem z uruchomieniem przetwornika HX711 z raspberry PI3 po I2C.
    Uruchomiłem szynę I2C i po tym wpisaniu w konsoli
    Kod:
    lsmod | grep i2c_
    otrzymuję:
    i2c_bcm2708 4834 0
    i2c_dev 5859 0
    Czyli wygląda OK?

    Ale po wpisani i2cdetect -y 1
    nie ma żadnego adresu.

    Fizycznie podłączyłem to w taki sposób:
    RP HX
    pin2 5V Vcc
    pin3 SDA SCK
    pin5 SCL DT
    pin6 GND GND
    Jestem w tym temacie zielony, proszę o pomoc.
    Do you have a problem with Raspberry? Ask question. Visit our forum Raspberry.
  • #2
    User removed account
    User removed account  
  • #3
    mahonxx
    Level 12  
    Źle wpisałem, oczywiście że jest tak:
    RP HX
    pin2 5V Vcc
    pin3 SDA DT
    pin5 SCL SCK
    pin6 GND GND
    Przełączyłem na 3,3V i nic nie daje, w zasadzie już próbowałem wcześniej.
  • #4
    User removed account
    User removed account  
  • #5
    mahonxx
    Level 12  
    Tak uruchomione I2C i SPI. Od 5V zaczynałem.
  • #6
    User removed account
    User removed account  
  • #7
    mahonxx
    Level 12  
    Tak jak pisałem, mam uruchomione oba.
  • #8
    User removed account
    User removed account  
  • #9
    mahonxx
    Level 12  
    Chodzi Ci o HX711?
  • Helpful post
    #10
    User removed account
    User removed account  
  • #11
    mahonxx
    Level 12  
    Dziękuję, czyli błąd na etapie doboru sprzętu.
    PZDR