Elektroda.pl
Elektroda.pl
X
BotlandBotland
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Budujemy inwerter sinus do zasilania pomp centralnego ogrzewania.

stev-an 12 Mar 2017 13:14 14091 100
  • #61
    atom1477
    Poziom 43  
    stev-an napisał:
    atom1477 napisał:
    Na początek trzeba sprawdzić czy procesor generuje przebiegi PWM.

    Czy procesor już działa?

    Nie wiem, bo to nie ja miałem to sprawdzić.
  • BotlandBotland
  • #62
    stev-an
    Poziom 18  
    No to pozostaje układ analogowy lub EGS002.
    Odnośnie transformatora to im większy rdzeń tym lepiej, niby nic nowego, ale tu sprawdza się znakomicie.
    Ponownie zachęcam do podzielenia się pomysłami na sposobem załączania przetwornicy w trybie UPS, może ktoś ma swoje rozwiązania.
  • #63
    stev-an
    Poziom 18  
    W prototypie zastosowałem układ zaniku sieci i strażnika baterii jak na zam. schemacie i działa. Ale mógłby być bardziej zaawansowany, bo dojdzie praca na PV lub wiatraku i miał mały apetyt na energię, bo czuwa na zasilaniu z akumulatora. Zamiast 431 coś CMOS i sygnał z sieci energetycznej przez transformator? Budujemy inwerter sinus do zasilania pomp centralnego ogrzewania.
  • BotlandBotland
  • #64
    Rysio13
    Poziom 9  
    Dzień dobry.
    Ja mam pytanie odnośnie przetwornicy zaprezentowanej przez autora tematu.
    ( https://obrazki.elektroda.pl/2416932200_1489322911_thumb.jpg )
    Czy ta przetwornica faktycznie daje na wyjściu sinus? bo ja ją poskładałem na płytce zamieszczonej przez autora, przetwornica odpaliła, na uzwojeniu wtórnym transformatora mam 230V, ale zamiast sinusa mam coś podobnego do prostokąta :( .
    Jak to poprawić? bo kombinuję i nic nie mogę wymyślić.
    Dziękuje
    Pozdrawiam
  • #65
    atom1477
    Poziom 43  
    Może pomyliłeś kolejność uzwojeń któregoś transformatora.
    Albo w ogóle o nią nie zadbałeś nie wiedząc że trzeba.
  • #66
    Rysio13
    Poziom 9  
    Co do uzwojeń to fazę sprzężenia zwrotnego mam podłączone zgodnie z fazą z R18 tyle że na R18 jest sinus a na transformatorze prostokąt.
    Jeszcze jutro z tym powalczę i napiszę co i jak.
  • #67
    atom1477
    Poziom 43  
    Daj schemat według którego to zbudowałeś (to wyżej co dałeś to jest miniaturka na której nic nie widać).
  • #69
    atom1477
    Poziom 43  
    Musisz posprawdzać przebiegi w różnych częściach układu.
  • #70
    Rysio13
    Poziom 9  
    Dokonałem pewnych pomiarów i tak:
    Na nodze nr 1 U2 jest trójkąt o amplitudzie około 2,5V, taki sam przebieg jest na nogach 6, 2 U3.
    Na nogach 14, 13 U1 jest sinus o amplitudzie 2V.
    Problem leży wydaje mi się w U4. Na nodze 1 i 7 U4 jest przebieg prostokątny. Równolegle z R15 dałem potencjometr montażowy 22k i tak, gdy rezystancja wypadkowa jet mniejsza od około 7kΩ to na wyjściu mam ładny sinus, na nogach 1, 7 U4 tez jest sinus, gdy rezystancja R15 wzrasta to przebieg na wyjściu zaczyna się robić coraz bardziej prostokątny.
    Mam więc pytanie, czy R15 mogę podmienić na stałe na te 7 kΩ i tak zostawić, czy szukać dalej?
    Sprawa druga to sprzężenie zwrotne, w ogóle nie reaguje na zmiany napięcia na wyjściu wywołane zmianami obciążenia, czy zmniejszenie R16 do 1k coś da?
  • #71
    stev-an
    Poziom 18  
    Witam!
    Rysio13 odpowiem po kolei diody o które pytałeś to diody szybkie typu UF4002 do 7 lub HER 102 do 8, FR.... Przetwornica może zasilać wszystkie odbiorniki wymagające sinusa. 200W osiągnie bez problemu. 400W to 12 tranzystorów i wymuszone chłodzenie transformatora.
    Skoro zbudowałeś zgodnie ze schematem to powodem może być transformator. To musi być transformator 230V/ 6-7V. Uzwojenie 6V nawinięte grubym drutem lub dwoma.Aby na wyjściu osiągnąć 230V U4 wzmacnia sygnał sinus aż do przesteru. Jeżeli masz odpowiedni transformator to będą inne podpowiedzi. Wielkości sygnałów są poprawne, ale zacznij uruchamianie bez sprzężenia zmieniając wartość R15 do uzyskania czystego sinusa na wyjściu.
  • #72
    komatssu
    Poziom 28  
    Rysio13 napisał:
    Schemat modulatora i falownika.

    Czy autor tego projektu mógłby zamieścić przykładowe prawidłowe oscylogramy w newralgicznych punktach układu? Ułatwiłoby to szukanie ew. błędów.
  • #73
    Rysio13
    Poziom 9  
    Witam
    Dzięki za odzew.
    Co do transformatora głównego to mam transformator 230V/8V, napięcie zasilania przetwornicy 14V, w falowniku siedzą IRFZ44N.
    Problem jest taki że ustawiam wartość R15 (przy odłączonym sprzężeniu zwrotnym)
    tak by na wyjściu mieć ładny sinus napięcie na wyjściu wynosi około 245V.
    Ale gdy podłączam sprzężenie zwrotne to napięcie na wyjściu spada do 110V, i nie mogę jej wyżej podnieść przez regulacje R17(mogę jedynie obniżyć).
    w obu przypadkach na 1 i 7 nodze U4 sinus nie jest przesterowany.
    Sprzężenie zwrotne mam podłączone zgodnie z fazą na nodze 1 U4.
    Transformator w sprzężeniu zwrotnym mam 230V/7V.
  • #74
    stev-an
    Poziom 18  
    komatssu napisał:
    Czy autor tego projektu mógłby zamieścić przykładowe prawidłowe oscylogramy w newralgicznych punktach układu?
    Do tego muszę się lepiej przygotować, ale moją intencją było zbudowanie układu dla osób , które oscyloskopu nie posiadają.
    Rysio13 napisał:
    by na wyjściu mieć ładny sinus
    Skoro tak jest to układ zbudowałeś poprawnie i działa od razu, pozostaje jedynie regulacja. Na tranzystorach IRF3205 i transformatorze 8V, 75W można uzyskać. Dokończ uruchamianie na tym co jest.
    Uruchomiłem specjalnie stary prototyp aby z Tobą to uruchomić. Podzespoły podobne mostek na IRF3205. Sprzężenie podłącz , R17 skręcony na zero, R15 ok 6k napięcie wyjściowe bez obciążenia 110V. R15 11k napięcie 245Vsinus ładny jak u ciebie.Zwiększam R17 znowu 110V a sinus jeszcze bardziej czysty/sprzężenie poprawia parametry/i tak dalej. R17 zwiększamy delikatnie, do roboty...
  • #75
    Rysio13
    Poziom 9  
    Po podłączeniu sprzężenia zwrotnego i doregulowaniu R15 udało mi się uzyskać na wyjściu 230V, przy wiarę dobrym przebiegu na wyjściu. Po podłączeniu na wyjściu żarówki 25W napięcie spada do 165V.
    Nieco lepszą stabilizację uzyskałem zwiększając R16 do około 50k, przy tym samym obciążeniu napięcie spadło z 230 do 204V.
    Pytanie mam takie czy można tą stabilizację jeszcze jakoś poprawić?
    Bo zwiększanie wartości R16 powinno ją chyba pogarszać?
    I jeszcze jedno jaki powinien być prąd stanu jałowego? Ja mam przy zasilaniu 14V i kondensatorze 4,7µF na wyjściu pobór około 1,15A
  • #76
    stev-an
    Poziom 18  
    Witaj!
    R 16 ma być taki jak R 14 czyli 10 k. Im wyższa wartość R15 tym szybsza reakcja na obciążenie. Dajemy jak największą , aby układ nie wzbudzał się . W prototypie mam 100k , ale wystarczy 60 do 82k. U mnie prąd spoczynkowy około 0,5 A . Zależy on pojemności na wjściu/ u mnie 1uF/ , częstotliwości trójkąta /u mnie 13 kHz/i strat na tranzystorach. W fabrycznym APC600W też jest 1 A więc może być.
  • #77
    Rysio13
    Poziom 9  
    Witam ponownie.
    Udało mi się w końcu uruchomić przetwornice.
    R15, R16 dałem takie jak na schemacie, jedyny problem miałem z R18, przy 10k nie mogłem uzyskać 230V, zwiększyłem wartość R18 do 47k. Na wyjściu mam 230V i bardzo ładny sinus nawet pod obciążeniem (ładniejszy niż w sieci energetycznej). Sprzężenie zwrotne działa bardzo stabilnie, zaryzykowałem i podałem na wejście przetwornicy 22V, napięci na wyjściu wzrosło o kilka V, bez stabilizacji było by tam pewnie ponad 300V.

    Jeżeli to kogoś interesuje, to mogę zamieścić (jeżeli tylko autor się zgodzi) zdjęcia przebiegów z poszczególnych miejsc układu, jak tylko znajdę wolną chwilę.

    Jeszcze takie jedno pytanie.
    Jaką bezpieczną mocą mogę obciążyć przetwornicę na 1 parze IRFZ44N (RDS=0.022Ω) przy zasilaniu 14V?. Bo tak sobie liczyłem i mi wyszło że gdzie w okolicach 70-80W.

    Dzięki za pomoc w uruchomieniu przetwornicy, nie wiem czy sam bym sobie z tym poradził.
  • #78
    zulusj23
    Poziom 23  
    Poproszę o zdjęcia przebiegów. A jaką zastosowałeś wartość R12 ?
  • #79
    stev-an
    Poziom 18  
    Rysio13 napisał:
    Jeżeli to kogoś interesuje, to mogę zamieścić (jeżeli tylko autor się zgodzi) zdjęcia przebiegów z poszczególnych miejsc układu
    To będzie twój wkład w tą konstrukcję, jeśli się zrozumie zasadę działania to można wyginać sinusa we wszystkie strony. Zmiana jednej wartości wpływa na inną, taka jest technika analogowa. Kilka części więcej, ale zawsze możemy w prosty sposób zmieniać ,,wsad" naszego układu. Gratuluję wykonania tej konstrukcji choć miałeś gotowca to i tak trzeba wiedzy i odwagi. Ciesze się ,że technika analogowa jeszcze kogoś interesuje i że są na forum ludzie którym opłaca się rozgrzewać lutownicę.
    Sprawdź działanie przy 11V, tu tranzystory i trafo 8V mogą mieć negatywny wpływ na wielkość i kształt napięcia wyjściowego.
  • #80
    Rysio13
    Poziom 9  
    Przy 11V sinus nawet bez obciążenia zaczyna się psuć. Najlepsze przebiegi wyjściowe uzyskałem przy zasilaniu od 13V w górę.
    Dziś to może już nie, ale juro zamieszczę przebiegi z układu.
    Technika analogowa (bynajmniej dla mnie) jest o wiele ciekawsza od cyfrowej. Tutaj trzeba usiąść i się zastanowić co się dziej z układem, a to powoduje że człowiek czegoś się uczy.

    R12 mam 33k

    Pozdrawiam
    Rysio
  • #81
    zulusj23
    Poziom 23  
    Nie wiem czy się nie mylę, ale wydaje mi się, że chyba gdzieś przeczytałem, że minimalne napięcie zasilania dla IR2184 to 10V. Może tu tkwi problem? Trochę to niepokojące, że przy 11V zaczyna się problem. Ideą jest zasilanie z akumulatora. Co prawda, taką wartość posiada już rozładowany akumulator ale jednak.
    No nic, na poważnie przymierzam się do tego układu i pewnie sam to wszystko zbadam, ale jeśli mogę prosić o testy przy zasilaniu z akumulatora to byłbym zobowiązany.
  • #82
    Rysio13
    Poziom 9  
    zulusj23
    Co do zasilania, żeby była jasność.
    Ja układ zasilam z dwóch zasilaczy.
    Pierwszy zasilacz zasila tyko falownik, czyli T1-T4
    Drugi zasila modulator wraz z ir2184, napięcie to jest na stałym poziomie 14V.
    Ja reguluję tylko napięci na samym falowniku przy niezmiennym napięciu (14V) na ir2184, wydaje mi się że granica dolnego napięcia zasilania zależy od przekładni transformatora głównego.
    Co do zasilania całego układu z 11V to nie wiem. Mogę to jutro sprawdzić.
    Ale niech się najlepiej wypowie autor tematu.
  • #83
    stev-an
    Poziom 18  
    zulusj23 napisał:
    Nie wiem czy się nie mylę, ale wydaje mi się, że chyba gdzieś przeczytałem, że minimalne napięcie zasilania dla IR2184 to 10V. Może tu tkwi problem?
    Przy 9V też działa, nie tu szukajcie problemu. Akumulatora poniżej 11V nie należy wykorzystywać, mało z tego korzyści.
    Problem to transformator i RDSon. Tu musi być 230/6-7V, gdzie najlepiej odwinąć parę zwojów pierwotnego, lub zastosować 230/12V i bateria 24 V.

    Dodano po 19 [minuty]:

    Rysio13 napisał:
    Co do zasilania całego układu z 11V to nie wiem.
    Wypowiem się od razu. Zailam przetwornicę zasilaczem regulowanym 20A z przerobionego trcera atx, gdzie potencjometrem zmieniam napięcie od 9 do 16V i w tym zakresie napięcie wyjściowe przetworki jest stabilne z żarówką 75W. Stabilne to znaczy parę voltów wachania. Proponuję ustawić na wyjściu 220V a nawet 210 gdy to zasila pompę, bo to w granicach parametrów sieci energetycznej i pobieramy mniejszą moc z akumulatora. Pompa i tak będzie mieszać, a praca będzie dłuższa.
  • #84
    zulusj23
    Poziom 23  
    Mam do zasilenia 2 pompy pod kominkiem z płaszczem wodnym. Nie mam pojęcia jakiej są mocy. Może jutro zmierzę pobierany z sieci prąd. Jakiej dopuszczalnej mocy należy spodziewać się z tej przetwornicy przy zastosowaniu tranzystorów IRF3205? A może coś w obudowie TO247?
  • #85
    Rysio13
    Poziom 9  
    Witam
    Tak jak obiecałem zamieszczam zdjęcia przebiegów z wybranych punktów układu.
    Przebiegi zrobiłem przy zasilaniu przetwornicy z 14V, napięcie na wyjściu przetwornicy 234V i bez obciążenia.
    Jeżeli ktoś chce przebiegi z innych miejsc, to proszę napisać.
    Przepraszam za jakość tych zdjęć robiłem telefonem, mam nadzieję że coś na tych fotkach widać.

    Przebieg z nóżek 13, 14 U1, nastawy 5ms/dz, 0.5V/dz
    Budujemy inwerter sinus do zasilania pomp centralnego ogrzewania.

    Przebieg górny nóżka 2,6 U3, 1V/dz, dolny noga 1 U2, 1V/dz 50µs/dz
    częstotliwość tych przebiegów zależy od wartości R12 u mnie 33k.
    Budujemy inwerter sinus do zasilania pomp centralnego ogrzewania.

    Przebieg górny 7 noga U4, 1V/dz, przebieg dolny 1 noga U4, 1V/dz, 5ms/dz
    Budujemy inwerter sinus do zasilania pomp centralnego ogrzewania.

    Przebieg górny 7 noga U3, 2V/dz, przebieg dolny 1 noga U3, 2V/dz, 10ms/dz
    Budujemy inwerter sinus do zasilania pomp centralnego ogrzewania.

    Przebieg górny bramka T2, 5Vdz dolny bramka T1, 10V/dz, 5ms/dz
    Budujemy inwerter sinus do zasilania pomp centralnego ogrzewania.

    Przebieg na wyjściu przetwornicy
    Budujemy inwerter sinus do zasilania pomp centralnego ogrzewania.
  • #86
    zulusj23
    Poziom 23  
    Wygrzebałem z garażu UPS-a Powercom BNT-600AP. Muszę sprawdzić transformator z niego ale chyba będzie drobny problem. Ma symetryczne uzwojenie od strony 12VAC. Wypadałoby połączyć je równolegle aby mieć do dyspozycji jego pełną moc. Są też w nim tranzystory 50N06. Skoro w UPS sterowały tym transformatorem to powinny być Ok. Dziękuję za zdjęcia. Na razie kompletuję elementy.

    Właśnie sprawdziłem pobór prądu. Dwie pompy + sterownik to łącznie 0,63A czyli jakieś 151W, ponieważ w gniazdkach mam ok 240VAC. Myślałem, że pobór prądu jest mniejszy. Akumulator i inwerter będzie obciążony sporym prądem.
  • #87
    Rysio13
    Poziom 9  
    Ja mam jeszcze taką prośbę.
    Czy można by prosić o opis przerobienia tej przetwornicy do pracy z innym transformatorem i napięciem?
    Bo tak sobie kombinuję , dałem trafo 13V/230V, podałem napięcie 24V, zmieniłem wartość R15,
    podmieniłem też R14, R16 ale nie wiele to dało.
    Na wyjściu mam ładny sinus ale tylko do wartości około 100V wyżej zaczyna się już psuć.
  • #88
    stev-an
    Poziom 18  
    To będzie dobry transformator, który będzie uzwojony dwoma drutami, bafilarnie. Zrobić równolegle i albo odjąć zwojów na 6V, albo dać 2 akumulatory. Na 12V będzie około 20A. Tranzystory też użyj , a obudowa gotowa. U mnie też pochodzi z APC 600 Back UPS.

    Dodano po 1 [godziny] 17 [minuty]:

    Rysio13 napisał:
    Przebieg górny 7 noga U4, 1V/dz, przebieg dolny 1 noga U4, 1V/dz, 5ms/dz
    Ten przebieg zbyt trójkątny, ale wróćmy do początku. R14 i R16 10k, R15 ustawiany i spróbuj zwiększyć R18. Im mniejsze napięcie FB tym większe wyjściowe i zasilaj to zwykłym akumulatorem, bo zasilacze płatają figle.
  • #89
    zulusj23
    Poziom 23  
    Witam.

    Moja przetwornica uruchomiona. Bez obciążenia, z kondensatorem 1uF i bez dławika na wyjściu pobiera 0,6A. Pod obciążeniem napięcie spada o ok. 1,5V. Przeszła testy pod obciążeniem żarówkami 20W oraz 100W. Trafo zimne, radiator lekko ciepły przy 20W, ciepły ale nie gorący przy 100W. Był też krótki test z żarówką 200W ale tu radiator dosyć szybko zrobił się gorący. Gdyby był większy lub posiadał wentylator, myślę, że przetwornica dała by radę. Są z odzysku z rozebranego UPS-a i są zdecydowanie mniejsze niż u autora projektu.
    Dodatkowo, przy 230V były obcięte symetrycznie szczyty sinusoidy na wyjściu. Przy 200V na wyjściu było już ok. Niestety, akumulator 40Ah od UPS-a, który mam do testów, okazał się uszkodzony. Ma jakiś problem, najprawdopodobniej pada mostek między celami i napięcie na nim mocno skacze pod dużym obciążeniem. Nie mam miernika cęgowego ani bocznika aby mierzyć duże prądy pobierane z akumulatora i bałem się mierzyć Metex-em na zakresie 20A bo ten zakres nie posiada bezpiecznika. Przy żarówce 20W przetwornica pobierała 3,5A. Teraz już wiem dlaczego USP co jakiś czas sygnalizował problem z akumulatorem.
    Bardzo dziękuję za udostępnieni projektu.

    Pozdrawiam.
  • #90
    stev-an
    Poziom 18  
    zulusj23 napisał:
    Dodatkowo, przy 230V były obcięte symetrycznie szczyty sinusoidy na wyjściu. Przy 200V na wyjściu było już ok.

    Koledzy pokazujcie wasze konstrukcje bo zdjęcia wiele mówią. Gdyby zniekształcenia występowały przy innym akumulatorze, to można skrócić uzwojenie pierwotne i przy lepszych tranzystorach uzyskamy większe moce.
    Gdy będziemy zasilać tyko pompę to wystarczy napięcie wyjściowe nawet 200V, dłużej pochodzi na akumulatorze. Oczywiście przy napięciu 11V.
    Gratuluję .