Elektroda.pl
Elektroda.pl
X
Sklep HeluKabel
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

[Rozwiązano] Zabezpieczenie triaków BT138 - napięcie od strony wyjścia

losiek177 07 Mar 2017 18:42 960 24
  • #1 07 Mar 2017 18:42
    losiek177
    Poziom 16  

    Witam.

    Potrzebuje rady bardziej doświadczonych kolegów. Zmontowałem układ "moduł wykonawczy z triakami" AVT1679. Podłączyłem go jako moduł załączający napięcie na rolety zewnętrzne domu. Jeden triak puszcza fazę na przewód podnoszenia, drugi puszcza fazę na przewód opuszczania. Zabezpieczenie przed podaniem dwóch faz realizuje mi centrala alarmowa. Nie ma możliwości podania napięcia sterującego na oba triaki.
    Przewody od triaków poprowadzone bezpośrednio do przewodów od rolet ( złączone w puszce od rolet i całość podpięta do przełącznika rolet ). Oczywiście faza zasilająca sterownik z triakami, to ta sama faza co zasilania rolet.
    Wszystko niby działa OK ( czas budowy ). Problem pojawił się gdy do całego układu doszły przełączniki otwierania/zamykania rolet. Po przyciśnięciu przycisku do triaka wraca faza zasilająca i tym samym podejrzewam go przebija. Efekt jest taki, że po kilku opuszczeniach/podniesieniach rolety triak dostaje przebicia i podaje szczątkowe napięcie - po czym roleta powoli mocno bucząc podnosi się do góry lub w dół ( w zależności który triak padnie ).

    Wymieniałem triaki z oryginalnie zastosowanych BT138 na BT139 16A - efekt ten sam.
    Czym zabezpieczyć triaki? Dioda prostownicza zaporowo od strony rolety? Wyprostuje mi jedna połówkę sinusoidy... zabrakło mi pomysłów. Proszę o pomoc.

    0 24
  • Sklep HeluKabel
  • #3 07 Mar 2017 20:51
    losiek177
    Poziom 16  

    Przekaźniki też próbowałem ale sklejały się styki.

    Opcja z diodą prostowniczą nie przejdzie?

    0
  • #4 07 Mar 2017 21:31
    michcior
    Poziom 30  

    losiek177 napisał:
    Po przyciśnięciu przycisku do triaka wraca faza zasilająca i tym samym podejrzewam go przebija.

    Tego nie rozumiem.

    Dobrze jest dodać trochę logiki to tego sterowania. Jeśli jechało w jedną stronę, to przed załączeniem w drugą robi się małą przerwę na zatrzymanie. Druga zasada, jeśli chce się na raz uruchomić więcej rolet, to nie należy tego robić w tym samym momencie bo prąd udarowy wywali bezpieczniki. Jak widzisz, elektronicznie to trzeba zmyślny sterownik.

    Masz przewody od rolet w jednym miejscu?

    0
  • #5 07 Mar 2017 21:47
    atom1477
    Poziom 43  

    To nie zwrotne napięcie z silnika zabija triaki.
    Miałem to samo.
    Przekaźniki: sklejało styki. Ale zmierzyłem prądy oscyloskopem podczas włączania i wcale nie były wysokie.
    Wartość udarowa przy włączeniu tylko około 2-krotnie większa niż w czasie pracy (2A, a podczas pracy normalnie jest 1A (przekaźniki były na 6A)).
    Triaki: paliło.
    Problemu nie rozwiązywały gasiki RC.
    Ale rozwiązało go dodanie zwykłych tanich warystorów na 275VAC.
    Wyglądało na to że to wszystko padało od przepięć. Ale dlaczego sklejało styki przekaźników nie wiem do tej pory.

    1
  • Sklep HeluKabel
  • #6 07 Mar 2017 21:57
    losiek177
    Poziom 16  

    Tak, przewody schodzą się od każdej puszki przycisku danej rolety do jednego centralnego punktu sterowanego przez wyjścia OC centrali alarmowej. Programowo zrealizowałem zabezpieczenie, że wyzwolenie sygnału "w dół" powoduje w tej samej chwili wyłączenie sygnału "w górę" i odwrotnie. Wszystko doskonale działało dopóki w układzie nie pojawiły się przełączniki rolet. Teraz przyciskając dany przełącznik przykładowo w górę faza zasilająca wraca do wyjścia triaka paląc go.

    Zastanawiam się nad diodami prostowniczymi dużej mocy w takim układzie:

    Zabezpieczenie triaków BT138 - napięcie od strony wyjścia

    0
  • #7 07 Mar 2017 22:01
    atom1477
    Poziom 43  

    Diod nie można zastosować bo silniki wymagają zasilania prądem przemiennym.
    Przełączniki są połączone normalnie równolegle do triaków? (w sensie elektrycznym oczywiście)

    0
  • #8 07 Mar 2017 22:06
    michcior
    Poziom 30  

    1) Dody prostownicze to absurd. Przecież silniki są prądu zmiennego, proszę nie idź w tą stronę.
    2) Jak ktoś udzielił Ci rady, z doświadczenia bo o to poprosiłeś to dlaczego upierasz się przy swoim?
    3) Triaki nie wyłączają w momencie zdjęcia sygnału sterującego tylko w zerze, natomiast załączają natychmiast (np prawie) czyli w najgorszym przypadku możesz mieć prawie 10ms kiedy oba przewodzą.
    4) Dalej nie rozumiem jak faza miała by "wracać"

    0
  • #9 07 Mar 2017 22:10
    atom1477
    Poziom 43  

    4) faza nie wraca.
    W najgorszym wypadku zostanie podana na wyjście triaka. Czyli będzie faza i na wejściu i na wyjściu triaka. Czyli nic strasznego.
    Jak już to się triak może palić z przepięć. A przełączniki mogą je generować.
    Albo po prostu coś jest źle podłączone.
    Musieli byśmy zobaczyć schemat wszystkich połączeń (wystarczy dla jednej rolety). I musiał byś mieć pewność że to jest rzeczywiście tak podłączone jak nam narysujesz na schemacie.

    0
  • #10 07 Mar 2017 22:43
    losiek177
    Poziom 16  

    Przełączniki podłączone równolegle.

    Schemat podłączenia:
    Zabezpieczenie triaków BT138 - napięcie od strony wyjścia

    Czyli przeskok iskry w przełączniku powoduje przepięcie palące triak? Warystor rzeczywiście powinien rozwiązać sprawę.

    Czyli triak nie powinien przepalić się gdy zarówno na jego wejściu i wyjściu pojawi się faza? Bo tak właśnie się dzieje gdy ktoś kliknie w przełącznik.

    0
  • #11 07 Mar 2017 22:46
    atom1477
    Poziom 43  

    losiek177 napisał:
    Czyli przeskok iskry w przełączniku powoduje przepięcie palące triak? Warystor rzeczywiście powinien rozwiązać sprawę.

    Nie. Iskra przeskakuje gdy wystąpi przepięcie i nic innego go nie przejmie.
    Ale iskra nie jest konieczna do palenia się triaka. Brak iskry oznacza po prostu że przepięcie poszło na coś innego. Np. na spalenie triaka.

    losiek177 napisał:
    Czyli triak nie powinien przepalić się gdy zarówno na jego wejściu i wyjściu pojawi się faza? Bo tak właśnie się dzieje gdy ktoś kliknie w przełącznik.
    Nie. Dlaczego miał bu się wtedy palić?
    Nawet gdyby się wtedy załączył to nic by się nie stało.

    Ale Twój rysunek wszystko wyjaśnia. Masz to źle podłączone.
    Przełączniki wcale nie są równolegle do triaków. Żeby były to przewód L powinien iść do triaków.
    W zasadzie to w Twojego rysunku wychodziło by że masz ciągłe zwarcie L z N.
    Na pewno dobrze to narysowałeś?

    0
  • #12 07 Mar 2017 22:49
    losiek177
    Poziom 16  

    7N 431K taki warystor powinien wystarczyć?

    0
  • #13 07 Mar 2017 22:50
    atom1477
    Poziom 43  

    Powinien wystarczyć.
    Ale najpierw popraw połączenia wyłączników.

    0
  • #14 07 Mar 2017 22:57
    losiek177
    Poziom 16  

    Skad zwarcie L i N? N podłączone bezpośrednio od rozdzielni do silnika rolety. Tak samo PE.

    Faza zasilająca podłączona pod przełącznik pod styk przełączany pomiędzy G i D oraz pod płytkę z triakami. Dalej po wysterowaniu triaki podają napięcie bezpośrednio na silnik i równolegle do triaków podpięty jest przełącznik. Czy faza z triaka czy z przełącznika to roleta albo G albo D.

    A przepraszam widzę gdzie mogłem zmylić. N nie jest w ogóle podłączone do płytki z triakami. Wymazałem tą linie.

    Zabezpieczenie triaków BT138 - napięcie od strony wyjścia

    0
  • #15 07 Mar 2017 23:02
    atom1477
    Poziom 43  

    No teraz jest dobrze. No to się może palić od przepięć.
    Albo od jednoczesnego wysterowania przełącznikiem i triakiem w przeciwne strony.

    0
  • #16 07 Mar 2017 23:08
    losiek177
    Poziom 16  

    michcior napisał:
    1)
    3) Triaki nie wyłączają w momencie zdjęcia sygnału sterującego tylko w zerze, natomiast załączają natychmiast (np prawie) czyli w najgorszym przypadku możesz mieć prawie 10ms kiedy oba przewodzą.


    Musze sprawdzić czy centrala da mi możliwość ustawienia jakiejś nawet sekundowej zwłoki w wysterowaniu triaków. Albo zastosuje układ RC na wejściu układu.

    Dodano po 3 [minuty]:

    atom1477 napisał:
    No teraz jest dobrze. No to się może palić od przepięć.
    Albo od jednoczesnego wysterowania przełącznikiem i triakiem w przeciwne strony.


    Tą opcję raczej wykluczam. Układ ma zamykać rolety głównie na żądanie z manipulatora a także przy uzbrojeniu systemu alarmowego, zatem mało prawdopodobne ( aczkolwiek możliwe ) że ktoś jednocześnie kliknie w manipulatorze zamykanie i pójdzie przyciskać klawisze. O tym już go poinformuje :)

    Nic innego nie pozostaje jak sprawdzić działanie warystorów.

    0
  • #17 07 Mar 2017 23:22
    atom1477
    Poziom 43  

    I wywal te diody ze układu. Zamiast nich możesz dać bezpieczniki rurkowe (na próbę, żeby widzieć czy jakiś prąd zwarciowy tędy nie płynie).

    0
  • #18 07 Mar 2017 23:28
    losiek177
    Poziom 16  

    Diody są tylko na rysunku :)

    0
  • #19 07 Mar 2017 23:56
    atom1477
    Poziom 43  

    Nie usunąłeś ich z rysunku mimo kilkukrotnego jego edytowania i wstawiania. Dlatego napisałem.

    0
  • #20 08 Mar 2017 00:02
    michcior
    Poziom 30  

    atom1477 napisał:
    Albo od jednoczesnego wysterowania przełącznikiem i triakiem w przeciwne strony.

    Dość oczywiste, i to chyba "error by design". Tak nie może zostać.
    Ja jednak dalej będę twierdził, że problemem jest napięcie generowane na nieaktywnym uzwojeniu. Warystory mogą tu pomóc.

    Żeby nie mówić teoretycznie, kiedyś zrobiłem takie sterowanie dla kolegi zwracając szczególną uwagę na czasy i randomizację załączania. To prymitywne urządzanie. Łączniki są niskonapięciowe po stronie logicznej a nie 230V.

    Styczniki są połączone tak, aby uniknąć nawet przypadkowego (w wyniku sklejenia ) podania napięcia jednocześnie na oba obwody. Działa bez warystorów.

    Zabezpieczenie triaków BT138 - napięcie od strony wyjścia
    Jeden styczniki załącza a drugi wybiera kierunek

    Zabezpieczenie triaków BT138 - napięcie od strony wyjścia
    Zabezpieczenie triaków BT138 - napięcie od strony wyjścia

    0
  • #21 08 Mar 2017 00:06
    atom1477
    Poziom 43  

    Ja tak miałem zrobione, a dalej się paliło.

    0
  • #24 08 Mar 2017 06:05
    Krzysztof Kamienski
    Poziom 42  

    atom1477 napisał:
    Wyglądało na to że to wszystko padało od przepięć. Ale dlaczego sklejało styki przekaźników nie wiem do tej pory.
    Jakich przekaźników ? Mam w tej instalacji typowe chińskie Omrony (5A) i działają bez problemu już parę lat.. @losiek177 Ten schemat z diodami to bzdura w samym zamyśle :cry: - to są silniki prądu przemiennego Koledzy alarmują!

    Jeszcze jedno, Kolego @losiek177 . Zmierz napięcie na wolnym zacisku silnika, w momencie, gdy on pracuje. Sądzę, że wartość tego napięcia mocno Cię zdziwi. :idea: Masz tu do czynienia z autotransformatorem o przekładni (2/1) - √2
    (w przybliżeniu, zależnie od budowy i obciążenia tego silnika). Maltańska firma Carlo Galvazzi produkuje dedykowane hybrydy triakowe do takich silników.

    1
  • #25 02 Kwi 2018 09:30
    losiek177
    Poziom 16  

    Witam.

    Czas zamknąć temat. Zastosowałem warystory na wyjściu triaków.
    Działa wyśmienicie już u kilku klientów od roku.

    Dziękuję za pomoc.

    Pozdrawiam

    0