Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Głośnik bezprzewodowy-wzmacniacz PAM8403+Bluetooth - piski w głośnikach

paczek85 08 Mar 2017 21:01 2004 4
  • #1 08 Mar 2017 21:01
    paczek85
    Poziom 6  

    Witam
    Chciałem zrobić a w zasadzie zrobiłem głośnik bezprzewodowy bluetooth, by słuchać muzyki z telefonu.

    Użyłem następujących części:
    - TP4056 z zabezpieczeniami -ładowarka ogniw li-ion
    - Przetwornica sep up 5V
    - Wzmacniacz PAM403 z potencjometrem
    - Transmiter bluetooth Yet M1
    - 2x głośnik 3W 4Ohm
    - 4 x ogniwo 2500mAh

    Podłączyłem wszystko jak na załączonym schemacie (przepraszam za taki rysunek, ale inaczej nie umiem:))
    Wszystko "prawie" dobrze działa, oprócz tego, że podczas podłączenia zasilania następuje piszczenie w głośnikach a po włączeniu odtwarzanego utworu piski(buczenie) nie ustaja. Na bezpośrednim podłączeniu kablem jack do telefonu piski(jakby buczenie) nie występują. Nie wiem czy wina leży po stronie przewodów, które łączą moduł bluetooth ze wzmacniaczem, czy może chodzi tu o filtrację zasilania (czytałem, ale nie za bardzo wiem co i gdzie, wiem tylko tyle, że musiałbym zastosować kondensator)

    Co do załączonego rysunku, ogniwa li-ion 4 sztuki połączone równolegle, moduł bluetooth wpięty przez usb do przetwornicy step up, która na wyjściu daje 5V i od spodu przetwornicy dolutowane 2 przewody od + i - do zasilania wzmacniacza, reszta chyba jasna.

    Czy takie podłączenie jest poprawne czy może do wzmacniacza poprowadzić bezpośrednio przewody z ładowarki TP4056? Oczywiście przed przetwornicą jest przełącznik odcinający zasilanie.

    Proszę o pomoc w rozwiązaniu problemu.

    -----

    Zauważyłem, że problem tkwi w zasilaniu. Jeżeli moduł bluetooth podepnę pod odrębne zasilanie inne niż wzmacniacz to piski ustają, tak więc pytanie jak podpiąć wszystko pod jedno zasilanie?

    0 4
  • #2 11 Mar 2017 14:44
    kulamario
    Poziom 22  

    Pewnie masy muszą być osobno czyli zostaje ci tylko użyć baterii do bt lub zbudować zasilacz samemu bo na tej przetwornicy nic nie wymyślisz

    0
  • #3 11 Mar 2017 14:52
    paczek85
    Poziom 6  

    Nie ma żadnej innej możliwości? Zastosowanie separatora masy, podpięcie bluetooth bezpośrednio pod ogniwa czy druga przetwornica. Rozumiem,że to nic nie da?
    Na tej przetwornicy nie da rady a na jakiej da?

    0
  • #5 11 Mar 2017 21:57
    paczek85
    Poziom 6  

    Podpiąłem wszystko pod powerbank, który miałem osobno. Pod jego gniazdo wpiąłem kabel usb a z niego wyprowadziłem plus i minus, którymi zasiliłem cały układ. Jest o niebo lepiej. Ale mogłoby być lepiej. Lekkie szumy (praktycznie nie przeszkadzające) słyszalne są nadal. Widocznie problem był z zasilaniem ( być może wadliwa przetwornica). Będę jeszcze testował i dam znać.
    Dziękuje za pomoc
    No nic, szumy (lekkie piski) są słyszalne, ten typ tak ma. Trzeba kupić chyba droższą płytkę, która jest 2w1 wzmacniaczem z bluetooth.

    Temat zamykam

    0