Elektroda.pl
Elektroda.pl
X
Mitronik
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Lenovo ThinkPad T400 - Komplikacje po wymianie matrycy

sylweksylwina 25 Mar 2017 00:08 732 4
  • #1 25 Mar 2017 00:08
    sylweksylwina
    Red. Komputery FAQ

    Witam wszystkich,
    Robię dla siebie laptopa Lenovo T400 jest to wersja z grafiką Intel 4500MHD + Radeon HD3470. Laptop miał zbitą matrycę (LTN141WD-L05 CCFL) o rozdzielczości 1440x900. Wymieniłem na matrycę z Lenovo T61 o rozdzielczości 1280x800 (LTN141W1-L05 CCFL). Osobiście demontowałem matrycę z klapy T61. Wg. strony Link matryca ta również jest kompatybilna/występowała w T400. Zainstalowany system to Windows 7 64-bit, aktualizowany poprzez WU, zainstalowane sterowniki + aplikacje ze strony Lenovo. BIOS w wer. 3.24, EC w wer. 1.06.

    Obraz w BIOS'ie jest, w systemie jest. Schody zaczynają się na grafice dedykowanej (na intelu jest wszystko ok). Kwestie przełączalnych grafik wykluczyłem ustawiając na sztywno kartę dedykowaną w biosie.

    Problem jest przy opcji klonowania obrazu na zewnętrzny monitor i/lub w aplikacjach pełnoekranowych (gry), gdy ustawiona rozdzielczość jest o proporcjach 4:3. Problem występuje tylko na grafice ATI. To czy monitor zewnętrzny jest podłączany bezpośrednio, czy poprzez stację dokującą nic nie zmienia.

    Pulpit (matryca wbudowana) - działające tryby:
    -1280x800
    -1280x768
    -1280x720
    -1024x768
    -960x600
    -800x600

    Pulpit (matryca wbudowana + zewnętrzny monitor VGA -> rozszerzenie pulpitu)
    Na matrycy wbudowanej działają wszystkie dostępne (wymienione wyżej) tryby, na monitorze zewnętrznym również.

    Pulpit (matryca wbudowana + zewnętrzny monitor VGA -> klonowanie)
    Działa:
    -1280x800
    -1280x768
    -1280x720
    -960x600

    Nie działa (obraz tylko na monitorze zewnętrznym, matryca w laptopie czarna, z podświetleniem, które można regulować):
    -1024x768 (4:3)
    -800x600 (4:3)

    Gry w trybie pełnoekranowym (bez monitora zewnętrznego)
    Działają tak jak przy klonowaniu, czyli dla:
    -1024x768
    -800x600
    Obrazu brak, matryca czarna, z podświetleniem, które można regulować.

    Gry w trybie pełnoekranowym (z klonowaniem na monitor zewnętrzny)
    to samo co wyżej, ale obraz na zewnętrznym monitorze jest.

    Tak więc nie wiem czy jest to problem ze sterownikami grafiki, bo z matrycą raczej nie ma problemu, gdyż na intelu wszystko działa jak powinno. Może jest to jakiś błąd w BIOS'ie VGA? Niestety niektóre starsze gry obsługują tylko rozdzielczości 4:3 (letterbox nie jest wielkim problemem), niektóre monitory również mają proporcje 4:3, więc wtedy odpada klonowanie na dedykowanej grafice. Jest to co najmniej dziwne zachowanie z którym jeszcze się nie spotkałem. Co ciekawe na linuxie (mint) wszystko działa jak powinno przy klonowaniu na dedykowanej grafice (dostępne rozdzielczości to 1024x768 i 800x600 oraz obraz na matrycy laptopa jest poprawnie skalowany - rozciągany na całą matryce). Co zrobić, by na windowsie nie było problemu? Znalazłem jeszcze jeden podobny przypadek z podobnym laptopem: tutaj. Poniżej interpretacja jak i dump EDID matrycy. Co zdążyłem sprawdzić to, to że EDID jest taki sam jak w nocie katalogowej matrycy (dostępna: tutaj)
    Lenovo ThinkPad T400 - Komplikacje po wymianie matrycy

    0 4
  • Mitronik
  • #2 28 Mar 2017 22:55
    mrx8
    Poziom 8  

    Uważam, że jako tako problem nie siedzi w sterownikach kart graficznych i w samych systemach. Wymieniając matrycę z Wxga+ na zwykła wxga powinieneś także wymienić taśmę matrycy. Owszem gdy podłączysz niższą rozdzielczość matrycy do taśmy gdzie jest obsługa większej rozdzielczości to wyświetlanie będzie działało ale przecież taśma ma inaczej rozłożone piny więc jest też inna kontrola wyświetlanego obrazu.

    Uważaj tylko gdy będzie wymieniał taśmę albowiem z doświadczenia, że w t400 siada podświetlenie jak zbyt agresywnie będziesz działał przy złączy taśmy z płyta główną. Blisko złącza jest regulator napięcia podświetlenie LCD więc uszkodzenie go wiąże się z utrata podświetlenia. Przy wymianie należy odpiąć zasilacz oraz wyjąć baterię, a następnie przytrzymać power kilka chwil aby rozładować napięcie na płycie głównej. Aby wymienić taśmę należy zdjąć palm-rest, klawiaturę oraz maskownicę nad klawiaturą. Taśma jest skręcana na 2 śrubki z płytą główną.

    Pozdrawiam

    0
  • Mitronik
  • #3 28 Mar 2017 23:53
    sylweksylwina
    Red. Komputery FAQ

    Coraz bardziej jestem skłonny uwierzyć, że jest to problem ze sterownikami ATI. Jak pisałem na grafice Intel wszystko działa jak należy. Taśma również jest ta sama dla WXGA i WXGA+ FRU: 44C5363 Link. W taśmie różnice są gdy jest LCD z podświetleniem LED lub z kamerą.

    0
  • #4 29 Mar 2017 09:04
    mrx8
    Poziom 8  

    A wrzuć sterowniki ze strony AMD (nawet nie tyle z lenovo support co wlasnie z support Amd). Z tego widzę sterowniko masz z WU. Powiem szczerze mialem na HP z Amd ati probelmy w sterownikach od WU. Po zainstalowaniu ze strony AMD wszystko jest dobrze. Aha wiem ze w T400 pomylili sie z nazwa karty graficznej. W specyfikacji chyba jest ati 3650 ale w rzeczywistości jest inny model.

    0
  • #5 26 Paź 2017 15:05
    sylweksylwina
    Red. Komputery FAQ

    To nie kwestia sterowników - miałem zainstalowane ze strony lenovo pod Windows 7. Postawiłem nawet ostatnio Vistę i sterowniki ze strony lenovo pod ten system i było to samo.

    Jak się okazało matryca LTN141W1-L05 nie była kompatybilna. Po podstawieniu całego skrzydła matrycy z innego T400 również z grafiką radeon o rozdzielczości 1440x900 wszystko wróciło do normy.

    0