Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Komunikacja sieci lokalnej z inną siecią lokalną. MikroTik CCR1016-12G.

19 Kwi 2017 10:31 876 19
  • Poziom 9  
    Witam

    Sieć lokalna oparta jest na switchu cisco i routerze MikroTik CCR1016-12G.

    DHCP na routerze przypisuje adresy z zakresy 192.168.1.1


    W sieci pracuje serwer Windows posiadający dwie karty sieciowe . Jest podłączony do naszej sieci posiadając adres 192.168.1.112
    oraz do sieci firmy sąsiadującej 10.207.149.11 za pomocą bezprzewodowego punktu dostępowego.

    Połączenie z firmą sąsiadująca jest wykorzystywane tylko do jednego celu. Mianowicie jest to aplikacja kliencka wyświetlająca informacje o produkcji z firmy obok.

    Obecnie aby podejrzeć te dane osoba zainteresowana łączy się za pomocą pulpitu zdalnego do serwera i korzysta z aplikacji.

    Chciałbym przepiąć tą sieć do routera i skonfigurować wszystko tak aby komputery pracujące w naszej sieci lokalnej posiadały własne aplikacje klienckie, aby każdy mógł sobie na swoim komputerze przeglądać te dane.

    Jakie kroki powinienem wykonać aby komputer w naszej sieci lokalnej był w stanie zapewnić przepływ danych dla tej aplikacji?
  • Poziom 37  
    przemo6996 napisał:
    Witam

    Sieć lokalna oparta jest na switchu cisco i routerze MikroTik CCR1016-12G.

    DHCP na routerze przypisuje adresy z zakresy 192.168.1.1


    W sieci pracuje serwer Windows posiadający dwie karty sieciowe . Jest podłączony do naszej sieci posiadając adres 192.168.1.112
    oraz do sieci firmy sąsiadującej 10.207.149.11 za pomocą bezprzewodowego punktu dostępowego.

    Połączenie z firmą sąsiadująca jest wykorzystywane tylko do jednego celu. Mianowicie jest to aplikacja kliencka wyświetlająca informacje o produkcji z firmy obok.

    Obecnie aby podejrzeć te dane osoba zainteresowana łączy się za pomocą pulpitu zdalnego do serwera i korzysta z aplikacji.

    Chciałbym przepiąć tą sieć do routera i skonfigurować wszystko tak aby komputery pracujące w naszej sieci lokalnej posiadały własne aplikacje klienckie, aby każdy mógł sobie na swoim komputerze przeglądać te dane.

    Jakie kroki powinienem wykonać aby komputer w naszej sieci lokalnej był w stanie zapewnić przepływ danych dla tej aplikacji?

    Skoro nie znasz odpowiedzi na tak proste pytanie to zazwyczaj najlepiej zatrudnić/zleć wykonanie firmie/informatykowi.

    Musisz wpiąć do routera jakieś urządzenie CPE (też może być od mikrotika) które się połączyc z siecią bezprzewodową sąsiedniej firmy. Potem na routerze odpowiednio ustawić routing/firewall i bangla.
  • Poziom 9  
    Właśnie w ten sposób połączenie jest zrealizowane. Chodzi mi bardziej o pomoc w routingu.
  • Specjalista Sieci, Internet
    Żandego routing nie musisz robić, domyślny wystarczy, tylko podepnij sieć tamtą.
  • Poziom 9  
    Podłączyłem siec do rutera. Przypisałem adres ip na odpowiednim interfejsie lecz nie działa to prawidłowo, mianowicie:
    1. Można pingować router oraz inne adresy z tej zewnętrznej sieci lecz usługa na której mi zależny nie działa.
    2. Po zresetowaniu połączenia w komputerze, komputer uzyskuje adres ip z tej zewnętrznej sieci a nie z mojej, co prawda aplikacja działa lecz nie jest to rozwiązanie gdyż nie ma wtedy dostępu do zasobów mojej sieci.
  • Specjalista Sieci, Internet
    Pewnie jeszcze trzeba dodać src-nat (ip adresem tamtej sieci) na łączu do innej sieci.
  • Poziom 9  
    Jak to powinno wyglądać?
  • Specjalista Sieci, Internet
    src-nat gdzie src-add=lan-ip out-iface=wan-do-tamtej-sieci
  • Poziom 9  
    Dodaję nową zasadę.
    chain: srcnat
    Src.Address: 10.207.149.10/24 (czyli taki jaki mam ustawiona na interfejsie do którego podłączona jest sieć)

    Co ustawić w zakładce Action?
  • Specjalista Sieci, Internet
    a co tam jest ?
  • Specjalista Sieci, Internet
    src-nat src-nat
  • Poziom 9  
    Po dodaniu. Nic się nie zmienia.
  • Poziom 31  
    przemo6996 napisał:
    Podłączyłem siec do rutera. Przypisałem adres ip na odpowiednim interfejsie lecz nie działa to prawidłowo, mianowicie:
    1. Można pingować router oraz inne adresy z tej zewnętrznej sieci lecz usługa na której mi zależny nie działa.
    2. Po zresetowaniu połączenia w komputerze, komputer uzyskuje adres ip z tej zewnętrznej sieci a nie z mojej, co prawda aplikacja działa lecz nie jest to rozwiązanie gdyż nie ma wtedy dostępu do zasobów mojej sieci.

    Interfejs do obcej sieci jest dodany do bridge, a być nie powinien.
  • Poziom 9  
    Dzięki szwagros . Jeden problem z głowy, już nie otrzymuję adresów z obcej dhcp.

    Mogę pingować do 10.207.149.1 lecz nadal adres uruchamiający aplikację jest niedostępny.

    Był bym wdzięczy za bardziej szczegółowe wyjaśnienie konfiguracji NAT. Myślę że tu robię błąd.
  • Specjalista Sieci, Internet
    Za dużo domysłów.
    Wrzuć schemat, i nanieś wszystkie urządzenia, jak router to podajesz dwa ip adresy, czyli podajesz IP _każdego_ interfejsu sieciowego urządzeń.
  • Poziom 9  
    Komunikacja sieci lokalnej z inną siecią lokalną. MikroTik CCR1016-12G.

    Tak to obecnie wygląda.

    Przełączyłem kabel do routera do eth3. Tak wygląda adresacja:

    lags: X - disabled, I - invalid, D - dynamic
    # ADDRESS NETWORK INTERFACE
    0 192.168.1.1/24 192.168.1.0 ether2
    1 XI 192.168.2.10/24 192.168.2.0 ether7
    2 D 176.103.173.67/32 192.168.101.1 pppoe-out1
    3 10.207.149.10/24 10.207.149.0 ether3

    tak routing:

    Flags: X - disabled, A - active, D - dynamic,
    C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
    B - blackhole, U - unreachable, P - prohibit
    # DST-ADDRESS PREF-SRC GATEWAY DISTANCE
    0 ADS 0.0.0.0/0 192.168.101.1 0
    1 X S 0.0.0.0/0 192.168.2.1 1
    2 ADC 10.207.149.0/24 10.207.149.10 ether3 0
    3 S 10.207.149.0/24 10.207.149.1 1
    4 ADC 192.168.1.0/24 192.168.1.1 bridge1 0
    5 ADC 192.168.101.1/32 176.103.173.67 pppoe-out1 0
  • Poziom 31  
    przemo6996 napisał:

    tak routing:

    Flags: X - disabled, A - active, D - dynamic,
    C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
    B - blackhole, U - unreachable, P - prohibit
    # DST-ADDRESS PREF-SRC GATEWAY DISTANCE
    0 ADS 0.0.0.0/0 192.168.101.1 0
    1 X S 0.0.0.0/0 192.168.2.1 1
    2 ADC 10.207.149.0/24 10.207.149.10 ether3 0
    3 S 10.207.149.0/24 10.207.149.1 1
    4 ADC 192.168.1.0/24 192.168.1.1 bridge1 0
    5 ADC 192.168.101.1/32 176.103.173.67 pppoe-out1 0

    Nie wiem do czego ma służyć wpis nr 3.

    Rozumiem że komputer z aplikacją ma adres 10.207.149.11 z bramą 10.207.149.1?
    Cały problem bierze się stąd, że zapewniłeś trasę dla pakietów w jedną stronę, ale zapomniałeś że pakiety muszą też wrócić. Zastanów się więc co zrobi komputer 10.207.149.11 z pakietem dla 192.168.1.2? Nie wie on nic o sieci 192.168.1.0/24 (nie ma wpisu w tabeli routingu), więc musi go wysłać do bramy domyślnej, czyli do routera 10.207.149.1. Ten również nic nie wie o trasie do 192.168.1.0/24, więc wyśle go przez pppoe do dostawcy (a ten go zapewne zignoruje). Rozwiązania są dwa - dopisać routing do sieci 192.168.1.0/24 via 10.207.149.10 w komputerze z aplikacją, bądź oszukać go zmieniając adres nadawcy w pakietach do niego wysyłanych na 10.207.149.10, dzięki temu to właśnie tam pakiety będą odsyłane.
  • Specjalista Sieci, Internet
    Ja bym podłączył ten server przez drugi port WAN na MT i na tym porcie załączył src-nat IP adresem WAN MT (zakładająć server nie robi żadnych zwrotnych połączeń do klienta)
  • Poziom 9  
    Problem rozwiązany. Skontaktowałem się z administratorem tamtej sieci który podał mi dodatkowe ścieżki po dodaniu których wszystko działa jak trzeba.