Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Samsung T19C300 - Przeróbka zasilacza - czemu nie działa?

07 Maj 2017 23:04 921 12
  • Poziom 12  
    Witam
    Tym razem trochę nietypowo, bo Samsung T19C300 (monitor z tunerem TV) mimo mych eksperymentów wciąż jeszcze działa. :D
    W czym problem - buduję terenowego kampera i potrzebuję monitora lub telewizora zasilanego z akumulatora samochodowego. Początkowo kupiłem w tym celu Samsunga T22E390 który ma zewnętrzny zasilacz 14V i z którego zasileniem nie byłoby problemu, ale okazał się za duży. Powędrował więc do kuchni, z której zabrałem Samsunga 19". Samsung zasilany jest niestety napięciem sieciowym. Oczywiście można by użyć przetwornicy 12/230V którą mam nawet na pokładzie auta ale jest to trochę bez sensu. Telewizorek, jak zmierzyłem, pobiera z sieci ok 10W. Nawet dobierając najmniejszą dostępną przetwornicę (100W, w aucie zabudowaną mam 2kW) straty na przetwarzaniu napięcia będą duże i niepotrzebne. Rozebrałem więc monitor i stosując domową inżynierię wsteczną (nie mam schematu) rozpracowałem. Zasilacz daje 3 napięcia (mierzone na diodach po transformatorze) 5,2V; 13,8 i 18,6 zasilający driver podświetlających LEDów. Z samej części zasilającej nie wychodzi nic więcej, więc uznałem że za pomocą 3 przetwornic step up / down podam na diody właściwe napięcia (docelowo też przez diody więc monitor będzie można będzie używać również z napięcia sieciowego). Kupiłem więc odpowiednie regulowane przetwornice (swoją drogą nie wiem jak się opłaca to produkować - ceny ok 6pln) ze sporymi mocami, ustawiłem, podłączyłem i...nic. Tzn dioda monitora początkowo świeciła normalnie, ale włączając monitor migała i ponownie zapalała się. Później zmieniło się to o tyle że już po podłączeniu zasilania krótko mruga - jakby wydajność prądowa przetwornic była za mała. Wydajność jest ok - napięcia przy próbie włączenia nie spadają ani o miliwolt. (przy oryginalnym zasilaczu napięcia poza 5v nieco fluktuują). Poza częścią sieciową na wyjściu której się wpiąłem, zasilacz jest dość skomplikowany. Główne 5V nie jest podawane na główną płytę monitora cały czas, tylko załączane. Na płytę idzie pomocnicze 5V, a główne jest załączane (a u mnie właśnie nie jest)pojawieniem się napięcia 13,8V, które znów jest włączane najprawdopodobniej sygnałem z płyty głównej, ale przechodzącej przez kilka tranzystorów w okolicach drivera LEDów. Z płytki głównej do zasilacza idą 3 sygnały oznakowane jako PS ON, BLV ON i EPVM co rozumiem jako włącznik podświetlenia, włącznik napięć B (tak są oznakowane główne 5V i 13,8) i regulacja jasności. Tak czy inaczej nie ma to znaczenia - napięcia dostarczam takie same jak główna część zasilacza, więc czemu nie działa??
  • Poziom 31  
    Logika monitora komunikuje się z zasilaczem. Samo podstawienie napięć nic nie da. Trzeba się dowiedzieć co potrzebuje na danych pinach tych PS on BLV on i EPVM i je też podstawić.
  • Poziom 12  
    Tak tylko wydaje mi się że są to sygnały idące do zasilacza, a nie odwrotnie.
  • Poziom 31  
    PS on zapewne uruchamia resztę napięć bo na stand-by jest pewnie tylko jedno blv on to pewnie od podświetlenia a epvm nie wiem musisz prześledzić do czego idą poszczególne ścieżki.
  • Poziom 12  
    Inżynierii wstecznej część dalsza. Sterownik LEDów to MAP3204. EPVM wchodzi na wejście ściemniania, BLU_ON na "enable". Resztę napięć musi więc załączać PS_ON w sposób dość skomplikowany. Nie ma żadnego sygnału zwrotnego do głównej płyty więc czemu nie działa?! Chyba że coś z tym PS_ON jest...
    Pomógłby schemat. Może ma ktoś? Zasilacz to BN44-00505A lub PSLF560501A
  • Poziom 37  
    Może kolega chociaż zdjęcie tej płytki zrobi.

    Ważniejsza jest matryca.Podświetlenie LED zasilane z płytki od matrycy czy z zasilacza ?
    Po najmniejszej linii oporu zajrzy kolega tu:
    https://www.elektroda.pl/rtvforum/topic2859840-1860.html#16461189
    Kontroler za parędziesiąt zł i problem rozwiązany. Praktycznie każda standardowa matryca da się w ten sposób uruchomić(sam zbudowałem dwa takie monitorki, jeden na laptopowej,drugi na IIyama E2475 z ubitą logiką).

    A jeżeli nie to najprościej pomierzyć napięcia w trybie standby oraz po załączeniu.
    Płyta logiczna najczęściej po prostu prosi zasilacz o załączenie napięcia głównego i tak jest to najczęściej rozwiązane.
    Można jeżeli zidentyfikuje kolega który to sygnał to można wykonać elektroniczny klucz na mosfecie + rezystorze (rozładowanie bramki).
  • Poziom 12  
    Witam
    Na wszystkie pytania odpowiedziałem w zasadzie we wcześniejszych postach
    pawelr98 napisał:
    Może kolega chociaż zdjęcie tej płytki zrobi.

    Wrzucenie do googla symbolu płytki (BN44-00505A) owocuje setką jej zdjęć
    https://electropartsonline.com/media/catalog/...ply-boar-83393ba1c7e402291dff7a3302019a43.jpg

    Cytat:
    Kontroler za parędziesiąt zł i problem rozwiązany

    Mnie nie chodzi o użycie matrycy, tylko wykorzystanie telewizora który ma tuner TV, pilota, głośniki itd.
    Cytat:
    A jeżeli nie to najprościej pomierzyć napięcia w trybie standby oraz po załączeniu

    Najprościej, co zresztą jak opisałem w pierwszym poście zrobiłem i dla nich wyprodukowałem odpowiednie zasilacze.
    Cytat:
    Płyta logiczna najczęściej po prostu prosi zasilacz o załączenie napięcia głównego...

    Tu też tak jest to rozwiązane. Płyta logiczna prosi sygnałem PS_ON o załączenie napięć - tylko sygnał pojawia się tylko przez chwilkę - nie wiem czy dlatego że w załączonych napięciach coś nie podoba się płycie logiki, czy problem jest po stronie zasilacza.
  • Pomocny post
    Poziom 31  
    W moim tv Acer 23" ps-on jest caly czas po załączeniu, sprawdzaj napiecia z wykorzystaniem oryginalnego zasilacza. Jakim multimetrem mierzysz ? bo nie kazdy sobie radzi z szybkimi zmianami napięć.
  • Poziom 12  
    Przeanalizowałem dziś jeszcze raz wszystko - na PS_ON pojawia się 3,5V z płyty głównej. Ta nie dostaje żadnego sygnału zwrotnego z płyty zasilacza. Uznałem że to musi działać. Podniosłem napięcie główne z 5,2V na 5,4V i ruszyło...
    Działa fajnie - z 12V pobiera 0,8A.
    Dziękuję wszystkim. Temat jest do zamknięcia.
  • Poziom 31  
    Ps-On jest tylko wiadomością dla zasilacza że ma włączyć pozostałe napięcia :) Fajnie że się udało. To zamknij temat ;)
  • Poziom 12  
    W tym zasilaczu jest dość skomplikowany układ załączania - realizowany już na poziomie samego zasilacza. Od spodu jest od tego kupa elementów SMD. Z tego co udało mi się wyśledzić PS_ON załącza chyba napięcie zasilające driver ledów. Wykrywany tam pobór prądu, załącza pomocnicze napięcie 13V i dopiero to napięcie załącza główne 5V. Do tego mimo iż zasilacz był stosowany w wielu monitorach, można go kupić jako część zamienną, jego schemat jest nieosiągalny. Zanim zamknę, mam jeszcze jedno pytanie. Po co napięcie z wyjścia transformatora prostują tak potężne diody i to zdublowane - na wyjściu 5V są 3 szt. z miejscem pod czwartą (pewnie w innym modelu monitora), gdy pobór prądu jest tam na poziomie 1A (pewnie przy włożeniu urządzenia USB i karty CI byłoby z 2)? Na pozostałych napięciach podobnie przy poborze prądu na poziomie 140 i 200 mA.
  • Poziom 31  
    Pobór prądu jest uzależniony od np jasności podświetlenia. Zasilacz już na poziomie konstruowania przez techników jest konstruowany pod wiele monitorów, dlatego między innymi nie raz są puste miejsca na elementy, kilka diód żeby np ograniczyć nagrzewanie się tego elementu ;)
  • Poziom 12  
    Dziękuję, zamykam temat.