Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Tranzystor BD136 dostaje przebicia

Krzych12 08 May 2017 14:48 2184 31
Altium Designer Computer Controls
  • #1
    Krzych12
    Level 12  
    Witam
    Ostatnio zbudowałem układ w którym wykorzystałem tranzystor BD136, do sterowania zaworem - układ klasyczny w kolektorze cewka zaworu. Podczas pracy tranzystor zaczyna się nagrzewać a na końcu dostaje przebicia C-E. Co chyba jest słuszne bo nie użyłem żadnego radiatora. Dodam że w punkcie pracy przez złącze C-E przepływa prąd około 630mA, a napięcie kolektor – emiter to około 1,5V(czyli około 0.8W) . Mam pytanie czy jeśli zastosuje radiator z pastą lub bez to pomoże, czy lepiej poszukać innego tranzystora, a może zastosować FET-a.
    [28-30.06.2022, targi] PowerUP EXPO 2022 - zasilanie w elektronice. Zarejestruj się za darmo
  • Altium Designer Computer Controls
  • #2
    marekhab
    Level 33  
    Diodę równolegle z cewką dałeś?
    To może być przyczyna.
  • #3
    Krzych12
    Level 12  
    Tak dałem równolegle z cewką jej typ to 1N4148

    Tranzystor BD136 dostaje przebicia

    A może faktycznie coś źle robię, dlatego powyżej wstawiłem układ
  • Altium Designer Computer Controls
  • #4
    Bieda z nędzą
    Level 34  
    Być może w momencie rozwierania obwodu komutuje się duża SEM samoindukcji i przebija złącze. Rozwiązaniem może być dioda blokująca uzwojenie albo zastosowanie innego tranzystora, np BD140.
    Ale i tak 1,5W mocy traconej na samą tylko obudowę TO-126 to za dużo.
    Użyj może BDX54D . Dodatkowo to, że darlington spowoduje, że będzie większa pewność wysterowania.
  • #7
    Krzych12
    Level 12  
    Tak zrobię dam jakiś mały radiator z blaszki i zobaczę, a jak nie to zastosuje inny typ tranzystora. Chociaż te 0.8W to niewiele myślałem że samo się rozproszy w tej obudowie
  • Helpful post
    #8
    Maciek_C
    Level 14  
    A ja bym spróbował przeanalizować parametry sygnału sterującego, bo napięcie Uce równe 1,5V to trochę zbyt dużo jak na ten tranzystor. Według karty katalogowej Ucesat wynosi maksymalnie 0,5V dla 0,5A więc masz chyba nie w pełni otwarty tranzystor i wydziela się na nim zbyt duża moc.
    Pozdrawiam,
    Maciek
  • #9
    Adamcyn
    Level 38  
    Maciek_C wrote:
    A ja bym spróbował przeanalizować parametry sygnału sterującego, bo napięcie Uce równe 1,5V to trochę zbyt dużo jak na ten tranzystor. Według karty katalogowej Ucesat wynosi maksymalnie 0,5V dla 0,5A więc masz chyba nie w pełni otwarty tranzystor i wydziela się na nim zbyt duża moc.

    Bardzo słusznie.
    Zmierz prąd bazy.
  • #10
    Krzych12
    Level 12  
    Po zamierzeniu około 20mA czy to mało? I jeszcze raz zmierzyłem napięcie C-E i pokazuje około 0.85V tamten pomiar był błędny
  • Helpful post
    #11
    trymer01
    VIP Meritorious for electroda.pl
    Adamcyn wrote:
    Daj 1N4007.

    Popieram, 1N4148 może być tu za słaba.
    Ale przede wszystkim
    Maciek_C wrote:
    napięcie Uce równe 1,5V to trochę zbyt dużo jak na ten tranzystor. Według karty katalogowej Ucesat wynosi maksymalnie 0,5V dla 0,5A więc masz chyba nie w pełni otwarty tranzystor i wydziela się na nim zbyt duża moc.

    Prąd bazy powinien wynosić ok. 50mA.
    Seria BD13x ma spore Ucesat, niezbyt wysoką betę - należałoby zastosować BD136-16, lepiej BD138-16, a najlepiej 2SA2039, 2SA2040 - albo MOSFET.
    Rozumiem, że włączenie następuje gdy sygnałem jest zwarcie do masy - opornik 560 Ohm ustala Ib=ok.20mA - to trochę za mało dla BD136.

    Czy na pewno stan wysoki sygnału sterującego wyłącza tranzystor? - bo jeśli stan wysoki wynosi mniej niż 11V to tranzystor nie jest domykany i wtedy też się grzeje.
    Co to za sygnał i z czego pochodzi?

    Darlingtona nie polecam, gdyż mają one wysokie Ucesat.

    Dodano po 7 [minuty]:

    Edit:
    20mA wynika z opornika 560 Ohm. 20mA to dla BD136 za mało - czytaj wyżej.
    Krzych12 wrote:
    tamten pomiar był błędny

    Niekoniecznie - napięcie Ucesat może Ci się zmieniać gdy tranzystor się nagrzewa - wtedy beta się zmienia, Ube się zmienia... - to oznacza, że Ib jest zbyt mały i tranzystor jest na granicy nasycenia.
  • #12
    Krzych12
    Level 12  
    Przy zamknięciu pomiar prądu wynosi 0mA czyli chyba się dobrze zamyka. Ponadto napięcie C-E wynosi tyle ile napięcie zasilania spróbuję zwiększyć prąd bazy i zastosować diodę 1N4007 tak jak radzicie a jak to nie pomoże to zmienię tranzystor na inny
  • #14
    Krzych12
    Level 12  
    Sygnał idzie z uC poprzez BC546 a później na BD ale zrobię jeszcze tak jak piszecie spróbuję zmniejszyć rezystor w bazie z 560 na mniejszy i sprawdzę czy zwiększy się prąd bazy a zmniejszy napięcie CE
    trymer01 jeśli będzie niepowodzenie to dam mosfeta takiego jak polecasz IRFR
  • #15
    _jta_
    Electronics specialist
    630mA * 1.5V = 0.945W, nie 0.8W. To spora moc, jak na tranzystor bez radiatora. 0.85V - czy to z tym samym tranzystorem? To by była moc 0.6W (bo prąd pewnie 700mA)... pytanie, jakie są warunki chłodzenia.

    Jest jeszcze kwestia, czy baza stale dostaje te 20mA, czy ten prąd się zmienia - być może napięcie zasilania ma tętnienia, które powodują szybkie wahania prądu i straty mocy większe, niż wyliczone dla stałego?

    W każdym razie, jeśli ta dioda nie wysiadła (i jest naprawdę podłączona - zdarza się lut, który nie łączy), to tranzystorowi grozi chyba tylko przegrzanie - powinien mieć jakiś mały radiatorek do chłodzenia.
  • #16
    Krzych12
    Level 12  
    Zrobiłem tak jak radziliście, czyli zamiast diody 1N4148 dałem 1N4007, wykonałem prowizoryczny radiator z kawałka podkładki, zmieniłem rezystor w bazie z 560 na 470 Ohm. Po pomiarach prąd bazy wzrósł tak jak pisaliście do około 22mA, napięcie C-E spadło do około 0.86V. Nawet po zastosowaniu "radiatorka" można wyczuć że się nagrzewa coraz mocniej, ale pracuje dłużej i jak na razie tranzystor nie przepala się. Po przerwie jeszcze raz zmieniłem rezystor bazy BD z 470 na 220 a napięcie CE spadło do około 0.5V. Zobaczymy teraz jak długo będzie chodził tranzystor czyli oczywiście sprawdzając cały czas temperaturę radiatora. Dodam że prąd bazy BD wynosi po tych zmianach około 45mA.
  • #17
    trymer01
    VIP Meritorious for electroda.pl
    Potwierdza się, że BD136 był na skraju nasycenia, teraz przy Ib=45mA jest w płytkim nasyceniu, co nie jest prawidłowym stanem, powinien pracować w głębszym nasyceniu.
    Tyle, że BD13x tu się nie bardzo nadaje, bo stara zasada mówi, aby nie używać klucza do pracy z prądem >30-50%Icmax - (czyli tutaj dla BD13x ok. 0,5A) - bo maleje beta, wzrasta Ucesat.
    Poza tym teraz wstępny stopień na BC546 pracuje z prądem Ic= 45mA - to znowu dla niego za dużo. Sprawdź czy on jest w nasyceniu, jakie ma Uce. Powinien mieć Ib= ok. 4mA.

    Zmień BD136 na MOSFET - wszelkie problemy ustąpią.
  • #18
    Krzych12
    Level 12  
    trymer01 tak jak piszesz pewnie docelowo zastosuje Mosfeta, a jeśli chodzi o prąd bazy BC546 to jak zmierzyłem było około 7mA. Po pracy całego klucza przez około 10minut napięcie BD C-E wyniosło <0.5V, i radiator utrzymywał stałą temperaturę chyba względnie dobrą. Sprawdzając czy ten klucz pozwoli mi na sterowanie zaworem impulsem o czasie trwania 50ms, klucz przeszedł próby dobrze. Na oscyloskopie nie zauważyłem żadnych złych rzeczy. Ale tak jak mówisz przejdę na Mosfeta, który dzisiaj ma do mnie dotrzeć, niestety żadnego pod ręką nie mam :(.
  • #19
    _jta_
    Electronics specialist
    Dopuszczalny prąd BD136 to -1.5A, beta maleje o połowę przy -0.8A (d;a U_CE=-2V). U_CEsat podają max -0.5V przy I_C=-0.5A.

    BC546 ma betę o połowę mniejszą przy I_C=100mA, a przy I_C=45mA ma zmniejszoną zaledwie o kilkanaście %. Prąd bazy zależy od innych elementów układu. Dla I_C=100mA i I_B=5mA producent podaje napięcie nasycenia typowe 0.2V, max. 0.6V. Czyli 45mA to dla niego wcale nie za dużo, i do głębokiego nasycenia (I_C/I_B=20 dla tego typu) wystarczyłby mu 3 razy mniejszy prąd bazy.
  • #20
    trymer01
    VIP Meritorious for electroda.pl
    Krzych12 wrote:
    prąd bazy BC546 to jak zmierzyłem było około 7mA.

    To na pewno wystarcza do głębokiego nasycenia.
    _jta_ wrote:
    Czyli 45mA to dla niego wcale nie za dużo

    Niemniej, jest to męczenie tranzystora nieprzewidzianego do pracy z takimi prądami. To tranzystor najmniejszej mocy (mniejszej już się nie produkuje) przeznaczony do Ic=0,1-10mA, max 30-50mA.
    Proszę nie rozumieć Icmax=100mA jako jego normalne warunki pracy!
    Dla każdego tranzystora Imax to wartość graniczna, do której zbliżanie się pogarsza niezawodność.
  • #21
    CYRUS2
    Level 42  
    Adamcyn wrote:
    1N4148 Daj 1N4007.
    To bez znaczenia.
    Układ zaprojektowany poprawnie.
    Na zasialniu 12V jest elektrolit ?
    Wygląda,ze tranzystor nie jest nasycony.
    Uce powinno być poniżej 0,5V.
    Zastosuj BD 136 gr10 lub 16.
    Niewykluczone, że na 560Ω jest mniej niż 10V.
    Niepełne sterowanie.
  • #22
    _jta_
    Electronics specialist
    To tranzystor najmniejszej mocy (mniejszej już się nie produkuje) przeznaczony do Ic=0,1-10mA, max 30-50mA.

    Nie - obejrzyj jego charakterystyki.

    Proszę nie rozumieć Icmax=100mA jako jego normalne warunki pracy!
    Dla każdego tranzystora Imax to wartość graniczna, do której zbliżanie się pogarsza niezawodność.


    Dla tego tranzystora prądy do 100mA to są normalne warunki pracy. Przekraczanie tego prądu (a nie zbliżanie się do niego) znacząco zmniejsza niezawodność, jakkolwiek dla układów, od których wymaga się bardzo dużej niezawodności, zalecano ograniczanie prądu do 70-80% I_Cmax - czyli dla tego tranzystora do 70-80mA. A jego prąd w tym układzie jest mniej, niż 2/3 tego. Nie popadajmy w paranoję!
  • #23
    CYRUS2
    Level 42  
    Rzeczywistość jest inna niż napisałem w poście #21.
    Ten tranzystor (BD 136) się do tego nie nadaje.
    Nawet BD 136 gr 16.
    Nie nasyca się jest na nim 2-3V.
    Pewnie "Beta" mu spada przy tym prądzie.
    Ten tranzystor - jak a pamiętam był robiony na mniejsze prądy.
    1,5A to wartość naciągana".
    Mam ze 100szt w pojemniku, pewnie wszystkie wyrzucę.

    BD786 - bez grupy - nasyca się do 0,26V
  • #24
    _jta_
    Electronics specialist
    Przy prądzie bazy 45mA autor tematu zmierzył i było 0.5V, nie ponad 2V - więc najwyraźniej tranzystor się nadaje do jego układu.

    CEMI faktycznie podawało mniejszy prąd, 0.5A - ale oni robili błędy przy podawaniu danych w katalogach.

    Co do spadania bety, to polecam oglądanie wykresów charakterystyk. BD786 (nie znam takiego), czy BD286?
  • #25
    CYRUS2
    Level 42  
    _jta_ wrote:
    Przy prądzie bazy 45mA autor tematu zmierzył i było 0.5V, nie ponad 2V - więc najwyraźniej tranzystor się nadaje do jego układu.
    Ze schematu wynika ok.20mA.

    Praca z betą 15 jak firma określa 100-160 ?
    Tak się robi projekty kolega _jta_?
    Jesteś niepoważny jak twierdzisz, że się nadaje.
  • #26
    Krzysztof Kamienski
    Level 43  
    Krzych12 wrote:
    Ostatnio zbudowałem układ w którym wykorzystałem tranzystor BD136, do sterowania zaworem - układ klasyczny w kolektorze cewka zaworu.
    Przepraszam. Ten układ nie jest klasyczny, tylko stojacy na głowie. Dlaczego Kolega użył tu tranzystora PNP ? Ujemnym napięciem baza sterowana, czy jak ?

    Bieda z nędzą wrote:
    Użyj może BDX54D . Dodatkowo to, że darlington spowoduje, że będzie większa pewność wysterowania.
    Owszem, tylko też pytam, dlaczego PNP ?
  • #27
    Bieda z nędzą
    Level 34  
    Krzysztof Kamienski wrote:

    Owszem, tylko też pytam, dlaczego PNP ?

    Może dlatego, że zawór musi być "na masie"?. Równie dobrze można zapytać czemu tranzystor a nie przekaźnik.
    A teraz do rzeczy. Olał bym tranzystor. Zastosował bym jakiegoś BTS, i bym był pewien, że się nie przebije, nie przegrzeje, zawsze załączy w pełni.
  • #28
    _jta_
    Electronics specialist
    :arrow: #25 Ze schematu wynika ok.20mA.

    A autor pisał w #16, że wymienił opornik, i wtedy prąd bazy był 45mA, i napięcie kolektor-emiter zmalało do 0.5V.

    Praca z betą 15 jak firma określa 100-160 ?

    Napięcie nasycenia firma określa dla I_C/I_B=10, czyli dla I_C=700mA powinno być I_B=70mA, to 45mA to trochę mało...

    Poza tym firma nie określa bety 100-160, tylko 40-250, i nie dla prądu 700mA, tylko dla 150mA, ani nie dla napięcia 0.5V, tylko 2V. A przy 700mA beta może być ze 30% mniejsza - czyli 24, więc bardzo płytkie nasycenie powinno się zacząć przy I_B poniżej 30mA, a ja w innym temacie zalecałem ze 2X więcej, niż gwarantowany próg nasycenia - czyli tu byłoby 60mA. W związku z tym opornik w bazie zamiast 560R powinien być 180R, albo i 160R - jeśli z opornikiem 220R było 45mA, to raczej to drugie.

    To nie oznacza, że tranzystor się nie nadaje - tylko że działa nieco gorzej od takiego, który by zapewnił napięcie nasycenia poniżej 0.5V przy małym prądzie bazy - np. BD436 (gwarantuje poniżej 0.5V przy I_C=2A, I_C/I_B=10). Za to jest łatwiej dostępny, pewnie tańszy, i jeśli wystarcza, to po co szukać innego? Jakby tego miało się robić większą ilość, to może 2N6727 - są po około 0.3zł (Semiconductors Bank w Łodzi) i działałyby znacznie lepiej (napięcie nasycenia przy 1A takie, jak BD136 przy 0.5A, beta ponad 50 przy 1V, 1A).
  • #29
    CYRUS2
    Level 42  
    [quote="_jta_"]Poza tym firma nie określa bety 100-160, tylko 40-250[/quiote]Ten tranzystor ma grupy 6,10 i 16.
    Wiec piszesz bzdury kolego.
    _jta_ wrote:
    i nie dla prądu 700mA, tylko dla 150mA
    Dlatego na prad 700mA nie powinien być stosowany.
    Czy to dla kolegi aż takie skomplikowane ?
    _jta_ wrote:
    przy 700mA beta może być ze 30% mniejsza - czyli 24
    Skąd ta wiedza ?, Jak widać beta wynosi 15.
    _jta_ wrote:
    więc bardzo płytkie nasycenie
    Podstawowa wiedza z układów elektronicznych.
    Uce 1V to nie jest nasycenie.

    _jta_ wrote:
    To nie oznacza, że tranzystor się nie nadaje - tylko że działa nieco gorzej od takiego, który by zapewnił napięcie nasycenia poniżej 0.5V
    W Afryce samochodem osobowym wożą kozy na tylnym siedzeniu.
    Uważają, że samochód się do tego nadaje.
    To są zasady bardzo kiepskiego projektanta.

    Masz w profilu "specjalista elektronik".
    To do czegoś zobowiązuje.
    Nie ucz młodych zasad błędnego projektowania.
  • #30
    _jta_
    Electronics specialist
    Czy kolega nadal chce się popisywać bzdurami? Z jakiej grupy był użyty tranzystor?

    A skąd ta wiedza - oczywiście z noty katalogowej, której kolega z lenistwa nie przejrzał.

    Uce 1V to nie jest nasycenie. - To wygląda na spór o znaczenie słów, co nie ma sensu.

    Pokazałem, jakie robisz błędy, jak chcesz je robić nadal, to już tylko twoja sprawa.