Elektroda.pl
Elektroda.pl
X
Relpol przekaźniki
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Zmywarka Bosch SGV43A03/17 - moduł sterownika nie działa

19 Maj 2017 10:27 3789 15
  • Poziom 10  
    Witam Koledzy,
    Mam problem ze swoją zmywarką Bosch SGV43A03/17 która po zakończeniu cyklu wyzionęła ducha. Obecnie żadna kontrolka sterownika nie świeci się. Po wyłączeniu i włączeniu przycisku power słychać przez chwilę jeden stuk (aquastopu?, pompy?) jednak sterownik pozostaje bez światełek.
    Sprawdziłem zamknięcie pokrywy i przycisk power - działają prawidłowo. Po wymontowaniu modułu okazało się, że wywaliło triaka i jego kluczyk.
    Zmywarka Bosch SGV43A03/17 - moduł sterownika nie działa

    Wstrzymałem się z wymianą bo najpierw chcę zobaczyć czy procesor się nie spalił. Wizualnie wszystko wygląda ok za wyjątkiem tego triaka i tranzystora.
    Zmywarka Bosch SGV43A03/17 - moduł sterownika nie działa Zmywarka Bosch SGV43A03/17 - moduł sterownika nie działa

    Po sprawdzeniu napięć okazało się, że nie ma napięcia DC (5V) ani na procesorze (sprawdzane przy kondensatorze na pinach vss vdd procesora) ani na na innych układach (np. ULN2003). Pomyślałem, że być może padł stabilizator- jednak nie mogę go znaleźć :oops: . W niektórych modułach jest on w okolicach układu TNY254 ale na mojej płytce w okolicach tego układu jest tylko BCP53.
    Pytanie:
    1. Co zrobić żeby sprawdzić czy logika (procesor) działa?
    2. Gdzie może być stabilizator 5v?
    3. Czy - zakładając że procesor jest sprawny - po podłączeniu wtyczki (NETZ/TuR) moduł powinien dać oznaki życia (świecące ledy)?

    Będę zobowiązany za pomoc bo nie widzi mi się szukać nowej zmywarki :(
  • Relpol przekaźniki

  • Poziom 39  
    Masz uszkodzony moduł na amen. Pozostaje Ci zakupić nowy moduł lub używany.
    Padł Ci procesor.
  • Relpol przekaźniki
  • Poziom 10  
    Piotr2608 napisał:
    Masz uszkodzony moduł na amen. Pozostaje Ci zakupić nowy moduł lub używany. Padł Ci procesor.
    No właśnie. Tak mi większość mówi, ale ponieważ ja typ dociekliwy, to będę jeszcze drążył i w razie czego cały czas czekam na odpowiedzi na moje 3 pytania. Zastanawiam się gdzie są te punkty na płytce, które są źródłem napięcia DC podawanego na procka i inne czipy. Czyżby to napięcie generował TNY254G z jakimś "dopieszczającym" układem...
  • Pomocny post
    Poziom 38  
    BCP53 stabilizuje 5V - poszukaj w Google "stabilizator parametryczny". Jeśli zasilacz sprawny, to na kondensatorze 220µF/16V powinieneś mieć 7,5V. Podłączenie zasilania tylko na NETZ/TUR nic nie da - trzeba jeszcze podłączyć odpowiednio HEIZ. Nie wnikając w szczegóły - 230V powinno być podane na kondensator przeciwzakłóceniowy X (C2) - wtedy zasilacz powinien wystartować. Natomiast żadnych "oznak życia" w postaci LEDów nie zobaczysz - do tego trzeba podać napięcie na pin 1 złącza NETZ/TUR.
  • Poziom 10  
    Dzięki za informację!
    Myślałem że Heiz to grzałka i jest to gniazdo wyjściowe nie mające wpływu na ewentualne włączenie modułu.
    Napięcie na kondensatorze 220uF/16V mam ok. 2V przy podłączonych wszystkich zmywarkowych wtyczkach.
    Zastanawiam się czy wobec tego nie zamontować nowych BCP53 i TNY254.
    Chyba, że jest takie miejsce na płytce w które można się wlutować tak by dać napięcie DC które zasiliłoby tylko logikę.
    Jakieś wskazówki???
  • Pomocny post
    Poziom 38  
    Możesz podać 7.5V na wspomniany kondensator 220µF/16V.

    Piny złącza HEIZ są podłączone do styków przekaźnika włączającego grzałkę (dlatego złącze silnoprądowe) i dodatkowo z jednego z nich jest pobierane L dla reszty elektroniki. Natomiast N dla elektroniki jest podawane złączem NETZ/TUR; N dla grzałki i kilku innych elementów wykonawczych jest podłączone bezpośrednio przewodami.
  • Pomocny post

    Poziom 39  
    Fakt jest faktem iż jeśli wybuchł triak, zwarty jest tranzystor sterujący, to należy wylutować uszkodzone elementy i teraz jeśli na ścieżce podającej sygnał z procesora do tranzystora względem masy jest rezystancja do ok 500Ω oznacza to definitywne uszkodzenie procesora - zwarcie wewnątrz procesora. Świadczyć może o tym brak napięcia +5V zasilającego procesor po podaniu napięcia sieciowego,
  • Poziom 10  
    Ok. Wylutowałem spalony tranzystor. Brak przewodzenia pomiędzy pinem procesora dochodzącym do tego tranzystora a masą procesora.
    Podłączyłem 7.5V z zasilacza warsztatowego do 220µF/16V. Pojawiło się napięcie na procesorze 1.15V. Jak podałem 5V to było 0.9V

    Podczas sprawdzanie napięć m.in na BCP53 pewnym momencie zaświeciły się diody (0.5s) Raczej wykluczam przypadkowe zwarcie. Na marginesie to napięcie na kolektorze BCP53 jest dokładnie takie samo jako na procesorze.
    Czy to na wyjściu tego układu powinno pojawić się +5V?

    Temat pewnie bym już odpuścił gdyby nie było tego mignięcia diod, (a linie sygnałowe diod z tego co widzę wychodzą bezpośrednio z procka). Teraz już zwątpiłem i jeśli mierząc napięcie na BCP53 zrobiłem zwarcie na jego pinach wskutek czego na kolektor poszło 7.5V no to miałbym już po procesorze.

    Ale zakładając że procesor jeszcze żyje to pojawiły mi się kolejne pytania:
    - czy jeżeli zasilam moduł napięciem +7.5V poprzez C2 nie powinno się w tym momencie pojawić +5V gdzieś na pinach zasilających procesora? Czy ewentualnie jest gdzieś potrzebne dodatkowe wpięcie wtyk(u/ów) zmywakowych - byłoby to dziwne.
    - gdzie jest ten punkt na płytce w którym niezależnie od napięcia na C2 jest zawsze +5V dedykowane dla procka?
    - czy to normalny stan, że na tranzystorach sterującymi triakami i np. na układzie ULN2003, powinno być napięcie takie jak kondensatorze C2 (7.5V). Ale na pozostałych układach cyfrowych jest niższe takie same napięcie (wspomniane we wcześniejszym wpisie 1.15V i 0.9V).
  • Pomocny post
    Poziom 38  
    Ad.1 Powinno pojawić się 5V. Jeśli nie ma, to uszkodzony stabilizator (BCP53 i kilka otaczających elementów) albo zwarcie na linii 5V.

    Ad.2 Na kolektorze BCP53

    Ad.3 7.5V na triaki i ULN - jak najbardziej normalne. Na pozostałych powinno być 5V.
  • Poziom 10  
    Wymieniłem BCP53 ale bez efektu. Pomierzyłem też napięcia w jego okolicach.
    Zmywarka Bosch SGV43A03/17 - moduł sterownika nie działa
    Może ktoś wpadnie na to co może nie grać.
  • Pomocny post

    Poziom 39  
    barti1977 napisał:
    Może ktoś wpadnie na to co może nie grać.


    Procesor nie gra bo ma zwarcie. Jak odlutujesz nogę w procesorze odpowiedzialną za jego zasilanie, pojawi Ci się napięcie +5V. Wokół procesora masz kilka kondensatorów SMD. Zmierz je na rezystancję - jeśli choć jeden ma zwarcie będziesz miał odpowiedź, że na 100% uszkodzeniu uległ procesor. Niestety - moduły są dobre do póty do póki nie dojdzie do ekstremalnego uszkodzenia jednego z triaków.
  • Poziom 10  
    Niestety. Procesor rzeczywiście jest padnięty. Grzeje się strasznie przy 5V. Diody się świecą (wszystkie)....
    ...i tylko cholera człowieka bierze jak widzi brak zabezpieczeń obwodu DC na okoliczność zwarć w obwodzie AC. I ktoś napisał, że jest to spowodowane cięciem kosztów - przy cenie modułu w serwisie 900zł. Koszt wymiany - 150zł, a pani z serwisu jeszcze z nieukrywanym zadowoleniem mówi mi że z uwagi na bliskość serwisu zapłacę tylko 39zł za dojazd serwisanta)...

    Jakąbyście koledzy proponowali obecnie zmywarkę (markę) - chodzi o jej niezawodność i relatywnie rzadkie wizty w serwisach (może już jest taki post na forum)?

  • Poziom 39  
    Tak nie do końca, jest jeszcze pół prawda. Procesor można wymienić bo w stosunku do ceny modułu kosztuje grosze - ok 40 PLN (zależy od kursu dolara i kraju pochodzenia). Pytanie kto to cholerstwo jest w stanie zaprogramować? Serwisy autoryzowane nie posiadają wsadów FLASH (nie mówimy o pamięci EEPROM która jest odrębnym ogniwem, też serwisy jej nie posiadają).
  • Poziom 15  
    Chyba nie ma takiej firmy zmywarek. Ale polecam ci te troche starsze bosche, które dzisłają na te starsze pompy. Te zmywarki są najłatwiejsze do samodzielnej naprawy. A płytka to w każdej zmywarce morze sie spalić, poprostu miałeś pecha
  • Poziom 10  
    Takie przemyślenia. Mój Bosch był u mnie 14 lat. Prawie że bez żadnych problemów. Z 7 lat temu padł brzęczyk. Później zaczął się problem z ciągłym nabieraniem i i wypuszczaniem wody - rozwiązałem to sam - poprzez usprawnienie pracy pływaków i czujnika przepływu. Teraz kiedy czytam fora nasze i niemieckie to nagminne są awarie sprzętu w pierwszych 3 miesiącach po utracie gwarancji (podobno Unia też przestała już wierzyć w zbiegi okoliczności i wzięła się za ten problem). Chyba trzeba się nastawić na kupno zmywarki na 5lat i wkalkulować w jej koszt ubezpieczenie rozszerzające gwarancję z 2 do 5 lat...
    Na marginesie: znajomy - pracownik z linii produkcyjnej Boscha powiedział, że nie ma szans wgrać softu do modułu nawet po znajomości.
    Szkoda że chińczyk nie widzi interesu w produkcji zamienników takich modułów.
  • Poziom 38  
    barti1977 napisał:
    nagminne są awarie sprzętu w pierwszych 3 miesiącach po utracie gwarancji


    Znowu teorie spiskowe... A skąd niby ta biedna zmywarka ma wiedzieć, że jej się gwarancja skończyła? Jakiś specjalny czujnik że podbito jej gwarancję, po czym podtrzymywany bateryjnie RTC (ten typ ma włącznik odcinający całkowicie zasilanie sieciowe) odliczający czas do autodestrukcji? ;)

    Chińczyk nie widzi interesu w produkcji zamienników, bo:
    - nie odczyta wsadu procesora, więc nie będzie miał jak zaprogramować,
    - wbrew pozorom nie zrobi tego znacząco taniej,
    - nikt od niego tego nie kupi - bo i po co?