Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Excel - automatyczny import danych do pliku

Rafasia 20 Cze 2017 14:31 810 3
  • #1 20 Cze 2017 14:31
    Rafasia
    Poziom 6  

    Witam

    Mój problem polega na tym, że dane (z pliku), których potrzebuję umieszczane są w jednym i tym samym miejscu, niestety nazwa pliku zmienia się za każdą aktualizacją danych (plik ma część niezmienną ale w nazwie pliku pojawia się data np: nazwapliku 2017-06-08.xslm).

    Czy istnieje taka formuła, która umożliwiałaby automatyczną aktualizacje danych, (ręczną potrafię, wystarczy w formule docelowej zaktualizować datę :) ) ? Dla ułatwienia dodam, że formuła ADR.POŚR działa tylko gdy plik jest otwarty na kompie....

    0 3
  • #2 20 Cze 2017 18:26
    JRV
    Specjalista - VBA, Excel

    Rafasia napisał:
    ręczną potrafię, wystarczy w formule docelowej zaktualizować datę

    w formule wystarczy odwolanie do komorki, w ktorej aktualna data.

    Dodano po 40 [sekundy]:

    np =DZIS()

    Dodano po 34 [sekundy]:

    lub DZIS naprosto w formule

    0
  • #3 21 Cze 2017 09:31
    Rafasia
    Poziom 6  

    Pliki pojawiają się na serwerze codziennie, za każdym razem plik ma inną nazwę, co nie zmienia faktu, że w tej nazwie zmienia się tylko data. Nie potrafię ogarnąć tego żeby aktualizacja danych odbyła się automatycznie. Część plików, z których pobieram dane nie zmienia swoich nazw i lokalizacji tak więc dane w moim arkuszu same się aktualizują jak otworzę dokument.

    np:

    =JEŻELI.BŁĄD(WYSZUKAJ.PIONOWO(B27;'http://firma/dzialy/sprzedaz/raportydaily/Raporty/[Raport 2017-06-18.xlsm]'!$D$8:$E$201;2;0);0)

    0
  • #4 22 Cze 2017 00:17
    lanzul
    Poziom 26  

    Rafasia napisał:
    Czy istnieje taka formuła, która umożliwiałaby automatyczną aktualizacje danych ... dodam, że formuła ADR.POŚR działa tylko gdy plik jest otwarty na kompie

    Jedynym, chyba, sposobem odwołania się poprzez 'formułę' do komórki z zamkniętego pliku jest 'formuła ręcznego pisania'.
    Przykład pobrania zawartości komórki 'A4' z arkusza 'Arkusz1' z pliku o nazwie 'a_Raport_2017-06-21.xls' umieszczonego w 'c:\temp'

    ='C:\Temp\[a_Raport_2017-06-21.xls]Arkusz1'!A4

    Rafasia napisał:
    Pliki pojawiają się na serwerze codziennie, za każdym razem plik ma inną nazwę, co nie zmienia faktu, że w tej nazwie zmienia się tylko data. Nie potrafię ogarnąć tego żeby aktualizacja danych odbyła się automatycznie. Część plików, z których pobieram dane nie zmienia swoich nazw i lokalizacji tak więc dane w moim arkuszu same się aktualizują jak otworzę dokument

    Wykorzystując tę 'formułę ręcznego pisania', można sobie napisać krótki kodzik vba, który będzie sięgać do plików z "codziennie nową datą" w nazwie, wpisując po prostu w odpowiedniej komórce, to co, normalnie trzeba by wpisywać ręcznie.
    Wykorzystać można pętlę np.: For ... Next, funkcję 'Date', funkcję 'Format', zmienne obszarowe bądź tablicowe do określenia obszaru pobierania danych, ewentualnie metodę 'UpdateLink'

    Wypróbowane ... działa ...

    1