Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

STM32F411E-Disco brak ST link

nabarks69 24 Cze 2017 21:04 771 5
  • #1 24 Cze 2017 21:04
    nabarks69
    Poziom 2  

    Witam, są to moje początki z stm32 więc proszę o wyrozumiałość.
    Problem jest następujący, po podłączeniu płytki komputer nie wykrywa urządzenia.
    STM32F411E-Disco brak ST link
    Sterowniki są wgrane, zworki na swoich miejscach. Sam układ również działa, pali się zarówno dioda zasilania jak i dioda COM.
    St link utility także nie może się połączyć
    STM32F411E-Disco brak ST link
    Uprzedzę pytania, tak sterowniki były reinstalowane.

    0 5
  • #2 24 Cze 2017 21:24
    Marek_Skalski
    Moderator Projektowanie

    Może kabel jest uszkodzony? Spróbuj z innym.
    Jakim kolorem świeci dioda COM?

    0
  • #3 24 Cze 2017 21:32
    nabarks69
    Poziom 2  

    Kable również testowane dwa różne na dwóch różnych komputerach, dioda miga jednostajnie kolorem czerwonym

    0
  • Pomocny post
    #4 24 Cze 2017 22:07
    2675900
    Użytkownik usunął konto  
  • Pomocny post
    #5 24 Cze 2017 22:11
    Marek_Skalski
    Moderator Projektowanie

    Skoro dioda tylko miga, to nie ma żadnej komunikacji między komputerem a programatorem. Przyczyny szukałbym w kablu. Sam kabel możesz sprawdzić podłączając telefon do komputera. Jak działa, to kabel jest ok. Jeżeli nie działa, to znaczy, że kabel jest tylko do ładowania; nie udostępnia komunikacji między urządzeniami.

    0
  • #6 24 Cze 2017 22:33
    nabarks69
    Poziom 2  

    Rzeczywiście problem prawdopodobnie w kablach obydwa są dwużyłowe, jutro lecę po nowy kabel i zobaczymy czy będzie działać.

    Dziękuję za pomoc.

    0