Elektroda.pl
Elektroda.pl
X
Elektroda.pl
PCBway
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Problem z zasilaczem impulsowym

17 Lip 2017 15:33 1659 23
  • Poziom 25  
    Witajcie.
    Mam dość dziwny problem. Zbudowałem subwoofer z zasilaczem impulsowym na bazie układu Qwet'a (dodana stabilizacja, ale zachowana separacja galwaniczna od sieci). Zasilacz ten nie posiada uziemienia (tylko przewód fazowy i neutralny).
    Równolegle z zasilaniem końcówki mocy podpięty był przedwzmacniacz poprzez symetryczny stabilizator na diodach zenera, jednak masa zasilania przedwzmacniacza była pociągnięta z końcówki mocy, aby nie robić pętli mas (połączona przez kabel sygnałowy).
    Źródłem sygnału był mikser Behringer DDM4000, zasilany zasilaczem impulsowym, jednak z uziemieniem.

    Problem jest taki, że przy podłączaniu kabla sygnałowego między mikserem i przedwzmacniaczem subwoofera dotknąłem przez przypadek bolcem sygnałowym kabla RCA do masy przedwzmacniacza. Z miejsca wyrzuciło bezpiecznik różnicowoprądowy w mieszkaniu i.. chyba spaliło mikser (po włączeniu zasilania włącza się i wyłącza). Czy powodem jest brak uziemienia w zasilaczu subwoofera?
  • PCBway
  • Poziom 12  
    Według mnie uziemienie jest zdjęciem potencjału z obudowy urządzenia dane uziemienie czyli PE jest w obwodzie elektrycznym połączone przez zabezpieczenie które zadziała w razie niebezpieczeństwa przebicia na obudowę. Brak uziemienia w zasilaczu nie jest powodem uszkodzenia występujących za nim urządzeń lecz jeśli występują zakłócenia sygnałowe to musisz je z filtrować za pomocą elektroniki. Przede wszystkim do takich urządzeń jak wzmacniacz nie stosuje się zasilaczy impulsowych to duży błąd.
  • PCBway
  • Poziom 25  
    Co Ty mówisz. Coraz więcej szanujących się firm jak np Yamaha stosuje zasilacze impulsowe ze względu na większą sprawność i brak przydźwięków sieciowych (przynajmniej tych słyszalnych).

    Jeśli zasilacz w subwooferze i w mikserze ma separacje galwaniczną to jakim cudem dotknięcie jedynie wyjścia miksera z masą przedwzmacniacza mogło spowodować szkodzenie miksera oraz wybicie głównego bezpiecznika różnicowoprądowego w mieszkaniu?
  • Poziom 29  
    Pomierz napięcia między wszystkimi masami tych urządzeń i dopiero można jakieś wnioski wyciągać. Jedno jest pewne że nie ma izolacji galwanicznej która powinna być.
  • Poziom 43  
    Skoro zareagował wyłącznik różnicowopradowy to musiał popłynąć spory prąd i przyczyn trzeba szukać badając przetwornicę i to czy izolacja galwaniczna w niej na prawdę jest skuteczna.
  • Poziom 25  
    Powinna być.
    Sterownik jest po stronie wtórnej, zasilany z transformatorka pomocniczego. Sterowanie kluczami przez trafko sterujące oraz przekładnik prądowy. Wszystkie uzwojenia transformatorów są oddzielone od siebie taśmą izolacyjną.

    W jaki sposób szukać problemu, co pomierzyć?
  • Pomocny post
    Poziom 43  
    aj123 napisał:
    W jaki sposób szukać problemu, co pomierzyć?
    Ja bym zmierzył prąd upływu pomiędzy stroną wtórną a PE, (albo lepiej do N - jeśli pomiar zostanie przerwany przez różnicówkę) na wypadek jeśli izolacja okazała by się uszkodzona wstawił bym jakiś opór ograniczający prąd szeregowo z amperomierzem np żarówkę, żeby nie było więcej szkód.
    Warto powtórzyć pomiar po zamianie przewodów L i N doprowadzonych do przetwornicy.
  • Poziom 22  
    Mogło to być przyczyną. Różnicówkę wyrzuciło, dlatego że pewnie potencjały obu mas nie były jednakowe i jak się zrobiło zwarcie w Twoim mikserze to popłynął prąd doziemny który to spowodował. Wygląda jakby strona pierwotna zasilacza bez uziemienia niezupełnie była odizolowana galwanicznie od strony wtórnej tzn. może istnieje tam jakieś sprzężenie pojemnościowe przez które płynie prąd ze strony pierwotnej do masy strony wtórnej. Urządzeń audio nie powinno się zasilać zasilaczami impulsowymi. Czasami zasilacze impulsowe mają stonę wtórną połączoną ze stroną pierwotną takim niebieskim elementem (chyba to jest warystor, który ma dwie płytki czyli jest jakby częściowo kondensatorem albo może to kondensator) może u Ciebie też jest coś takiego i może ten element to spowodował.
  • Poziom 43  
    Cytat:
    Czasami zasilacze impulsowe mają stonę wtórną połączoną ze stroną pierwotną takim niebieskim elementem (chyba to jest warystor, który ma dwie płytki czyli jest jakby częściowo kondensatorem albo może to kondensator) może u Ciebie też jest coś takiego i może ten element to spowodował.
    Pomiędzy pierwotną, a wtórną, stosuje sie kondensatory przeciwzakłóceniowe, pojemności kilku nF, prąd płynący przez taki kondensator jest poniżej 1mA, więc różnicówki nie wyzwoli, w projekcie Qwet-a takiego kondensatora nie było.
  • Poziom 25  
    jarek_lnx napisał:
    Cytat:
    Czasami zasilacze impulsowe mają stonę wtórną połączoną ze stroną pierwotną takim niebieskim elementem (chyba to jest warystor, który ma dwie płytki czyli jest jakby częściowo kondensatorem albo może to kondensator) może u Ciebie też jest coś takiego i może ten element to spowodował.
    Pomiędzy pierwotną, a wtórną, stosuje sie kondensatory przeciwzakłóceniowe, pojemności kilku nF, prąd płynący przez taki kondensator jest poniżej 1mA, więc różnicówki nie wyzwoli, w projekcie Qwet-a takiego kondensatora nie było.

    I u mnie również go nie ma.

    jarek_lnx napisał:
    Ja bym zmierzył prąd upływu pomiędzy stroną wtórną a PE, (albo lepiej do N - jeśli pomiar zostanie przerwany przez różnicówkę) na wypadek jeśli izolacja okazała by się uszkodzona wstawił bym jakiś opór ograniczający prąd szeregowo z amperomierzem np żarówkę, żeby nie było więcej szkód.
    Warto powtórzyć pomiar po zamianie przewodów L i N doprowadzonych do przetwornicy.

    Opisz proszę dokładniej jak wykonać ten pomiar.

    Ogólnie przetwornica pracuje, napięcie jest dość stabilne oraz nic się w nim nie grzeje. Jedyne co zauważyłem, to że normalnie bez obciążenia transformator nie skwierczy, a kiedy dotknę metalowym śrubokrętem pr-ka od stabilizacji to zaczyna lekko skwierczeć (tak jakby sam dotyk powodował jakieś zaburzenia).
  • Pomocny post
    Poziom 43  
    W takim układzie jeśli izolacja jest dobra prąd powinien być zerowy, jeśli jak podejrzewam jest przebicie to prąd popłynie.
    Problem z zasilaczem impulsowym

    Cytat:

    Jedyne co zauważyłem, to że normalnie bez obciążenia transformator nie skwierczy, a kiedy dotknę metalowym śrubokrętem pr-ka od stabilizacji to zaczyna lekko skwierczeć (tak jakby sam dotyk powodował jakieś zaburzenia).
    Dotykając wprowadzasz napięcie przemienne do obwodu (jesteś anteną zbierającą pole elektryczne z sieci)
  • Poziom 25  
    Miałeś rację.
    Jako rezystora zabezpieczającego użyłem żarówki o mocy 46W, przetwornica startuje, w chwili startu miliamperomierz pokazuje ~25mA, po chwili lawinowo spada i oscyluje ~2mA (żarówka lekko się żarzy). Transformator skwierczy jak wściekły. Obeszło się bez obracania przewodów, za pierwszą próbą.

    Wydaje mi się, że odpowiedź na pytanie co jest nie tak już mamy. A teraz, gdzie szukać tego przebicia?
  • Poziom 43  
    aj123 napisał:
    Wydaje mi się, że odpowiedź na pytanie co jest nie tak już mamy. A teraz, gdzie szukać tego przebicia?
    Nie wiem dokładnie jak wygląda twój projekt zarówno schemat jak i PCB, skoro to twoja modyfikacja przetwornicy Qwet-a. W solidnie wykonanych przetwornicach stronę pierwotną od wtórnej oddziela szeroka przerwa izolacyjna zarówno ścieżki jak i elementy są daleko od siebie, jeśli tak jest u ciebie, powinno się dać na pierwszy rzut oka stwierdzić gdzie przebicia na pewno nie ma. Reszta to elementy które łączą obydwie strony zapewniając izolację - transformator i transoptor (zgaduję nie mając schematu) te elementy trzeba sprawdzić no chyba że są jeszcze jakieś inne.

    Wstępnie można sprawdzić omomierzem, ale taki pomiar nie daje pewności, izolację zawsze sprawdza się miernikami pracującymi z wysokim napięciem bo niektóre przebicia mogą sie ujawnić dopiero przy wyższych napięciach, mierniki do pomiarów izolacji dają co najmniej kilkaset V.

    Normy wymagają aby izolacja wytrzymała znacznie więcej np EN 60335-1 przewiduje że urządzenie II klasy izolacji powinno wytrzymać 3kV pomiędzy stroną pierwotną a wtórną (trochę uprościłem)
  • Poziom 25  
    W załączniku schemat oraz PCB.
    Co do PCB to akurat było w lekkiej przebudowie (stąd kilka "niedociągniętych" ścieżek). Lecz część wysokich napięć jest identyczna oraz odległości jakie oddzielają te ścieżki również jak w moim układzie.

    Być może za mało izolacji dałem w transformatorze głównym lub w którymś z pomocniczych?

    EDIT:
    Wpadłem na pewien pomysł. Gdybym tak wylutował transformator główny i w jego miejsce podłączył żarówke? Mógłbym w ten sposób sprawdzić czy zniknęło przebicie w głównym transformatorze, ewentualnie powtórzyć to samo z przekładnikiem?
  • Poziom 43  
    aj123 napisał:
    Wpadłem na pewien pomysł. Gdybym tak wylutował transformator główny i w jego miejsce podłączył żarówke? Mógłbym w ten sposób sprawdzić czy zniknęło przebicie w głównym transformatorze, ewentualnie powtórzyć to samo z przekładnikiem?

    Jak wylutujesz transformator to możesz sprawdzić go na przebicie w zewnętrznym układzie.

    Żarówka w miejscu transforatora - nie widzę sensu.
  • Poziom 25  
    Nie mam zewnętrznego układu.
    Tym wlutowaniem żarówki zamiast trafa gównego mógłbym sprawdzić czy przekładnik/trafko sterujące nie ma przebicia. Chyba, że to z góry niepotrzebny pomysł, to wtedy skupię się tylko na głównym trafie.
  • Poziom 43  
    aj123 napisał:
    Nie mam zewnętrznego układu.
    Tak jak poprzednio chodziło mi o układ złożony z (względnie) wysokiego napięcia, jakiegoś ogranicznika prądu i amperomierza.
  • Poziom 25  
    Kurde, nie wiem jak coś takiego powinno wyglądać. Może po prostu nawinę trafo jeszcze raz, dając grubszą warstwę izolacji?

    Przy okazji, przyjrzałeś się płytce?
  • Pomocny post
    Poziom 43  
    Cytat:
    Kurde, nie wiem jak coś takiego powinno wyglądać.

    Problem z zasilaczem impulsowym
    Jak nie masz pod ręką wyższego napięcia to użyj sieciowego.

    Cytat:
    Może po prostu nawinę trafo jeszcze raz, dając grubszą warstwę izolacji?
    Ale nie wiesz które

    Cytat:
    Przy okazji, przyjrzałeś się płytce?
    Tak, odstęp jest i raczej nie łatwo o przebicie na PCB jeśli nie będzie wilgoci, na etapie projektowania łatwo było by dać większe.
  • Poziom 25  
    Przetestowałem transformator główny.
    Uzwojenie pierwotne podłączone pod 230V, uzwojenie wtórne przez miliamperomierz z żarówką do drugiego przewodu 230V (ciężko powiedzieć, który jest fazowy, a który neutralny).

    Przy pierwszej próbie miernik pokazuje 0.00mA (miernik z dokładnością do 1%), po obróceniu przewodów sieciowych pokazuje 0.02mA (to nie jest błąd bo pokazuje taki wynik tylko przy tym jednym podłączeniu, po odłączeniu lub zamianie kabli zawsze spada do 0.00mA).

    Teoretycznie prąd ten powinien być zerowy, jednak coś się tam dzieje. Pytanie brzmi czy jest to wina transformatora głównego czy sprawdzać dalej?
  • Poziom 43  
    aj123 napisał:
    Teoretycznie prąd ten powinien być zerowy, jednak coś się tam dzieje. Pytanie brzmi czy jest to wina transformatora głównego czy sprawdzać dalej?

    Sprawdzać dalej, nie jest to przyczyna wyzwolenia różnicówki 30mA.
  • Poziom 25  
    Problem rozwiązany.
    Okazało się, że przebicie miało miejsce w transformatorze sterującym, choć nadal nie wiem jak to się stało. W każdym razie nawinąłem go na nowo i prąd upływu wynosi teraz <0,01mA.

    Dziękuję za pomoc.