Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Falownik LS S100 i regulacja PID

21 Lip 2017 17:46 975 3
  • Poziom 20  
    Witam

    Mam falownik LS 0185s100-4EOFNM z dodatkowym wyświetlaczem ciekłokrystalicznym, do tego podpięta pompa 18,5kW która pompuje wodę do nawodnień. Za pompą jest kilkanaście zaworów do podlewania i w zależności jaki zawór jest otwarty to ciśnienie jest różne, zależy mi żeby było stałe na poziomie powiedzmy 7 barów. Przy 50 Hz ciśnienie w zależności od zaworu jest 7,5-10 bar. Na linii założony przetwornik ciśnienia 0-16 bar 4-20mA oraz naczynie przeponowe oczywiście.

    Problem polega na uruchomieniu regulatora PID. Po wstępnych problemach z zadziałaniem, udało się. Wydawało się że wszystko działa, znaczy się ciśnienie niższe od założonego było podnoszone do zadanego i odwrotnie po kilku takich cyklach, coś się popierdzeli*o. Teraz falownik startuje i goni do pełnych 50 Hz.

    Przetwornik zapięty pod styki VR i I2, DIP przestawiony na pomiar prądu. W pozycji monitor wejścia I2 widzę prąd z czujnika i zmienia się od 4mA (brak ciśnienia) do 12-13 mA (około 10 bar). Sterowanie częstotliwością zmienione z klawiatury na wejście I2. Procesor PID uruchomiony, jednostki przestawione na bar i skalibrowane.

    Zastanawiają mnie 3 wartości:
    - PID Output- 10,2 bar
    - PID Ref Value- 7,004 bar
    - PID FDB Value- 8,5 bara
    Nastawa referencyjna PID ustawiona na 41,2 % czyli 7 bar.

    Falownik się "rozpędza", mija 7 barów i dobija do 50Hz, co daje 8,5 bara.
    Wcześniej bez żadnych zmian parametrów mijał 7 barów i zwalniał, spadało poniżej 7 barów, aż znalazł punkt środkowy. Tak to działało jakieś 5 minut.
    Dlaczego parametr PID Output jest aż 10,2 bara?
    Wygląda jakby regulator PID się zawiesił, falownik był resetowany- nie pomogło.

    Proszę o jakieś podpowiedzi, bo pierwszy raz uruchamiam PID a wydaje mi się że dali mi najbardziej skomplikowany falownik jaki był.
    Z tego co podglądałem falownik schneider electric jest dużo prostszy w konfiguracji. Przynajmniej można zadać bezpośrednio bary a nie procenty.

    Z góry dzięki za pomoc
    Darmowe szkolenie: Ethernet w przemyśle dziś i jutro. Zarejestruj się za darmo.
  • Poziom 12  
    https://www.elektroda.pl/rtvforum/posting.php?mode=reply&t=3361471 strona 150
    Cytuję
    AP.16 PID Output Wyświetla istniejącą wartość wyjściową sterownika PID. Jednostka, wzmocnienie, oraz skala które były ustawione w AP. 42-44 mają zastosowanie dla wyświetlacza.
    AP.17 PID Ref Value Wyświetla istniejącą wartość referencyjną dla sterownika PID. Jednostka, wzmocnienie, oraz skala które były ustawione w AP. 42-44 mają zastosowanie dla wyświetlacza.
    AP.18 PID Fdb Value Wyświetla wartość wejściową sterownika PID która jest zawarta w najnowszym sprzężeniu zwrotnym. Jednostka, wzmocnienie, oraz skala które były ustawione w AP. 42-44 mają zastosowanie dla wyświetlacz

    To potwierdza, że Twój falownik przesterował i nie radzi sobie z powrotem w dół. Sprawdź nastawy, AP. 22, AP.23, AP.24, może ktoś pogrzebał, bo chciał coś ulepszyć, i spowodował, że układ zaczął uciekać do góry, a że jest ograniczony wartością maksymalną, ty wyżej nie pójdzie.
    A reset mógł tylko zaszkodzić
  • Poziom 20  
    Co znaczą które wartości to wiem, tylko nie rozumiem dlaczego AP.16 PID idzie do oporu i nie reaguje w dół.

    AP.22 jest 50% (domyślnie)
    AP.23 jest 10 sec (domyślnie)
    AP.24 jest 0 msec (domyślnie)
    Zmieniając te parametry nie ma żadnej różnicy.

    Jedyne zmienione parametry to AP.01, AP.19, AP.21, AP.30, AP.32, AP.42, AP.43, AP.44

    Jest opcja żeby regulator PID się zawiesił, wyłączył lub padł z jakiegoś powodu?

    Na tą chwilę falownik chodzi tylko ma ustwioną częstotliwość na 46,5 Hz żeby lekko ciśnienie zredukować, bo mi instalacje uszkadza na 50Hz.
  • Poziom 20  
    Witam po długiej przerwie ale zapierdziel w robocie i czas szybko leci.
    Temat ogarnięty, wystarczyło przywrócić ustawienia fabryczne i od nowa ustawić wszystko. Działa od strzału. Trochę wolno reaguje, bo po przekroczeniu ciśnienia wolno obniża Hz, ale próba regulacji AP.25 i Ap.27 jedynie pogarsza sytuacje bo układ robi się niestabilny. Jednak chłopaki od nawodnień zadowoleni i akceptują drobne wachnięcia o 0,5 bara przez 5-7 sekund.
    Jedynie po 2 tygodniach padł mi czujnik ciśnienia- zaczął oszukiwać o 2 bary w stosunku do manometru. Mam nadzieję że to jednorazowe.