Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Implusowy pobór prądu, a spadki napięcia zasilania i wzbudzanie się układu

nwcnwc 24 Lip 2017 13:46 486 11
  • #1 24 Lip 2017 13:46
    nwcnwc
    Poziom 5  

    Mam pewien problem, zasilam swoje urządzenie audio oparte na mikrokontrolerze z ładowarki od telefonu różnych modeli 5V prąd 1-2,5A. W momencie zwiększenia poziomu głośności, wzrasta implusowo pobór prądu, co skutkuje spadkiem napięcia i chyba wzbudzeniem się układu bo zaczyna trzeszczeć i trzeba zresetować mikrokontroler. Pobór prądu to tylko około 100-150mA na tym poziomie głośności, więc zasilacza nie katuje do granic możliwości. Wzmacniacz audio to 2x3W ale mogę z niego wycisnąć około 1/7 maksymalnej mocy.
    - filtracja zasilania dla mikrokontrolera - jest
    - dałem kondensator 470uF, który powinien przytrzymać to napięcie - nie pomogło
    - różne ładowarki - nie pomogło
    Czy ma ktoś jakieś pomysły jak to zabezpieczyć przed wzbudzaniem lub spadkami napiecia choć na tych 4,3V do którego spada też powinno to działać.

    0 11
  • #2 24 Lip 2017 14:05
    neo_dc
    Poziom 32  

    Zasil owo urządzenie z baterii - zobaczysz, czy zjawisko, które opisujesz leży w zasilaniu czy gdzie indziej. Daj znać o wynikach.

    0
  • #3 24 Lip 2017 14:08
    jarek_lnx
    Poziom 43  

    Masz oscyloskop, mierzyłeś to?

    470uF to nie jest duży kondensator przy prądzie 0,5A w ciągu 1ms napięcie na nim spadnie o 1V

    nwcnwc napisał:
    Czy ma ktoś jakieś pomysły jak to zabezpieczyć przed wzbudzaniem lub spadkami napiecia choć na tych 4,3V do którego spada też powinno to działać.
    Mikrokontroler pobierający prąd o wiele mniejszy niż wzmacniacz można wyposażyć w dodatkowy kondensator filtrujący oddzielony od zasilania wzmacniacza rezystorem lub cewką lub diodą Schottky-ego, tak aby podczas chwilowych spadków napięcia kondensator ten nie był rozładowywany przez wzmacniacz.

    Piszesz o wzbudzeniu na czym ono miało by polegać?

    Co to za wzmacniacz? klasa D? może to zjawisko bus-pumping?

    0
  • #4 24 Lip 2017 14:22
    nwcnwc
    Poziom 5  

    Zasiliłem z ogniwa li-ion 18650 o napięciu około 4,1V, wszystko działa dobrze. Wzmacniacz to PAM8403 czyli klasy D. Oscyloskopu niestety nie mam więc ciężko mi uchwycić jak mocno spada to napięcie impulsowo.

    Wzbudzanie jak to nazwałem polega na pykaniu z głosnika/trzeszczeniu/piszczeniu pomaga reset mikrokontrolera jedynie, czasem się resetuje również przy tym.

    0
  • #5 24 Lip 2017 14:28
    Rezystor240
    Poziom 33  

    Zasilasz układ, do tego wzmacniacz m:cz jakąś badziewna impulsową ładowarka. Masakra.
    Weź transformator o odpowiednim napięciu i wydajności prądowej.
    Zastosuj mostek prostowniczy i jakiś kondensator przynajmniej 4700µF, zwłaszcza, że to wzmacniacz m:cz gdzie zasilanie powinno być 'czyste' pod względem tętnień.
    Zobaczysz to na oscyloskopie.

    Dodano po 4 [minuty]:

    nwcnwc napisał:
    Zasiliłem z ogniwa li-ion 18650 o napięciu około 4,1V, wszystko działa dobrze.

    Czyli wina leży po stronie zasilacza.
    Zrób tak jak pisałem, dołóż stabilizator LM7805 i można dodatkowo dorzucić tranzystor wykonawczy.

    0
  • #6 24 Lip 2017 16:23
    jarek_lnx
    Poziom 43  

    Cytat:
    Zastosuj mostek prostowniczy i jakiś kondensator przynajmniej 4700µF
    A może wystarczy dołożyć taki kondensator do zasilacza impulsowego, zalecał bym zacząć od dodawania kondensatorów o różnych wartościach od 1000uF do kilkunastu tysięcy uF.

    ->Rezystor240 Większość współczesnych wzmacniaczy audio to wzmacniacze impulsowe (klasa D), podobnie jak zasilacze, w sklepach zasilaczy liniowych od dawna nie dostaniesz, trzeba się do tego przyzwyczaić, że to jest typowe rozwiązanie i tylko w szczególnych przypadkach warto się zastanawiać nad stosowaniem staroświeckiego zasilacza liniowego.

    ->nwcnwcSprawdź czy te twoje zasilacze naprawdę dają takie prądy jak na tabliczce znamionowej, ten wzmacniacz z dwoma głośnikami 4Ω może pociągnąć w impulsie 2,5A

    0
  • #7 24 Lip 2017 16:45
    Rezystor240
    Poziom 33  

    jarek_lnx napisał:
    Większość współczesnych wzmacniaczy audio to wzmacniacze impulsowe (klasa D), podobnie jak zasilacze, w sklepach zasilaczy liniowych od dawna nie dostaniesz, trzeba się do tego przyzwyczaić, że to jest typowe rozwiązanie i tylko w szczególnych przypadkach warto się zastanawiać nad stosowaniem staroświeckiego zasilacza liniowego.


    Powiem tak, zasilaczy impulsowych nie lubię.
    Choć mają wiele zalet:
    -Nie zajmują wiele miejsca, w porównaniu z zasilaczem transformatorowym.
    -Są lekkie.
    -Mają szeroki zakres napięć wejściowych.
    -Nie pobierają tak dużo energii z sieci, podług zasilaczy transformatorowych/liniowych gdzie nadmiar energii jest wytracany w postaci ciepła.
    Mają też wady, przez które ich nie lubię:
    -Zakłócają radio na falach długich i średnich (tak wiem, że nie wszystkie ale większość ma tę przypadłość)
    -Zasilacz taki podczas usterki może 'wypuścić' napięcie wejściowe na wyjście.
    -Napięcie z takiego zasilacza trudno odfiltrować tak jak w przeciwieństwie do zasilacza liniowego.

    Więc ja wolę stosować 'stare staroświeckie zasilacze'.

    0
  • #8 24 Lip 2017 16:50
    nwcnwc
    Poziom 5  

    Sprawdziłem na zasilaczu liniowym, który sam zrobiłem działa pięknie, ale nie chce wkładać dodatkowo do obudowy zasilacza liniowego tym bardziej że obudowa jest z drewna.
    @jarek_lnx Skombinuje taki duży kondensator i sprawdzę czy to pomogło, a ładowarek nie mam za bardzo jak stestować bo amperomierz tylko do 200mA aktualnie mam, choć jeden z nich wydaje się solidny zasilacz do raspberry PI 5,2V 2500mA

    @edit jeszcze jedna mała rzecz o której musze wspomnieć zasilane z USB 3.0 z komputera z dobrym zasilaczem też nie działa poprawnie.
    @edit2 czy mogę połaczyć przykladowo 10 sztuk 470uF równolegle?

    0
  • #9 24 Lip 2017 17:00
    Rezystor240
    Poziom 33  

    nwcnwc napisał:
    ale nie chce wkładać dodatkowo do obudowy zasilacza liniowego tym bardziej że obudowa jest z drewna.


    Co za problem?
    Odpowiednio duży radiator i wymuszone chłodzenie, poprzez wentylator.
    I niema prawa się zapalić.

    0
  • #10 24 Lip 2017 23:14
    Urgon
    Poziom 36  

    AVE...

    Rozwiązanie już podano: dać duży kondensator filtracyjny, by energia w miarę potrzeby była brana z niego, a nie z zasilacza, który może nie dać potrzebnego w impulsie prądu...

    @Rezystor240
    Technicznie rzecz biorąc to praktycznie wszystkie sieciowe zasilacze impulsowe mają galwaniczną izolację wejścia od wyjścia, więc nawet jak taki zasilacz wybierze papieża, to na wyjściu nie ma prawa pojawić się napięcie wejściowe...

    0
  • #11 24 Lip 2017 23:26
    Rezystor240
    Poziom 33  

    @Urgon

    Tak wiem, że ma separację galwaniczną od napięcia sieciowego.
    Tak samo jak transformator w zasilaczu liniowym, też separuje galwanicznie napięcie sieciowe od reszty układu.
    Myślę, że to nie jest najlepszy temat do porównywania wyższości zasilaczy.

    0
  • #12 28 Lip 2017 11:40
    nwcnwc
    Poziom 5  

    Niestety ale z zasilaczami implusowymi się nie lubi mój układ.
    Sprawdziłem jeszcze jedną rzecz, zasiliłem z zasilacza 12V impulsowego taki układ. Bo akurat nie miałem trafa.
    Implusowy pobór prądu, a spadki napięcia zasilania i wzbudzanie się układu
    Tranzystor jest na sporym radiatorze nie mam jego parametrów, ale ma rozmiar ok 10x4cm. I działa bardzo dobrze, ale jest mi ten zasilacz potrzebny do czego innego.

    Chciałbym zbudować coś podobnego ale z pominieciem C12,C10 i R7 no i z pominieciem mostka prostowniczego, ale jak sobie policzyłem to dla takich małych radiatorków mocowanych na tranzystor na płytce co mają Rth = 21W/K, to będzie się bardzo grzać dla pełnej mocy. Pomyślałem żeby dodać wcześniej jakieś diody prostownicze lub rezystory w emiter tranzystora, które trochę przechwycą mocy bo i tak LM7805M potrzebuje jedynie 8V na wejściu, a nie mam zasilacza 9V. Amperomierz też mam na ten moment jedynie do 200mA, więc nie jestem w stanie określić ile mocy potrzebuje układ dla pełnej głośności.
    Proszę o pomysł, jak rozwiązać problem z wydzielaną mocą. Pozdrawiam

    @edit mam gdzieś rezystor 0,5ohm to zmierze prad z użyciem bocznika i będe myslał dalej jak będe wiedział ile mocy

    @edit2 już po pomiarach prąd rzeczywiście jest pobierany impulsowo jedynie na dwóch pierwszy poziomach głośności nie wystepuje to, a właśnie dla tego poziomu wszystko działa ok na impulsowym.
    Reasumując Pobór prądu przez układ to około 100mA-850mA(w impulsie co udało się odczytać z woltomierza) średni prąd zakładam w najgorszym przypadku, że jest 25% niższy czyli 640mA. Moc pobierana przez obciążenie to 3,2W.
    Z dalszych obliczeń wynika że na tranzystorze wydzieli się 4.0-4.5W mocy.

    Rths-a = 21K/W - rezystancja termiczna radiatora
    Rthj-case = 1,4K/W - rezystancja termiczna złącze - obudowa
    Tj = 27+(21K/W+1,4K/W)*4,5W=128°C
    Tjmax = 150°C

    0