Elektroda.pl
Elektroda.pl
X
Oscyloskop cyfrowy Siglent SDS1104X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

MOSFET przełączanie, brak strat mocy

volan223 06 Sie 2017 00:43 1485 10
  • #1 06 Sie 2017 00:43
    volan223
    Poziom 3  

    Cześć wszystkim.
    Robię projekt na studia, który opiera się na analizie tranzystora MOSFET. Jednakże napotkałem na problem, który dotyczy przełączania. Otóż, podczas załączania, prąd drenu zaczyna rosnąć dopiero wtedy, gdy napięcie dren-źródło spadnie do zera. Wychodzi wtedy na to, że nie ma w ogóle strat, co wydaje mi się trochę dziwne. Druga sprawa, że nie wiem jak w takim przypadku określić czas tego załączania. W celu zobrazowania, zamiast wyglądać to tak:
    MOSFET przełączanie, brak strat mocy

    To wygląda tak:
    MOSFET przełączanie, brak strat mocy

    Niżej jest zrobiony wykres w excelu ze zrzuconych danych z oscyloskopu.

    Wrzucam screen z oscyloskopu:
    MOSFET przełączanie, brak strat mocy

    Dodam, że jest to low-side switch, obciążenie rezystancyjne, z tym że przy tych 5kHz, które są widoczne na oscylogramie, indukcyjność odbiornika wyniosła 100mH. Wraz ze wzrostem częstotliwości malała.
    Czy powinno to tak wyglądać? Nie wiem teraz w jaki sposób mam wyznaczyć czas załączania i określić straty mocy, bo ich brak wydaje mi się odrobinę dziwny.

    0 10
  • Oscyloskop cyfrowy Siglent SDS1104X
  • #2 06 Sie 2017 08:26
    _lazor_
    Moderator Projektowanie

    Daj schemat układu, bez niego nie ma czego analizować

    volan223 napisał:

    Dodam, że jest to low-side switch, obciążenie rezystancyjne, z tym że przy tych 5kHz, które są widoczne na oscylogramie, indukcyjność odbiornika wyniosła 100mH. Wraz ze wzrostem częstotliwości malała.


    Indukcyjność nie mogła maleć... co najwyżej impedancja obciążenia mogła maleć...

    Jeśli odbiornik ma 100mH indukcyjności, to już nie jest to obciążenie rezydencyjne, tylko jakaś
    cewka, która może powodować pracę w ZVS (zero voltage switching).

    0
  • Oscyloskop cyfrowy Siglent SDS1104X
  • #3 06 Sie 2017 08:54
    jarek_lnx
    Poziom 43  

    Zacznę od tego że oscyloskop ustawiłeś tak żeby nie było nic widać, dane wyeksportowane do excela to potwierdzają, mała rozdzielczość i duże szumy - próbowałeś rozciągnąć w X i w Y ale to trzeba było zrobić na oscyloskopie - na ekranie ma być widać to co chcesz zobaczyć, jeśli nie da sie ustawić tak żeby wszystko było widać na raz to trzeba powiększyć każdy interesujący fragment oddzielnie (zbocze narastające i opadające). A jak chcesz oglądać zbocza to lepiej każdy przebieg powiększyć tak żeby zajmował ponad połowę wysokości ekranu.

    Oglądając zbocze opadające na Ch3 zwiększaj czułość toru Y uważając na to aby nie przekroczyć punktu w którym przebieg zostaje nieproporcjonalnie zniekształacony z powodu że (niewidoczne wtedy) zbocze narastające przesteruje tor Y, w oscyloskopie przebieg ma prawo wyjść "poza" ekran, oscyloskopy dobrych firm (widzę że pracujesz na Tektronix-ie) mają duzy zapas dynamiki i są szanse że da sie to powiększyć tak żeby było wyraźnie widać. Jak nie to można dobudować ogranicznik napięcia który obetnie te 250V (tylko na potrzeby oglądania zbocza opadającego) narastające obejrzysz na 50V/div tylko nie w tej skali czasu.

    Cytat:
    Dodam, że jest to low-side switch, obciążenie rezystancyjne, z tym że przy tych 5kHz, które są widoczne na oscylogramie, indukcyjność odbiornika wyniosła 100mH.
    Czy ty wiesz o czym piszesz? Masz obciążenie RL indukcyjność jest duża więc przy załączaniu prąd narasta jeszcze długo po załączaniu tranzystora, odwrotny efekt będzie przy wyłączaniu, prąd będzie płynął długo (w stosunku do czasu przełączania) po wyłączeniu tranzystora - przebicie lawinowe.

    0
  • #4 06 Sie 2017 13:10
    volan223
    Poziom 3  

    Dzięki za odpowiedzi. Faktycznie jest to praca w ZVS. Dopiero wczoraj się dowiedziałem, że coś takiego jest. Straty mocy mam tylko podczas wyłączania. Dzięki za pomoc. Temat można zamknąć.

    0
  • #5 06 Sie 2017 14:39
    jarek_lnx
    Poziom 43  

    To nie jest ZVS, ponieważ napięcie na kluczu w chwili włączania nie jest zerowe, po prostu indukcyjność ogranicza szybkość narastania prądu, bardziej pasowało by określenie ZCS.

    0
  • #6 06 Sie 2017 19:14
    _lazor_
    Moderator Projektowanie

    jarek_Inx ZVS zachodzi gdy przewodzi dioda na mosfecie, bo nie ma siły by wtedy przełączenie następowało w napięciu na DS. Fakt, że wpierdzielenie indukcyjności na obciążenie nie gwarantuje ZVS, gdyż układ może zacząć drgać i przełączać się w napięciu.

    ZCS na pewno nie, gdyż ZCS idzie osiągnąć tylko w układach drgających (quazirezonansowych lub rezonansowych) I to zazwyczaj jest tylko przybliżenie, bo w zerowym prądzie nigdy się nie przełączy.

    0
  • #7 06 Sie 2017 22:16
    jarek_lnx
    Poziom 43  

    Cytat:
    jarek_Inx ZVS zachodzi gdy przewodzi dioda na mosfecie, bo nie ma siły by wtedy przełączenie następowało w napięciu na DS. Fakt, że wpierdzielenie indukcyjności na obciążenie nie gwarantuje ZVS, gdyż układ może zacząć drgać i przełączać się w napięciu.
    Piszesz wg teorii, a ja patrzę praktycznie na to co sie dzieje w tym układzie, widzisz screen z oscyloskopu - załączenie trwa 50us wyłączenie 150us (częstotliwość 5kHz) drgania w obwodzie L cewki i (zapewne jedynej pojemności w układzie) - Coss mosfeta gasną po kilku us, jakim cudem po kolejnych stu-kilkudziesieciu mikrosekundach miało by cokolwiek drgać? W tym układzie przy tej częstotliwości nie ma i nie będzie ZVS.

    0
  • #8 06 Sie 2017 22:39
    _lazor_
    Moderator Projektowanie

    Oscylogramów nie mamy dokładnych, co sam pisałeś w jednym z poprzednich postów. Tak czy siak, prawdopodobnie nie ma tutaj ani ZVS ani ZCS, a oscylogramy są zbyt małej dokładności by cokolwiek powiedzieć. Jak autor wrzuci zmieni rozdzielczość czasu i pokaże jeszcze raz oscylogramy, to się pozastanawiamy ponownie.

    0
  • #9 07 Sie 2017 00:34
    volan223
    Poziom 3  

    Generalnie, w najbliższym czasie nie dam rady wrzucić oscylogramów w innej rozdzielczości, bo dostęp do sprzętu mam tylko na uczelni. Mogę dorzucić oscylogram z częstotliwości 100kHz, jeżeli to w czymś pomoże. Mimo wszystko, w każdym pomiarze prąd drenu załączał się dopiero, gdy napięcie dren-źródło spadło do zera. Straty mocy obliczyłem tylko przy wyłączaniu. Swoją drogą dziwi mnie to, że jest tak duża indukcyjność, skoro odbiornikiem są połączone szeregowo-równolegle same rezystory. Rozumiem, że ze ścieżek mogą jakieś występować, ale aż takie?

    MOSFET przełączanie, brak strat mocy

    Dodam jeszcze, że badany tranzystor jest wysokonapięciowy, przez którego przepuszczałem napięcie tylko od 5 do 20V. Jeżeli ma to jakiekolwiek znaczenie.

    0
  • #10 07 Sie 2017 19:41
    jarek_lnx
    Poziom 43  

    volan223 napisał:
    Mimo wszystko, w każdym pomiarze prąd drenu załączał się dopiero, gdy napięcie dren-źródło spadło do zera. Straty mocy obliczyłem tylko przy wyłączaniu. Swoją drogą dziwi mnie to, że jest tak duża indukcyjność, skoro odbiornikiem są połączone szeregowo-równolegle same rezystory. Rozumiem, że ze ścieżek mogą jakieś występować, ale aż takie?
    Prąd narasta ze stałą czasową 0,5us, rezystancja w obwodzie 5Ω, czyli indukcyjność ok 2,5uH nie wiem skąd wzięło ci się 100mH.
    3uH to nadal dosyć dużo jak na same rezystory, podobną indukcyjność ma 2m przewodu. A czy źródło napięcia podczas załączania tranzystora nie "siada"?

    0
  • #11 07 Sie 2017 20:09
    volan223
    Poziom 3  

    "Nie siada" to znaczy? Nie zaobserwowałem nic dziwnego. Rezystancja wynosi dokładnie 5,64Ω. Co prawda odbiornik nie jest na jednej płytce wraz z całym układem. Został podłączony do drenu krótkim przewodem, który miał tak na oko z 20cm.

    0