Elektroda.pl
Elektroda.pl
X
Elektroda.pl
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

PGA2311 - Pobieranie dużego prądu dla zasilania cyfrowego.

nik156 17 Sie 2017 02:10 462 3
  • Poziom 18  
    Witam, mam problem z PGA2311. Jakiś czas temu zrobiłem sobie projekcik na PGA2310 który działa bardzo fajnie. Ale ostatnio wpadło mi kilka szt pga2311 i zrobiłem na nim układ. Niestety problem polega na tym że zasilam digital z standby 24/7, a analog z zasilacza na LM317/lm337. Niestety układ zachowuje się inaczej niż PGA2310 ponieważ bez zasilania Analogowego pobiera on ok 60mA prądu z zasilacza standby. Po zasileniu analogu wszystko wraca do normy, układ działa prawidłowo, gra, nic nie buczy itp. Gdy wyłączę zasilacz od analogu znów układ pobiera dużą wartość napięcia.
    Co może być powodem takiego zjawiska, może ktoś ma PGA i może to sprawdzić? Co się stanie jak podamy na PGA zasilanie tylko na cyfrowe zasilanie. Może programowo można by wyłączyć SPI tak by CS został w stanie niskim ponieważ aktualnie to stan wysoki +5V.
  • Poziom 29  
    nik156 napisał:
    Gdy wyłączę zasilacz od analogu znów układ pobiera dużą wartość napięcia.

    A może prądu?

    Zobacz czy nie masz gdzieś zwarcia na wyjściu.
    Według noty katalogowej typowy prąd pobierany w spoczynku to 10mA, prąd podczas zwarcia 50mA. Razem by się sumowało do Twojego pomiaru.
  • Poziom 18  
    Tak, ale gdy zasilę układ tak jak powinien to wszystko wraca do normy. Poza tym PGA2310 w tej samej płytce działa prawidłowo. Nawet gdy zasianie jest tylko dla części cyfrowej.


    Czy ktoś z obecnych zna lub ma projekt gdzie zasila osobno cześć cyfrową i analogową?

    Da się jakoś ustawić atmega by SPI było w stanie uśpienia? Soft Tak by ATmega nie dawała napięcia na PGA.