Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

ASUS R510JK - Laptop nie korzysta z zewnętrznego mikrofonu

Hidereq 18 Sep 2017 22:53 2439 12
  • #1
    Hidereq
    Level 5  
    Witam,

    Przedwczoraj zakupiłem sobie słuchawki HyperX Cloud Core z wbudowanym mikrofonem, z którego laptop niestety nie potrafi zacząć korzystać. W laptopie (ASUS R510JK) mam jedno wejście słuchawkowe, po podłączeniu do tego wejścia sluchawek (jack 4 pinowy od słuchawek) pojawia się okno programu SmartAudio, który jest instalowany razem ze sterownikami Conexant. Jeśli w tym oknie zaznaczę, że podłączyłem zestaw słuchawkowy, dźwięk jest przekierowywany na słuchawki, jednak mikrofon nie reaguje. Jeśli zaznaczę, że podłączyłem zewnętrzne głośniki to działają słuchawki oraz mikrofon wbudowany do laptopa.

    Zainstalowałem najnowsze sterowniki ze strony Asusa (Conexant Smart Audio HD wer. 8.65.41.50), próbowałem całkowicie odinstalować sterownik i zainstalować ponownie. Mikrofon jest na pewno sprawny, ponieważ sprawdzałem go na komputerze stacjonarnym, tam mam sterownik Realtek i wszystko działa.

    W menedżerze urządzeń nie ma żadnych wykrzykników ani nic takiego, wszystko wydaje się być w porządku.
    W ustawieniach audio Windowsa (mam Windowsa 7) , w "Urządzeniach do nagrywania" widnieją dwie pozycje, "Mikrofon (Conexant SmartAudio HD) oraz "Mikser". "Mikrofon" reaguje tylko wtedy, gdy w SmartAudio zaznaczę, że podpięte zostały głośniki zewnętrzne, jak pisałem. W przeciwnym wypadku zielone kreski po prawo wcale się nie podnoszą nawet podczas dmuchania w mikrofon w słuchawkach.
    W ustawieniach mikrofonu wszystko jest ok, głośność na 100%, żadnych dziwnych opcji, bo jak mówiłem mikrofon wbudowany działa bez problemu, a po podłączeniu słuchawek nic się w tych opcjach nie zmienia więc też powinno być wszystko ok.
    Próbowałem znaleźć rozwiązanie w internecie ale zazwyczaj kończyło się na tym, że dany wątek nie był zakończony żadnym sensownym rozwiązaniem.

    Jakieś pomysły co mogę zrobić żeby ten mikrofon zaczął działać?

    Pozdrawiam, Łukasz.
    Ethernet jednoparowy (SPE) - rozwiązania w przemyśle. Szkolenie 29.09.2021r. g. 11.00 Zarejestruj się za darmo
  • #2
    User removed account
    Level 1  
  • #3
    Hidereq
    Level 5  
    Problem polega na tym, że nawet jak podlacze sam mikrofon jackiem 3 pinowym (do zestawu miałem dołączone rozgalezienie) to wtedy mikrofon również nie działa (albo działa a nie działają wbudowane głośniki, bo laptop myśli ze podłączony jest cały zestaw? Nie wiem).

    Nie wiesz czy da się może na moim sprzęcie zainstalować sterowniki realtek? Na realteku wszystko jest ok, ale jak po prostu spróbowałem zainstalować to żaden konfigurator realteka się nie zainstalował (Realtek HD Audio czy cos)

    Dodano po 10 [godziny] 37 [minuty]:

    Po podłączeniu samego mikrofonu nic się nie pojawia, dodatkowo komputer myśli że podłączane są słuchawki i wyłącza dźwięk z głośników. Sam mikrofon także nie działa gdyż nie podnoszą się ani trochę zielone kreski w "Nagrywaniu" obok mikrofonu. Nie mam nawet możliwości wyboru w opcjach sterownika, że podłączyłem sam mikrofon, zawsze jest to albo "Zestaw słuchawkowy" albo "Głośniki zewnętrzne".
    Jakiś pomysł co zrobić aby opcja że podłączam ten mikrofon się pojawiła?
  • #4
    User removed account
    Level 1  
  • #5
    Hidereq
    Level 5  
    Tylko jak je znaleźć ;) Nie wiem czy wgl mogę zainstalować sterowniki inne niż conexant jeśli mam ten układ dźwiękowy :/
  • #7
    Hidereq
    Level 5  
    Dokładnie ten tylko ze z Windowsem 7. Ale jeśli próbowałem odinstalować conexant i zainstalować np realtek to nie dawało rady
  • #8
    User removed account
    Level 1  
  • #9
    Hidereq
    Level 5  
    No tak próbowałem już odinstalować to całe oprogramowanie conexant, dało to tyle ze AudioWizard czy co to tam jest przestał działać no i nic więcej, mikrofon dalej nie był wychwytywany. Ale spróbuję później znaleźć te sterowniki które masz Ty i odpalić je bez conexanta, może to coś da.

    Dodano po 9 [minuty]:

    Na tych bajerach mi nie zależy, chciałbym tylko aby ten mikrofon działał oraz dźwięk leciał ze słuchawek

    Dodano po 5 [godziny] 42 [minuty]:

    Ok więc sprawa wygląda tak. Odinstalowałem ten sterownik conexant, i teraz w menedżerze urządzeń również mam "Urządzenie zgodne z High Definition Audio", nie mam tego Intel(R) Audio dla ekranów. Plusem tego jest to, że w Urządzeniach do nagrywania pojawił się drugi mikrofon, natomiast zniknął "Mikser" który był tam wcześniej. A więc są teraz 2 mikrofony. Ten wyżej to mikrofon wbudowany w laptopa, działa tak jak działał. Natomiast ten na dole to zdaję się być mikrofon ze słuchawek, ponieważ jak odłączę jacka to wyświetla się, że nie podłączono. Wszystko fajnie. Tylko, że nadal nie przechwytuje on dźwięku :/
    Dodam jeszcze tylko, że w menedżerze urządzeń widnieje jeszcze jakiś NVIDIA Virtual Audio Device.

    Powoli zbliżamy się do celu, bo laptop teraz już daje znać, że podłączam do niego mikrofon. Nawet jeśli jest on jednak włączony i ustawiony jako domyślny, nie przechwytuje on dźwięku. Po włączeniu nasłuchiwania słychać jedynie cichy, stały szum, niezależnie od tego co dzieje się z mikrofonem (mogę go nawet wypiąć ze słuchawek bo mam taką możliwość, szum nie ustaje, a komputer wtedy nie orientuje się, że mikrofon został wypięty - muszę wypiąć głównego jacka z laptopa). Sprawdziłem opcje, nic nie jest wyciszone, ani nic z tych rzeczy.
  • #10
    User removed account
    Level 1  
  • #11
    Hidereq
    Level 5  
    A jak mogę wyłączyć sam mikrofon wbudowany w menedżerze urządzeń? Nigdzie go nie widać
  • #12
    User removed account
    Level 1  
  • #13
    Hidereq
    Level 5  
    Niestety wyłączenie wbudowanego mikrofonu nie pomogło, dalej to samo.