Elektroda.pl
Elektroda.pl
X
PCBway
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Emulator zmieniarki dla aut grupy VAG

GrzesiekN 09 Lis 2017 21:27 37092 146
  • #121
    luka_m1984
    Poziom 11  
    Wlodek83 napisał:
    U mnie "coś" się posunęło do przodu w pracy zmieniarki. A tak naprawdę to chyba pomogło wyłączenie radia od zasilania, bo po przyniesieniu radia do domu i podłączeniu, zmieniarka zaczęła pracować.
    Ale nie jest tak do końca dobrze...
    W radiu dalej nie widać żadnej płyty, jednak po włożeniu karty lub pendriva zaczyna odtwarzać. Jeżeli są włożone jednocześnie karta i pendrive nie można pomiędzy nimi przełączać ponieważ radio nie widzi żadnej płyty.
    Najczęściej po pierwszym wyłączeniu radia i ponownym włączeniu coś się zacina. Nie działa przełączanie utworów i po wyłączeniu ponownym radia nie wyłącza się zmieniarka. Radio wówczas nie wysyła żadnego sygnału na wyjściu DATA_OUT. Pomaga odłączenie zasilania od radia lub tylko od zmieniarki, lecz nie jest to regułą. Raz było tak że po włączeniu radia nie działało przełączanie a po ponownym jego włączeniu już tak. Poniżej film z pracy zmieniarki.



    A w dalszym ciągu masz zwarty pin 1 do masy? Jeśli tak to rozłącz go a zewrzyj pin 5 bo z tego co widzę to masz wersję przewlekaną a tam jest inny pinout.
  • PCBway
  • #122
    GrzesiekN
    Poziom 11  
    @luka_m1984 Bardzo mnie ciekawi ten Twój przypadek dziwnego zachowania zasilania. Jeżeli używasz płytki mojego projektu sprawdź proszę jedną sprawę. Dwie sekcje masy łączą się "mostkiem" poprzez dfplayera (piny 7 oraz 10). Może coś jest nie tak z tym połączeniem.
  • #123
    Wlodek83
    Poziom 17  
    luka_m1984 napisał:


    A w dalszym ciągu masz zwarty pin 1 do masy? Jeśli tak to rozłącz go a zewrzyj pin 5 bo z tego co widzę to masz wersję przewlekaną a tam jest inny pinout.


    Tak, cały pinout sobie przeniosłem na moją wersję. Gdybym zawierał 1 pin to by w ogóle nie wystartował bo to reset jest.
  • #124
    szeef
    Poziom 2  
    Wykonałem układ wg schematu na swojej płytce. Po wgraniu programu ruszyło od kopa!
    Ważne żeby ustawić fusebity tak żeby High było 0xD1 a Low 0xE4.
  • #125
    bielak930
    Poziom 9  
    U mnie również odpaliło od pierwszego razu. Mam jednak problem z cichym dźwiękiem(podobnym do emitowanego przez transmitery). Domyślam się, że problem wynika z połączenia masy audio i cyfrowej. Jak to wygląda u was? Masa jest u mnie wzięta z kostki ISO A z pinu 8.
    Emulator zmieniarki dla aut grupy VAGEmulator zmieniarki dla aut grupy VAG
  • #126
    rafi84
    Poziom 24  
    bielak bardzo ładnie wykonana płytka może zamieścisz też swój projekt ??
  • PCBway
  • #127
    figaro
    Poziom 14  
    Witam
    GrzesiekN bardzo fajny projekt
    mam pytanie czy będzie działać z radiem Clarion w Citroenie
    kiedy można się spodziewać wersji z bluetooth?
  • #128
    krisRaba
    Poziom 28  
    A czy ktoś posiada lub natknął się na informacje odnośnie protokołu CDC w Oplu? Radio CD30+mp3 z AUX.
    Chcę zrobić emulator zmieniarki do tego radia, tylko problem w tym, że nie mogę znaleźć info o protokole :-/ Mam w szufladzie moduł BT audio, niby mogę go podłączyć po prostu przez AUXa, a sterownia z kierownicy na bazie komparatora okienkowego, bo z tego co wiem to tam przyciski są na zasadzie dzielników rezystancyjnych różnej wartości... Ale chciałbym trochę ambitniej, tym bardziej że może udałoby się nazwy utworów wrzucić na wyświetlacz itp.
    Myślałem, żeby w takim razie kupić tanio zmieniarkę i ją rozpracować, ale na allegro wyskakują mi albo już emulatory typu yatour, albo zmieniarki Blaupunkta, a to chyba do Astry II, bo tam fabrycznie były Blaupunkty...
    CD30 z tego co kojarzę to produkt GM / Delphi Grundig.
  • #129
    szeef
    Poziom 2  
    U mnie jest trochę ciszej niż z radia, ale nie na tyle żeby był to problem. Wygląda że wejście zmieniarki wymaga mocniejszego sygnału niż daje moduł playera. Ja masę zasilania układu wziąłem z obudowy radia. Dla mnie OK.
  • #130
    luka_m1984
    Poziom 11  
    GrzesiekN napisał:
    @luka_m1984 Bardzo mnie ciekawi ten Twój przypadek dziwnego zachowania zasilania. Jeżeli używasz płytki mojego projektu sprawdź proszę jedną sprawę. Dwie sekcje masy łączą się "mostkiem" poprzez dfplayera (piny 7 oraz 10). Może coś jest nie tak z tym połączeniem.

    Ja swój układ zrobiłem na płytce uniwersalnej- masa jest połączona i dla sygaału audio i dla zasilania. Masa całego układu jest wzięta z obudowy radia więc to chyba nie tutaj problem. @GrzesiekN A tak trochę z innej beczki- jak idą prace z wersją z bluetooth? Posunęło się coś do przodu?
  • #131
    przemyska
    Poziom 7  
    Ja zamiast złącza Aux wpiolem moduł bluetooth, z możliwością podpięcie mikrofonu do zestawu głośnomówiącego, zaprojektowalem nawet płytkę pod ten moduł Ale ma kilka wad które muszę poprawić, jak narazie działa idealnie :)
  • #132
    krawciox
    Poziom 9  
    Z niecierpliwością czekam na wersję z bluetooth.
  • #133
    bielak930
    Poziom 9  
    Mam pytanie do użytkowników emulatora. Czy zauważyliście problemy z obsługą dużej liczby folderów? W moim przypadku podczas zmiany folderu (okolice połowy całkowitej liczby folderów) radio wyświetla informację o braku zmieniarki. Zastanawiam się czy to jest rzeczywiście wina długiego czasu listowania katalogów czy raczej FW dfplayera. Domyślam się, że chodzi o timeout odpowiedzi w transmisji z radiem. Może w kolejnej wersji fw emulatora można byłoby pokusić się o wysyłanie odpowiedzi fałszywej gdy dfplayer nie potwierdził zmiany katalogu?
  • #135
    luka_m1984
    Poziom 11  
    Cytat:
    Ja również mam pewne spostrzeżenia, bardzo irytujące jest to że po każdym odlaczeniu zasilania utwory lecą od początku, przydałoby się coś z tym zrobić, pozdrawiam :)


    Spróbuj podpiąć układ pod stałe zasilanie a nie na 12V ze zmieniarki. Wtedy powinno być ok.
  • #136
    GrzesiekN
    Poziom 11  
    bielak930 napisał:
    Czy zauważyliście problemy z obsługą dużej liczby folderów?

    Na mój pendrive USB wlazło 11 katalogów po 99 utworów. Przy tej ilości nic się nie działo u mnie
    bielak930 napisał:
    radio wyświetla informację o braku zmieniarki.

    Na sztywno wpisałem 400ms jako maksymalny czas odpowiedzi dysku. U mnie pomogła zmiana nośnika USB na znacznie nowszy model, starszy model miał takie problemy. Może użyj karty SD u mnie działały bardzo dobrze. W nowej wersji wszystkie takie kwiatki znikną
    przemyska napisał:
    bardzo irytujące jest to że po każdym odlaczeniu zasilania utwory lecą od początku

    Nie wiem jak to odbierzesz, ale sugeruję nie odłączać zasilania i problem się rozwiąże

    Mnie osobiście strasznie męczy brak powrotu do początku odtwarzanego utworu. Nie wiem jak to mogłem przeoczyć. Dodatkowo gdy folder zawiera więcej niż 99 utworów radio zawiesza się przy przełączeniu na ostatni utwór z pierwszego. Mam już wszystko do nowej wersji ale ostatnio strasznie dużo programuję służbowo i nie znalazłem jeszcze czasu na powrót do tego projektu, który w swojej pierwotnej wersji powstał pod wpływem impulsu w ciągu 2 dni.
  • #137
    bielak930
    Poziom 9  
    Myślałeś o udostępnieniu hexa z wydłużonym czasem odpowiedzi nośnika? 400ms w takiej aplikacji wydaje się czasem za krótkim. Tym bardziej że większym dyskomfortem jest teraz przełączanie na zmieniarkę (po komunikacie o jej braku) niż trochę dłuższe oczekiwanie przy każdej zmianie folderu. U mnie problem występuje od około 40 folderu. W tych 40 folderach mam około 1000 plików. Nie mam w posiadaniu innych nośników i trochę nie chce strzelać w ciemno z zakupami.
  • #138
    j4rek
    Poziom 18  
    Witam, zmontowałem układ (Atmega w dip-ie, PD3 do masy) i podłączyłem dziś go u znajomego, w passacie B5FL z radiem VW MCD (2 din). Niestety moduł nie działa - efekt to brak poprawnej emulacji, nawet CDC5 się nie zgłasza, po wywołaniu zmieniarki z radia pojawia się tylko komunikat NO DISK. Brak też reakcji na wpinanie pendrive, czy karty uSD (z dobrze nazwanymi katalogami i utworami). Dodam to, że układ podłączałem w miejsce oryginalnej zmieniarki w bagażniku, czyli około 3m kabla trzeba pewnie liczyć. Kolega zmontował identyczny układ i z radiem Audi Concert II ruszyło "z kopa".

    Sprawdzałem, zamianę sygnałów data_out z data_in i ma to wpływ na zachowanie radia, ponieważ nie ma wtedy reakcji na wywołanie zmieniarki. Wnioskuję więc, że pierwotne podłączenie jest ok, bo w jakiś sposób radio jednak widzi emulator, lecz nie działa on do końca poprawnie z radiem MCD.
  • #139
    Wlodek83
    Poziom 17  
    j4rek napisał:
    Witam, zmontowałem układ (Atmega w dip-ie, PD3 do masy) i podłączyłem dziś go u znajomego, w passacie B5FL z radiem VW MCD (2 din). Niestety moduł nie działa - efekt to brak poprawnej emulacji, nawet CDC5 się nie zgłasza, po wywołaniu zmieniarki z radia pojawia się tylko komunikat NO DISK...


    Walczyłem z tą zmieniarka u siebie, też Passat b5fl radio MFD i niestety poleglem. Płytka uniwersalna i wytrawiona, kilka razy sprawdzone połączenia, atmega też w dip-ie, zasilanie atmegi poprawne, dwie sztuki atmegi, zaprogramowane poprawnie, zmienione przewody połączeniowe i dalej bez zmian. Zmieniarka zaczęła coś odtwarzać po wyłączeniu i włączeniu radia od zasilania, ale dalej nie działa jak należy. Na wszystkich płytach NO DISC, i po odpalenie auta nie działa przełączanie utworów (kilka postów wyżej to opisywałem i wklejałem film).
    Wydaje mi się, że jest różnica w sterowaniu pomiędzy radiami Audi Concert a MCD/MFD VW, stąd te problemy.
  • #140
    slawcioo88
    Poziom 21  
    Co ciekawe z chińskimi tanimi zmieniarkami też jest problem taki że działa z radiami audi vw oprócz navi MFD, przy niej działa ale przy ponownym włączeniu czy odpaleniu samochodu się zawiesza, z tego co pamiętam pomaga taki myk, odcięcie stałego plusa zmieniarki i podłączenie pod zasilenie 12V z niebieskiej kostki mini iso ale pod to które jest aktywowane po włączeniu radia.
  • #141
    Wlodek83
    Poziom 17  
    slawcioo88 napisał:
    Co ciekawe z chińskimi tanimi zmieniarkami też jest problem taki że działa z radiami audi vw oprócz navi MFD, przy niej działa ale przy ponownym włączeniu czy odpaleniu samochodu się zawiesza, z tego co pamiętam pomaga taki myk, odcięcie stałego plusa zmieniarki i podłączenie pod zasilenie 12V z niebieskiej kostki mini iso ale pod to które jest aktywowane po włączeniu radia.


    U mnie niestety nie pomogła zmiana zasilania.
  • #142
    maniac537
    Poziom 2  
    Witam. Również chciałbym wykonać taką zmieniarkę.
    Moje pytanie brzmi czy DFPlayer mini TF-16P fz1281 P3 oem arduino avr ruszy z twoim softem?
    Pozdrawiam.
  • #143
    rafi84
    Poziom 24  
    Kolego GrzesiekN czy poprawiłeś już tą wersję płytki do wspomnianej wersji 1.1 ??
    Pozdrawiam
  • #144
    maniac537
    Poziom 2  
    A istnieje możliwość podpięcia DFPlayer mini TF-16P fz1281 P3 oem arduino avr bezpośrednio pod kabel czy trzeba tworzyć całą płytkę?
    Wystarczy mi zmieniarka na kartę SD.
  • #145
    maanieek
    Poziom 10  
    Witam Wszystkich.
    Uruchomiłem zgodnie z dokumentacją. DFPlayer działa bez zarzutu. Mam natomiast problem z wejściem liniowym. Cicho gra podłączony pod nie telefon lub mp3. Czy ktoś ma taki objaw. Dodam, że masa podłączona jest również pod radio zgodnie ze schematem.
  • #146
    Mad Jaro
    Poziom 16  
    Kiedy możemy się spodziewać wersji 1.1 z obsługa bluetooth ? Czy projekt już nie będzie rozwijany ?
  • #147
    avatr
    Poziom 10  
    Ostatnio zebrałem się i zbudowałem ten emulator. Jednak nie działa tak jak powinien :( Podpięty pod radio Symphony II. Może ktoś podpinał już pod to radio?
    Po podłączeniu emulatora nie łączy nawet z AUX (CDC5) jeżeli podepnę pendrive to czasami zadziała. Jest to bardzo losowe i nie działa przełączanie piosenek. W najlepszym wypadku gra dalej w gorszym wyłącza emulator i nie idze go włączyć.
    Czy ktoś ma może jakieś pomysły lub informację czy to działa w Symphony II?