Elektroda.pl
Elektroda.pl
X
Sklep HeluKabel
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Przetwornica half-bridge pali tranzystory.

BlackDeath3 15 Paź 2017 14:11 1038 20
  • #1 15 Paź 2017 14:11
    BlackDeath3
    Poziom 14  

    Witam.

    Zbudowałem przetwornicę half-bridge według własnego schematu. Miała ona dawać na wyjściu regulowane napięcie (2-60V) i regulowany prąd (0-10A).

    Schemat:
    Przetwornica half-bridge pali tranzystory.

    Transformator wykonałem zgodnie z projektem feryster: http://www.feryster.pl/jacek/rysuj.php?lang=pl&indeks=7b3d54f706721ff74c2749f57baa35ad

    Przetwornica działała dobrze gdy dawałem na wejście 30V zamiast 230V, również pod obciążeniem (tylko napięcie wyjściowe było zbyt małe, ale to normalne). Oscyloskop nie pokazywał niczego podejrzanego, ale mogły występować jakieś krótkotrwałe szpilki napięcia, których mój "oscyloskop" ("oscyloskop" w cudzysłowie bo to raczej zabawka do samodzielnego montażu, 40 khz to już dla niego dużo) nie mógł wykryć.

    W końcu podłączyłem układ do sieci 230V. Na początku pracował prawidłowo, poza tym, że transformator wydawał dziwne, głośne dźwięki (trochę przypominały łuk elektryczny, ale to prawdopodobnie tylko dźwięki wydawane przez rdzeń). Jednak nic się nie paliło więc postanowiłem podłączyć obciążenie. Zmniejszyłem napięcie do minimum i podłączyłem żarówkę 12V 20W. Następnie zacząłem zwiększać napięcie. Zwiększało się ono dziwnie wolno, wolniej niż bez obciążenia, a transformator wydawał coraz głośniejsze dźwięki. W pewnym momencie był błysk. Spalił się bezpiecznik. Przyczyną było uszkodzenie tranzystorów Q1 i Q2. Wszystkie nóżki zwarte ze sobą.

    Co mogło być przyczyną awarii tranzystorów? Myślałem o tym, żeby dać obwód Zobla (kondensator i rezystor) równolegle do transformatora. Czy to może wyeliminować problem? Jeśli tak to jak obliczyć rezystor i kondensator? Google milczy na ten temat, jedyne co znalazłem to obliczanie obwodu Zobla do głośników, ale z tego wynika, że kondensator musi mieć wartość kilkuset mF, a rezystor wartość bliską 0.

    Dam 50 punktów za dobrą odpowiedź jeśli układ będzie działał prawidłowo. :D

    0 20
  • Sklep HeluKabel
  • #2 15 Paź 2017 14:17
    398216 Usunięty
    Poziom 43  

    Możliwe zwarcia między-zwojowe (przebicia) w trafie, lub zbyt wolne zamykanie tranzystorów kluczujących.
    Nawiń trafo raz jeszcze przykładając uwagę na to, by nie dopuścić do jakiegokolwiek uszkodzenia emalii. Pomiędzy warstwami konieczny jest izolator z estrafolu.

    1
  • #3 15 Paź 2017 14:33
    RitterX
    Poziom 36  

    Weź schemat zasilacza AT/ATX półmostkowego i zobacz czego brakuje. Na dzień dobry nie masz odseparowania składowej stałej z dzielnika pojemnościowego. Potrzebny jest szeregowo kondensator MKP rzędu 1uF z uzwojeniem trafo oraz wspominany układ gasikowy równolegle z trafo. Zastosuj taki jak w zasilaczu AT/ATX.
    Jak wygląda układ sterujący? Zawiera dead-time? Czytałeś notę aplikacyjną np. Infineon an2007-04 ?

    1
  • #4 15 Paź 2017 14:37
    Futrzaczek
    Admin Grupy Retro

    398216 Usunięty napisał:
    Nawiń trafo raz jeszcze przykładając uwagę na to, by nie dopuścić do jakiegokolwiek uszkodzenia emalii. Pomiędzy warstwami konieczny jest izolator z estrafolu.

    Czemu polecasz nawinięcie transformatora od nowa, skoro przyczyną mogło być:
    398216 Usunięty napisał:
    zbyt wolne zamykanie tranzystorów kluczujących

    :?:
    BlackDeath3 napisał:
    Cały schemat EAGLE:

    Wklej schemat w formie obrazka, tak będzie czytelniej.

    Mierzyłeś prąd pobierany przez układ przy niskim napięciu? Jaki jest margines czasowy przy przełączaniu tranzystorów?
    BlackDeath3 napisał:
    ("oscyloskop" w cudzysłowie bo to raczej zabawka do samodzielnego montażu, 40 khz to już dla niego dużo

    To bardzo źle wróży, bo jego czas narastania to ok. 9us, a do zaobserwowania są czasy nanosekundowe.

    1
  • Sklep HeluKabel
  • #5 15 Paź 2017 15:17
    398216 Usunięty
    Poziom 43  

    Futrzaczek napisał:
    Czemu polecasz nawinięcie transformatora od nowa, skoro przyczyną mogło być:
    398216 Usunięty napisał:
    zbyt wolne zamykanie tranzystorów kluczujących
    W wypadku zwarć między zwojowych to nieodzowne. A pisałem również o zbyt wolnym zamykaniu tranzystorów kluczujących. Odgłosy wydobywające się z transformatora bardziej mi pasowały do tej pierwszej opcji.

    0
  • #6 15 Paź 2017 17:12
    BlackDeath3
    Poziom 14  

    RitterX napisał:
    Weź schemat zasilacza AT/ATX półmostkowego i zobacz czego brakuje. Na dzień dobry nie masz odseparowania składowej stałej z dzielnika pojemnościowego. Potrzebny jest szeregowo kondensator MKP rzędu 1uF z uzwojeniem trafo oraz wspominany układ gasikowy równolegle z trafo. Zastosuj taki jak w zasilaczu AT/ATX.
    Jak wygląda układ sterujący? Zawiera dead-time? Czytałeś notę aplikacyjną np. Infineon an2007-04 ?


    Spróbuję tak zrobić. Zamówię elementy i napiszę czy zadziałało.
    Układ sterujący to TL494 taki, jak na schemacie.


    Futrzaczek napisał:
    Wklej schemat w formie obrazka, tak będzie czytelniej.


    Już zaktualizowałem post. Schemat wygląda tak:
    Przetwornica half-bridge pali tranzystory.


    Futrzaczek napisał:
    Mierzyłeś prąd pobierany przez układ przy niskim napięciu? Jaki jest margines czasowy przy przełączaniu tranzystorów?


    Przy niskim napięciu prąd jest prawie równy 0. Testowałem nawet jak się zachowa zasilacz na zwarciu. Przy zwarciu wyjścia na wyjściu płynęło około 7A (więcej się nie dało ze względu na niskie napięcie wejściowe), a na wejściu około 2A (to przez to, że miernik ma dosyć dużą rezystancję i musiało się na nim trochę mocy wydzielić).
    Margines czasowy to około 1µS. Nie jestem w stanie dokładniej tego zmierzyć. Jestem w 100% pewny, że 2 tranzystory nie przewodzą jednocześnie.


    Futrzaczek napisał:
    To bardzo źle wróży, bo jego czas narastania to ok. 9us, a do zaobserwowania są czasy nanosekundowe.


    Niestety mam tylko to. Nie mam 1000 zł na prawdziwy oscyloskop. Wiem, że te szpilki napięcia mogą mieć nawet wiele MHz.


    398216 Usunięty napisał:
    Możliwe zwarcia między-zwojowe (przebicia) w trafie, lub zbyt wolne zamykanie tranzystorów kluczujących.
    Nawiń trafo raz jeszcze przykładając uwagę na to, by nie dopuścić do jakiegokolwiek uszkodzenia emalii. Pomiędzy warstwami konieczny jest izolator z estrafolu.


    Spróbuję gdy wszystko inne zawiedzie.

    0
  • #7 15 Paź 2017 17:51
    Futrzaczek
    Admin Grupy Retro

    BlackDeath3 napisał:
    Przy niskim napięciu prąd jest prawie równy 0.

    Prąd średni - owszem. A szczytowy? Tego nie wiesz.
    Niestety, budowa przetwornicy bez dobrego oscyloskopu jest _bardzo_ trudna.

    0
  • #8 15 Paź 2017 18:45
    BlackDeath3
    Poziom 14  

    Futrzaczek napisał:
    BlackDeath3 napisał:
    Przy niskim napięciu prąd jest prawie równy 0.

    Prąd średni - owszem. A szczytowy? Tego nie wiesz.


    Prąd szczytowy raczej nie jest wysoki. Przy niskim napięciu wejściowym i obciążeniu 5V 1A podłączałem "oscyloskop" do transformatora i nawet na nim był widoczny czas martwy.

    0
  • #9 15 Paź 2017 22:14
    _lazor_
    Moderator Projektowanie

    A jak wygląda hardware? pokaż jak zrobiłeś połączenia, interesują mnie w szczególności długość ścieżek.

    Przy jakiej częstotliwości całość ma działać? w sensie praca kluczy.

    Jakie radiatory dałeś na mosfety?

    jak nawinąłeś transformatory sterujące?

    0
  • #10 15 Paź 2017 22:34
    BlackDeath3
    Poziom 14  

    _lazor_ napisał:
    A jak wygląda hardware? pokaż jak zrobiłeś połączenia, interesują mnie w szczególności długość ścieżek.

    Przy jakiej częstotliwości całość ma działać? w sensie praca kluczy.

    Jakie radiatory dałeś na mosfety?

    jak nawinąłeś transformatory sterujące?



    Tak to wygląda (wiem, nieestetyczne, ale zwarć nie ma):
    Przetwornica half-bridge pali tranzystory.Przetwornica half-bridge pali tranzystory.Przetwornica half-bridge pali tranzystory.

    Płytka z elementami wysokonapięciowymi (obwody wejściowe, transformator, klucze i część drivera). Uzwojenia wtórne transformatorów sterujących podłączone są do kostek X7 i X10.
    To już jest płytka po wylutowaniu uszkodzonych tranzystorów.
    (To czarne to marker, nie spalona płytka.)

    Radiator jest duży, a do tego w obudowie jest jeszcze wentylator. Radiator nawet nie zrobił się ciepły. (Zastosowałem podkładki izolujące pod tranzystory)

    Częstotliwość 40kHz.

    Transformatory sterujące to 2x30 zwojów skrętki na rdzeniu Ni Zn (AL=2693nH) (Link). Miernik pokazuje około 3,2mH indukcyjności każdego z uzwojeń.

    0
  • #11 15 Paź 2017 22:53
    _lazor_
    Moderator Projektowanie

    Transformatory separujące muszą być nawinięte bifilarnie a i wtedy reakcja takiego transformatora nie jest za wielka, ja uzyskałem 200ns narostu na takich trafo, i to podobno już było nieźle.

    https://www.elektroda.pl/rtvforum/viewtopic.php?t=3251863&highlight=

    W poście o numerze 20 z powyższego tematu mam pokazany schemat sterowania uzwojenia pierwotnego, transformatora do sterowania kluczy.
    Możliwe, że przez to, że nie rozładowujesz energii z transformatora to dzieją się dziwne rzeczy, chociaż tej energii nie powinno być za dużo, to może ona powodować opóźnienia działania sterowania.

    Jak już jesteśmy przy opóźnieniach, jaki masz ustawiony dead time? Niestety w Twoim wypadku ustawiłbym dead time jak najdłuższy, sięgający nawet kilku us.

    0
  • #12 16 Paź 2017 21:48
    RitterX
    Poziom 36  

    Dla porównania w zasialczu AT/ATX, który naprawdę wiele wybacza bo jest bardzo dobrze skonstruowany na TL494 jest kondensator 1uF/250V MKP szeregowo między odczepem dzielnika pojemnościowego a uzwojeniem pierwotnym. Bez odizolowania składowej a ta może pojawić się choćby od rezystorów wyrównujących dzielnika pojemnościowego to proszenie się o pozanormatywne podmagnesowywanie rdzenia i to bez szczeliny. Układ w najlepszym przypadku będzie się zachowywał w zagadkowy sposób w czasie dynamicznych zmian obciążenia. Drugie zabezpieczenie w AT/ATX to dodatkowe uzwojenie w trafo sterującym tranzystorami. Należy dodać, że jest tam jeszcze jedno uzwojenie, które jest połączone szeregowo z uzwojeniem pierwotnym trafo głównego czyli oba trafo są połączone sygnałowo od prądu uzwojenia pierwotnego. Uzwojenie dodatkowe poprzez diodę i układ całkujący podaje sygnał o przekroczeniu prądu uzwojenia pierwotnego, prądu magnesowania albo na wyprowadzenie blokujące pracę albo na wzmacniacz operacyjny układu sterującego PWM (TL494).
    Jak dodamy po stronie wtórnej zasilacza AT/ATX jeszcze dławik sprzężony oraz magnetyczny stabilizator napięcia to będzie trzeba przyznać, że ktoś kto to projektował miał naprawdę pojęcie o tym co chce zrobić a przy okazji zrobić układ możliwie tani.
    IGBT-y nie uratują zasilacza z tematu gdyż według mnie konstrukcja ma sporo mankamentów a dla Pout=600W nie sądzę by układ był zbyt pobłażliwy.

    0
  • #13 16 Paź 2017 22:53
    _lazor_
    Moderator Projektowanie

    RitterX ja słyszałem o wielu rzeczach, takich jak wzmacniacze magnetyczne, czy mechaniczne generatory prądu udarowego, ale o "magnetycznych stabilizatorach napięcia" to ja nigdy nie słyszałem.
    Nie chodziło Tobie przypadkiem i zwykły filtr Pi?

    Dławik sprzężony ma jedynie nie przenosić zakłóceń wspólnych do zasilanych elementów, a jako że PC zawiera delikatne komponenty to jego użycie jest uzasadnione, ale nie koniecznie tanie.

    0
  • #14 17 Paź 2017 00:23
    RitterX
    Poziom 36  

    To, że o czymś nie słyszałeś nie oznacza, że tego nie ma. Spotkałeś elektromagnetyczne stabilizatory napięcia sieciowego?
    www.mlodytechnik.pl/files/cpy/58-mt-02-stabilizator_napiecia.pdf
    albo nieferrorezonansowy "Podstawy Automatyki" E.Cholewa PWSZ 1964 str.183 .
    W zasilaczu AT/ATX jest podmagnesowywany składową stałą szeregowy dławik w obwodzie 3.3V. Podmagnesowywanie składową stałą wpływa na impedancję dławika a więc całego obwodu szeregowego z obciążeniem. W ten sposób można stabilizować napięcie 3.3V ponad 10A tranzystorem 2N2907. Zdecydowanie za mały mocowo na rolę regulatora równoległego. Sygnał błędu jest brany od napięcia wyjściowego.

    p.s.
    Jakbyś miał niedosyt to jeszcze są wzmacniacze dielektryczne zbudowane w oparciu o segnetodielektryki czyli kondensatory o dielektryku posiadającym nieliniową charakterystykę. Opis na str.150 wymienionej wyżej książki.

    0
  • #15 17 Paź 2017 00:32
    Łukasz.K
    Poziom 21  

    Z mojego doświadczenia wynika że w stanie jałowym oraz również przy obciążeniu maksymalnym nie powinny z układu wydobywać się żadne głośne, dziwne dźwięki oprócz ewentualnie delikatnego, cichego pisku. Jeżeli się takie dźwięki wydobywają w stanie jałowym to moim zdaniem transformator nie jest zasilany przebiegiem prostokątnym tylko jakimś zniekształconym. Przyczyną tego może być np. źle działający obwód regulacji napięcia lub ograniczenia prądowego (nie wiem czy ten układ takowe posiada, bo go nie analizowałem a tylko podaję ogólne moje obserwacje). W każdym razie, w przetwornicy impulsowej powinien być obwód ograniczenia prądowego na przekładniku prądowym lub co najmniej na rezystorze (czego nie polecam) i powinien on działać bardzo dobrze i niezawodnie. To co kolega opisał to problem dość skomplikowany jak dla mnie, no ale może znajdzie się ktoś kto koledze pomoże. Ja bym zmierzył prąd pobierany przez transformator przy niskim napięciu zasilającym i podczas jego zwiększania. Warto tranzystory załączające transformator w czasie prób zasilać przez rezystor np. przez szeregowo połączoną lutownicę grzałkową 100-500W/230V, grzałkę 100-500W/230V, grzejnik 100-500W/230V itp. W czasie pracy obserwować przbiegi prądów i napięć podczas zwiększania obciążenia od stanu jałowego do chwili zadziałania ograniczenia prądowego. W stanie jałowym prąd transformatora nie powinien narastać do więcej niż jakieś 5% jego wartości przy pracy pod maksymalnym obciążeniem. Ale tak jak mówię rozwiązanie tego problemu np. w moim przypadku to zadanie dość trudne. Choć 600W to jeszcze nie koniec świata i przy poświęceniu trochę czasu (kilka tygodni, miesięcy, lat) powinieneś osiągnąć dobry efekt.

    0
  • #16 17 Paź 2017 08:33
    _lazor_
    Moderator Projektowanie

    RitterX napisał:

    p.s.
    Jakbyś miał niedosyt to jeszcze są wzmacniacze dielektryczne zbudowane w oparciu o segnetodielektryki czyli kondensatory o dielektryku posiadającym nieliniową charakterystykę. Opis na str.150 wymienionej wyżej książki.


    czy nie chodzi Tobie o ferroelektryk? Nie czepiam się, po prostu jestem ciekawy czy "segnetodielektryki" stara nazwa czy pomyłka.

    Tak czy siak autorowi tematu nie polecam bawić się w magnetyczne stabilizatory napięcia, gdyż nie bezpowodu wyszły one z użytku ogólnego. Myślę że dla większości zastosowań filtr PI na wyjściu jak najbardziej wystarczy.

    0
  • #17 17 Paź 2017 14:01
    RitterX
    Poziom 36  

    We wspomnianym układzie stabilizacji nie jest użyty element indukcyjny tylko kondensator zbudowany w oparciu o dielektryk z nieliniową charakterystyką. To jest rozwiązanie dualne względem elementu indukcyjnego. To jedynie taka ciekawostka.
    Masz rację, w tytułowej przetwornicy na wyjściu powienie być jedynie filtr PI jako skuteczne i proste rozwiązanie problemu filtracji. Za stabilizację pojedynczego napięcia wyjsciowego powinno odpowiadać sprzeżenie zwrotne od napięcia wyjściowego oraz ważniejsze, od prądu.

    @Łukasz.K, przy 600W wypadałoby zastosować przekładnik w obwodzie głównym po pierwotnej stronie. To nie rozrzutność lecz praktyka. Dlatego jakby nie uruchamiać zasilacza docelowego to i tak będzie z nim problem w czasie eksploatacji bez układu ograniczenia prądu strony pierwotnej. Problem, moim zdaniem, nie leży w sposobie uruchamiania lecz jest natury konstrukcyjnej.
    Skoro w 200W seryjnie produkowanym zasilaczu pofatygowano się w ten sposób o pomiar i ograniczenie prądu uzwojenia pierwotnego to tym bardziej w zasilaczu 600W wypada to zrobić. Tym bardziej, że ma pacować w szeroki zakresie napięć wyjściowych i prądów czyli będzie poddawany bardziej nieprzewidywalnym warunkom eksploatacji.

    0
  • #18 19 Paź 2017 07:42
    Łukasz.K
    Poziom 21  

    Tak jak napisałem ten układ bez obciążenia nie powinien wydawać żadnych odgłosów. Jeżeli wydaje, to na 100% gdzieś jest poważny błąd albo w schemacie albo w stanie użytych elementów. Jak dla mnie to wygląda jakby z powodu nie prawidłowo działającego obwodu ograniczenia prądowego lub stabilizacji napięcia obwód ograniczenia prądowego lub stabilizacji napięcia wyłączał prąd i po chwili go włączał spowrotem, przez co transformator jest zasilany przebiegiem nie prostokątnym, lecz jakimś zniekształconym w wyniku oscylacji powstałych podczas włączania i wyłączania tranzystorów kluczujących prąd transformatora. Co powoduje nasycanie się rdzenia, wzrost prądu magnesującego i uszkodzenie tranzystorów. Lub w układzie jest błąd logiczny projektu tzn. stworzony został układ który nie ma prawa działać poprawnie. O jest obwód kontroli prądu i stabilizacji napięcia. Tyle że moim zdaniem lepiej żeby prąd mierzyć w uzwojeniu pierwotnym transformatora a nie wtórnym, bo jak nam wzrośnie prąd magnesujący to go nie zmierzymy i tranzystory się uszkodzą choć pomiar prądu wykaże zero. No i kondensatory filtrujące na wyjściu moim zdaniem nie muszą mieć 10mF bo tam jest podwyższona częstotliwość i wystarczy jakieś 1000uF. Widziałem układy z pomiarem po stonie wtórnej ale do tego trzeba mieć pewność że transofrmator jest zbudowany poprawnie. No ale skoro układ jest to można sprawdzić czy transformator jest ok, czyli tak jak napisałem wcześniej dać rezystor i grzałkę 100-500W od plusa w pierwotnym i obserwować wartości prądu oscyloskopem przy zwiększaniu napięcia zasilania pierwotnego. Przy pełnym napięciu 325V na kondensatorach prąd magnesujący transformator nie powinien przekraczać 0.5A pod koniec przewodzenia danego tranzystora gdy przebiegi napięcia na bramkach są prostokątne. Jeżeli prąd magnesujący narasta do większych wartości to najprawdopodobniej transformator ma zbyt niską indukcyjność jak na daną częstotliwość pracy. Może też odstęp między połówkami prostokąta nie jest wystarczający przez co oba tranzystory przewodzą przez chwilę jednocześnie. Odstęp ten powinien wynosić co najmniej 0.5us albo więcej, dla prób można dać na początek np. 4us jeżeli układ TL494 daje taką możliwość.

    0
  • #19 12 Lis 2017 10:12
    BlackDeath3
    Poziom 14  

    Zamontowałem w układzie kondensator 1.2uF do pozbycia się składowej stałej i dodałem układy rc równolegle do transformatora oraz wymieniłem tranzystory. Okazało się, że głośna praca i wybuch był spowodowany uszkodzeniem diody, ponieważ zastosowałem tam diodę o napięciu przebicia 100V (układ miał dawać 60V więc myślałem, że dioda 100V wystarczy). Po przeliczeniu przekładni transformatora okazało się że daje on znacznie więcej. Użyłem więc diody o napięciu przebicia 200V (MBR20200CT) i wszystko działa dobrze. Dodałem również kondensatory 1uF między nóżki 2 i 3 oraz między 3 i 15 aby układ się nie wzbudzał. Jedyny problem mam teraz z hałasem przy małym obciążeniu. Przypomina on szum, jest wydawany przez transformator. Nie występuje on przy dużym obciążeniu ani przy braku obciążenia tylko przy małym obciążeniu. Zasilacz testowałem przy obciążeniach 60V 160W; 12V 50W i 10V 4W i tylko przy tym ostatnim występował hałas. Czy to tak ma być? Jest jeszcze jakiś błąd czy miszę się z tym pogodzić? Death time jest dobry, tranzystory nie przewodzą jednocześnie. Przy zasilaniu 230V i obciążeniu 160W nie są nawet ciepłe.

    0
  • #20 13 Lis 2017 23:07
    RitterX
    Poziom 36  

    A gdzie masz układ, w najprostszym przypadku zwykły rezystor ~2W, wstępnego obciążenia. Ta "muzyka" jest związana z niestabilną pracą układu sprzężenia zwrotnego. Bardziej zaawansowane wstepne obciążenie da się zrobić ale potrzeba nieco więcej finezji, np. w oparciu o źródło stałoprądowe.

    0
  • #21 13 Lis 2017 23:18
    _lazor_
    Moderator Projektowanie

    Są jeszcze sterowniki z burst mode dla bardzo małych obciążeń, gdzie praktycznie przetwornice mogą pracować bez obciążenia i wszystko śmiga elegancko.

    0