Elektroda.pl
Elektroda.pl
X
PCBway
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Zasilanie wzmacniacza operacyjnego - jak się podłącza?

30 Paź 2017 22:26 924 3
  • Poziom 5  
    Mam taki układ do pomiaru prądu z silników przez mostek H L298N w celu odfiltrowania pików z silników i wzmocnienia odkładającego się napięcia na rezystorze pomiarowym dla ADC w Arduino.

    Schemat wygląda tak: Zasilanie wzmacniacza operacyjnego - jak się podłącza?

    Mam to polutowane tak i podłączone do płytki stykowej (spokojnie później wszystko polutuje do płytki prototypowej) :
    Zasilanie wzmacniacza operacyjnego - jak się podłącza? Zasilanie wzmacniacza operacyjnego - jak się podłącza?


    I jak widzicie nie ma jeszcze podłączonego zasilania do wzmacniacza, bo nie wiem jak, pytania jakie mam w tej kwestii:


    1. Powiedzmy, że zasilam to z baterii AA + z baterii muszę podłączyć do pinu 8 (Vs) a minus do pinu 4 (GND wzmacniacza)?
    2. Czy masa wzmacniacza i masa mostka muszą być połączone?
    3. Czy mogę zasilić ten wzmacniacz z pinu 5V z mostka H dając kondensator 100nF pomiędzy zasilanie, a masę wzmacniacza?
  • PCBway
  • Poziom 27  
    Zasilanie według danych katalogowych to min. 3V, więc zasilanie z 5V może być. Zasilanie: + do pin8, GND - do pin4 oraz masy połączone. Filtrowanie wskazane. Zastanów się, czy na pewno potrzebujesz wzmacniać pomiar prądu? W większości wystarczy rezystor pomiarowy, spadek na nim odfiltrować za pomocą R=10k i C=100nF, następnie sygnał do ADC.
  • PCBway
  • Moderator Projektowanie
    EasyPeasy_ napisał:
    1. Powiedzmy, że zasilam to z baterii AA + z baterii muszę podłączyć do pinu 8 (Vs) a minus do pinu 4 (GND wzmacniacza)?

    Tak, ale nie z baterii AA.
    EasyPeasy_ napisał:
    2. Czy masa wzmacniacza i masa mostka muszą być połączone?

    Tak, przecież to zaznaczono na schemacie (symbole masy).
    EasyPeasy_ napisał:
    3. Czy mogę zasilić ten wzmacniacz z pinu 5V z mostka H dając kondensator 100nF pomiędzy zasilanie, a masę wzmacniacza?

    Tak, ale:
    - 100nF w pobliżu LM358,
    - napięcie zasilania musi być większe o ok. 3V od spodziewanego Uwy, oraz o ok. 1,5V od spodziewanego Uwe. A wzór na Uwy masz na schemacie - policz sobie. W praktyce przy Uzas=5V uzyskasz nie więcej niż ok. Uwy= ok. 2-3V, co przy tym wzmocnieniu (zależnym od oporników 4,7k i 100k) oznacza max Uwe= ok. 16-25mV, co oznacza (przy Rs=0,1 Ohm) max prąd obciążenia (płynący przez Rs) = ok. 0,16-0,25A.
    Jeśli chcesz mieć Uwy=0-5V to musisz zasilać go napięciem min. 9V, wypadałoby zabezpieczyć też uC przed zbyt wysokim napięciem z tego wzmacniacza.
    Tu są dane LM358: http://www.ti.com/lit/ds/snosbt3i/snosbt3i.pdf

    Z drugiego wzm LM358 zrób wtórnik, jego wejście na masę, wy. "wisi".
  • Poziom 5  
    adam_es napisał:
    Zasilanie według danych katalogowych to min. 3V, więc zasilanie z 5V może być. Zasilanie: + do pin8, GND - do pin4 oraz masy połączone. Filtrowanie wskazane. Zastanów się, czy na pewno potrzebujesz wzmacniać pomiar prądu? W większości wystarczy rezystor pomiarowy, spadek na nim odfiltrować za pomocą R=10k i C=100nF, następnie sygnał do ADC.


    No, ale ja jak ściągałem pomiary z tego rezystora pomiarowego (już odfiltrowanego) to dla zatrzymanych obu silników (bo mam po dwa podłączone na jeden kanał) otrzymałem odczyt 40mV, czyli 0.04V.

    W Arduino jest rozdzielczość 5V/1024 ~= 0.005mV, więc otrzymałbym możliwość rozróżniania tylko 8 różnych wartości prądów silnika, a całe 1024-8=1016 innych byłoby nie wykorzystane, bez wzmacniania sygnału.

    I dla R=10k C=10nF chyba, bo 1/(2*pi*10k*10*10^-9)~=1.6kHZ, a dla 100nF byłoby 160Hz

    trymer01 napisał:

    Tak, ale:
    - 100nF w pobliżu LM358,

    Wydaje mi się, że te wyjście z mostka 5V jest już odfiltrowane właśnie takim kondensatorem przed wejściem na stabilizator 5v na tym schemacie zaznaczyłem na czerwono:
    Zasilanie wzmacniacza operacyjnego - jak się podłącza?

    trymer01 napisał:

    - napięcie zasilania musi być większe o ok. 3V od spodziewanego Uwy, oraz o ok. 1,5V od spodziewanego Uwe. A wzór na Uwy masz na schemacie - policz sobie. W praktyce przy Uzas=5V uzyskasz nie więcej niż ok. Uwy= ok. 2-3V, co przy tym wzmocnieniu (zależnym od oporników 4,7k i 100k) oznacza max Uwe= ok. 16-25mV, co oznacza (przy Rs=0,1 Ohm) max prąd obciążenia (płynący przez Rs) = ok. 0,16-0,25A.

    Wzór jest: Uwy=Rsense*I_load*22.27

    Co dla Uwy=3V daje U_we=R*sense*I_load=3V/22.27~=0.135V co daje dla Rsense=0.1Om I_load=0.135V/0.1Om=1.35A
    trymer01 napisał:

    Z drugiego wzm LM358 zrób wtórnik, jego wejście na masę, wy. "wisi".


    Drugiego wykorzystam do pomiaru prądu także z takim samym układem z drugiego kanału.

    Ogólnie dzięki za pomoc, już podłączyłem go tak, że działa. Tylko tak jak mówiłem mój maks odczyt przy zatrzymanych silnika z rezystora (nie wzmacniacza) to 0.04V, co przy rezystorze 0.1Om wychodzi, że dwa silniki zatrzymane podłączonego do jednego kanału biorą tylko 0.4A, co jest troszkę dziwne, bo mostek może dać na kanał 2A. Może powodem jest to, że zasilam mostek z baterii 9V, a nie np. Lipola 2S?