Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Ładowarka impulsowa na MAX713

Andrzej Stachurski 08 Sie 2005 10:07 5150 12
  • #1 08 Sie 2005 10:07
    Andrzej Stachurski
    Poziom 20  

    Szukam osób które popełniły taką ładowarkę. Mnie kosztowało to
    już trzy kości MAX i ciągle nie chodzi. Czy może ktoś wspomóc
    swoim doświadczeniem?
    Schemat jest z
    http://www.google.com/url?sa=D&q=http://pdfserv.maxim-ic.com/en/ds/MAX713SWEVKIT.pdf
    Robiłem też modyfikowany z
    http://www.google.com/url?sa=D&q=http://home....7Edelemarre/HTMLobj-267/Charger_Delemarre.pdf
    i też nie działa. Do obydwu układów sam projektowałem płytki.

    Zaznaczam że maxy były sprawne bo sprawdzałem je w ładowarce z kitu
    AVT i chodziło prawidłowo. Tylko ze względu na duży prąd
    ładowania (2,4 - 4,8A), 12 cel i zasilanie 30V zdecydowałem zrobić
    impulsową.
    Najważniejszym problemem jaki wywnioskowałem z dotychczasowych eksperymentów jest zbyt małe wysterowanie tranzystora mocy (nie wiem czy zbyt mała wydajność driwera czy też wzbudzanie się układu spowodowane np złym prowadzeniem ścieżek)

    Jeśli by ktoś robił też inną wersję impulsowej na maxie 713 (np
    tę z dodatkiem max724 z noty aplikacyjnej maxima) to proszę o info.

    Byłbym też ewentualnie zainteresowany jakimś naprawdę sprawdzonym schematem
    ładowarki na innych podzespołach o pasujących parametrach ładowania - gdyby
    ktoś był skłonny podzielić się.


    Proszę o zainteresowanie i pomoc

    0 12
  • #2 09 Sie 2005 16:25
    wladi.klimek
    Poziom 18  

    Czesc,polecam artykul nt. MAX 713 w "Serwisie Elektroniki " 6/2001
    i schemat w nim z rys. nr7,

    0
  • #3 24 Lip 2008 20:43
    ][mako][
    Poziom 13  

    Witam
    Trochę odświeżę ten temat bo właśnie sobie zrobiłem taką ładowarkę impulsową z tego pdfa od maxima i jak wszyscy mam z nią problem i nie wiem co dalej.
    A teraz konkrety:
    ładowarka ma być na 9 ogniw i co za tym idzie jest zasilana napięciem 20V (korzystam z zasilacza od della 20V 3,5A), oczywiście chcę również ładować nią inne ilości ogniw (jak 4 czy 6)
    ze względu na duże napięcie zasilania zrobiłem tak jak pisali w pdf-ie i dałem "transistor level shifter" (heh jak to sie nazywa po polsku bo jakoś nie mogę konkretnej nazwy wymyślić)
    a problem jest taki, że na bramkę mosfeta idzie za duże napięcie, w pdf-ie piszą że ma być 5-15V, a u mnie jest 17-18V :( i ładowarka zamiast ładować to po podłączeniu baterii tylko mrugnie (2 sekundy) lampką i tyle
    próbowałem zmieniać te oporniki co są przy sterowniku mosfeta ale nic się nie zmienia.
    Wszystkie próby robię na pakiecie z 6 ogniw (7,2V), a jeszcze jest inna dziwna sprawa bo jak podłącze tą ładowarkę do zasilacza 15V to o dziwo zaczyna działać i nawet ładuje aku ale co mi po tym jak mi trzeba 9 ogniw ładować.

    0
  • #4 24 Lip 2008 21:32
    -RoMan-
    Poziom 42  

    W podanej nocie jak wół widnieją napisy: "Connect the input power source (14V to 16V, 1.3A as configured)" oraz "The board is shipped configured for six cells and 1A of charge current." . Jest rzeczą oczywistą, że bez istotnych zmian nie należy na siłę zwiększać napięcia zasilania i ilości podłączonych ogniw.

    Podłączenie przesuwnika poziomu wymaga przerwania JU2 i połączenia JU1. Ale i to nie zadziała do końca poprawnie przy wyższych napięciach a - przede wszystkim - na pewno nie zadziała poprawnie, jeśli wcześniej MOSFET był sterowany bezpośrednio i wyjście DRV i/lub sam MOSFET zostały już uszkodzone.

    0
  • #5 24 Lip 2008 21:59
    ][mako][
    Poziom 13  

    -RoMan- napisał:
    Podłączenie przesuwnika poziomu wymaga przerwania JU2 i połączenia JU1. Ale i to nie zadziała do końca poprawnie przy wyższych napięciach

    No to właśnie mam tak zrobione tylko mam pytanie dlaczego nie działa przy wyższych napięciach przecież 20V to nie jest mocno więcej jak 15V, a przecież właśnie w tym pdf-ie jest napisane że jak napięcie zasilania przekracza 15V to że trzeba tak zrobić więc więc nie wydaje mi się żeby im chodziło o np. 16 czy 17V
    -RoMan- napisał:
    a - przede wszystkim - na pewno nie zadziała poprawnie, jeśli wcześniej MOSFET był sterowany bezpośrednio i wyjście DRV i/lub sam MOSFET zostały już uszkodzone.

    czyli o co Ci chodzi bo nie czaje, mosfet od początku jest sterowany tak jak na schemacie (to się chyba wtórnik symetryczny nazywa czy jakoś tak :) ), mosfet jest nowy więc raczej sprawny, a scalak też działa bo mam w domu jeszcze jedną ładowarkę na max317 z kitu avt i tamta działa bez zarzutu, a poza tym przecież jak podłącze zasilacz 15V to działa wszystko :?

    Czyli skoro trzeba coś zmienić to co to powinno być, podejrzewam że trzeba przerobić sterowanie mosfeta tylko jak :?:

    0
  • #6 24 Lip 2008 22:23
    -RoMan-
    Poziom 42  

    Układ z PDFa jest dość mocno niedopracowany. Najlepiej działa w wersji pierwotnej a wersja z przesuwaniem poziomu wymaga spełnienia dodatkowych warunków. Podstawowym jest to, że musi zadziałać poprawnie wewnętrzny stabilizator w MAX713 a napięcie zasilania musi być o te 5-15V wyższe od napięcia na nóżce V+ MAX713.

    Jeśli zrobiłeś choć jedną próbę bez przesuwnika napięcia lub zrobiłeś jakieś zwarcie przypadkowo i na bramce MOSFETa pojawił się potencjał masy (czyli -20V względem źródła), to MOSFET mógł ulec uszkodzeniu.

    Samo to, że jak piszesz na bramce pojawia się aż -17-18V świadczy o błędzie w montażu - poprawnie zmontowany układ nie ma prawa przy zasilaniu 20V podać tak niskiego napięcia na bramkę.

    Chciałbym wiedzieć, jakie elementy zastosowałeś - czy użyłeś "diody" prądowej (CCLHM080) tak jak na schemacie czy też rezystora R1. Jeśli rezystora, to o jakiej wartości. Jakie napięcia masz na nóżce V+. Pytań jest całe mnóstwo, bo na razie wszystko wskazuje na błąd montażu lub doboru elementów.

    0
  • #7 25 Lip 2008 00:29
    ][mako][
    Poziom 13  

    hymm, więc tak
    Nie wiem czy nie pisze teraz jakiejś bzdury ale ja mam na bramce mosfeta napięcie +17V (mierzone względem masy) i chyba jest dobrze zmontowane bo jak już pisałem jak dam zasilacz 15V to ładowarka działa.
    Użyłem rezystora 1,8k bo nie mieli w sklepie takich diód (chyba będę musiał kupić taką na necie) i napięcie na V+ mam ok. 5V więc jest dobre
    I tak poza tym to jeszcze zastosowałem takie elementy: mosfet IRF9540N, zamiast CMPTA06 dałem 2N2222A, a reszta jak na schemacie

    0
  • #8 25 Lip 2008 01:09
    -RoMan-
    Poziom 42  

    1.8 kom to trochę za dużo. Dla zasilania 20V powinno być 1.5 kom max.

    Co do napięcia na bramce pMOSFETa - tam jest potrzebny oscyloskop a nie miernik. Jeśli tam jest napięcie stałe +17V względem masy, to na pewno jest źle - ma być przebieg prostokątny.

    Być może problem tkwi w dławiku - nic o nim nie piszesz...

    IRF9540? Strzelasz ze strasznie wielkiej armaty do takich małych wróbli...

    Dodano po 13 [minuty]:

    Jeszcze jedno: IRF9540 ma ładunek całkowity bramki 97 nC, IRFR9024 - tylko 19 nC - 5-krotnie mniej. To też ma wpływ na działanie całości. Jak na dokładkę dławik jest marnej jakości a R3 drutowy - całość nie ma prawa działać.

    0
  • #9 25 Lip 2008 14:37
    ][mako][
    Poziom 13  

    -RoMan- napisał:
    1.8 kom to trochę za dużo. Dla zasilania 20V powinno być 1.5 kom max.

    hymm no nie wiem, ja ten opornik policzyłem normalnie dla 8mA, jak dam 1,5k to będzie prąd ok. 10mA ale zdaje mi się że to nie powinno mieć znaczenia, w końcu prąd ma być z zakresu 5-20mA i chyba każdy będzie dobry, zaraz zabiorę się do poprawek :)

    -RoMan- napisał:
    Co do napięcia na bramce pMOSFETa - tam jest potrzebny oscyloskop a nie miernik. Jeśli tam jest napięcie stałe +17V względem masy, to na pewno jest źle - ma być przebieg prostokątny.

    To że trzeba oscyloskop to ja wiem ale niestety nie mam takiego cuda, a w końcu przecież nawet jak są impulsy to miernik też będzie pokazywał napięcie, nie :?:

    -RoMan- napisał:
    Być może problem tkwi w dławiku - nic o nim nie piszesz...

    hymm z każdym kolejnym zdaniem coraz więcej problemów, skoro dławik też może robić problemy to pewnie robi bo założyłem taki z zasilacza od kompa, jak mierzyłem go taką przystawką do miernika to wychodziło coś koło 160-170uH i najgorzej że tez nie znalazłem czegoś takiego w sklepie u mnie w mieście :(

    -RoMan- napisał:
    IRF9540? Strzelasz ze strasznie wielkiej armaty do takich małych wróbli...

    heheh nie było w sklepie takiego jak na schemacie, a zauważyłem przeszukując internet, że wszyscy co robili ta ładowarkę stosowali właśnie tego irf-a więc ja też takiego kupiłem :)

    -RoMan- napisał:
    Jeszcze jedno: IRF9540 ma ładunek całkowity bramki 97 nC, IRFR9024 - tylko 19 nC - 5-krotnie mniej. To też ma wpływ na działanie całości. Jak na dokładkę dławik jest marnej jakości a R3 drutowy - całość nie ma prawa działać.

    Z tym ładunkiem to faktycznie może być problem ale w końcu jak innym ludziom działa na takim mosfecie to chyba i mi powinno, chyba że się mylę :?
    Opornik mam taki zwykły 0,27Ohm 5W (biały, prostokątny)

    no nic to w takim razie chyba pozostaje mi kupić parę nowych części na necie i zobaczymy czy się coś zmieni ...

    //edit
    przed chwilą podpiąłem częstościomierz z miernika pod bramkę mosfeta i pokazał 1,7kHz więc chyba są jakieś impulsy tylko nie wiem jakie ale są :)

    0
  • #10 25 Lip 2008 15:46
    -RoMan-
    Poziom 42  

    Biały, prostokątny 5W rezystor to na pewno druciak a druciaków nie wolno stosować jako czujników kontroli prądu w układach impulsowych. Kup rezystor metalizowany 0R22 0.6W - są dostępne w sklepach elektronicznych.

    Mierniki napięcia podłączane w miejscach, w których jest sygnał prostokątny mogą pokazywać wszystko - od średniego napięcia w tym miejscu po temperaturę w Timbuktu.

    Pojęcie "dławik z komputera" nic mi nie mówi - tam ma być dławik 220 uH o prądzie nasycenia co najmniej 2A.
    Można taki dławik nawinąć np. na rdzeniu dławika wyjściowego z zasilacza komputerowego.
    Dziwi mnie to, że w układzie ewaluacyjnym zastosowano stosunkowo mały dławik SMD - to jest proszenie się o kłopoty w układzie, gdzie kontrola prądu jest tak mocno pośrednia jak w MAX713...

    0
  • #11 28 Lip 2008 22:51
    ][mako][
    Poziom 13  

    -RoMan- napisał:
    Pojęcie "dławik z komputera" nic mi nie mówi - tam ma być dławik 220 uH o prądzie nasycenia co najmniej 2A.
    Można taki dławik nawinąć np. na rdzeniu dławika wyjściowego z zasilacza komputerowego.

    heh to ja się teraz trochę po czepiam :P bo wcale nie napisałem "dławik z komputera", a "dławik z zasilacza od kompa" a to jest różnica :P i prąd myślę że by wytrzymał bo jest nawinięty dość grubym drutem ale jak już pisałem z moich pomiarów wychodziło ok. 170uH i jak się okazuje to trochę za mało. Ale nic poszedłem za radą i nawinąłem sobie taki dławik i mam teraz wg wskazań miernika 260uH (użyłem drutu 1mm więc o prąd chyba nie muszę się martwić).

    I teraz tak zmiany zacząłem od wymiany opornika R1 na 1,5k ale nic to nie zmieniło (na układzie dalej jest 5V ale pewnie płynie przez niego większy prąd).
    Ale po wymianie dławika dochodzę do wniosku że ten element ma bardzo duże znaczenie w działaniu tej ładowarki bo właśnie po wymianie dławika ładowarka o dziwo zaczęła działać :D, udało mi się nawet naładować 4 akumulatorki i chyba ładowanie wyłączyło się w dobrym momencie (aku były już dość ciepłe ale nie aż tak żeby nie dało się uch dotknąć). Popróbuję jeszcze z ładowaniem innych ilości ogniw i zobaczę jak będzie działać.
    Także myślę że to było by na tyle jeżeli chodzi o zmianę jakichś elementów bo skoro już działa to chyba już będzie dobrze (chyba że się mylę :?)
    Spróbuję jeszcze kupić i wymienić opornik od czujnika prądu ale mam wątpliwości czy to coś zmieni (poza samopoczuciem :))

    0
  • #12 29 Lip 2008 01:06
    -RoMan-
    Poziom 42  

    Prąd nasycenia dławika nie zależy od średnicy drutu ale od właściwości rdzenia, na którym ten dławik nawinięto.
    Od średnicy drutu zależą tylko i wyłącznie straty na grzanie tego drutu. Do spalenia włącznie.

    Co do rezystora kontroli prądu - jest to krytyczny element dla poprawnego działania każdego układu impulsowego. Rezystory metalizowane są dostępne bez problemu i nie ma sensu dziadować z powodu kilkunastu-kilkudziesięciu groszy.

    0
  • #13 29 Lip 2008 11:18
    ][mako][
    Poziom 13  

    ehh a skąd ja mam wiedzieć jakie właściwości ma rdzeń :?, ale mam nadzieję że będzie dobry, jest to rdzeń właśnie z wyjścia zasilacza komputerowego a tam zazwyczaj są dość duże prądy więc może będzie dobrze, spróbuję włączyć ładowanie z większym prądem to się okaże czy jest dobry.
    Co do tego rezystora to ja nie dziaduję :P tylko po prostu nie mam gdzie takiego kupić, jak będę gdzieś w pobliżu jakiegoś lepszego sklepu to z pewnością w nim poszukam :). A w tej chwili założyłem zwykły opornik (tzn. chyba węglowy bo jest okrągły zielony i ma normalnie kod paskowy) 0,22Ohm 3W bo takie mieli w moim sklepie :?

    0