Elektroda.pl
Elektroda.pl
X

Wyszukiwarki naszych partnerów

Wyszukaj w ofercie 200 tys. produktów TME
Europejski lider sprzedaży techniki i elektroniki.
Proszę, dodaj wyjątek elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

[EXCEL FORMUŁA] - Zaznaczanie wyniku poza specyfikacją

gruby33 15 Lis 2017 02:10 117 2
  • #1 15 Lis 2017 02:10
    gruby33
    Poziom 18  

    Cześć,

    Mam problem z formułą, która zmieniała by mi odpowiednio nazwę komórki jeśli w innej komórce będzie wynik poza specyfikacją. Wszystkie komórki to komórki liczbowe.

    Przykładowo:
    Komórka A1 - Górna granica
    Komórka A2 - Dolna granica
    Komórka A3 - Wynik uzyskany

    Chcę aby w komórce A4 automatycznie wpisywało się OK jeśli wynik będzie mieścił się w parametrach lub NOK z czerwonym wypełnieniem jeśli będzie poza parametrami.

    Obecnie mam taką formułę:

    =JEŻELI(LUB(A3>=A2;A3<=A1="tak");"OK";"NOK")

    Niestety formuła działa jedynie kiedy wynik uzyskany jest mniejszy niż dolna granica, a kiedy wynik jest większy niż górna granica to i tak wstawiane jest OK.

  • Pomocny post
    #2 15 Lis 2017 02:26
    dt1
    Moderator - Komputery Serwis

    Witaj. Zamiast LUB powinno być ORAZ. Oba warunki muszą być spełnione, aby można uznać, że liczba jest zawarta w przedziale (i do przedziału OK należą też granice zdefiniowane w A1 i A2).

    Co do wypełnienia to skorzystaj z formatowania warunkowego.

    =JEŻELI(ORAZ(A3>=A2;A3<=A1);"OK";"NOK")

  • #3 15 Lis 2017 03:14
    gruby33
    Poziom 18  

    Dziękuję bardzo za pomoc teraz jest tak jak powinno być :)

 Szukaj w ofercie
Zamknij 
Wyszukaj w ofercie 200 tys. produktów TME