Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Skoda Octavia II - Błędy CAN Gateway, błąd komunikacji z radiem fabrycznym

sztorm 22 Lis 2017 07:07 1668 9
  • #1 22 Lis 2017 07:07
    sztorm
    Poziom 13  

    Witam.
    Jakiś czas temu nabyłem autko Octavie 2 z 2005 r. Ostatnio przy okazji innej naprawy znajomy mechanik podłączył auto pod komputer w celu wykonania auto scana. Komp wypluł następujące błędy:

    Spoiler:
    Chassis Type: 1Z (1K0)
    Scan: 01 03 08 09 15 16 17 19 25 42 44 46 52 55 56 62 69 72 76
    00-Steering Angle Sensor -- Status: OK 0000
    01-Engine -- Status: OK 0000
    03-ABS Brakes -- Status: OK 0000
    08-Auto HVAC -- Status: OK 0000
    09-Cent. Elect. -- Status: OK 0000
    15-Airbags -- Status: OK 0000
    16-Steering wheel -- Status: OK 0000
    17-Instruments -- Status: OK 0000
    19-CAN Gateway -- Status: Malfunction 0010
    25-Immobilizer -- Status: OK 0000
    42-Door Elect, Driver -- Status: OK 0000
    44-Steering Assist -- Status: OK 0000
    46-Central Conv. -- Status: OK 0000
    52-Door Elect, Pass. -- Status: OK 0000
    55-Headlight Range -- Status: OK 0000
    56-Radio -- Status: Malfunction 1010
    62-Door, Rear Left -- Status: OK 0000
    69-Trailer -- Status: OK 0000
    72-Door, Rear Right -- Status: OK 0000
    76-Park Assist -- Status: OK 0000

    Address 19: CAN Gateway Labels: 1K0-907-530-V1.clb
    Part No SW: 1K0 907 530 E HW: 1K0 907 951
    Component: Gateway H09 0110
    Revision: 09 Serial number: 27001051210AE0
    Coding: 7D3F4740072302
    Shop #: WSC 73430 790 00000
    VCID: 295E26E6806262099E-807C

    2 Faults Found:
    01305 - Databus for Infotainment
    004 - No Signal/Communication - Intermittent
    Freeze Frame:
    Fault Status: 00100100
    Fault Priority: 1
    Fault Frequency: 20
    Reset counter: 63
    Mileage: 184421 km
    Time Indication: 0
    Date: 2000.00.00
    Time: 00:00:02

    01304 - Radio
    004 - No Signal/Communication - Intermittent
    Freeze Frame:
    Fault Status: 00100100
    Fault Priority: 1
    Fault Frequency: 20
    Reset counter: 63
    Mileage: 184421 km
    Time Indication: 0
    Date: 2000.00.00
    Time: 00:00:02
    ------------------------------------------------------------------------------------
    Address 56: Radio Labels: 1K0-035-1xx-56.lbl
    Part No SW: 1Z0 035 161 A HW: 01. 01. 03
    Component: Radio FO3 1008
    Coding: 0000400
    Shop #: WSC 56176 175 13829
    VCID: 2C50DFF28F90772165-8078

    No Faults Found
    or DTCs not supported by controller
    or a communication error occurred

    -------------------------------------------------------------------------------------

    Powyższe błędy po skasowaniu zaraz powracają. Auto w fabrycznej konfiguracji Radio Skoda Stream. W aucie wszystko działa - również to nieszczęsne radio. Działa włączanie po przekręceniu stacyjki, wyłącza się po wyciągnięciu kluczyka ze stacyjki, działa sterowanie z kierownicy. Otwieranie drzwi też w jakiś sposób wzbudza radio. Do radyjka dokładałem emulator zmieniarki yatoura który też działa bez problemu łącznie ze sterowaniem z kierownicy. Wiązki przy radiu oryginalne, nie ciete, nie lutowane. Przy próbie połączenia się kompem z radiem, radio się wyłącza, na wyświetlaczu pojawia się napis DIAG, jednakże komp nie chce się połączyć wypluwając "No Faults Found or DTCs not supported by controller or a communication error occurred". Rozumiem że przez to wywala też błędy Gatewaya. Niestety poległem przy wyszukiwaniu rozwiązania tego problemu, stąd prośba do szanownych forumowiczów o pomoc. Gdzie szukać przyczyny...

    0 9
  • #2 22 Lis 2017 07:14
    sk700
    Poziom 31  

    Jakbyś nie miał komunikacji z radiem nie miałbyś tej części:
    Part No SW: 1Z0 035 161 A HW: 01. 01. 03
    Component: Radio FO3 1008
    Coding: 0000400
    Shop #: WSC 56176 175 13829
    VCID: 2C50DFF28F90772165-8078

    0
  • #3 22 Lis 2017 07:28
    sztorm
    Poziom 13  

    Pewnie masz racje, chociaż "004 - No Signal/Communication - Intermittent" mogłoby sugerować że problem występuje sporadycznie ?

    0
  • #4 22 Lis 2017 07:44
    sk700
    Poziom 31  

    Zainteresuj się tym błędem wyżej, on najprawdopodobniej odpowiada za problem z radiem.

    0
  • #5 22 Lis 2017 08:06
    andrzej20001
    Poziom 43  

    Jak wszystko działa to użytkuj auto ,po co stres?

    0
  • #6 22 Lis 2017 08:06
    sztorm
    Poziom 13  

    Interesuje się właśnie. Mógłbyś rozszerzyć swoją myśl. W którym miejscu szukać. Uszkodzenie przewodu przy gatewayu ? Zaśniedziałe styki. Uszkodzone radio lub sam gateway ? Ale to by chyba dawało jakieś dodatkowe objawy a nie tylko sam błąd... Proszę o dalsze sugestie...

    andrzej20001 - autko użytkuje, jednak stres pozostaje. Rzeźbie w wolnych chwilach, aby się nie okazało że zaraz coś się wysypie... w końcu te błędy nie powstały same z siebie i gdzieś jest przyczyna.

    0
  • #7 22 Lis 2017 16:32
    sk700
    Poziom 31  

    Możliwe, że jest wsadzone inne radio niż te z którym auto wyjechało z fabryki, ktoś grzebał w pamięci radia lub coś nagrzebane w gatewayu np coś w kodowaniu. Zapewne można to naprawić ale jeśli nie ma żadnych negatywnych skutków to bez sensu pchać się w koszty bo to nie będą groszowe sprawy zwłaszcza doliczając czas.

    0
  • #8 23 Lis 2017 07:15
    sztorm
    Poziom 13  

    Witam.
    Niby tak ale może przy pomocy szanownych forumowiczów uda się jakoś rozwiązac ten problem.

    Auto raczej w fabrycznej konfiguracji - czy było coś grzebane nie wiem. Radio Stream ten pierwszy stary więc odpowiadałoby to rocznikowi auta. Gateway też dosyć stary. W tym radiu ew. kod generuje się z tego co wiem na podstawie numerów z naklejki fabrycznej więc grzebanie przy pamięci w celu jego wyciągnięcia też wykluczam. Chyba że była jakaś inna usterka o której nic nie wiem...

    Wczoraj znajomy udostępnił mi kabelek i miałem dłuższą chwilę z VCDS. I tak (nie wiem czy to istotne, może pisze bzdury):

    Radio poprzez ukryte menu poprawnie wyświetla VIN pojazdu, poprawnie działa włączanie/wyłączanie po przekręceniu zapłonu, działa sterowanie z kierownicy. Poprawnie też wyświetlane są informację z PDC, climatronika i inne które maja być wyświetlane. Jak rozumiem komunikacja leci przez gateway, skoro więc radyjko wyświetla te rzeczy to problem uwalonych przewodów chyba odpada.

    Podpinając się pod moduł radia, VCDS poprawnie wykrywa sterownik radia. Można wejść w bloki pomiarowe i wyświetlić ich zawartość, można wejść w kodowanie i adaptację, radyjko poprawnie robi tez output test. Jednakże przy próbie odczytu kodów błędów wyskakuje komunikat No Faults Found or DTCs not supported by controller or a communication error occurred. Przy próbie mimo wszystko kasowania błędów otrzymuje informację że żądanie usunięcia kodów nie jest przyjęte przez sterownik i po chwili że sterownik nie odpowiada. Po wyjściu z okna kasowania błędów ponownie vcds łączy się z kontrolerem i poprawnie go identyfikuje.

    Jakieś uszkodzenie radia ?

    0
  • #9 23 Lis 2017 14:41
    tzok
    Moderator Samochody
  • #10 24 Lis 2017 10:37
    sztorm
    Poziom 13  

    Witam. Z licznika km przy pierwszym podłączeniu VCDSA wynikało iż błąd zarejestrowany był wcześniej przed podłączeniem emulatora zmieniarki. Dodatkowo w blokach pomiarowych radia ten emulator jest poprawnie identyfikowany jako aktywna zmieniarka. Nie mniej jednak odpięcie jej z radia nie zmieniło sprawy. Dalej siedzi w/w bład. Pozdrawiam...

    0